Microsoft Office Excel 2007 - Level 3

- Working with Tables
- Working with Advanced Filters
- Exporting and Importing Data
- Working with Outlines
- Using Advanced Charting Features
- Using Conditional and Custom Formats
- Using Templates
- Using Paste Special
- Customizing Excel Preferences
- Using Worksheet Protection
- Using Multiple Workbooks
- Sharing Workbooks
ABOUT ONDEMAND SOFTWARE

The OnDemand Software Division of Global Knowledge is the worldwide leader of software solutions that enable rapid adoption, broad acceptance and increased accuracy in the use of enterprise applications related to enterprise resource planning, supply chain management, procurement, e-commerce and customer relationship management.

The flagship product, OnDemand Personal Navigator™, provides one synchronized documentation, training and performance support platform. Founded in 1986, the OnDemand Software Division has over 850 Global 2000 customers in 12 countries. The OnDemand Software Division of Global Knowledge, a Welsh, Carson, Anderson and Stowe portfolio company, is headquartered in King of Prussia, Pennsylvania, with offices located worldwide. Additional information can be found at http://www.ondemandgk.com.

COPYRIGHT

Copyright © Global Knowledge Software LLC. 2008. All rights reserved. Information in this document is subject to change without notice and does not represent a commitment on the part of Global Knowledge.

No part of this publication, including interior design, cover design, icons or content may be reproduced by any means, be it transmitted, transcribed, photocopied, stored in a retrieval system, or translated into any language in any form, without the prior written permission of Global Knowledge Network, Inc.

Products mentioned herein, including SAP R/3, PeopleSoft, Siebel Systems, Microsoft Windows, Microsoft Office, Microsoft FrontPage, Microsoft Outlook, Macromedia Flash, Adobe Acrobat, and JavaScript are trademarks or registered trademarks of their respective owners.

OnDemand Personal Navigator and Courseware Express are trademarks of Global Knowledge Software LLC. CustomDOC and Knowledge Pathways are registered trademark of Global Knowledge Software LLC. Global Knowledge and the Global Knowledge logo are trademarks of Global Knowledge, Inc.

DISCLAIMER

Global Knowledge has taken every effort to ensure the accuracy of this manual. If you should discover any discrepancies, please notify us immediately.

Global Knowledge Software LLC.
OnDemand Software Division
475 Allendale Road
King of Prussia, PA 19406
(610) 337-8878
www.ondemandgk.com
# Microsoft Office Excel 2007 - Level 3

About OnDemand Software .............................................................. I

Copyright ............................................................................................ I

Disclaimer .......................................................................................... I

Lesson 1 - Working with Tables ...................................................... 1
  Using Tables .................................................................................. 2
  Creating a Table from Existing Data .............................................. 2
  Changing the Table Name .............................................................. 5
  Changing the Table Style ............................................................... 6
  Changing Table Style Options ....................................................... 8
  Creating a Total Row .................................................................... 11
  Adding Table Rows and Columns ................................................ 14
  Inserting/Deleting Table Rows/Columns ....................................... 17
  Creating a Calculated Column ...................................................... 18
  Selecting Parts of a Table ............................................................. 21
  Moving a Table ............................................................................ 24
  Sorting Data by Multiple Levels ................................................ 25
  Using Text Filters ......................................................................... 29
  Using Number Filters ................................................................... 32
  Using Data Validation .................................................................. 35
  Validating Data using a List ......................................................... 38
  Creating a Custom Error Message .............................................. 41
  Removing Data Validation ............................................................. 44
  Exercise ......................................................................................... 46
  Working with Tables ...................................................................... 46

Lesson 2 - Working with Advanced Filters .................................. 49
  Creating a Criteria Range .............................................................. 50
  Using a Criteria Range ................................................................ 52
  Showing All Records .................................................................... 54
  Using Comparison Criteria ......................................................... 55
  Using an Advanced And Condition ............................................. 56
Using an Advanced Or Condition .............................................................. 59
Copying Filtered Records ........................................................................ 62
Using Database Functions ....................................................................... 66
Finding Unique Records ......................................................................... 69
Removing Duplicates from a Table ............................................................ 71
Exercise .................................................................................................... 73
Working with Advanced Filters ............................................................... 73

LESSON 3 - EXPORTING AND IMPORTING DATA ................................. 75
Exporting Data to Other Applications ....................................................... 76
Importing Data from Access ..................................................................... 79
Importing Data from Text Files ................................................................. 82
Changing External Data Range Properties .............................................. 85
Importing Data from Other Applications ................................................. 88
Removing the Query Definition ............................................................... 94
Importing Dynamic Data from the Web .................................................... 95
Copying a Table from a Web Page ............................................................ 99
Exercise .................................................................................................... 103
Exporting and Importing Data ............................................................... 103

LESSON 4 - WORKING WITH OUTLINES ........................................... 105
Applying an Outline ................................................................................ 106
Collapsing/Expanding an Outline ............................................................ 108
Modifying Outline Settings ..................................................................... 110
Using Auto Outline ................................................................................ 112
Clearing an Outline ................................................................................ 114
Creating Subtotals in a List ..................................................................... 116
Removing Subtotals from a List ............................................................... 120
Exercise .................................................................................................... 122
Working with Outlines ............................................................................ 122

LESSON 5 - USING ADVANCED CHARTING FEATURES ..................... 125
Adding and Removing Gridlines ............................................................ 126
Formatting Gridlines ............................................................................. 128
Formatting an Axis ................................................................................ 130
Changing the Axis Scaling .................................................................... 132
Formatting the Data Series ................................................................... 135
Adding Data from Different Worksheets ............................................................... 138
Using a Secondary Axis ....................................................................................... 140
Changing Data Series Chart Types ..................................................................... 142
Adding a Trendline ............................................................................................... 145
Creating a Chart Template ................................................................................... 147
Applying a Chart Template .................................................................................. 149
Exercise .................................................................................................................. 153
Using Advanced Charting Features ..................................................................... 153

LESSON 6 - USING CONDITIONAL AND CUSTOM FORMATS ............ 155
Applying Conditional Formats ............................................................................ 156
Changing a Conditional Format .......................................................................... 158
Adding a Conditional Format .............................................................................. 161
Creating a Custom Conditional Format ............................................................... 163
Using Data Bars ..................................................................................................... 165
Deleting a Conditional Format ............................................................................. 167
Creating a Custom Number Format .................................................................... 169
Exercise .................................................................................................................. 173
Using Conditional and Custom Formats .............................................................. 173

LESSON 7 - USING TEMPLATES ................................................................. 175
Working with Templates ....................................................................................... 176
Saving a Workbook as a Template ..................................................................... 176
Using a Template .................................................................................................. 178
Editing a Template ................................................................................................. 181
Inserting a New Worksheet .................................................................................... 183
Deleting a Template .............................................................................................. 185
Creating Default Templates .................................................................................. 187
Finding Online Templates .................................................................................... 188
Exercise .................................................................................................................. 191
Using Templates ..................................................................................................... 191

LESSON 8 - USING PASTE SPECIAL ......................................................... 193
Working with Paste Special ................................................................................. 194
Copying Values between Worksheets ................................................................. 194
Copying Formulas between Worksheets .............................................................. 196
Performing Mathematical Operations ................................................................. 198
<table>
<thead>
<tr>
<th>LESSON 9 - CUSTOMIZING EXCEL PREFERENCES</th>
<th>203</th>
</tr>
</thead>
<tbody>
<tr>
<td>Setting Edit Options</td>
<td>204</td>
</tr>
<tr>
<td>Setting Display Options</td>
<td>205</td>
</tr>
<tr>
<td>Setting Manual Calculation</td>
<td>208</td>
</tr>
<tr>
<td>Resetting Automatic Calculation</td>
<td>210</td>
</tr>
<tr>
<td>Setting Popular Options</td>
<td>211</td>
</tr>
<tr>
<td>Exercise</td>
<td>213</td>
</tr>
<tr>
<td>Customizing Excel Preferences</td>
<td>213</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>LESSON 10 - USING WORKSHEET PROTECTION</th>
<th>215</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unlocking Cells in a Worksheet</td>
<td>216</td>
</tr>
<tr>
<td>Protecting a Worksheet</td>
<td>217</td>
</tr>
<tr>
<td>Unprotecting a Worksheet</td>
<td>220</td>
</tr>
<tr>
<td>Creating Allow-Editing Ranges</td>
<td>221</td>
</tr>
<tr>
<td>Deleting Allow-Editing Ranges</td>
<td>225</td>
</tr>
<tr>
<td>Protecting Workbook Windows</td>
<td>227</td>
</tr>
<tr>
<td>Unprotecting Workbook Windows</td>
<td>229</td>
</tr>
<tr>
<td>Assigning a Password</td>
<td>230</td>
</tr>
<tr>
<td>Opening a Password-protected File</td>
<td>233</td>
</tr>
<tr>
<td>Removing a Password</td>
<td>235</td>
</tr>
<tr>
<td>Exercise</td>
<td>237</td>
</tr>
<tr>
<td>Using Worksheet Protection</td>
<td>237</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>LESSON 11 - USING MULTIPLE WORKBOOKS</th>
<th>239</th>
</tr>
</thead>
<tbody>
<tr>
<td>Opening Multiple Workbook Windows</td>
<td>240</td>
</tr>
<tr>
<td>Cascading Open Workbook Windows</td>
<td>242</td>
</tr>
<tr>
<td>Activating Cascaded Workbook Windows</td>
<td>243</td>
</tr>
<tr>
<td>Tiling Open Workbook Windows</td>
<td>244</td>
</tr>
<tr>
<td>Activating Tiled Workbook Windows</td>
<td>246</td>
</tr>
<tr>
<td>Comparing Workbooks Side by Side</td>
<td>247</td>
</tr>
<tr>
<td>Copying Data between Workbooks</td>
<td>251</td>
</tr>
<tr>
<td>Saving a Workspace</td>
<td>252</td>
</tr>
<tr>
<td>Closing All Open Workbooks</td>
<td>255</td>
</tr>
<tr>
<td>Opening a Workspace</td>
<td>256</td>
</tr>
</tbody>
</table>
Linking Workbooks
Opening Linked Workbooks
Exercise
Using Multiple Workbooks

LESSON 12 - SHARING WORKBOOKS
Using Shared Workbooks
Saving a Shared Workbook
Viewing Users Sharing a Workbook
Viewing Shared Workbook Changes
Changing the Update Frequency
Highlighting Changes
Managing Conflicting Changes
Resolving Conflicting Changes
Setting Change History Options
Adding a History Worksheet
Reviewing Tracked Changes
Merging Shared Workbook Files
Exercise
Sharing Workbooks

INDEX
LESSON 1 -
WORKING WITH TABLES

In this lesson, you will learn how to:

- Use tables
- Create a table from existing data
- Change the table name
- Change the table style
- Change table style options
- Create a total row
- Add table rows and columns
- Insert/Delete table rows/columns
- Create a calculated column
- Select parts of a table
- Move a table
- Sort data by multiple levels
- Use text filters
- Use number filters
- Use data validation
- Validate data using a list
- Create a custom error message
- Remove data validation
USING TABLES

Discussion

Excel’s special table features provide powerful ways to work with, and analyze, data. You can create multiple tables on the same worksheet and you can insert new columns or rows within a table without affecting other data in your worksheet.

When you define a range as a table, powerful filtering and sorting options are automatically added to the table, a large gallery of table formatting styles is available to make your table easy to read and a Table Tools contextual Design tab is added to the Ribbon.

Tables automatically expand if you type data in the row directly below the table. All table styles, conditional formatting, calculations and data validation rules that you have applied to table data are extended to the new row. Similarly, if you type data in the column directly to the right of the table, the new column is automatically included in the table and adopts the table style.

If you add a column to the table and enter a formula in a single cell in the column that references other data in the same row, the formula is automatically copied to all rows in the table.

Each table you create is automatically assigned a name. You can change the table name to something more descriptive, if desired. Table names let you create formulas that reference elements of the table by their column name instead of using cell addresses. This type of referencing ensures that formulas expand automatically when you add new data to the table.

In previous versions of Excel, tables were known as Lists or Databases. All the features previously associated with Lists or Databases are now incorporated into the new Tables feature, together with some significant enhancements.

CREATING A TABLE FROM EXISTING DATA

Discussion

You can define an existing range of data as a table and then use Excel’s table features to work with, and analyze, the data.
The data to be defined as a table must be arranged in consecutive columns and rows to form a list of similar information. The data in each row must refer to a single item in the list, such as a person in an address list. Each column must contain consistent information about the items in each row. In an address list, all the city names must be in one column, all the postal codes in another column, and so on. Usually, a table has labels, called headers, at the top of each column to describe the data in the column. If your data does not have headers, Excel adds default headers when you define it as a table, with the labels Column1, Column2, etc. You can overtype these with descriptive names for your columns, if desired.

When defining the table range, it is not necessary to select the range of cells if the table is based on an entire range of consecutive cell entries. When you select a cell in the range, Excel assumes that you want to use all the consecutive cells for the table.

When a range is defined as a table, Filter arrows appear in the header row of the table, a table style is applied to the range and the Table Tools contextual Design tab appears.

You can create multiple tables on the same worksheet.
Procedures

1. Select a cell in the range of cells containing the data you wish to define as a table.
2. Select the Home tab.
3. Select \textit{Format as Table} in the Styles group.
4. Select the desired Table Style from the gallery.
5. Select or deselect the \textit{My table has headers} option in the Format as Table dialog box, as appropriate.
6. Select \textbf{OK}.

Step-by-Step

From the Student Data directory, open TABLE.XLSX. Create a table.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select a cell in the range of cells containing the data you wish to define as a table.  
\textit{The cell is selected.} | Click cell \textbf{D5}, if necessary |
| 2. Select the Home tab.  
\textit{The Home tab is displayed.} | Click \textbf{Home} |
| 3. Select the Format as Table button in the Styles group.  
\textit{The Table Styles gallery opens.} | Click \textbf{Format as Table} |
### Steps

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>4. Select the desired Table Style from the gallery. The desired style is selected, the gallery closes and the Format as Table dialog box opens with the range of consecutive cells around the current cell selected as a suggested range for the table.</td>
<td>Click <strong>Table Style Medium 9</strong> (2nd option, second row in the <strong>Medium</strong> section of the gallery)</td>
</tr>
<tr>
<td>5. Select or deselect the <strong>My table has headers</strong> option in the Format as Table dialog box, as appropriate. The <strong>My table has headers</strong> option is selected or deselected accordingly.</td>
<td>Click ☑ <strong>My table has headers</strong> to select it, if necessary</td>
</tr>
<tr>
<td>6. Select <strong>OK</strong>. The Format as Table dialog box closes, the selected Table Style is applied to the table, Filter arrows appear at the top of each column in the table, the <strong>Table Tools contextual Design</strong> tab appears on the <strong>Ribbon</strong> and the table range is selected.</td>
<td>Click <strong>OK</strong></td>
</tr>
</tbody>
</table>

Click on a cell outside the table to deselect it. Notice that the **Design** tab disappears. Click on a cell within the table. Notice that the **Design** tab appears.

---

### Changing the Table Name

#### Discussion

When you define a range as a table, Excel automatically assigns a name to the table, such as **Table1, Table2**, etc. You can use this name in formulas and macros to reference the table. If you apply a more descriptive name to the table, you will find it easier to identify the correct table in a workbook that contains more than one table. Formulas and macros that reference the table will also be more meaningful.

![Warning](image)

Although you can change the name of a table at any time, if you have created macros that reference a table and then change the table name, you will also have to edit your macros. For this reason, it is better to apply descriptive names to your tables when you first create them.
Procedures

1. Select a cell in the table.
2. Select the Design tab.
3. Select the Table Name box in the Properties group.
4. Enter the desired name for the table.
5. Press [Enter].

Step-by-Step

Change a table name.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select a cell in the table.</td>
<td>Click cell E6</td>
</tr>
<tr>
<td>The cell is selected and the Design tab appears on the Ribbon.</td>
<td></td>
</tr>
<tr>
<td>2. Select the Design tab.</td>
<td>Click Design</td>
</tr>
<tr>
<td>The Design tab is displayed.</td>
<td></td>
</tr>
<tr>
<td>3. Select the Table Name box in the Properties group.</td>
<td>Click the Table Name box in the Properties group</td>
</tr>
<tr>
<td>The existing table name is selected.</td>
<td></td>
</tr>
<tr>
<td>4. Enter the desired name for the table.</td>
<td>Type RepSales</td>
</tr>
<tr>
<td>The new name replaces the existing text.</td>
<td></td>
</tr>
<tr>
<td>5. Press [Enter].</td>
<td>Press [Enter]</td>
</tr>
<tr>
<td>The new name is applied to the table.</td>
<td></td>
</tr>
</tbody>
</table>

CHANGING THE TABLE STYLE

Discussion

You can change the Table Style at any time. The Table Styles gallery provides a wide variety of styles to enhance the appearance and readability of your data.

The Table Styles group in the Design tab displays a Quick Styles gallery of table styles. You can select one of the four displayed styles by clicking on the desired style.
You can use the scroll arrows to the right of the Quick Styles gallery to display additional styles four at a time or you can select the More button below the scroll arrows to open the Table Styles gallery to view all the available styles.

As you move the mouse over a style in either the Quick Styles gallery or the Table Styles gallery, the style is previewed on the selected table.

Although Excel applies a Table Style to the data when you define a range as a table, you can remove the Table Style, if desired. Click the More button in the Quick Styles gallery and select Clear from the menu below the Table Styles gallery.

Procedures

1. Select a cell in the table.
2. Select the Design tab.
3. Select the More button to the right of the Quick Styles gallery in the Table Styles group.
4. Select the desired table style.
**Step-by-Step**

Change the Table Style.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select a cell in the table. &lt;br&gt; <em>The cell is selected and the Design tab appears on the Ribbon.</em></td>
<td>Click cell B7</td>
</tr>
<tr>
<td>2. Select the Design tab. &lt;br&gt; <em>The Design tab is displayed.</em></td>
<td>Click Design</td>
</tr>
<tr>
<td>3. Select the More button to the right of the Quick Styles gallery in the Table Styles group. &lt;br&gt; <em>The Table Styles gallery opens.</em></td>
<td>Click</td>
</tr>
<tr>
<td>4. Select the desired table style. &lt;br&gt; <em>The selected style is applied to the table.</em></td>
<td>Scroll as necessary and click Table Style Dark 3</td>
</tr>
</tbody>
</table>

**Practice the Concept:** Scroll up 5 rows in the Quick Styles gallery and select Table Style Medium 12.

---

**Changing Table Style Options**

**Discussion**

Excel provides options that allow you to make additional changes to the Table Style. When you enable or disable these options, the styles displayed in the Table Styles gallery change accordingly.

Many of the styles in the Table Styles gallery apply banding to the table rows, you can turn off this option so that all the data rows appear in the same color. Similarly, you can turn on column banding so that alternate columns appear in a darker color.

You can also apply emphasized formatting to the first or last column of the table. For all Table Styles, bolding is applied to the entries in the first or last column of the table when these options are enabled. For some styles in the Medium and Dark sections of the Table Style gallery, the color of the Header Row is also applied to the column.

You can also hide or redisplay the Header Row.
Procedures

1. Select a cell in the table.
2. Select the Design tab.
3. To enable or disable the display of data rows in alternating colors, select or deselect the Banded Rows option in the Table Style Options group.
4. To enable or disable the display of data columns in alternating colors, select or deselect the Banded Columns option in the Table Style Options group.
5. To enable or disable emphasized formatting for the first table column, select or deselect the First Column option in the Table Style Options group.
6. To enable or disable emphasized formatting for the last table column, select or deselect the Last Column option in the Table Style Options group.
7. To hide or redisplay the header row, deselect or select the Header Row option in the Table Style Options group.
Step-by-Step

Change Table Style Options.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select a cell in the table.</td>
<td>Click cell D4</td>
</tr>
<tr>
<td>The cell is selected and the Design tab appears on the Ribbon.</td>
<td></td>
</tr>
<tr>
<td>2. Select the Design tab.</td>
<td>Click Design</td>
</tr>
<tr>
<td>The Design tab is displayed.</td>
<td></td>
</tr>
<tr>
<td>3. To enable or disable the display of data rows in alternating colors,</td>
<td>Click [Banded Rows] to deselect it</td>
</tr>
<tr>
<td>select or deselect the Banded Rows option in the Table Style Options</td>
<td></td>
</tr>
<tr>
<td>group. Alternating colors for the data rows are turned on or turned off</td>
<td></td>
</tr>
<tr>
<td>accordingly.</td>
<td></td>
</tr>
<tr>
<td>4. To enable or disable the display of data columns in alternating</td>
<td>Click [Banded Columns] to select it</td>
</tr>
<tr>
<td>colors, select or deselect the Banded Columns option in the Table</td>
<td></td>
</tr>
<tr>
<td>Style Options group. Alternating colors for the data columns are</td>
<td></td>
</tr>
<tr>
<td>turned on or turned off accordingly.</td>
<td></td>
</tr>
<tr>
<td>5. To enable or disable emphasized formatting for the first table</td>
<td>Click [First Column] to select it</td>
</tr>
<tr>
<td>column, select or deselect the First Column option in the Table Style</td>
<td></td>
</tr>
<tr>
<td>Options group. Emphasized formatting for the first table column is</td>
<td></td>
</tr>
<tr>
<td>turned on or turned off accordingly.</td>
<td></td>
</tr>
<tr>
<td>6. To enable or disable emphasized formatting for the last table</td>
<td>Click [Last Column] to select it</td>
</tr>
<tr>
<td>column, select or deselect the Last Column option in the Table Style</td>
<td></td>
</tr>
<tr>
<td>Options group. Emphasized formatting for the last table column is</td>
<td></td>
</tr>
<tr>
<td>turned on or turned off accordingly.</td>
<td></td>
</tr>
</tbody>
</table>
Steps | Practice Data
--- | ---
7. To hide or redisplay the header row, deselect or select the **Header Row** option in the **Table Style Options** group. *The Header Row is hidden or displayed accordingly.* | Click ✅ **Header Row** to deselect it

**Practice the Concept:** Redisplay the **Header Row**, turn off emphasized formatting for the **First Column** and **Last Column** and display **Banded Rows** instead of **Banded Columns**.

**CREATING A TOTAL ROW**

**Discussion**

A total row is a special calculation row you can add to the bottom of an Excel table to calculate column results.

By default, when you add a total row to a table, Excel adds the word Total below the first column and automatically adds a calculation to the last column. If the last column contains numeric entries, it sums the entries. If the last column contains text or date entries, it counts the number of entries.

You can create a calculation for any column in your table. When you select any cell in the total row, a drop down arrow appears to the right of the cell providing access to a list of commonly used functions. The functions listed are **Average**, **Count**, **Count Numbers**, **Max**, **Min**, **Sum**, **StdDev**, and **Var**. You can select any of these functions for each column or remove a calculation by selecting **None** from the list. You can change which function is applied to a column at any time by redisplaying the list of functions.

You can turn off the total row at any time. When you turn it back on, Excel remembers which calculations were used for each column.
Creating a total row

Although the list of functions displays the names of common aggregate functions, Excel enters a special SUBTOTAL function when you select one of these options. The SUBTOTAL function uses two arguments. The first argument is known as the function_num argument, which determines the type of calculation applied to the column. When you select a function from the list, Excel enters a SUBTOTAL function with the appropriate function_num argument (101 for Average, 102 for Count, and so on). Because these numbers are in the range 101-111, the SUBTOTAL function ignores rows that are hidden by filters. If you filter the table, the results in the total row will change to calculate only the column data that is currently visible. Although this generally gives you the results you need, if you want the total row to calculate using all the data in the column, even when it is filtered, you can edit the formula and subtract 100 from the number (1 for Average, 2 for Count, and so on).

When you select any of the eight aggregate functions in the drop down list, Excel uses the column name as the second argument for the SUBTOTAL function. This structured referencing means that when data is added to the table, it is automatically included in the calculation.
You can use any Excel function in the total row by selecting **More Functions** from the drop down list to open the Insert Function dialog box. To use structured referencing in these functions instead of ordinary cell references, type the column name enclosed in square brackets. This will ensure that new data added to the table will be included in your calculations automatically.

**Subtotal** is the only function that recalculates its result when you filter a table.

---

**Procedures**

1. Select a cell in the table.
2. Select the **Design** tab.
3. Select the **Total Row** option in the **Table Style Options** group.
4. Select the cell in the total row for the field you want to calculate.
5. Select the list arrow.
6. Select the desired function.

---

**Step-by-Step**

Create a total row.

Use the **Year** Filter arrow to display only data for the year **2006**.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select a cell in the table.  
*The cell is selected and the Design tab appears on the Ribbon.* | Click cell B4         |
| 2. Select the **Design** tab.  
*The Design tab is displayed.* | Click **Design**      |
3. Select the **Total Row** option in the **Table Style Options** group.
   *A total row appears at the bottom of the table.*

4. Select the cell in the total row for the field you want to calculate.
   *A list arrow appears to the right of the cell.*

5. Select the list arrow.
   *A list of functions is displayed.*

6. Select the desired function.
   *The selected calculation appears in the cell.*

**Practice the Concept:** Select the cell in the **Total** row for the **Purchaser** column (column H) and click the list arrow. The **Count** function is displaying a count of entries. Select **None** to remove the calculation for this column.

Select the **Year** Filter button and choose **Clear Filter From “Year”**. Notice that the total for the **Sales** column recalculates. Change the function in the **Total** row for the **Sales** column to display the highest sale (**Max**).

Hide the total row by clicking the **Total Row** button on the **Design** tab. Redisplay the total row. Notice that Excel remembers which type of calculation was used for the **Sales** column.

---

### ADDING TABLE ROWS AND COLUMNS

#### Discussion

While some lists may be used for information that is static and unchanging, other tables may grow as new information is added. You can easily add new rows or columns to a table.

As new data is typed or pasted into the row below the table, the table automatically resizes to include the new row of data. If you are using the total row, you must temporarily hide it to add new data rows in this way; you can redisplay it after adding the new data rows. The formulas in the total row will automatically include the new data in their calculations.

Similarly, as new data is typed or pasted into the column to the right of the table, the table automatically resizes to include the new column.
Although Tables automatically resize when you add data in adjacent rows and columns, you may prefer to manually resize a Table before entering new data. You can resize a Table by dragging the sizing handle in the lower right corner of the Table or by selecting the **Resize Table** button in the **Properties** group on the **Design** tab and entering the new Table range. When the total row is displayed, the sizing handle is not available but you can use the **Resize Table** button.

You can also add new rows of data by selecting the bottom, right-hand data cell and pressing `[Tab]`. A new, blank row is added to the table and the first cell in the new row is selected ready for you to type new data. You can use this method even with the totals row displayed; Excel adds the new row between the existing data and the totals row. You can also use the `[Tab]` key to move from cell to cell in the row as you enter the new data. When you reach the end of the row, pressing `[Tab]` once more adds another new row.

When you use the `[Tab]` method to add new data rows, if you have data stored in cells below the table, Excel automatically shifts any data below the table down, when it reaches the first row containing such data.
Procedures

1. Select the last data cell in the table.
2. Press [Tab].
3. Enter the desired data in the cell.
4. Press [Tab].
5. Continue entering the row data.

Step-by-Step

Add new rows of data.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the last data cell in the table. &lt;br&gt; <em>The cell is selected.</em></td>
<td>Click cell H23</td>
</tr>
<tr>
<td>2. Press [Tab]. &lt;br&gt; <em>A new row is added to the table and the first cell in the new row is selected.</em></td>
<td>Press [Tab]</td>
</tr>
<tr>
<td>3. Enter the desired data in the cell. &lt;br&gt; <em>The data appears in the selected cell.</em></td>
<td>Type Gina Mann</td>
</tr>
<tr>
<td>4. Press [Tab]. &lt;br&gt; <em>The entry is confirmed and the next cell in the row is selected.</em></td>
<td>Press [Tab]</td>
</tr>
<tr>
<td>5. Continue entering the row data. &lt;br&gt; <em>The data appears in the row.</em></td>
<td>Follow the instructions below to complete this step</td>
</tr>
</tbody>
</table>

Enter the following data, pressing [Tab] after each entry except the last. Press [Enter] to confirm the last entry.

<table>
<thead>
<tr>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Central</td>
<td>Jul</td>
<td>2007</td>
<td>2500</td>
<td>Golf Balls</td>
<td>SportsCity</td>
</tr>
<tr>
<td>Joe Marks</td>
<td>Southwest</td>
<td>Apr</td>
<td>2007</td>
<td>1850</td>
<td>Gloves</td>
<td>SportsCity</td>
</tr>
</tbody>
</table>

**Practice the Concept:** Select cell I7. Type **John Dean** and press [Enter]. Notice that the table expands to include the new column and that Excel enters a default column name. Select cell I3. Type **Manager** and press [Enter] to replace the default column name. Complete the column entries using **John Dean** for all **Central** region rows, **Lucy Brown** for the **Northeast** region, **Carl Jones** for the **Southwest** region, **Bob**
Gould for the Southeast region, and Suzy Wells for the Northwest region. (Hint: Excel’s AutoComplete feature will help you enter these entries quickly.)

**INSERTING/DELETING TABLE ROWS/COLUMNS**

**Discussion**

As you work with a table, you may need to add rows or columns within the table, instead of below or to the right of existing rows and columns. You may also need to remove rows or columns. Right-clicking a cell in the table displays a shortcut menu that contains the **Insert** and **Delete** options for making these changes.

New columns are inserted to the left of the selected cell; new rows are inserted above the selected cell. Deleting a column or row, deletes the column or row containing the selected cell. Insertions and deletions apply to the Table range only, not to the entire worksheet. A column inserted into the Table only inserts cells as far as the bottom of the Table.

You can also insert or delete rows in a table by clicking the arrow on the right-hand part of the **Insert** or **Delete** button in the **Cells** group on the **Home** tab to display the **Insert** or **Delete** menu. When a table cell is selected, these menus offer options for inserting or deleting table columns and table rows.

**Procedures**

1. Right-click a cell in the Table where you want to insert or delete a row or column.

2. To insert a column or row, point to **Insert**. To delete a column or row, point to **Delete**.

3. Select the desired option from the submenu.

**Step-by-Step**

Insert and delete table columns and rows.

Select cell **C27**, type the word **Region** into the cell and press **[Enter]**.
Steps | Practice Data
---|---
1. Right-click a cell in the Table where you want to insert or delete a row or column. 
*The cell is selected and a menu opens.* | Right-click cell C19

2. To insert a column or row, point to **Insert**. To delete a column or row, point to **Delete**. 
*A submenu opens.* | Point to **Insert**

3. Select the desired option from the submenu. 
*The menu closes and a column or row is inserted or deleted accordingly.* | Click **Table Columns to the Left**

Notice that the word **Region** still appears in cell C27, even though you inserted a column in the Table. Column cells were only inserted within the Table range.

**Practice the Concept:** Right-click a Table cell in column C. Delete column C from the Table. Notice that the word **Region** in cell C27 is not deleted. Column cells were only deleted within the Table range.

Right-click a Table cell in row 15. Insert a new row. Notice that the word **Region** is now in cell C28. All data below the table moves down when a row is inserted. Delete row 15 from the Table. Then delete the word **Region** that you typed under the Table.

---

**CREATING A CALCULATED COLUMN**

**Discussion**

A calculated column in a table contains a formula that performs the same calculation for each row in the table. When you enter a formula in any single cell in a column, Excel automatically applies the formula to all cells in the column.

A valid formula for a calculated column should only refer to data in the same table row as the cell in which it is entered. If the formula refers to data in other table rows, it will become an invalid formula in rows at either the top or bottom end of the table because it will refer to rows outside the table.

An exception to this rule is that the formula can refer to a cell outside the table which contains a constant, such as a tax rate, as long as the reference to the cell outside the table is an absolute reference.
If you create the formula by the pointing method (clicking on cells within the table, instead of typing cell references), Excel uses structured references, which creates a more robust and descriptive formula.

You can create a calculated column either by inserting a new column within a table and entering a formula in a cell in the column, or by typing a formula in any cell in the column immediately to the right of the table.

Creating a calculated column

Procedures

1. Select any cell in the column you want to use as a calculated column.
2. Create the desired formula.
3. Press [Enter] to complete the formula.
4. Select the column header and enter a descriptive name to replace the default column name, if desired.

Step-by-Step

Create a calculated column.
## Steps

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select any cell in the column you want to use as a calculated column.</td>
<td></td>
</tr>
<tr>
<td>The cell is selected.</td>
<td>Click cell J6</td>
</tr>
<tr>
<td>2. Create the desired formula.</td>
<td>Follow the instructions shown below the table before continuing on to the next step</td>
</tr>
<tr>
<td>The formula appears in the cell and in the Formula Bar as you create it.</td>
<td>Press [Enter]</td>
</tr>
<tr>
<td>3. Press [Enter] to complete the formula.</td>
<td>Press [Enter]</td>
</tr>
<tr>
<td>The result is displayed in the current cell and the formula is immediately copied to the other cells in the column.</td>
<td>Click in cell J3 and type Profit</td>
</tr>
<tr>
<td>4. Select the column header and enter a descriptive name to replace the default column name, if desired.</td>
<td>Type = (equal sign) to begin the formula. Click on cell F6. Notice that Excel enters a structured reference in the formula that consists of the Table Name (RepSales) and the Column Name ([Sales]), with a special item specifier that refers to just the portion of the column that appears in the current row ([#This Row]). Type * (asterisk). Type 20%.</td>
</tr>
</tbody>
</table>

Type = (equal sign) to begin the formula. Click on cell F6. Notice that Excel enters a structured reference in the formula that consists of the Table Name (RepSales) and the Column Name ([Sales]), with a special item specifier that refers to just the portion of the column that appears in the current row ([#This Row]). Type * (asterisk). Type 20%.

Return to the table and continue on to the next step (step 3).

### Practice the Concept:

Click on several different cells in the Profit column and view the formula in the Formula Bar. Notice that the formula is the same in each cell.

Select cell B1 and type Profit Margin. Select cell C1 and type 20%.

Double-click on cell J10 to edit the formula and delete 20% from the formula, then click on cell C1 to place a reference to the cell in the formula. Press [F4] to change the reference to cell C1 to an absolute reference ($C$1), then press [Enter].

View the formula in several different cells in the Profit column. Notice that the formula is the same in each cell.

Change the figure in cell C1 to 15%. Notice how all the results in the Profit column change.
SELECTING PARTS OF A TABLE

Discussion

Excel provides several methods for selecting parts of a table. These methods are particularly useful for large tables.

You can quickly select an entire row or column. You can select just the data in a column without the Header and Total Rows, which is useful if you want to format the column data without changing Headers and Totals. You can also select all the table data or the entire table including the Header Row and Total Row, which is useful if you want to copy or delete the data or the whole table.

You can also select columns and rows by right-clicking on a cell in the desired column or row, pointing to Select in the shortcut menu that appears and clicking the appropriate option in the Select submenu.

To select all the table data using the menu, right-click any cell in the table and click Table Column Data in the Select submenu, then right-click within the selected column and click Table Row in the Select submenu.
To select the entire table using the menu, right-click any cell in the table and click **Entire Table Column** in the **Select** submenu, then right-click within the selected column and click **Table Row** in the **Select** submenu.

You can also select parts of the table using the keyboard. To select a table row, click any cell in the row then press **[Shift+Spacebar]**. To select column data, click any cell in the column then press **[Ctrl+Spacebar]**. To select the entire table column, press **[Ctrl+Spacebar]** twice. To select all table data, click any cell in the table then press **[Ctrl+A]**. To select the entire table including the Header Row and Total Row, press **[Ctrl+A]** twice.

**Procedures**

1. To select a table row, hover the mouse pointer just inside the left edge of the leftmost column in the row until ➡️ appears.
2. Click to select the table row.
3. Select any cell to deselect the row.
4. To select the data in a table column, hover the mouse pointer just inside the top edge of the topmost row in the column until 🆕️ appears.
5. Click to select the column data.
6. To select the entire column, click the mouse button a second time.
7. Select any cell to deselect the column.
8. To select all the data in a table, hover the mouse pointer just inside the top-left corner of the top-left cell in the table until ⬠ appears.
9. Click to select the table data.
10. To select the entire table, click the mouse button a second time.
11. Select any cell to deselect the table.

**Step-by-Step**

Select parts of a table.
<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. To select a table row, hover the mouse pointer just inside the</td>
<td>Point to the left edge of cell B8 until ➔ appears</td>
</tr>
<tr>
<td>left edge of the leftmost column in the row.</td>
<td></td>
</tr>
<tr>
<td><em>The mouse pointer changes to a right-pointing arrow.</em></td>
<td></td>
</tr>
<tr>
<td>2. Click to select the table row.</td>
<td>Click the left mouse button</td>
</tr>
<tr>
<td><em>The table row is selected.</em></td>
<td></td>
</tr>
<tr>
<td>3. Select any cell to deselect the row.</td>
<td>Click any cell</td>
</tr>
<tr>
<td><em>The cell is selected.</em></td>
<td></td>
</tr>
<tr>
<td>4. To select the data in a table column, hover the mouse pointer</td>
<td>Point to the top edge of cell G3 until ‣ appears</td>
</tr>
<tr>
<td>just inside the top edge of the topmost row in the column.</td>
<td></td>
</tr>
<tr>
<td><em>The mouse pointer changes to a down-pointing arrow.</em></td>
<td></td>
</tr>
<tr>
<td>5. Click to select the column data.</td>
<td>Click the left mouse button</td>
</tr>
<tr>
<td><em>The column data is selected.</em></td>
<td></td>
</tr>
<tr>
<td>6. To select the entire column, click the mouse button a second time.</td>
<td>Click the left mouse button</td>
</tr>
<tr>
<td><em>The entire column is selected.</em></td>
<td></td>
</tr>
<tr>
<td>7. Select any cell to deselect the column.</td>
<td>Click any cell</td>
</tr>
<tr>
<td><em>The cell is selected.</em></td>
<td></td>
</tr>
<tr>
<td>8. To select all the data in a table, hover the mouse pointer just</td>
<td>Point to the top-left corner of cell B3 until ⇓ appears</td>
</tr>
<tr>
<td>inside the top-left corner of the top-left cell in the table.</td>
<td></td>
</tr>
<tr>
<td><em>The mouse pointer changes to an arrow pointing down and to the right.</em></td>
<td></td>
</tr>
<tr>
<td>9. Click to select the table data.</td>
<td>Click the left mouse button</td>
</tr>
<tr>
<td><em>The table data is selected.</em></td>
<td></td>
</tr>
<tr>
<td>10. To select the entire table, click the mouse button a second time.</td>
<td>Click the left mouse button</td>
</tr>
<tr>
<td><em>The entire table is selected.</em></td>
<td></td>
</tr>
<tr>
<td>11. Select any cell to deselect the table.</td>
<td>Click any cell</td>
</tr>
<tr>
<td><em>The cell is selected.</em></td>
<td></td>
</tr>
</tbody>
</table>
MOVING A TABLE

Discussion

You can select and move a table within a worksheet in one easy step by dragging it. All table formatting moves with the table and formulas outside the table that reference data within the table will adjust their references accordingly.

Dragging the table is a useful method if you only need to move it a few rows or columns. If you need to move the table to another area of the worksheet entirely, it is easier to use the Cut and Paste feature.

If you drag a table over existing data in the worksheet, Excel displays the following message: Do you want to replace the contents of the destination cells? Click OK to overwrite the existing data or click Cancel to cancel the table move.

If you drag a table to the left or right, you will probably need to adjust column widths to display the data correctly.
Procedures

1. Select any cell in the table.
2. Hover the mouse pointer over the top, bottom, left, or right edge of the table until ⇧ appears.
3. Hold down the mouse button and drag to the desired destination.
4. Release the mouse button.

Step-by-Step

Move a table by dragging.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select any cell in the table. <em>The cell is selected.</em></td>
<td>Click cell C6</td>
</tr>
<tr>
<td>2. Hover the mouse pointer over the top, bottom, left, or right edge of the table. <em>The mouse pointer changes to a white arrow with a four-headed black arrow at its tip.</em></td>
<td>Point to the top edge of cell B3 until ⇧ appears</td>
</tr>
<tr>
<td>3. Hold down the mouse button and drag to the desired destination. <em>The table is selected as you hold down the mouse button and a shaded outline and a ScreenTip show the new position of the table as you drag.</em></td>
<td>Drag the table 4 rows downwards to B7:J30</td>
</tr>
<tr>
<td>4. Release the mouse button. <em>The table moves to the new position.</em></td>
<td>Release the mouse button</td>
</tr>
</tbody>
</table>

Sorting Data by Multiple Levels

Discussion

The Sort options available from the Filter buttons in the Header Row of a table only let you sort the table rows using the entries in a single column of the table. However, when a column contains many entries that are the same, such as a Region column, you
may want to add a second level of sorting to organize the rows within each Region. By using the Sort dialog box, you can add as many levels of sorting as you need.

You can use the entries in any column to sort table data. Text columns let you sort the data from A to Z or Z to A. Number columns let you sort from Smallest to Largest or Largest to Smallest. Date columns and Time columns let you sort from Oldest to Newest or Newest to Oldest. You can also sort by a custom list (such as month names, which do not produce the result you need when sorted alphabetically) or by the cell format (such as the Cell Color, Font Color, or Icon Set applied to cells by conditional formatting).

Sorting data by multiple levels

- To reverse a sort, you can use the Undo feature immediately following the sort operation.

Procedures

1. Select any cell in the table.
2. Select the Data tab.
3. Select Sort in the Sort & Filter group.
4. Select the Column Sort by list.
5. Select the name of the column you want to use for the first level of sorting.
6. Select the Sort On list.
7. Select the desired option.
8. Select the Order list.
9. Select the desired option.
10. Select Add Level.
11. Select the Column Then by list.
12. Select the name of the column you want to use for the second level of sorting.
13. Select the Sort On list.
14. Select the desired option.
15. Select the Order list.
16. Select the desired option.
17. Add additional levels of sorting as required.
18. Select OK.

Step-by-Step

Sorting data by multiple levels.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select any cell in the table. &lt;br&gt;&lt;i&gt;The cell is selected.&lt;/i&gt;</td>
<td>Click cell G10</td>
</tr>
<tr>
<td>2. Select the Data tab. &lt;br&gt;&lt;i&gt;The Data tab is displayed.&lt;/i&gt;</td>
<td>Click Data</td>
</tr>
<tr>
<td>3. Select the Sort button in the Sort &amp; Filter group. &lt;br&gt;&lt;i&gt;The Sort dialog box opens.&lt;/i&gt;</td>
<td>Click Sort</td>
</tr>
<tr>
<td>Steps</td>
<td>Practice Data</td>
</tr>
<tr>
<td>-------</td>
<td>---------------</td>
</tr>
<tr>
<td>4. Select the Column <strong>Sort by</strong> list. A list of table column names is displayed.</td>
<td>Click <strong>Sort by</strong></td>
</tr>
<tr>
<td>5. Select the name of the column you want to use for the first level of sorting. <em>The column name appears in the Sort by box.</em></td>
<td>Click <strong>Region</strong></td>
</tr>
<tr>
<td>6. Select the <strong>Sort On</strong> list. A list of options is displayed.</td>
<td>Click <strong>Sort On</strong></td>
</tr>
<tr>
<td>7. Select the desired option. <em>The selected option appears in the Sort On box.</em></td>
<td>Click <strong>Values</strong>, if necessary</td>
</tr>
<tr>
<td>8. Select the <strong>Order</strong> list. A list of options is displayed.</td>
<td>Click <strong>Order</strong></td>
</tr>
<tr>
<td>9. Select the desired option. <em>The selected option appears in the Order box.</em></td>
<td>Click <strong>A to Z</strong>, if necessary</td>
</tr>
<tr>
<td>10. Select the <strong>Add Level</strong> button. A new row of options is displayed.</td>
<td>Click <strong>Add Level</strong></td>
</tr>
<tr>
<td>11. Select the Column <strong>Then by</strong> list. A list of table column names is displayed.</td>
<td>Click <strong>Then by</strong></td>
</tr>
<tr>
<td>12. Select the name of the column you want to use for the second level of sorting. <em>The column name appears in the Then by box.</em></td>
<td>Click <strong>Year</strong></td>
</tr>
<tr>
<td>13. Select the <strong>Sort On</strong> list. A list of options is displayed.</td>
<td>Click <strong>Sort On</strong></td>
</tr>
<tr>
<td>14. Select the desired option. <em>The selected option appears in the Sort On box.</em></td>
<td>Click <strong>Values</strong>, if necessary</td>
</tr>
<tr>
<td>15. Select the <strong>Order</strong> list. A list of options is displayed.</td>
<td>Click <strong>Order</strong></td>
</tr>
<tr>
<td>16. Select the desired option. <em>The selected option appears in the Order box.</em></td>
<td>Click <strong>Smallest to Largest</strong>, if necessary</td>
</tr>
</tbody>
</table>
**Steps** | **Practice Data**
--- | ---
17. Add additional levels of sorting as required.  
*The additional sort levels are displayed in the Sort dialog box.*  
Follow the instructions shown below the table before continuing on to the next step
18. Select **OK**.  
*The Sort dialog box closes and the table data is sorted.*  
Click **OK**

Click the **Add Level** button. Select the Column **Then By** list and click **Month**. Select the **Sort On** list and click **Values**, if necessary. Select the **Order** list and click **Custom List**. In the Custom Lists dialog box, select the **Jan, Feb, Mar, Apr, May, Jun** option from the **Custom lists** box, then click **OK**.

*Return to the table and continue on to the next step (step 18).*

**Practice the Concept:** Click the **Sort** button to reopen the Sort dialog box. Add another sort level to sort by **Product** values in **A to Z** order. Notice that the new level is added just after the first level. Use the **Move Down** button at the top of the Sort dialog box to move the new sort level to the bottom of the list of levels. Click **OK** to apply the new sort level. Notice that where there is more than one row within a Region with the same Month and Year (such as the Dec 2006 rows in the **Northeast** region), they are now sorted by Product.

Use the **Undo** button on the **Quick Access Toolbar** to undo all sorting and return the table to its unsorted state.

---

**USING TEXT FILTERS**

**Discussion**

When a table column contains text entries, the Filter menu for the column offers several special Text Filters which provide powerful options for filtering the data. Instead of simply filtering the data by selecting one or more column entries, you can filter the data to display all entries that begin with the same characters or end with the same characters, such as all entries that begin with **sport**. You can filter to display all entries that contain the same characters anywhere in the entry, such as entries that contain **sport** somewhere in the entry. You can also filter to display all entries that do not contain **sport**.

When you select one of the Text Filters from the Filter menu, the Custom AutoFilter dialog box opens with the chosen filter type pre-selected. You simply need to enter the characters by which you want to filter. You can specify a second filter criteria in the dialog box, if desired. When you specify a second filter criteria, you must also choose whether both criteria need to be met to display a row in the filtered data (choose **And**) or whether a row that meets either criteria should be displayed (choose **Or**).
Using text filters

![Image of Excel table with filters applied]

You can also use wildcard characters when typing matching text into the right-hand boxes in the Custom AutoFilter dialog box. Use ? (question mark) to match a single unknown character (b?lls will match balls, bells, blls, bbls, and so on). Use * (asterisk) to match any number of unknown characters (r*t will match rat and rot but will also match roden and radiant). Wildcards can be particularly useful for coping with misspellings in your data.

When you have used filters on several columns in the table, you can clear all the filters by clicking the Clear button in the Sort & Filter group on the Data tab.

Procedures

1. Select the desired Filter arrow.
2. Point to Text Filters.
3. Select the desired text filter option.
4. Enter the desired matching text in the box to the right of the selected text filter.
5. Enter a second filter criteria in the dialog box, if desired.

6. Select \[\text{OK}\].

---

**Step-by-Step**

Filter data using text filters.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the desired Filter arrow. &lt;br&gt; <em>The Filter menu opens.</em></td>
<td>Click Purchaser []</td>
</tr>
<tr>
<td>2. Point to Text Filters. &lt;br&gt; <em>The Text Filters submenu opens.</em></td>
<td>Point to Text Filters</td>
</tr>
<tr>
<td>3. Select the desired text filter option. &lt;br&gt; <em>The Custom AutoFilter dialog box opens with the desired filter pre-selected.</em></td>
<td>Click Contains</td>
</tr>
<tr>
<td>4. Enter the desired matching text in the box to the right of the selected text filter. &lt;br&gt; <em>The text appears in the box.</em></td>
<td>Type sport</td>
</tr>
<tr>
<td>5. Enter a second filter criteria in the dialog box, if desired. &lt;br&gt; <em>The desired criteria appear in the second row of boxes.</em></td>
<td>Follow the instructions shown below the table before continuing on to the next step</td>
</tr>
<tr>
<td>6. Select the OK button. &lt;br&gt; <em>The Custom AutoFilter dialog box closes and the table data is filtered.</em></td>
<td>Click [\text{OK}]</td>
</tr>
</tbody>
</table>

Select the left-hand list in the second row of boxes in the dialog box. Scroll as necessary and select **does not contain**. Click in the right-hand box in the second row of boxes and type **city**. Select the **And** option between the two rows of boxes, if necessary.

Return to the table and continue on to the next step (step 6).

**Practice the Concept:** Select the **Product** Filter arrow and point to **Text Filters**. Select **Ends With** from the submenu. In the Custom AutoFilter dialog box, type **balls** in the right-hand box in the first row. Select the left-hand list in the second row. Scroll as necessary and select **ends with**. Click in the right-hand box in the second row and type **machines**. Select the **Or** option, then click **OK**. Notice that the filtered data displays Products that end with **balls** or that end with **machines**.
Click the **Clear** button in the **Sort & Filter** group on the **Data** tab to clear the filters from all the columns.

**USING NUMBER FILTERS**

**Discussion**

When a table column contains number entries, the Filter menu for the column offers several special Number Filters which provide powerful options for filtering the data. Instead of simply filtering the data by selecting one or more column entries, you can filter the data to display entries that are **Greater Than**, **Greater Than or Equal To**, **Less Than**, or **Less Than or Equal To** a specified number. You can also filter to display all entries that fall between two specified numbers or that are not equal to a specified number.

When you select any of the first seven Number Filters from the Number Filters submenu, the Custom AutoFilter dialog box opens with the chosen filter type pre-selected. You simply need to enter the number by which you want to filter. You can specify a second filter criteria in the dialog box, if desired. When you specify a second filter criteria, you must also choose whether both criteria need to be met to display a row in the filtered data (choose **And**) or whether a row that meets either criteria should be displayed (choose **Or**).

The **Top 10** number filter goes a lot further than its name implies. Although it is preset to show the top ten number entries by value, you can change the options to show the bottom values instead and you can change the number of values to any number you require. You can also change an option to display values in the top, or bottom, ten percent (or the top three percent, bottom 15 percent, etc.)

When you select the Top 10 number filter, Excel opens the Top 10 AutoFilter dialog box. When you use the Above Average or Below Average number filters, no dialog box is displayed; Excel immediately calculates the average value in the column and displays only the values that are above, or below, the average value.
Using number filters

- When you have used filters on several columns in the table, you can clear all the filters by clicking the **Clear** button in the **Sort & Filter** group on the **Data** tab.

- Although the Custom AutoFilter dialog box indicates that you can use wildcard characters, wildcards can only be used with text filters, not number filters.

### Procedures

1. Select the desired Filter arrow.
2. Point to **Number Filters**.
3. Select the desired number filter option.
4. Enter the desired number in the box to the right of the selected number filter.
5. Enter a second filter criteria in the dialog box, if desired.
6. Select **OK**.
**Step-by-Step**

Filter data using number filters.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the desired Filter arrow.</td>
<td>Click Sales</td>
</tr>
<tr>
<td><em>The Filter menu opens.</em></td>
<td></td>
</tr>
<tr>
<td>2. Point to <strong>Number Filters</strong>.</td>
<td>Point to <strong>Number Filters</strong></td>
</tr>
<tr>
<td><em>The Number Filters submenu opens.</em></td>
<td></td>
</tr>
<tr>
<td>3. Select the desired number filter option.</td>
<td>Click <strong>Greater Than</strong></td>
</tr>
<tr>
<td>*The Custom AutoFilter dialog box opens with the desired filter pre-</td>
<td></td>
</tr>
<tr>
<td>selected.*</td>
<td></td>
</tr>
<tr>
<td>4. Enter the desired number in the box to the right of the selected</td>
<td>Type <strong>1000</strong></td>
</tr>
<tr>
<td>number filter.</td>
<td></td>
</tr>
<tr>
<td><em>The number appears in the box.</em></td>
<td></td>
</tr>
<tr>
<td>5. Enter a second filter criteria in the</td>
<td>Follow the instructions</td>
</tr>
<tr>
<td>dialog box, if desired.</td>
<td>shown below the table</td>
</tr>
<tr>
<td><em>The desired criteria appear in the second row of boxes.</em></td>
<td>before continuing on to</td>
</tr>
<tr>
<td></td>
<td>the next step</td>
</tr>
<tr>
<td>6. Select the <strong>OK</strong> button.</td>
<td>Click <strong>OK</strong></td>
</tr>
<tr>
<td>*The Custom AutoFilter dialog box closes and the table data is</td>
<td></td>
</tr>
<tr>
<td>filtered.*</td>
<td></td>
</tr>
</tbody>
</table>

Select the left-hand list in the second row of boxes in the dialog box. Scroll as necessary and select **is less than or equal to**. Click in the right-hand box in the second row of boxes and type **2500**. Select the **And** option between the two rows of boxes, if necessary.

*Return to the table and continue on to the next step (step 6).*

**Practice the Concept:** Select the **Sales** Filter button and point to **Number Filters**. Select **Top 10** from the submenu. In the Top 10 AutoFilter dialog box, select **Bottom** in the first box, **15** in the second box and **Percent** in the third box, then click **OK**. Notice that only three values lie in the bottom 15 percent.

Open the Top 10 AutoFilter dialog box again and change Percent to **Items**, then click **OK**. Notice that the filtered list now contains 15 rows but that they are not in any particular order. Click the **Sales** Filter button and select **Sort Largest to Smallest**.

Click the **Clear** button in the **Sort & Filter** group on the **Data** tab to clear both sorting and filtering from all the columns.
Close TABLE.XLSX.

**USING DATA VALIDATION**

### Discussion

Tables can contain incorrect information due to data entry errors. One method of controlling the accuracy of data entered is to place validation limits on the type of data to be entered and to decide whether or not blank entries are allowed.

Using data validation, you can restrict the type of data allowed in a cell and the minimum, maximum, or upper and lower limits for whole numbers, decimals, dates, or times. If the cell will contain text, you can set an upper and lower limit for the number of characters permitted.

When a user enters an invalid entry into a cell that contains data restrictions, Excel opens a Microsoft Office Excel message box, called an alert, which explains that the entry is not valid and only restricted values can be entered into this cell.

![Using data validation](image)

**You can copy the data validation from one cell to another using the Validation option in the Paste Special dialog box.**

**Selecting Custom from the Allow list on the Settings page in the Data Validation dialog box allows you to enter or refer to cell containing a logic formula. The formula must calculate a true or false result, with true results being valid entries and false results being invalid entries.**

**You can use the Data Validation feature for any cell data. Its use is not restricted to Table data.**
Procedures

1. Select the column data for which you want to restrict data entry.
2. Select the Data tab.
3. Select the left-hand part of the Data Validation button in the Data Tools group.
4. Select the Settings tab.
5. Select the Allow list.
6. Select the desired option.
7. Select the Data list.
8. Select the desired option.
9. Enter the desired limits.
10. Select or deselect the Ignore Blank option, as desired.
11. Select OK.

Step-by-Step

From the Student Data directory, open TABLE2.XLSX.
Use data validation to restrict data entry.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the column data for which you want to restrict data entry. <em>The column data is selected.</em></td>
<td>Click ↓ above Year</td>
</tr>
<tr>
<td>2. Select the Data tab. <em>The Data tab is displayed.</em></td>
<td>Click Data</td>
</tr>
<tr>
<td>3. Select the left-hand part of the Data Validation button in the Data Tools group. <em>The Data Validation dialog box opens.</em></td>
<td>Click Data Validation</td>
</tr>
<tr>
<td>4. Select the Settings tab. <em>The Settings page is displayed.</em></td>
<td>Click Settings, if necessary</td>
</tr>
</tbody>
</table>
### Steps

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 5. Select the **Allow** list.  
*A list of options is displayed.* | Click **Allow** |
| 6. Select the desired option.  
*The desired option appears in the Allow box.* | Click **Whole number** |
| 7. Select the **Data** list.  
*A list of options is displayed.* | Click **Data** |
| 8. Select the desired option.  
*The desired option appears in the Data box and one or more boxes (depending on the option selected) appear below the Data box for entering limit values.* | Click **between** |
| 9. Enter the desired limits.  
*The limits appear in the appropriate boxes.* | Follow the instructions shown below the table before continuing on to the next step |
| 10. Select or deselect the **Ignore Blank** option, as desired.  
*The option is selected or deselected accordingly.* | Click **[ ] Ignore Blank** to deselect it |
| 11. Select **OK**.  
*The Data Validation dialog box closes and data validation is applied to the selected cells.* | Click **OK** |

Click in the **Minimum** box and type **2006**. Click in the **Maximum** box and type **2010**.

*Return to the table and continue on to the next step (step 10).*

Type **2004** in cell **E9** and press [Enter]. A Microsoft Office Excel message box opens, informing you that your entry is not valid. Select **Retry** to close the message box. Type **2007** and press [Enter].

Press [Delete] to delete the entry in cell **E9**. Notice the **Error** button that appears beside the cell. Click the **Error** button and select **Display Type Information** from the menu that appears. Notice the **Field Type Information** message that opens. Click **OK** to close the message. Type **2007** in cell **E9** and press [Enter].
Validating Data Using a List

Discussion

You can use data validation to restrict cell entry to specific values in a list. The list values can be text or numbers, such as a list of region names or a list of exact prices instead of minimum and maximum numbers.

When you restrict data entry in a cell to a specified list, you can choose whether a drop-down arrow appears when the user selects the cell. If you choose to use the drop-down option, the user can either select a valid entry from the list or type a valid entry. If you choose not to use the drop-down option, the user must type a valid entry. In both cases, entries that are not in the validation list are considered invalid.

Validating data using a list

The validation list can be stored in another sheet in the workbook, if desired. You could store all your validation lists in one sheet. To make it easy to use the validation lists, create a name for each list, such as RegionList, using the Name Box. In the Data Validation dialog box, you can then simply type =RegionList in the Source box to select the list. This also makes it easy to find and update a validation list if you need to add new entries. Use the Name Box to go to the list and insert cells within the list to contain the new entries. Any cells using RegionList for data validation will automatically recognize the new entries as valid entries.
Procedures

1. Select the column data for which you want to restrict data entry.
2. Select the Data tab.
3. Select the left-hand part of the Data Validation button in the Data Tools group.
4. Select the Settings tab.
5. Select the Allow list.
6. Select List.
7. Click the Collapse Dialog button in the Source box.
8. Drag to select the list range in the worksheet.
9. Click the Expand Dialog button in the Data Validation dialog box.
10. Select or deselect the Ignore Blank option, as desired.
11. Select or deselect the In-cell dropdown option, as desired.
12. Select OK.

Step-by-Step
Validate table data using a list.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the column data for which you want to restrict data entry. <em>The column data is selected.</em></td>
<td>Click ↓ above Region</td>
</tr>
<tr>
<td>2. Select the Data tab. <em>The Data tab is displayed.</em></td>
<td>Click Data</td>
</tr>
<tr>
<td>3. Select the left-hand part of the Data Validation button in the Data Tools group. <em>The Data Validation dialog box opens</em></td>
<td>Click Data Validation</td>
</tr>
<tr>
<td>Steps</td>
<td>Practice Data</td>
</tr>
<tr>
<td>-------</td>
<td>---------------</td>
</tr>
</tbody>
</table>
| 4. Select the **Settings** tab.  
   *The Settings page is displayed.* | Click **Settings**, if necessary |
| 5. Select the **Allow** list.  
   *A list of options is displayed.* | Click **Allow**  
   ![Allow](image) |
| 6. Select **List**.  
   *List appears in the Allow box and a Source box appears.* | Click **List** |
| 7. Click the **Collapse Dialog** button in the **Source** box.  
   *The Data Validation dialog box collapses.* | Click ![Collapse](image) in the **Source** box |
| 8. Drag to select the list range in the worksheet.  
   *A blinking marquee appears around the selected range and the address appears in the Data Validation dialog box.* | Drag to select G1:G5, and release the mouse button |
| 9. Click the **Expand Dialog** button in the Data Validation dialog box.  
   *The Data Validation dialog box expands.* | Click ![Expand](image) in the Data Validation dialog box |
| 10. Select or deselect the **Ignore Blank** option, as desired.  
   *The option is selected or deselected accordingly.* | Ensure ![Ignore Blank](image) is selected |
| 11. Select or deselect the **In-cell dropdown** option, as desired.  
   *The option is selected or deselected accordingly.* | Ensure ![In-cell dropdown](image) is selected |
| 12. Select **OK**.  
   *The Data Validation dialog box closes and data validation is applied to the selected cells.* | Click ![OK](image) |

Select cell C10. Notice the drop-down arrow that appears to the right of the cell. Click the drop-down arrow and select **Southeast** from the list. Type **West** into cell C10 and press [Enter]. A Microsoft Office Excel message box opens, informing you that your entry is not valid. Select **Cancel** to close the message box. Click the drop-down arrow and select **Northeast**.
Creating a Custom Error Message

Discussion

When a user enters an invalid entry into a cell with restricted data entry, Excel opens a message box, informing the user that the entry is invalid. You can create a custom alert message that appears in the message box instead of the default message.

Excel includes three styles of alert message boxes: Stop, Warning, and Information. Each style provides different buttons in the message box and, more importantly, different restrictions. The default error alert style is Stop, which does not allow invalid data to be entered into cells. Both the Warning and Information styles allow invalid data to be entered.

Creating a custom error message

You can enable the Apply these changes to all other cells with the same settings option on the Settings page in the Data Validation dialog box. This option applies any changes you have made to all cells that contain the same data validation as the changed cells.

You can use the Input Message page in the Data Validation dialog box to create a message that appears in a ScreenTip when the user selects a cell. This message can provide information for the user about the type of data to be entered.
Procedures

1. Select the column data for which you want to customize the error message.
2. Select the Data tab.
3. Select the left-hand part of the Data Validation button in the Data Tools group.
4. Select the Error Alert tab.
5. Select the Style list.
6. Select the desired style.
7. Select the Title box.
8. Type the desired title.
9. Select the Error message box.
10. Type the desired error message.
11. Select OK.

Step-by-Step

Create a custom error message.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the column data for which you want to customize the error message. The column data is selected.</td>
<td>Click ➡ above Year</td>
</tr>
<tr>
<td>2. Select the Data tab. The Data tab is displayed.</td>
<td>Click Data</td>
</tr>
<tr>
<td>3. Select the left-hand part of the Data Validation button in the Data Tools group. The Data Validation dialog box opens.</td>
<td>Click Data Validation</td>
</tr>
<tr>
<td>4. Select the Error Alert tab. The Error Alert page is displayed.</td>
<td>Click Error Alert</td>
</tr>
<tr>
<td>Steps</td>
<td>Practice Data</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>---------------------------------------------------</td>
</tr>
<tr>
<td>5. Select the <strong>Style</strong> list.</td>
<td>Click <strong>Style</strong></td>
</tr>
<tr>
<td><em>A list of styles is displayed.</em></td>
<td></td>
</tr>
<tr>
<td>6. Select the desired style.</td>
<td>Click <strong>Warning</strong></td>
</tr>
<tr>
<td><em>The desired style appears in the <strong>Style</strong> box.</em></td>
<td></td>
</tr>
<tr>
<td>7. Select the <strong>Title</strong> box.</td>
<td>Click in the <strong>Title</strong> box</td>
</tr>
<tr>
<td><em>The insertion point appears in the <strong>Title</strong> box.</em></td>
<td></td>
</tr>
<tr>
<td>8. Type the desired title.</td>
<td>Type <strong>Year Error</strong></td>
</tr>
<tr>
<td><em>The text appears in the <strong>Title</strong> box.</em></td>
<td></td>
</tr>
<tr>
<td>9. Select the <strong>Error message</strong> box.</td>
<td>Click in the <strong>Error message</strong> box</td>
</tr>
<tr>
<td><em>The insertion point appears in the <strong>Error message</strong> box.</em></td>
<td></td>
</tr>
<tr>
<td>10. Type the desired error message.</td>
<td>Type <strong>Year should be between 2006 and 2010!</strong></td>
</tr>
<tr>
<td><em>The text appears in the <strong>Error message</strong> box.</em></td>
<td></td>
</tr>
<tr>
<td>11. Select <strong>OK</strong>.</td>
<td>Click <strong>OK</strong></td>
</tr>
<tr>
<td><em>The Data Validation dialog box closes and the error message is saved.</em></td>
<td></td>
</tr>
</tbody>
</table>

Type **2005** in cell E9 and press [Enter]. A warning box opens with your custom title and message. Select **Yes** to enter your text despite the warning. Notice the green triangle in the top-left corner of cell E9. Select cell E9. Notice the **Error** button that appears beside the cell. Although Excel allowed the entry, it still warns that the entry violates data validation rules.

With cell E9 selected, click the left-hand part of the **Data Validation** button in the **Data Tools** group. On the **Error Alert** page, change the **Style** to **Stop**. Change the word **should** in the **Error message** box to **must**. Click the **Settings** tab and select the **Apply these changes to all other cells with the same settings** option. Click **OK**.

Select cell E12. Type **2005** and press [Enter]. Notice that the error message does not allow you to continue with an incorrect entry. Click the **Cancel** button to close the message. Type **2007** in cell E9.
Discussion

You can remove all the restrictions on data entry in a cell by clearing the data validation from the cell. Removing data validation allows any entry to be entered in a cell.

- Selecting the Clear All button on any page in the Data Validation dialog box clears the restrictions on all the pages for the selected range.

Procedures

1. Select the cells with the data validation you want to remove.
2. Select the Data tab.
3. Select the left-hand part of the Data Validation button in the Data Tools group.
4. Select Clear All.
5. Select OK.

Step-by-Step

Remove data validation.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the cells with the data validation you want to remove. The cells are selected.</td>
<td>Click ‡ above Year</td>
</tr>
<tr>
<td>2. Select the Data tab. The Data tab is displayed.</td>
<td>Click Data</td>
</tr>
</tbody>
</table>
**Steps** | **Practice Data**
--- | ---
3. Select the left-hand part of the *Data Validation* button in the *Data Tools* group.  
*The Data Validation dialog box opens.* | Click ![Data Validation](Data%20Validation.png)

4. Select *Clear All.*  
*The restrictions are cleared on all pages in the Data Validation dialog box.* | Click ![Clear All](Clear%20All.png)

5. Select *OK.*  
*The Data Validation dialog box closes and data validation is removed from the selected cells.* | Click ![OK](OK.png)

Click in any cell to deselect the range.  
Close **TABLE2.XLSX.**
EXERCISE

WORKING WITH TABLES

Task

Use table features.

1. Open TABLE1EX.XLSX.

2. Format the sales data as a table using a table style of your choice.

3. Change the table name to ProductSales.

4. Filter the table to display only information on the sales rep Terry Caracio.

5. Sort the list by Inv Num with the largest number at the top.

6. Add another filter to show only the Golf Balls and Gloves sold by Terry.

7. Clear all filtering and sorting.

8. Insert a new column in the table between Product and Inv Num. Then delete the new column.

9. Add a calculated column in column G by creating a formula in cell G5 that multiplies the Price Each figure by the Qty Sold figure. Change the column header to Sales.

10. Add emphasized formatting to the first and last columns.

11. Filter to show only sales of Footballs.

12. Display the Total Row.

13. Change the calculation for the Sales total to Max.

14. Add a total for the Qty Sold column to calculate the Average.

15. Clear the filter from the Product column.

16. Scroll as necessary and select cell G67. Press [Tab] and enter the following data:

<table>
<thead>
<tr>
<th>Column</th>
<th>Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>Product</td>
<td>Gloves</td>
</tr>
<tr>
<td>Inv Num</td>
<td>4230</td>
</tr>
<tr>
<td>Sales Rep</td>
<td>John Carpenter</td>
</tr>
<tr>
<td>Column</td>
<td>Data</td>
</tr>
<tr>
<td>-----------</td>
<td>-----------</td>
</tr>
<tr>
<td>Date Sold</td>
<td>7/23/2007</td>
</tr>
<tr>
<td>Price Each</td>
<td>12</td>
</tr>
<tr>
<td>Qty Sold</td>
<td>19</td>
</tr>
</tbody>
</table>

17. Add data validation to the **Product** column using the **ProductList** in column I.

18. Add a custom error message to the data validation for the **Product** column using the **Stop** style with the title **Product Error** and the message **Select a valid Product from the drop-down list!**

19. Select a cell in the **Product** column and test the data validation by typing **shoes**. Click **Cancel** in the error message box.

20. Use a **Number Filter** on the **Sales** column to display **Below Average** sales.

21. Use a **Number Filter** on the **Sales** column to display the **top 5%**. Then clear the filter from the **Sales** column.

22. Use a **Text Filter** on the **Product** column to show only sales of **balls**.

23. Close the workbook without saving it.
LESSON 2 -
WORKING WITH ADVANCED FILTERS

In this lesson, you will learn how to:

- Create a criteria range
- Use a criteria range
- Show all records
- Use comparison criteria
- Use an advanced And condition
- Use an advanced Or condition
- Copy filtered records
- Use database functions
- Find unique records
- Remove duplicates from a table
Creating a Criteria Range

Discussion

You can use advanced filters to create more complicated conditions to filter a table. To use advanced filters, you must specify the table range and the criteria range.

The table range is the table including the Header Row.

The criteria range is a separate range of cells in the worksheet in which you will enter selection criteria. The criteria range can be located anywhere in the worksheet outside the table, or in another worksheet. The criteria range consists of one row of criteria labels and at least one row of search conditions. The criteria range must contain at least two rows and one column.

Although the criteria labels are not case-sensitive, they must be spelled exactly the same as the column names in the table. The most accurate method of ensuring this consistency is to copy the table Header Row and paste it into the top row of the criteria range.

You can change criteria as often as desired. You can also create more than one criteria range in a worksheet; however, only one criteria range can be used at a time.
There must be at least one blank row between the criteria range and the table.

Procedures

1. Drag to select the table Header Row.
2. Click the Copy button in the Clipboard group.
3. Select the cell where you want to create the criteria range.
4. Click the top part of the Paste button in the Clipboard group.

Step-by-Step

From the Student Data directory, open EMPLOY8.XLSX. Create a criteria range.

If necessary, display the Home tab.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Drag to select the table Header Row.</td>
<td>Drag to select A9:F9</td>
</tr>
<tr>
<td><em>The column headers are selected.</em></td>
<td></td>
</tr>
<tr>
<td>2. Click the Copy button in the Clipboard group.</td>
<td>Click</td>
</tr>
<tr>
<td><em>A blinking marquee appears around the copied selection.</em></td>
<td></td>
</tr>
<tr>
<td>3. Select the cell where you want to create the criteria range.</td>
<td>Click cell A1</td>
</tr>
<tr>
<td><em>The active cell appears in the new location.</em></td>
<td></td>
</tr>
<tr>
<td>4. Click the top part of the Paste button in the Clipboard group.</td>
<td>Click</td>
</tr>
<tr>
<td><em>The column labels for the criteria range appear in the new location.</em></td>
<td></td>
</tr>
</tbody>
</table>

Press [Esc] to deselect the copy range. Click in any cell to deselect the paste range.
Using a Criteria Range

Discussion

To filter a table to find records that match a specific number, date, or text, you can enter matching criteria in the row below the criteria labels.

For example, to filter the table to show all employees in the sales department, you would type sales in the row below the Department heading in the criteria range. Text in the criteria range is not case-sensitive. If you type sales, Excel will search the Department column in the table for sales, Sales, or SALES.

You specify the ranges containing the table and criteria in the Advanced Filter dialog box. The table range contains the Header Row and data and the criteria range contains the criteria labels and the conditions for which you want to search.

If the active cell is positioned in the table before you open the Advanced Filter dialog box, Excel automatically selects the table range. Otherwise, you can manually enter the table range by typing the range address or by selecting the range in the worksheet.

You can use comparison criteria to enter criteria. Comparison criteria include wildcards for text and operators for numbers.
When you use the Advanced Filter, Excel removes the Filter buttons from the Header Row of the table. To reinstate the Filter buttons in the Header Row, click the Filter button in the Sort & Filter group on the Data tab. This also clears any Advanced Filtering from the table.

Procedures

1. Select the cell below the criteria label corresponding to the table column you want to search.
2. Type the desired criteria.
3. Press Enter.
4. Select any cell in the table.
5. Select the Data tab.
7. Click the Collapse Dialog button in the Criteria range box.
8. Drag to select the criteria range.
9. Click the Expand Dialog button in the Advanced Filter - Criteria Range dialog box.
10. Select OK.

Step-by-Step

Use a criteria range to search a list.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>Click cell D2</td>
</tr>
<tr>
<td></td>
<td>The cell is selected.</td>
</tr>
<tr>
<td>2.</td>
<td>Type sales</td>
</tr>
<tr>
<td></td>
<td>The text appears in the cell and in the Formula Bar.</td>
</tr>
</tbody>
</table>
**Steps** | **Practice Data**
---|---
3. Press [Enter].
   *The text is entered into the cell.* | Press [Enter]
4. Select any cell in the table.
   *The cell is selected.* | Click cell A9
5. Select the **Data** tab.
   *The **Data** tab is displayed.* | Click **Data**
6. Select the **Advanced** button in the **Sort & Filter** group.
   *The Advanced Filter dialog box opens with the table range selected in the list range box.* | Click ![Advanced](Advanced.png)
7. Click the **Collapse Dialog** button in the **Criteria range** box.
   *The Advanced Filter dialog box collapses.* | Click ![criteria range](criteria_range.png)
8. Drag to select the criteria range.
   *A blinking marquee indicates that the criteria range is selected.* | Scroll to the top of the worksheet and drag to select A1:F2
9. Click the **Expand Dialog** button in the Advanced Filter - Criteria Range dialog box.
   *The Advanced Filter dialog box expands.* | Click ![criteria range](criteria_range.png)
10. Select **OK**.
    *The Advanced Filter dialog box closes and only those records matching the criteria appear.* | Click ![OK](OK.png)

**SHOWING ALL RECORDS**

**Discussion**

At any time when a data list is filtered, you can use the **Clear** button to clear the filter and display all the table data. It does not, however, delete the criteria in the criteria range.
Procedures

1. Select the Data tab.
2. Select in the Sort & Filter group.

Step-by-Step

Show all rows in a table.

If necessary, create criteria to filter the table.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the Data tab.  
   *The Data tab is displayed.* | Click Data |
| 2. Select the Clear button in the Sort & Filter group.  
   *All rows in the table are displayed.* | Click Clear |

Delete the criteria sales in cell D2.

**USING COMPARISON CRITERIA**

Discussion

You can also use comparison criteria in a criteria range when you want to find text or numeric values.

When specifying criteria to find text values, you can enter the first few characters of text to search for all entries beginning with those characters. Entering **ba** as search criteria for a column of last names finds names such as Baker, Bachman, and so on.

You can also use special characters called wildcards when creating criteria. Wildcards represent one or more characters in a search. You can use one of two wildcard characters in search criteria. A question mark (?) represents a single character, whereas an asterisk (*) can represent an unspecified number of characters. Typing **?erry** as search criteria for a column of first names will find records with first names beginning with any single character followed by *erry*, such as Terry or Perry. Typing **F*s** as search criteria for a column of last names will find any records with last names starting with F and ending in s, such as Feldgus and Fredericks. Wildcard characters only work for finding text values.
You can use operators as comparison criteria for finding numeric values. You can use any of the following comparison operators:

<table>
<thead>
<tr>
<th>Operator</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>equal to</td>
</tr>
<tr>
<td>&lt;</td>
<td>less than</td>
</tr>
<tr>
<td>&lt;=</td>
<td>less than or equal to</td>
</tr>
<tr>
<td>&gt;</td>
<td>greater than</td>
</tr>
<tr>
<td>&gt;=</td>
<td>greater than or equal to</td>
</tr>
<tr>
<td>&lt;&gt;</td>
<td>not equal to</td>
</tr>
</tbody>
</table>

For example, to search for all employees with salaries that are less than or equal to $35,000, you type `<=35000` in the cell below the Salary criteria label.

**Using an Advanced AND Condition**

**Discussion**

You can create **And** conditions in a criteria range. In an **And** condition, a table row must meet all the criteria to be included in the filtered results. For example, you can find all employees who work in the Sales department and whose salaries are less than $35,000. This example is a typical **And** condition, where both conditions must be met for a table row to be selected.

All the criteria for **And** conditions must be located in the same row in the criteria range.
Procedures

1. Select the cell below the criteria label corresponding to the first table column you want to search.
2. Type the desired criteria.
3. Press [Enter].
4. Select the cell below the criteria label corresponding to the second table column you want to search.
5. Type the desired criteria.
6. Press [Enter].
7. Select any cell in the table.
8. Select the Data tab.
10. Click the Collapse Dialog button in the Criteria range box.
11. Drag to select the criteria range.
12. Click the Expand Dialog button in the Advanced Filter - Criteria Range dialog box.
13. Select \[OK\].

### Step-by-Step

Use an **And** condition in a criteria range.

If necessary, copy the table Header Row to row 1 and delete any previous criteria in the criteria range.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the cell below the criteria label corresponding to the first table column you want to search. <em>The cell is selected.</em></td>
<td>Click cell D2</td>
</tr>
<tr>
<td>2. Type the desired criteria. <em>The text appears in the cell and in the Formula Bar.</em></td>
<td>Type <em>sales</em></td>
</tr>
<tr>
<td>3. Press [Enter]. <em>The text is entered into the cell.</em></td>
<td>Press [Enter]</td>
</tr>
<tr>
<td>4. Select the cell below the criteria label corresponding to the second table column you want to search. <em>The cell is selected.</em></td>
<td>Click cell E2</td>
</tr>
<tr>
<td>5. Type the desired criteria. <em>The text appears in the cell and in the Formula Bar.</em></td>
<td>Type <em>2</em></td>
</tr>
<tr>
<td>6. Press [Enter]. <em>The text is entered into the cell.</em></td>
<td>Press [Enter]</td>
</tr>
<tr>
<td>7. Select any cell in the table. <em>The cell is selected.</em></td>
<td>Click cell A9</td>
</tr>
<tr>
<td>8. Select the <strong>Data</strong> tab. <em>The Data tab is displayed.</em></td>
<td>Click <strong>Data</strong></td>
</tr>
<tr>
<td>9. Select the <strong>Advanced</strong> button in the <strong>Sort &amp; Filter</strong> group. <em>The Advanced Filter dialog box opens with the table range selected in the list range box.</em></td>
<td>Click <strong>Advanced</strong></td>
</tr>
</tbody>
</table>
Steps | Practice Data
---|---
10. Click the **Collapse Dialog** button in the **Criteria range** box. 
*The Advanced Filter dialog box collapses.* | Click [Collapse Dialog](#) in the Criteria range box

11. Drag to select the criteria range. 
*A blinking marquee indicates that the criteria range is selected.* | Scroll to the top of the worksheet and drag to select A1:F2

12. Click the **Expand Dialog** button in the Advanced Filter - Criteria Range dialog box. 
*The Advanced Filter dialog box expands.* | Click [Expand Dialog](#) in the Advanced Filter - Criteria Range dialog box

13. Select **OK**. 
*The Advanced Filter dialog box closes and only those rows matching all the criteria are displayed.* | Click [OK](#)

Delete the criteria in the criteria range and show all table data.

## USING AN ADVANCED OR CONDITION

**Discussion**

You can create **Or** conditions in a criteria range. In an **Or** condition, if a table row meets any of the criteria it is included in the filtered results. For example, you can find all employees who work in the **Administration** department or whose salaries are less than $22,000. This example is a typical **Or** condition, in which a table row meeting either condition is selected.

The criteria for **Or** conditions must be located in different rows in the criteria range. Each **Or** condition occupies its own row. You can use as many rows as you need.
Using an advanced Or condition

It is important to note that when selecting the criteria range for an **Or** condition, you must expand the criteria range to include all rows containing criteria.

To make it easy to switch between different sizes of criteria range, use the **Name Box** to create names for each size of criteria range, such as **Criteria1**, **Criteria2**, **Criteria3**, and so on. Then, in the Advanced Filter dialog box, you can simply type the name of the Criteria range you want to use.

**Procedures**

1. Select the cell below the criteria label corresponding to the first table column you want to search.
2. Type the desired criteria.
3. Press **[Enter]**.
4. Select the cell two rows below the criteria label corresponding to the second table column you want to search.
5. Type the desired criteria.
6. Press **[Enter]**.
7. Select any cell in the table.
8. Select the Data tab.
10. Click the Collapse Dialog button in the Criteria range box.
11. Drag to select all the rows in the criteria range.
12. Click the Expand Dialog button in the Advanced Filter - Criteria Range dialog box.
13. Select OK.

Step-by-Step

Use an Or condition in a criteria range.

If necessary, copy the table Header Row to row 1 and delete any previous criteria in the criteria range.

You will use criteria to find employees who are either in the Administration department or who have a salary greater than or equal to $50,000.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the cell below the criteria label corresponding to the first table column you want to search. The cell is selected.</td>
<td>Click cell D2</td>
</tr>
<tr>
<td>2. Type the desired criteria. The text appears in the cell and in the Formula Bar.</td>
<td>Type administration</td>
</tr>
<tr>
<td>3. Press [Enter]. The text is entered into the cell.</td>
<td>Press [Enter]</td>
</tr>
<tr>
<td>4. Select the cell two rows below the criteria label corresponding to the second table column you want to search. The cell is selected.</td>
<td>Click cell F3</td>
</tr>
<tr>
<td>5. Type the desired criteria. The text appears in the cell and in the Formula Bar.</td>
<td>Type &gt;=50000</td>
</tr>
</tbody>
</table>
### Steps

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 6. Press [Enter].  
*The text is entered into the cell.* | Press [Enter] |
| 7. Select any cell in the database list.  
*The cell is selected.* | Click cell A9 |
| 8. Select the **Data** tab.  
*The Data tab is displayed.* | Click **Data** |
| 9. Select the **Advanced** button in the  
**Sort & Filter** group.  
*The Advanced Filter dialog box opens with the table range selected in the list range box.* | Click **Advanced** |
| 10. Click the **Collapse Dialog** button in the **Criteria range** box.  
*The Advanced Filter dialog box collapses.* | Click in the **Criteria range** box |
| 11. Drag to select all the rows in the criteria range.  
*A blinking marquee indicates that the criteria range is selected.* | Scroll to the top of the worksheet and drag to select A1:F3 |
| 12. Click the **Expand Dialog** button in the Advanced Filter - Criteria Range dialog box.  
*The Advanced Filter dialog box expands.* | Click in the Advanced Filter - Criteria Range dialog box |
| 13. Select **OK**.  
*The Advanced Filter dialog box closes and only rows matching any of the criteria are displayed.* | Click **OK** |

### Practice the Concept:

Delete the **Salary** criteria. Then, find all employees who are either in the **Administration** department or in the **Sales** department.

Remove all criteria and display all table data.

---

**COPYING FILTERED RECORDS**

### Discussion

You can use an advanced filter to find and copy table rows to another area of the worksheet instead of filtering the original table.
Copying filtered records allows you to create different lists of similar records in various areas of the worksheet or on other worksheets. For example, if a table contains details of all employees in all departments, you can create similar data lists of the employees in each department.

![Image showing copying filtered data]

You can also use standard filter options to filter a table and then select the filtered rows and copy them to another location. This also copies the table formatting. The advantage of using an advanced filter is that more complex criteria are possible than with a standard filter.

### Procedures

1. Select the cell below the criteria label corresponding to the table column you want to search.
2. Type the desired criteria.
3. Press [Enter].
4. Select any cell in the table.
5. Select the **Data** tab.
6. Select **Advanced** in the **Sort & Filter** group.
7. Click the **Collapse Dialog** button in the **Criteria range** box.

8. Drag to select the criteria range.

9. Click the **Expand Dialog** button in the Advanced Filter - Criteria Range dialog box.

10. Under **Action**, select the **Copy to another location** option.

11. Click the **Collapse Dialog** button in the **Copy to** box.

12. Select the cell in the upper left corner of the location to which you want to copy the filtered data.

13. Click the **Expand Dialog** button in the Advanced Filter - Copy To dialog box.

14. Select **OK**.

---

**Step-by-Step**

Copy filtered table rows to another location.

If necessary, copy the table Header Row to row 1 and delete any previous criteria in the criteria range.

<table>
<thead>
<tr>
<th><strong>Steps</strong></th>
<th><strong>Practice Data</strong></th>
</tr>
</thead>
</table>
| 1. Select the cell below the criteria label corresponding to the table column you want to search.  
  *The cell is selected.*                                               | Click cell D2                             |
| 2. Type the desired criteria.                                            | Type *sales*                               |
|  1. Type the desired criteria.                                           |                                           |
|  2. Type the desired criteria.                                           |                                           |
| 3. Press [Enter].                                                        | Press [Enter]                             |
|  1. Press [Enter].                                                       |                                           |
| 4. Select any cell in the table.                                         | Click cell A9                             |
|  1. The cell is selected.                                                |                                           |
|  2. The cell is selected.                                                |                                           |
| 5. Select the **Data** tab.                                              | Click **Data**                            |
|  1. The **Data** tab is displayed.                                       |                                           |
|  2. The **Data** tab is displayed.                                       |                                           |
### Steps

<table>
<thead>
<tr>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>Click &quot;Advanced&quot; button in the Sort &amp; Filter group. The Advanced Filter dialog box opens with the table range selected in the list range box.</td>
</tr>
<tr>
<td>Click in the Criteria range box</td>
</tr>
<tr>
<td>Scroll to the top of the worksheet and drag to select A1:F2</td>
</tr>
<tr>
<td>Click in the Advanced Filter - Criteria Range dialog box</td>
</tr>
<tr>
<td>Click &quot;Copy to another location&quot; option</td>
</tr>
<tr>
<td>Click in the Copy to box</td>
</tr>
<tr>
<td>Click cell H9</td>
</tr>
<tr>
<td>Click in the Advanced Filter - Copy To dialog box</td>
</tr>
<tr>
<td>Click OK</td>
</tr>
</tbody>
</table>

### Practice Data

<table>
<thead>
<tr>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>Click &quot;Advanced&quot; button in the Sort &amp; Filter group. The Advanced Filter dialog box opens with the table range selected in the list range box.</td>
</tr>
<tr>
<td>Click in the Criteria range box</td>
</tr>
<tr>
<td>Scroll to the top of the worksheet and drag to select A1:F2</td>
</tr>
<tr>
<td>Click in the Advanced Filter - Criteria Range dialog box</td>
</tr>
<tr>
<td>Click &quot;Copy to another location&quot; option</td>
</tr>
<tr>
<td>Click in the Copy to box</td>
</tr>
<tr>
<td>Click cell H9</td>
</tr>
<tr>
<td>Click in the Advanced Filter - Copy To dialog box</td>
</tr>
<tr>
<td>Click OK</td>
</tr>
</tbody>
</table>

Scroll as necessary to view the copied data.

Then, delete the copied data. Remove all criteria and display all table data.
**USING DATABASE FUNCTIONS**

**Discussion**

Database functions, or Dfunctions, are used to provide calculations based on criteria. For example, from an employee table of all departments, you may want to calculate the salaries of employees just in the sales department. Although you can physically filter the data to display the records from the sales department and total the found records, you can also use a database function to find the answer without filtering the data.

A database function includes three arguments: database, field, and criteria. The database argument is the table (including the Header Row). The field argument is name of the column you want to use in the computation. The criteria argument refers to the cells that define the conditions for the function. For example, in the Dfunction =DSUM(A9:F37,F9,A1:F2), A9:F37 is the database argument (and includes the column labels), F9 is the field argument (the column label of the field you want to calculate), and A1:F2 is the criteria argument.

Naming cells makes it easier to enter, copy, or edit database functions. When the database function refers to an Excel table, the Table Name (which refers to the table data without the Header Row) and Excel’s structured referencing make it easier to use database functions. The only range for which you need to create a name is the Criteria Range. Using names and structured referencing the above Dfunction could be entered as =DSUM(EmpData[#All],“Salary”,Criteria1).

![Using a database function](image)
The field argument (the column to be calculated) can be entered as the cell address of the field label, the column number of the field in the database, or the text of the field label enclosed in double quotation marks. Therefore, F9, 6, or “Salary” can all be used to identify the same field.

If you change or delete the criteria referenced in the Dfunction, the function automatically recalculates. To create database functions for several values in a field, you must create a separate criteria range for each value. Therefore, to display the salaries of two different departments, you will need to create two separate Department criteria ranges. Each criteria range only needs two cells, the Department heading and a cell below it in which to type the department name.

Procedures

1. Select the cell where you want the result of the formula to appear.

2. Click the Insert Function button on the Formula Bar.

3. Select the Or select a category list.

4. Select Database.

5. Select the name of the database function you want to use in the Select a function list box.

6. Select OK.

7. Select the table range (including the Header Row) or type the table name (with [#All] qualifier) in the Database box.

8. Select the Field box.

9. Enter the address or name of the column label of the field you want to use in the formula.

10. Select the Criteria box.

11. Enter the address or name of the criteria range.

12. Select OK.
### Step-by-Step

Use a database function.

If necessary, copy the column labels to row 1 and delete any previous criteria in the criteria range.

Type **production** in cell D2 to enter the criteria. Display the **Name Box** list on the formula bar to view the cell names. The table name is **EmpData** (which refers to just the table data without the Header Row), the one-row (And) criteria range is named **Criteria1**, and the two-row (Or) criteria range is named **Criteria2**.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the cell where you want the result of the formula to appear.  
*The cell is selected.* | Click cell F4 |
| 2. Click the **Insert Function** button on the **Formula Bar**.  
*The Insert Function dialog box opens.* | Click on the **Formula Bar** |
| 3. Select the **Or select a category** list.  
*A list of function categories is displayed.* | Click **Or select a category** |
| 4. Select **Database**.  
*A list of all available database functions is displayed in the Select a function list box.* | Click **Database** |
| 5. Select the name of the database function you want to use in the **Select a function** list box.  
*The function and its arguments appear at the bottom of the Insert Function dialog box.* | Scroll as necessary and click **DSUM** |
| 6. Select **OK**.  
*The Insert Function dialog box closes and the Function Arguments dialog box opens with the insertion point in the Database box.* | Click **OK** |
| 7. Select the table range (including the Header Row) or type the table name (with [All] qualifier) in the Database box.  
*The database reference appears in the formula on the formula bar.* | Type **EmpData[#All]** |
### Steps

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>8. Select the <strong>Field</strong> box.  &lt;br&gt; <em>The insertion point appears in the Field box.</em></td>
<td>Click in the <strong>Field</strong> box</td>
</tr>
<tr>
<td>9. Enter the address or name of the column label of the field you want to use in the formula.  &lt;br&gt; <em>The field reference appears in the formula on the formula bar (Excel will automatically add quotes around the name).</em></td>
<td>Type <em>Salary</em></td>
</tr>
<tr>
<td>10. Select the <strong>Criteria</strong> box.  &lt;br&gt; <em>The insertion point appears in the Criteria box.</em></td>
<td>Click in the <strong>Criteria</strong> box</td>
</tr>
<tr>
<td>11. Enter the address or name of the criteria range.  &lt;br&gt; <em>The range address appears in the formula on the formula bar.</em></td>
<td>Type <em>Criteria1</em></td>
</tr>
<tr>
<td>12. Select <strong>OK</strong>.  &lt;br&gt; <em>The Function Arguments box closes and the result of the function appears in the cell.</em></td>
<td>Click <strong>OK</strong></td>
</tr>
</tbody>
</table>

The correct answer is $466,000, which represents the total salary for people in the Production department.

Change the criteria in cell D2 to *Sales*. Notice that the **DSUM** function in cell F4 recalculates.

Close **EMPLOY8.XLSX**.

---

### Finding Unique Records

#### Discussion

Duplicated data is a common problem in large tables. A duplicate is where all values in one row are an exact match of all the values in another row.

Duplicate values are determined by the value stored in the cell and not necessarily the value displayed. If one cell contains the value 35,000 and another contains the value 35,000.25, but both cells are formatted to display zero decimal places, then both cells appear to contain the same value (35,000). However, Excel examines what is actually stored in the cell and correctly identifies them as different values.
The Advanced Filter dialog box contains an option which lets you filter to show unique records only. This temporarily hides duplicate records but does not remove them.

You do not need to specify a Criteria Range to find all unique records. However, you can use a Criteria Range if needed; for example, if you only want to find the unique records in the sales department.

To remove duplicate values, use the Remove Duplicates button in the Data Tools group on the Data tab.

**Procedures**

1. Select any cell in the table.
2. Select the Data tab.
3. Select the Advanced button in the Sort & Filter group.
4. Select the Unique records only option.
5. Select OK.

**Step-by-Step**

From the Student Data directory, open EMPLOY9.XLSX. Find unique records in a table.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select any cell in the table. The cell is selected.</td>
<td>Click cell A5</td>
</tr>
<tr>
<td>2. Select the Data tab. The Data tab is displayed.</td>
<td>Click Data</td>
</tr>
<tr>
<td>3. Select the Advanced button in the Sort &amp; Filter group. The Advanced Filter dialog box opens with the table range selected in the list range box.</td>
<td>Click Advanced</td>
</tr>
</tbody>
</table>
Steps | Practice Data
--- | ---
4. Select the **Unique records only** option.  
*The option is selected.* | Click **Unique records only**
5. Select **OK**.  
*The Advanced Filter dialog box closes and duplicate records are hidden.* | Click **OK**

Notice that two apparently duplicate records remain. Click on cells F6 and F7 and view the cell entries in the **Formula Bar**. Notice that the entries are different, but they appear the same in the cells because the cells are formatted to display zero decimal places.

Clear the filter to redisplay all table data.

### REMOVING DUPLICATES FROM A TABLE

#### Discussion

Although filtering for unique records lets you temporarily hide duplicated data, you can delete duplicates just as easily.

Duplicate values are determined by the value stored in the cell and not necessarily the value displayed. If one cell contains the value 35,000 and another contains the value 35,000.25, but both cells are formatted to display zero decimal places, then both cells appear to contain the same value (35,000). However, Excel examines what is actually stored in the cell and correctly identifies them as different values.

When you filter for unique records, Excel assumes you mean exact duplicates; that is, where all values in one row are an exact match of all the values in another row. The Remove Duplicates feature can be used more flexibly than this. By default, it assumes that you want to remove exact duplicates but it also allows you to specify that one or more columns should be ignored when comparing records as potential duplicates.

You should use the Remove Duplicates feature with care, particularly if you choose to ignore one or more columns. You may find that Excel deletes far more records than you expect. Using the Advanced Filter to display **Unique records only** will show you which records will remain after removing exact duplicates but it cannot show you the result of ignoring certain columns. If you make a copy of the table before removing duplicates, then you can compare the original with the result after removing duplicates and can easily reinstate any unexpected deletions.
Procedures

1. Select any cell in the table.
2. Select the Data tab.
3. Select the Remove Duplicates button in the Data Tools group.
4. Select OK.
5. Select OK.

Step-by-Step

Remove duplicates from a table.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select any cell in the table.</td>
<td>Click cell A5</td>
</tr>
<tr>
<td><em>The cell is selected.</em></td>
<td></td>
</tr>
<tr>
<td>2. Select the Data tab.</td>
<td>Click Data</td>
</tr>
<tr>
<td><em>The Data tab is displayed.</em></td>
<td></td>
</tr>
<tr>
<td>3. Select the Remove Duplicates button in the Data Tools group.</td>
<td>Click Remove Duplicates</td>
</tr>
<tr>
<td><em>The Remove Duplicates dialog box opens with all columns selected.</em></td>
<td></td>
</tr>
<tr>
<td>4. Select OK. A Microsoft Office Excel message box appears informing</td>
<td>Click OK</td>
</tr>
<tr>
<td>how many duplicates were found and removed and how many unique values</td>
<td></td>
</tr>
<tr>
<td>remain.</td>
<td></td>
</tr>
<tr>
<td>5. Select OK. The message box closes.</td>
<td>Click OK</td>
</tr>
</tbody>
</table>

Notice that although five duplicates were removed, one apparent duplicate remains. Click in cells F6 and F7 and view the entries in the Formula Bar; although they are different, they appear to be the same in the table because the Salary column is formatted to show zero decimal places.

Click the Remove Duplicates button again. Deselect the Salary column in the Remove Duplicates dialog box, then click OK. One duplicate is removed. Close EMPLOY9.XLSX.
EXERCISE

WORKING WITH ADVANCED FILTERS

Task

Work with Advanced Filters.

1. Open PERSON7.XLSX.

2. Create a criteria range by copying the table Header Row to the first row of the worksheet.

3. Use the Name Box to create the name Criteria1 for the criteria range (A1:G2).

4. Find all employees with a status of 4.

5. Clear the filter to show all records.


7. Find all employees with a status of 2 and a salary greater than $40,000.

8. Find all employees with a status of 3 or 7. (Hint: Remember to change the criteria range.)

9. Show all records.

10. Use the Advanced Filter dialog box to copy all employees with salaries greater than $40,000 to the range beginning in cell J9. (Hint: Remember to change the criteria range.)

11. Use the DCOUNT function in cell F6 to find the number of employees with a status of 2. (Hint: First enter the criteria into the criteria range. Using the Insert Function and Function Arguments dialog boxes, select the Database argument (A9:G37 or EmpInfo[#All]), the Field argument (Status) and the Criteria argument (F1:F2 or Criteria1). The correct answer is 16.)

12. Change the criteria to show the number of employees with a status of 3.

13. Close the workbook without saving it.
Lesson 2 - Working with Advanced Filters

Excel 2007 - Lvl 3

<table>
<thead>
<tr>
<th>First Name</th>
<th>Last Name</th>
<th>ID Number</th>
<th>Department</th>
<th>Birthday</th>
<th>Status</th>
<th>Salary</th>
</tr>
</thead>
<tbody>
<tr>
<td>George</td>
<td>Elliott</td>
<td>6605</td>
<td>Admin</td>
<td>1/2/1951</td>
<td>Good</td>
<td>66,000</td>
</tr>
<tr>
<td>Mark</td>
<td>Lee</td>
<td>9963</td>
<td>Production</td>
<td>2/2/1990</td>
<td>Good</td>
<td>36,000</td>
</tr>
<tr>
<td>Elin</td>
<td>Davis</td>
<td>1095</td>
<td>Admin</td>
<td>5/12/1986</td>
<td>Good</td>
<td>55,000</td>
</tr>
<tr>
<td>John</td>
<td>Williams</td>
<td>5655</td>
<td>Sales</td>
<td>9/1/1997</td>
<td>Fair</td>
<td>55,000</td>
</tr>
<tr>
<td>Steve</td>
<td>Johnson</td>
<td>8273</td>
<td>Production</td>
<td>3/1/1960</td>
<td>Good</td>
<td>38,000</td>
</tr>
<tr>
<td>Wendy</td>
<td>Council</td>
<td>3986</td>
<td>Production</td>
<td>5/8/1968</td>
<td>Good</td>
<td>42,000</td>
</tr>
<tr>
<td>Peter</td>
<td>Merz</td>
<td>8474</td>
<td>Sales</td>
<td>3/10/1971</td>
<td>Good</td>
<td>42,000</td>
</tr>
</tbody>
</table>
LESSON 3 -
EXPORTING AND IMPORTING DATA

In this lesson, you will learn how to:

- Export data to other applications
- Import data from Access
- Import data from text files
- Change external data range properties
- Import data from other applications
- Remove the query definition
- Import dynamic data from the Web
- Copy a table from a web page
EXPORTING DATA TO OTHER APPLICATIONS

Discussion

Microsoft Excel can export data to other applications. It does this by enabling you to save files in formats that can be recognized by the receiving applications. Excel can save files in formats of older versions of Excel or as XML data. It can also save files in text formats, or in formats recognized by various database programs.

If you are exporting data you want to use in a database application, you should remove any worksheet titles or other extraneous text. Row 1 of the worksheet you are exporting should start with the field names; or, if you are excluding field names, the first record of field data.

Excel can only save a single worksheet as a text file. Therefore, if your workbook contains multiple sheets, only the current worksheet will be exported.

You can use the comma delimited (CSV) format to exchange information with the contacts address list in Microsoft Outlook. You can also open Outlook and directly import a named range containing contact information from an Excel workbook into your Outlook Contacts folder.

To bring Excel data into an Access database, open the database in Access and use the Excel button in the Import group on the External Data tab to import a worksheet or named range.

Procedures

1. Select the Office button.
2. Select Save As.
3. Type the desired file name.
4. Select the Save as type list.
5. Select the format in which you want to save the file.
6. If the **Save As** dialog box is in compact mode, select **Browse Folders**.

7. Select the double arrow at the left of the **Address bar**.

8. Select the drive where you want to save the workbook.

9. Select the folder where you want to save the workbook.

10. Select **Save**.

11. Select **OK**.

12. Select **Yes**.


14. Select **No**.

---

**Step-by-Step**

From the Student Data directory, open **EXPORT1.XLSX**.

Export an Excel worksheet to another application.

If necessary, display the **Employees** worksheet.

The following step-by-step is for workbooks containing multiple worksheets. The steps will differ slightly for workbooks containing a single worksheet.

<table>
<thead>
<tr>
<th><strong>Steps</strong></th>
<th><strong>Practice Data</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the <strong>Office</strong> button. <em>The Office menu opens.</em></td>
<td>Click</td>
</tr>
<tr>
<td>2. Select <strong>Save As</strong>. <em>The Save As dialog box opens with the text in the File name box selected.</em></td>
<td>Click <strong>Save As</strong></td>
</tr>
<tr>
<td>3. Type the desired file name. <em>The file name appears in the File name box.</em></td>
<td>Type <strong>Exptxt</strong></td>
</tr>
<tr>
<td>4. Select the <strong>Save as type</strong> list. <em>The Save as type list is displayed.</em></td>
<td>Click <strong>Save as type</strong></td>
</tr>
<tr>
<td>5. Select the format in which you want to save the file. <em>The format is selected.</em></td>
<td>Click <strong>CSV (Comma delimited)</strong></td>
</tr>
<tr>
<td>Steps</td>
<td>Practice Data</td>
</tr>
<tr>
<td>-------</td>
<td>---------------</td>
</tr>
<tr>
<td>6. If the <strong>Save As</strong> dialog box is in compact mode, select the <strong>Browse Folders</strong> button. The Save As dialog box expands to display the files and folders in the current location.</td>
<td>Click <img src="image" alt="Browse Folders" /> if necessary</td>
</tr>
<tr>
<td>7. Select the double arrow at the left of the <strong>Address</strong> bar. A list of available drives and common folders is displayed.</td>
<td>Click <img src="image" alt="Next" /></td>
</tr>
<tr>
<td>8. Select the drive where you want to save the workbook. A list of available folders is displayed.</td>
<td>Click the student data drive</td>
</tr>
<tr>
<td>9. Select the folder where you want to save the workbook. The contents of the folder are displayed.</td>
<td>Click to open the student data folder</td>
</tr>
<tr>
<td>10. Select <strong>Save</strong>. The Save As dialog box closes and a Microsoft Office Excel warning box opens, warning you that multiple worksheets cannot be supported for this file type.</td>
<td>Click <img src="image" alt="Save" /></td>
</tr>
<tr>
<td>11. Select <strong>OK</strong>. The Microsoft Office Excel warning box closes and a Microsoft Office Excel message box opens, explaining that features in the worksheet may not be compatible with the text format.</td>
<td>Click <img src="image" alt="OK" /></td>
</tr>
<tr>
<td>12. Select <strong>Yes</strong>. The Microsoft Office Excel message box closes and the file is saved with the new name and type to the selected folder.</td>
<td>Click <img src="image" alt="Yes" /></td>
</tr>
<tr>
<td>13. Close the file. A Microsoft Office Excel warning box opens, asking if you want to save the changes.</td>
<td>Click <img src="image" alt="Close" /> at the right-hand end of the <strong>Ribbon</strong></td>
</tr>
<tr>
<td>14. Select <strong>No</strong>. The Microsoft Office Excel warning box and the file close.</td>
<td>Click <img src="image" alt="No" /></td>
</tr>
</tbody>
</table>
Open Microsoft Word and use the Open option on the Office menu to open Exptxt.csv from the student data folder. (Hint: Select All Files instead of All Word Documents from the drop-down list above the Open button.) Notice that the data is separated by commas. Close Microsoft Word without saving the file.

**IMPORTING DATA FROM ACCESS**

**Discussion**

Excel has the capability to retrieve (import) data from external sources into a worksheet. For example, Excel can use data from mainframe databases or from other applications such as Microsoft Access. It can also use data that has been created or saved in a text file format or data from a web site. Once the external data is imported into a worksheet, you can use Excel’s comprehensive analysis tools to analyze the data. By retrieving or importing the data from another source, you save the time it would take to retype the information into the worksheet.

When you retrieve data from an external source, you define the data you want to import by selecting the original data source and the types of data (fields) you want to import. This combined data is the query definition, which is saved in the worksheet. The query definition links the imported data to its original source. You can break the link between the imported data and its source data at any time.

The procedure to create the query definition differs depending on the type of data file you are importing. For instance, the Text Import Wizard opens when you import the data from a text file, while the Select Table dialog box opens when you are importing from an Access database.

![Data imported from Access](image-url)
You can also refresh external data by right-clicking any cell in an imported data range and selecting Refresh to refresh the current data range. You can refresh all imported data ranges in the workbook by selecting the top part of the Refresh All button in the Connections group on the Data tab.

By default, external data will be imported into the worksheet into newly inserted cells. Existing data in the worksheet that falls within this range will be shifted to the right. You should save an existing workbook before you import external data, since you cannot use the Undo feature to reverse the action.

Procedures

1. Select the Data tab.
2. Select From Access in the Get External Data group.
3. Select the folder where the file you want to import is located.
4. Select the file you want to import.
5. Select Open.
6. Select the desired table.
7. Select OK.
8. Select OK.
9. Select the cell where you want the upper, left corner of the imported table to appear.
10. Select OK.

Step-by-Step

From the Student Data directory, open IMPTWSG.XLSX. Import Microsoft Access data into a worksheet.

If necessary, display the Customers worksheet.
<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the <strong>Data</strong> tab. <strong>The Data tab is displayed.</strong></td>
<td>Click <strong>Data</strong></td>
</tr>
<tr>
<td>2. Select the <strong>From Access</strong> button in the <strong>Get External Data</strong> group. <strong>The Select Data Source dialog box opens.</strong></td>
<td>Click <img src="" alt="From Access" /></td>
</tr>
<tr>
<td>3. Select the folder where the file you want to import is located. <strong>The contents of the folder are displayed.</strong></td>
<td>Click to open the student data folder</td>
</tr>
<tr>
<td>4. Select the file you want to import. <strong>The file is selected.</strong></td>
<td>Click <strong>WSGDATA.MDB</strong></td>
</tr>
<tr>
<td>5. Select the left-hand part of the <strong>Open</strong> button. <strong>The Select Data Source dialog box closes, and the Select Table dialog box opens.</strong></td>
<td>Click <img src="" alt="Open" /></td>
</tr>
<tr>
<td>6. Select the desired table. <strong>The table name is highlighted.</strong></td>
<td>Click <strong>Customers</strong></td>
</tr>
<tr>
<td>7. Select <strong>OK</strong>. <strong>The data is selected, the Select Table dialog box closes, and the Import Data dialog box opens.</strong></td>
<td>Click <img src="" alt="OK" /></td>
</tr>
<tr>
<td>9. Select the cell where you want the upper, left corner of the imported table to appear. <strong>The cell is selected, and its address appears in the Import Data dialog box.</strong></td>
<td>Click cell A7</td>
</tr>
<tr>
<td>10. Select <strong>OK</strong>. <strong>The Import Data dialog box closes and the imported data appears in the worksheet.</strong></td>
<td>Click <img src="" alt="OK" /></td>
</tr>
</tbody>
</table>

Change the text in cell D8 to **Clark**. Click any cell in the imported data range and then click the top part of the **Refresh All** button in the **Connections** group on the **Data** tab. Notice that cell D8 reverts to the original text, **Robinson**. Close **IMPTWSG.XLSX**.
**IMPORTING DATA FROM TEXT FILES**

**Discussion**

Excel can import data saved in a text file format directly into a worksheet. The text file format is commonly used when data is exported from mainframes and other database applications.

Database information contains field names and field data. When that information is exported to a text file, the fields must be separated, or delimited. The characters that separate fields are known as delimiters. Common delimiters include tabs, commas, or spaces. When working with text-formatted data, Excel can import files containing the following formats: Text (tab delimited - .txt), CSV (comma delimited - .csv), or Formatted Text (space delimited - .prn).

You use the Text Import Wizard to convert the text data and place it in the proper cells in the worksheet. When importing delimited data, the Text Import Wizard displays the data in columns and enables you to format each column or prevent selected columns from being imported. When importing fixed width data, you can adjust the width of the columns before placing them in the worksheet.

![The Text Import Wizard - Step 3 of 3](image)

- To import comma (.csv) or space (.prn) delimited files, you need to select All Files instead of Text Files from the list above the Open button in the Import Text File dialog box.

- You can choose the row on which you want to start the import in step 1 of the Text Import Wizard. For example, you can start the import on row 2 to exclude the column headings of the imported data.
Procedures

1. Select the Data tab.
2. Select in the Get External Data group.
3. Select the double arrow at the left of the Address bar.
4. Select the drive where the text file you want to import is located.
5. Select the folder in which the text file you want to import is located.
6. Select the name of the text file you want to import.
7. Select the left-hand part of the Import button.
8. Select .
9. Select the delimiter used in the text file.
10. Select .
11. Select the column you want to format in the Data preview pane.
12. Under Column data format, select the desired format option.
13. Select .
14. Select the location where you want the imported data to appear.
15. Select .

Step-by-Step

From the Student Data directory, open IMPTWSG.XLSX.
Import data from a text file into an Excel worksheet.

If necessary, display the Customers worksheet.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Data tab.</td>
<td>Click Data</td>
</tr>
<tr>
<td><em>The Data tab is displayed.</em></td>
<td></td>
</tr>
</tbody>
</table>
### Lesson 3 - Exporting and Importing Data

#### Excel 2007 - Lvl 3

**Steps** | **Practice Data**
---|---
2. Select the **From Text** button in the **Get External Data** group.  
*The Import Text File dialog box opens.* | Click ![From Text](image)
3. Select the double arrow at the left of the **Address** bar.  
*A list of available drives and common folders is displayed.* | Click ![Double Arrow](image)
4. Select the drive where the text file you want to import is located.  
*A list of available folders is displayed.* | Click the student data drive
5. Select the folder in which the text file you want to import is located.  
*The contents of the folder are displayed.* | Double-click to open the student data folder
6. Select the name of the text file you want to import.  
*The file name is highlighted in the list and appears in the **File name** box.* | Click **CUSTOMERS.TXT**
7. Select the left-hand part of the **Import** button.  
*The Import Text File dialog box closes and the Text Import Wizard dialog box opens at Step 1 of 3 with the Delimited option selected.* | Click ![Import](image)
8. Select **Next**.  
*The Text Import Wizard progresses to Step 2 of 3 with the data to be imported displayed in the **Data preview** pane.* | Click ![Next >](image)
9. Select the delimiter used in the text file.  
*The delimiter is selected.* | Click ![Tab](image) to select it, if necessary  
10. Select **Next**.  
*The Text Import Wizard progresses to Step 3 of 3 with the data separated into columns in the **Data preview** pane.* | Click ![Next >](image)
11. Select the column you want to format in the **Data preview** pane.  
*The column is selected.* | Click the **Phone Number** column (third column)
Steps | Practice Data
---|---
12. Under **Column data format**, select the desired format option. *The format option is selected.* | Click

13. Select **Finish**. *The Text Import Wizard dialog box closes, and the Import Data dialog box opens with the *Existing worksheet* option selected.* | Click

14. Select the location where you want the imported data to appear. *The cell is selected, and its address appears in the *Existing worksheet* box.* | Click cell A7

15. Select **OK**. *The Import Data dialog box closes and the imported data appears in the worksheet.* | Click

Change the text in cell C8 to **BBB**. Click any cell in the imported data range and then click the top part of the **Refresh All** button in the **Connections** group on the **Data** tab. When the Import Text File dialog box opens, select the **CSTOMERS.TXT** file and then click the left-hand part of the **Import** button. Notice that cell C8 reverts to the original text, **SJS**.

**CHANGING EXTERNAL DATA RANGE PROPERTIES**

**Discussion**

You can change the properties of an external data range before or after you import it. Some properties are important to change before the data is imported, such as whether the data should be inserted as new cells or whether it should overwrite existing data. Other elements can be changed at a later time without consequence.

By default, an external data range only refreshes when you manually refresh the link. You can set the link to refresh automatically each time you open the workbook. In addition, you can set the link to refresh after a specified time interval.

Excel provides a variety of options you may want to set when you initially import or refresh the data. If you have formatted the imported data, you may want to disable the option that automatically resets column widths and enable the option that maintains the current cell formatting.
If the amount of data in the external source changes after it has been imported, you can select how you want the imported data to refresh. Excel provides options to insert either cells or rows to accommodate additional data, as well as an option to overwrite data in existing cells.

If you have added columns for data analysis or calculation to the right of the imported range, you can have Excel automatically fill in the formulas for adjacent columns whenever you refresh the data.

The External Data Range Properties dialog box

Although the import of an external data range cannot be undone, the Undo feature can be used to reverse a refresh action.

You can open the External Data Range Properties dialog box before you import a range by selecting the Properties button in the Import Data dialog box. The Import Data dialog box opens as the last step in importing data.

Procedures

1. Select any cell in the database.
2. Select Properties in the Connections group on the Data tab.
3. Select or deselect options under **Refresh control**, as desired.

4. Select or deselect options under **Data formatting and layout**, as desired.

5. Select **OK**.

---

### Step-by-Step

Change external data range properties.

If necessary, display the Customers worksheet.

In cell F7, type the text **New Limit**. In cell F8, type the formula =D8+500.

---

<table>
<thead>
<tr>
<th><strong>Steps</strong></th>
<th><strong>Practice Data</strong></th>
</tr>
</thead>
</table>
| 1. Select any cell in the database.  
*The cell is selected.* | Click cell B7 |
| 2. Select the **Properties** button in the **Connections** group on the Data tab.  
*The External Data Range Properties dialog box opens.* | Click ![Properties](Properties.png) |
| 3. Select or deselect options under **Refresh control**, as desired.  
*The options are selected or deselected accordingly.* | Click ![Prompt for file name on refresh](Prompt.png) to deselect it |
| 4. Select or deselect options under **Data formatting and layout**, as desired.  
*The options are selected or deselected accordingly.* | Click ![Fill down formulas in columns adjacent to data](Fill.png) to select it |
| 5. Select **OK**.  
*The External Data Range Properties dialog box closes, and the properties are saved.* | Click **OK** |

Click any cell in the data range and then click the top part of the **Refresh All** button in the **Connections** group on the Data tab. Notice that you are not prompted to select a text file and that the formula in column F is automatically filled in for the extent of the data range.
IMPORTING DATA FROM OTHER APPLICATIONS

Discussion

You can use Microsoft Query to import information from database applications. For example, Excel can import database information from dBase Files, Excel Files and Microsoft Access.

The Query Wizard, part of Microsoft Query, guides you through the steps to create a query. This method is helpful if you are new to the process of creating a query, or if you only need to create a simple query using a single table. For more complex queries, you can work directly with Microsoft Query.

Using the Query Wizard, you: select the database file, table, and fields from which you will import the data; create any desired filter criteria; select the sort order for the data; and, finally, place the data in a specific location in the worksheet.

You can use the Save Query button on the last page of the Query Wizard to save the query to a query file (.dqy). This file can then be opened and run in Excel or Microsoft Query. By default, the query is saved with the workbook.

You must use Microsoft Query to import data from multiple tables. You can run the Query Wizard and use the Choose Columns dialog box to select fields from more than one table. When you select Next, the Query Wizard opens a Query window for you to create the relationships between tables. After joining the tables, you can select the File menu from the Microsoft Query menu bar and then the Return Data to Microsoft Excel option to insert the data into the worksheet.
You can create a connection to a new data source by selecting the **New Data Source** option and **OK** in the Choose Data Source dialog box. You can then name the data source, select the drive, and connect to the desired data source. By default, all tables are available, but you can select to connect to only one table.

You can also use the **From Access** button to import an entire table from Microsoft Access but you cannot filter it before importing or select which fields to import.

The first time you use Microsoft Query in an Excel session, a Microsoft Office Excel Security Notice box opens, warning you that connecting to external data sources presents a potential security concern. You should only proceed if you trust the source of the data file from which you want to import data.

### Procedures

1. Select the **Data** tab.

2. Select **From Other Sources** in the **Get External Data** group.

3. Select **From Microsoft Query**.

4. Select the type of database file you want to access.

5. Select the **Use the Query Wizard to create/edit queries** option.

6. Select **OK**.

7. Select the **Drives** list.

8. Select the drive where the file you want to import is located.

9. Under **Directories**, double-click to open the folder containing the file you want to import.

10. Double-click the database file you want to open.

11. Expand the database table you want to use in the query in the **Available tables and columns** list box.
12. Double-click the first column of data you want to add to the query.

13. Continue adding columns as desired.

14. To preview the data, select the column containing the data you want to preview:

15. Select **Preview Now**.

16. Select **Next >**.

17. To filter the data, select the column by which you want to filter:

18. Select the column drop-down list under **Only include rows where**.

19. Select the desired filter option.

20. Type the filter criteria.

21. Select **Next >**.

22. To sort the data, select the **Sort by** list.

23. Select the column you want to use to sort the data.

24. Select the desired sort order.

25. Select **Next >**.

26. Select **Save Query...**.

27. Type the desired file name.

28. Select **Save**.

29. Select **Finish**.

30. Select the cell where you want the upper left corner of the query table to appear.

31. Select **OK**.

---

**Step-by-Step**

Import data from other applications.

Display the **Tennis Orders** worksheet.

You will create a query to import Microsoft Access data into a worksheet.
**Steps** | **Practice Data**
--- | ---
1. Select the **Data** tab.  
   *The Data tab is displayed.* | Click **Data**
2. Select the **From Other Sources** button in the **Get External Data** group.  
   *The From Other Sources menu opens.* | Click
3. Select **From Microsoft Query**.  
   *The Choose Data Source dialog box opens.* | Click **From Microsoft Query**
4. Select the type of database file you want to access.  
   *The type of database file is selected.* | Click **MS Access Database**
5. Select the **Use the Query Wizard to create/edit queries** option, if necessary.  
   *The Use the Query Wizard ... option is selected.* | Click **Use the Query Wizard ...** to select it, if necessary
6. Select **OK**.  
   *The Choose Data Source dialog box closes and the Select Database dialog box opens.* | Click **OK**
7. Select the **Drives** list.  
   *A list of available drives is displayed.* | Click **Drives**
8. Select the drive where the file you want to import is located.  
   *A list of available folders is displayed.* | Click the student data drive, if necessary
9. Under **Directories**, double-click to open the folder containing the file you want to import.  
   *The contents of the folder are displayed.* | Double-click to open the student data folder
10. Double-click the database file you want to open.  
    *The Select Database dialog box closes, and the Query Wizard dialog box opens at the Choose Columns page.* | Double-click **WSGDATA2.MDB**
### Steps

<table>
<thead>
<tr>
<th>Step</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>11.</td>
<td>Select the database table you want to use in the query in the <strong>Available tables and columns</strong> list box. The table expands to display the columns.</td>
</tr>
<tr>
<td>12.</td>
<td>Double-click the first column of data you want to add to the query. The column is added to the <strong>Columns in your query</strong> list box.</td>
</tr>
<tr>
<td>13.</td>
<td>Continue adding columns as desired. The columns are added to the <strong>Columns in your query</strong> list box.</td>
</tr>
<tr>
<td>14.</td>
<td>To preview the data, select the column containing the data you want to preview. The column is selected.</td>
</tr>
<tr>
<td>15.</td>
<td>Select <strong>Preview Now</strong>. The data appears in the <strong>Preview of data in selected column</strong> list box.</td>
</tr>
<tr>
<td>16.</td>
<td>Select <strong>Next</strong>. The Query Wizard progresses to the <strong>Filter Data</strong> page.</td>
</tr>
<tr>
<td>17.</td>
<td>To filter the data, select the column by which you want to filter. A drop-down list appears for the selected column under <strong>Only include rows where</strong>.</td>
</tr>
<tr>
<td>18.</td>
<td>Select the column drop-down list under <strong>Only include rows where</strong>. A list of options is displayed.</td>
</tr>
<tr>
<td>19.</td>
<td>Select the desired filter option. The option appears in the column box and the insertion point appears in the next drop-down box.</td>
</tr>
<tr>
<td>20.</td>
<td>Type the filter criteria. The text appears in the column box.</td>
</tr>
<tr>
<td>21.</td>
<td>Select <strong>Next</strong>. The Query Wizard progresses to the <strong>Sort Order</strong> page.</td>
</tr>
</tbody>
</table>
### Steps | Practice Data
--- | ---
22. **To sort the data, select the Sort by list.**  
A list of the columns in the query is displayed. | Click **Sort by**
23. **Select the column you want to use to sort the data.**  
The column appears in the Sort by box. | Click **Sales Rep**
24. **Select the desired sort order.**  
The desired option is selected. | Click **Ascending** to select it, if necessary
25. **Select Next.**  
The Query Wizard progresses to the Finish page. | Click **Next >**
26. **Select Save Query.**  
The Save As dialog box opens with the Queries folder and the text in the File name box selected. | Click **Save Query...**
27. **Type the desired file name.**  
The file name appears in the File name box. | Type **Tennis Orders**
28. **Select Save.**  
The Save As dialog box closes and the query is saved. | Click **Save**
29. **Select Finish.**  
The Query Wizard dialog box closes, and the Import Data dialog box opens. | Click **Finish**
30. **Select the cell where you want the upper left corner of the query table to appear.**  
The cell reference appears in the Import Data dialog box. | Click cell A7
31. **Select OK.**  
The Import Data dialog box closes and the query table appears in the worksheet. | Click **OK**

Add the following columns to your query:

| **Customer Number**  
| **Sales Rep**  
| **Order Date**  
| **Shipping Charge** |
Return to the table and continue on to the next step (step 14).

Practice the Concept: Right-click any cell in the imported data range, point to Table in the shortcut menu that appears, then click Edit Query in the submenu. Select Next to advance to the Query Wizard - Filter Data page. Select Order Number in the Column to filter list box and change the criteria to is greater than 1800. Select Next and sort the data by Order Number (instead of by Sales Rep). Click Next, then Finish. Notice that the imported data changes to reflect your edits.

REMOVING THE QUERY DEFINITION

Discussion

When you import data into a worksheet from an external source, you create a link to the original data source. The worksheet and the original data source are linked by the query definition, which is saved in the worksheet. You can break the link between the imported data and its source data at any time by removing the query definition from the worksheet. Removing the query definition lets you retain a permanent version of the data that cannot be refreshed and allows you to make modifications to the cells without the risk of the data being overwritten.

To break the link to the Query Definition for data imported from a text file or from the Web, right-click a cell in the data and select Data Range Properties from the shortcut menu that appears. Deselect the Save query definition option and click OK. Click OK in the Microsoft Office Excel warning box that appears.

Procedures

1. Right-click on any cell in the imported data.
2. Point to Table in the shortcut menu.
3. Select Unlink from Data Source.
4. Select OK.

Step-by-Step

Remove the query definition.
If necessary, display the **Tennis Orders** worksheet.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| **1.** Right-click on any cell in the imported data.  
   *A shortcut menu opens.* | Right-click on cell B8 |
| **2.** Point to **Table** in the shortcut menu.  
   *The Table submenu opens.* | Point to **Table** |
| **3.** Select **Unlink from Data Source**.  
   *A Microsoft Office Excel warning message appears, asking you to confirm the removal of the query definition.* | Click **Unlink from Data Source** |
| **4.** Select **OK**.  
   *The Microsoft Office Excel warning box closes and the query definition is removed from the worksheet.* | Click **OK** |

## Importing Dynamic Data from the Web

### Discussion

Excel has the capability of importing data from a web page located on the Internet or an intranet site. You can retrieve a table from a web page to analyze its data with Excels analysis tools. For example, you may want to retrieve stock quotes from the Internet and then perform trend analysis or chart the data.

When importing data from the Internet or an intranet site using the New Web Query dialog box, Excel creates a refreshable link to the original data source.

Imported data can be static or dynamic. A static data source is one that does not normally change or need to be refreshed. However, you may want to refresh the data if you make changes to the imported data on the worksheet and want to return to the original data. Dynamic data, on the other hand, is usually in a constant state of change. Real-time data is the actual reported data with little delay. Stock market quotes and currency exchange rates on the Internet are examples of real-time data.

When importing tables using the New Web Query dialog box, each table on the web page appears with a small arrow icon located in its upper, left corner. These arrow icons enable you to select the table you want to import. In addition to selecting one specific table, you can import all the tables on the web page or the web page itself by selecting multiple arrow icons. If the arrow icons do not appear, you may need to
select the **Show Icons** button on the toolbar in the New Web Query dialog box. When importing XML data from a web page, you should use the **Options** button on the toolbar to select the **Full HTML formatting** option in the Web Query Options dialog box.

You can use the **Save Query** button in the New Web Query dialog box to save the query to a query file (.iqy). This file can then be opened and run in another Excel workbook. By default, the query is saved with the workbook.

Setting external data range properties

- If the HTML file was originally created in Excel, you can import the data back to Excel by opening the HTML file in Internet Explorer and using the **Edit** button or list on the **Internet Explorer** toolbar to open the file in Excel.

- You can manually refresh dynamic data or use the External Data Range Properties dialog box to create an automatic refresh setting.

- To edit a Web Query, right-click in the imported data and select **Edit Query** from the shortcut menu that appears.

- To edit the External Data Range Properties, right-click in the imported data and select **Data Range Properties** from the shortcut menu that appears or select the **Properties** button in the **Connections** group on the **Data** tab.
You must have a browser installed to use the New Web Query dialog box to import data from a web page on the Internet or an intranet site. In addition, you must be able to connect to the Internet to import data from the World Wide Web.

Procedures

1. Select the Data tab.
2. Select From Web in the Get External Data group.
3. Type the web address of the web page containing the table you want to import into the Address box.
4. Select Go.
5. If necessary, click the Show Icons button on the toolbar to display the selection arrows.
6. Select the table you want to import.
7. Select the Options button on the toolbar in the New Web Query dialog box.
8. Select the desired options.
9. Select OK.
10. Select Import.
11. Select the cell where you want the upper left corner of the imported table to appear.
12. To change the external data range settings, select Properties...
13. Select the desired options.
14. Select OK.
15. Select OK.

Step-by-Step

Import dynamic data from the Web.
Note: You will need an Internet connection to complete this step-by-step.

Display the Currency Exchange worksheet.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the **Data** tab.  
The **Data** tab is displayed. | Click **Data** |
| 2. Select the **From Web** button in the **Get External Data** group.  
The New Web Query window appears with the text in the **Address** box selected. | Click ![From Web](image) |
| 3. Type the web address of the web page containing the table you want to import into the **Address** box.  
The web address appears in the **Address** box. | Type `moneycentral.msn.com/investor/market/exchangerates.aspx` |
| 4. Select **Go**.  
The selected web page appears in the New Web Query dialog box. | Click ![Go](image) |
| 5. If necessary, click the **Show Icons** button on the toolbar to display the selection arrows.  
Arrows in yellow boxes appear beside selectable items in the browser window. | Click ![Show Icons](image), if necessary |
| 6. Select the table you want to import.  
The arrow for the selected table changes to a green check box and the table is selected. | Scroll as necessary and click ![Table Selection](image) in the upper, left corner of the Currency Rates table |
| 7. Select the **Options** button on the toolbar in the New Web Query dialog box.  
The Web Query Options dialog box opens. | Click ![Options](image) |
| 8. Select the desired options.  
The options are selected. | Click ![Options](image) Full HTML formatting |
| 9. Select **OK**.  
The Web Query Options dialog box closes. | Click ![OK](image) |
### Steps

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 10. Select **Import**.  
*The New Web Query dialog box closes and the Import Data dialog box opens.* | Click ![Import](#) |
| 11. Select the cell where you want the upper left corner of the imported table to appear.  
*The cell reference appears in the Import Data dialog box.* | Click cell A5 |
| 12. To change the external data range settings, select **Properties**.  
*The External Data Range Properties dialog box opens.* | Click ![Properties…](#) |
| 13. Select the desired options.  
*The options are selected.* | Follow the instructions shown below the table before continuing on to the next step |
| 14. Select **OK**.  
*The External Data Range Properties dialog box closes.* | Click ![OK](#) |
| 15. Select **OK**.  
*The Import Data dialog box closes and the table appears in the worksheet.* | Click ![OK](#) |

Under Refresh control, select the **Refresh every** option and change the spin box to 1 minute. Then, under **Data formatting and layout**, select the **Overwrite existing cells with new data, clear unused cells and Fill down formulas in columns adjacent to data** options.

*Return to the table and continue on to the next step (step 14).*

Click a cell in column A in the imported data range (click cell A7). Wait one minute for the automatic refresh to see how the change in the currency rates affect your prices.

---

**COPYING A TABLE FROM A WEB PAGE**

#### Discussion

You can copy data from the World Wide Web and paste it directly into a worksheet. By default, copied data is static and contains no links. However, once data is pasted from the Web, you can use the **Paste Options** button to link to the data and create a
refreshable web query. If you elect to create a refreshable web query, Excel opens the New Web Query dialog box, from which you can select the desired table.

- You can select the **Match Destination Formatting** option from the **Paste Options** list to format the imported data with the worksheet area settings.

- If the HTML file was originally created in Excel, you can import the data back to Excel by opening the HTML file in Internet Explorer and using the **Edit** button or list on the **Internet Explorer** toolbar to open the file in Excel.

- It is often helpful to use keyboard commands when copying and pasting from the Internet. You can use the **[Ctrl+C]** key combination to copy a selection and the **[Ctrl+V]** key combination to paste a selection.

**Procedures**

1. Select the data you want to copy from the web page.
2. Copy the data.
3. Switch to Excel.
4. Select the desired worksheet.
5. Select the cell where you want to paste the data.
6. Paste the copied data.
7. To create a refreshable web query, click the **Paste Options** button.
8. Select the **Create Refreshable Web Query** option.
9. If necessary, click the **Show Icons** button on the toolbar to display the selection arrows.
10. Select the table you want to import.
11. Select **Import**.
Step-by-Step

Copy a table from a web page.

If you have a connection to the Internet, open your browser and type
www.kp.globalknowledge.com/mie5/products.htm in the Address bar, then press
[Enter].

If you do not have a connection to the Internet, open the Open dialog box to the
student data folder, select the PRODUCTS.HTM document, select the right-hand
part of the Open button, and select the Open in Browser option.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the data you want to copy from the web page. The data is selected.</td>
<td>Drag to select the first four rows (including the Header Row) of the WSG Baseball Products table</td>
</tr>
<tr>
<td>2. Copy the data. The data is copied to the Clipboard.</td>
<td>Press [Ctrl+C]</td>
</tr>
<tr>
<td>3. Switch to Excel. The Excel workbook is activated.</td>
<td>Click the IMPTWSG button in the taskbar</td>
</tr>
<tr>
<td>4. Select the desired worksheet. The worksheet is selected.</td>
<td>Click the Equipment tab</td>
</tr>
<tr>
<td>5. Select the cell where you want to paste the data. The cell is selected.</td>
<td>Click cell B8</td>
</tr>
<tr>
<td>6. Paste the copied data. The cells are pasted, and the Paste Options button appears.</td>
<td>Press [Ctrl+V]</td>
</tr>
<tr>
<td>7. To create a refreshable web query, click the Paste Options button. A list of available paste options is displayed.</td>
<td>Click ![icon]</td>
</tr>
<tr>
<td>8. Select the Create Refreshable Web Query option. The New Web Query dialog box opens to the web page containing the data source.</td>
<td>Click Create Refreshable Web Query</td>
</tr>
</tbody>
</table>
9. If necessary, click the **Show Icons** button on the toolbar to display the selection arrows. *Arrows in yellow boxes appear in the browser window, if appropriate.*

10. Select the table you want to import. *The arrow for the selected table changes to a green check box and the table is selected.*

11. Select **Import**. *The New Web Query dialog box closes and the table appears in the worksheet.*

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>9. If necessary, click the <strong>Show Icons</strong> button on the toolbar to display the selection arrows. <em>Arrows in yellow boxes appear in the browser window, if appropriate.</em></td>
<td>Click ☑, if necessary</td>
</tr>
<tr>
<td>10. Select the table you want to import. <em>The arrow for the selected table changes to a green check box and the table is selected.</em></td>
<td>Scroll as necessary and click ☑ in the upper, left corner of the <strong>WSG Baseball Products</strong> table</td>
</tr>
<tr>
<td>11. Select <strong>Import</strong>. <em>The New Web Query dialog box closes and the table appears in the worksheet.</em></td>
<td>Click <strong>Import</strong></td>
</tr>
</tbody>
</table>

Change cell B9 to **Football** and then refresh the table. Notice that the data in cell B9 changes back to **Baseball**.

**Practice the Concept:** Switch to the WSG Products Internet Explorer window and copy the WSG Football Products table. Switch to Excel, select cell B23 and paste the table.

Close your browser.
Close **IMPTWSG.XLSX**.
**EXERCISE**

**EXPORTING AND IMPORTING DATA**

**Task**

Export and import data.

1. Open **IMPTEX.XLSX**.

2. In the Sales worksheet, import the **SALESDPT.TXT** text file. Select **Comma** as the delimiter. Do not import the **Hire Date** or **Status** fields. Place the data starting in cell A6 in the worksheet.

3. In the Customers worksheet, use the Query Wizard to import data from the Microsoft Access file named **WSGDATA2.MDB**.

4. Use the Customers table to create a query that includes the following fields: **Store Name**, **Region**, **Sales Rep**, **Credit Limit**, and **Contract Date**.

5. Filter the data to exclude the **Northwest** region. (*Hint: Use the does not equal filter for the Region field.)*

6. Sort the data in descending order by the **Credit Limit** field.

7. Save the query as **Stores** in the **Queries** folder.

8. Place the data in the Customers worksheet, starting in cell A4.

9. Open **PRODUCTS.HTM** from the student data folder in your browser, copy the WSG Football Products table and then close your browser.

10. Paste the table to cell B23 in the **Equipment** worksheet.

11. Create a refreshable query to the football products table with full HTML formatting.

12. Type **Qty Price (100)** in cell G23.

13. Enter the formula **=C24*100*45%** in cell G24.

14. Change the External Data Range Properties of the football table to fill down formulas in adjacent columns.

15. Refresh the football table. Then, select cells F22:F29 and use the **Format Painter** to copy the format to cell G22.
16. Remove the query definition from the football table. (Hint: Deselect Save query definition in the External Data Range Properties dialog box.)

17. In the Customers worksheet, copy cells A4:D52 (excluding the Contract Date data) and paste into cell A1 in the Credit Limits worksheet.

18. Export the Credit Limits worksheet as a tab delimited text file with the name LMTXPORT.TXT.

19. Close LMTXPORT.TXT without saving the changes.

20. Open Microsoft Word, then open the LMTXPORT.TXT file. (Hint: Select All Files instead of All Word Documents in the Open dialog box.)

21. Select the Show/Hide button in the Paragraph group on the Home tab. Notice the Tab code (right-pointing arrow) which separates each field, then click the Show/Hide button again to hide the codes.

22. Exit Microsoft Word.
In this lesson, you will learn how to:

- Apply an outline
- Collapse/Expand an outline
- Modify outline settings
- Use Auto Outline
- Clear an outline
- Create subtotals in a list
- Remove subtotals from a list
APPLYING AN OUTLINE

Discussion

Outlining a worksheet makes it easier to understand and analyze information. Outlines divide a worksheet into logical units or levels. Lower levels usually contain the detail data associated with a higher level (such as a row or column of summary data).

You can use outline levels to group similar information together. Then, you can collapse and expand the outline to control the level of detail that appears.

Outlines allow you to see the relationships between detail data and summary data. For example, if a formula in cell A10 totals the numbers in cells A1 through A9, you can use the Outline feature to display a symbol on the left side of the worksheet, showing that the total in row 10 is based on the detail data in rows 1 through 9.

Outlining is a convenient way to display summary data. A complex sheet (such as one that contains monthly sales figures for each region of a company) can be large and difficult to use. You must often scroll through detail data to locate the summary data. When you use an outline, you can hide the detail data in order to display only the desired summaries. In addition, you can print just the summary data.

An outline can have up to eight levels of detail.
Excel assumes that the detail data for rows and columns appears above or to the left of the summary rows and columns. If this is not the case, you can change the direction by selecting the Data tab and clicking the Outline launcher arrow to display the Settings dialog box.

If you select a range of cells in a worksheet, rather than entire columns or rows, Excel displays the Group dialog box when you click the Group button in the Outline group. You can then indicate how you want the cells grouped by selecting the Rows or Columns option in the Group dialog box.

**Procedures**

1. Select the rows or columns that contain the detail data.
2. Select the Data tab on the Ribbon.
3. Select the top part of the Group button in the Outline group.

**Step-by-Step**

From the Student Data directory, open OUTLINE.XLSX. Apply an outline to a worksheet.

If necessary, go to the District 1 worksheet.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the rows or columns that contain the detail data. The rows or columns are selected.</td>
<td>Drag across column headings B through D, then release the mouse button</td>
</tr>
<tr>
<td>2. Select the Data tab on the Ribbon. The Data tab is displayed.</td>
<td>Click Data</td>
</tr>
<tr>
<td>3. Select the top part of the Group button in the Outline group. The selected rows or columns are grouped and outline symbols appear at the left or top of the worksheet accordingly.</td>
<td>Click</td>
</tr>
</tbody>
</table>
**Practice the Concept:** Drag to select B3:I6 and apply an outline to the rows by clicking the top part of the **Group** button and selecting the **Rows** option in the Group dialog box. Select **OK** to apply the outline and close the dialog box. Select rows 11 through 14 and apply an outline to the rows by clicking the top part of the **Group** button. Click any cell to deselect the range.

---

**COLLAPSING/EXPANDING AN OUTLINE**

**Discussion**

Once you have grouped rows and/or columns into an outline, Excel displays **Outline Level** buttons (numbered 1, 2, 3, etc., up to 8 levels) at the top-left of the spreadsheet frame. **Column Outline Level** buttons appear above the row numbers; **Row Outline Level** buttons appear to the left of the column letters. You can use these buttons to collapse and expand entire outline levels.

The highest numbered **Column Outline Level** or **Row Outline Level** button displays all detail levels for columns or rows accordingly. Each lower numbered button collapses all higher numbered levels to hide the detail columns or rows.

Excel also displays **Group Level** buttons above grouped columns and beside grouped rows. These buttons let you collapse or expand individual groups within a level. Collapsing a group hides the detail data for that group. Expanding a group displays the detail data for that group.

Expanding and collapsing outline groups or levels lets you control how much data appears on the screen as well as how much data is printed.
You can also use the **Hide Detail** and **Show Detail** buttons in the **Outline** group on the **Data** tab to expand and collapse an outline. To use these buttons you must first select a cell within the outline level group you wish to collapse or expand. If the cell you select is within both a column and a row outline level group, the **Hide Detail** or **Show Detail** button will collapse or expand both columns and rows at the same time.

### Procedures

1. To collapse an outline level, select the desired **Column Outline Level** or **Row Outline Level** button.  
2. To expand an outline level, select the desired **Column Outline Level** or **Row Outline Level** button.  
3. To collapse a single group within an outline level, click the group **Hide Detail** button.  
4. To expand a single group within an outline level, click the group **Show Detail** button.
Step-by-Step

Collapse and expand the details in an outline.

If necessary, go to the District 1 worksheet.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. To collapse an outline level, select the desired Column Outline Level or Row Outline Level button. The detail columns or rows in higher numbered outline levels are hidden accordingly.</td>
<td>Click 1 to the left of the column letters</td>
</tr>
<tr>
<td>2. To expand an outline level, select the desired Column Outline Level or Row Outline Level button. The detail columns or rows of the selected outline level are displayed accordingly.</td>
<td>Click 2 to the left of the column letters</td>
</tr>
<tr>
<td>3. To collapse a single group within an outline level, click the group Hide Detail button. The detail columns or rows of the group are hidden accordingly.</td>
<td>Click - to the left of row 7</td>
</tr>
<tr>
<td>4. To expand a single group within an outline level, click the group Show Detail button. The detail columns or rows of the group are displayed accordingly.</td>
<td>Click + to the left of row 7</td>
</tr>
</tbody>
</table>

Practice the Concept: Collapse and expand the Sales detail rows by clicking the Hide Detail button above column E and then the Show Detail button. Select cell C12 and use the Hide Detail button in the Outline group on the Data tab to collapse both the column and row detail for February Sales. Use the Show Detail button in the Outline group on the Data tab to redisplay the February Sales detail columns and rows.

MODIFYING OUTLINE SETTINGS

Discussion

When you apply an outline to a worksheet, Excel assumes that the summary data is below the detail rows or to the right of the detail columns. If your worksheet is set up
differently, you can change the default settings. You should change the settings before you apply the outlines.

![The Settings dialog box]

- Changes to outline settings apply only to the current worksheet. This allows you to use different settings in each sheet in a workbook.
- You can create an outline as you change the outline settings by using the Create button in the Settings dialog box. You must select the columns or rows you wish to outline before opening the Settings dialog box.

**Procedures**

1. Select the worksheet in which you want to change the outline settings.
2. Select the Data tab on the Ribbon.
3. Select the Outline launcher arrow.
4. Select or deselect the desired options.
5. Select OK.

**Step-by-Step**

Modify outline settings.
### Steps

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the worksheet in which you want to change the outline settings. The selected worksheet is displayed.</td>
<td>Click the District 2 worksheet tab</td>
</tr>
<tr>
<td>2. Select the <strong>Data</strong> tab on the <strong>Ribbon</strong>. The <strong>Data</strong> tab is displayed.</td>
<td>Click <strong>Data</strong></td>
</tr>
<tr>
<td>3. Select the <strong>Outline</strong> launcher arrow. The <strong>Settings</strong> dialog box opens.</td>
<td>Select <strong>Outline</strong></td>
</tr>
<tr>
<td>4. Select or deselect the desired options. The desired options are selected or deselected accordingly.</td>
<td>Click <strong>✓</strong> <strong>Summary columns to right of detail</strong> to deselect it</td>
</tr>
<tr>
<td>5. Select <strong>OK</strong>. The <strong>Settings</strong> dialog box closes.</td>
<td>Click <strong>OK</strong></td>
</tr>
</tbody>
</table>

#### Practice the Concept:
Select columns D through F. Click the top part of the **Group** button in the **Outline** group. Notice the arrangement of the **Group Level** button above the columns. Select columns C through F. Click the top part of the **Group** button. Notice the arrangement of the **Group Level** buttons above the columns. Click the **Group Level** buttons to collapse and expand the various levels and observe how the columns are hidden and redisplayed.

### Using Auto Outline

#### Discussion

You can create an outline automatically on a worksheet using the Auto Outline feature. Excel analyzes your worksheet and creates levels based on the summary formulas it finds.

To use Auto Outline, the worksheet must be set up according to the following criteria:

1. Data should be presented in a continuous range with no blank columns or rows.
2. To outline rows, column labels should appear in the first row of each column of data. To outline columns, row labels should appear in the first column of each row of data.
3. The worksheet must have columns or rows that summarize detail data.
4. The orientation of the summary columns or rows to the detail data must be consistent across the worksheet. That is, the summary columns or rows must be consistently above, below, to the right, or to the left of the detail data.
Using Auto Outline

If a range is selected, Auto Outline creates an outline for that range only. If only one cell is selected, Auto Outline creates an outline for the entire worksheet.

Procedures

1. Select a single cell in the worksheet.
2. Select the Data tab on the Ribbon.
3. Select the bottom part of the Group button in the Outline group.
4. Select Auto Outline.

Step-by-Step

Use Auto Outline to create an outline in a worksheet.
Go to the District Rpt. worksheet.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select a single cell in the worksheet.</td>
<td>Click cell A1</td>
</tr>
<tr>
<td>The cell is selected.</td>
<td></td>
</tr>
<tr>
<td>2. Select the Data tab on the Ribbon.</td>
<td>Click Data</td>
</tr>
<tr>
<td>The Data tab is displayed.</td>
<td></td>
</tr>
<tr>
<td>3. Select the bottom part of the Group</td>
<td>Click Group</td>
</tr>
<tr>
<td>button in the Outline group.</td>
<td></td>
</tr>
<tr>
<td>The Group menu opens.</td>
<td></td>
</tr>
<tr>
<td>4. Select Auto Outline.</td>
<td>Click Auto Outline</td>
</tr>
<tr>
<td>Excel creates an outline based on the</td>
<td></td>
</tr>
<tr>
<td>position of detail and summary columns</td>
<td></td>
</tr>
<tr>
<td>and rows in the worksheet and outline</td>
<td></td>
</tr>
<tr>
<td>symbols appear above and to the side of</td>
<td></td>
</tr>
<tr>
<td>the worksheet.</td>
<td></td>
</tr>
</tbody>
</table>

Practice the Concept: Collapse and expand the outline as desired. Notice that Excel has created multiple levels.

### CLEARING AN OUTLINE

#### Discussion

You can remove all outline levels to clear an outline from a worksheet. Although all the data remains on the worksheet, the distinctions between detail and summary data are removed.

- You can clear outlining from part of a worksheet by selecting a range of cells before choosing the Clear Outline option. If a single cell is selected, the Clear Outline option removes all outlining in the current worksheet.

- You can ungroup parts of an outline by selecting grouped rows or columns and clicking the top part of the Ungroup button in the Outline group on the Data tab. This action promotes the selected rows or columns to the next highest level.
If you clear an outline by mistake, you cannot use the Undo feature to reverse the action; instead, you must recreate the outline.

Procedures

1. Select a single cell in the worksheet.
2. Select the Data tab on the Ribbon.
3. Select the bottom part of the Ungroup button in the Outline group.
4. Select Clear Outline.

Step-by-Step

Clear an outline from a worksheet.

If necessary, go to the District 2 worksheet.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select a single cell in the worksheet. The cell is selected.</td>
<td>Click cell A1</td>
</tr>
<tr>
<td>2. Select the Data tab on the Ribbon. The Data tab is displayed.</td>
<td>Click Data</td>
</tr>
<tr>
<td>3. Select the bottom part of the Ungroup button in the Outline group. The Ungroup menu opens.</td>
<td>Click Ungroup</td>
</tr>
<tr>
<td>4. Select Clear Outline. The outline is cleared from the current worksheet and the outline symbols are removed.</td>
<td>Click Clear Outline</td>
</tr>
</tbody>
</table>

Practice the Concept: Select the District 1 worksheet tab. Select the range B3:D6 then click the bottom part of the Ungroup button and select the Clear Outline option. Notice that outlining is cleared only from the selected area of the worksheet.
Select the District Rpt. worksheet tab. Drag to select columns F through H. Click the top part of the Ungroup button to ungroup the detail columns. Notice that the detail columns are promoted to the next level of the outline.

Creating Subtotals in a List

Discussion

When a list is sorted by the values in a column, records containing identical values are grouped together. For example, if you sort a list by department, all records from the same department are grouped together and appear consecutively in the list.

Once a list is grouped, the subtotal command lets you calculate a variety of subtotals for each group, together with a grand total for all values. It achieves this by inserting a summary row under each group containing the group name and subtotals. The grand totals appear at the bottom of the list. In addition, outlining is automatically applied to the list, which lets you display or hide the detail data for each group.

There are 11 different summary functions available in the subtotal command including SUM, COUNT, COUNT NUMBERS, AVERAGE, MAX and MIN. You can create subtotals for multiple columns in each group.

The Subtotal dialog box
You can add more than one type of subtotal to each group. First, create the subtotals using the first function (such as SUM). Then, reopen the Subtotal dialog box, select the second function (such as AVERAGE) and choose the columns to which you want to add the new subtotals, then deselect the Replace current subtotals option. The new subtotals are inserted in a new row below each group and a further level appears in the outline.

Once you have applied subtotals to a list, the additional, inserted rows mean that you can no longer treat the data as a list for sorting and filtering. However, all subtotals and outlining can be removed in a single step, which returns the list to its original state.

Procedures

1. Select the Data tab.
2. Select a cell in the column containing the entries you want to use for grouping.
3. Select the desired sort order from the buttons in the Sort & Filter group: or .
4. Select Subtotal in the Outline group.
5. Select the At each change in list.
6. Select the name of the column you used to sort the list.
7. Select the Use function list.
8. Select the desired function.
9. Select the column for which you want to calculate subtotals in the Add subtotal to list box.
10. Select or deselect additional columns, as desired.
11. Select or deselect subtotal options, as desired.
12. Select OK.
**Step-by-Step**

Create subtotals in a list.

Display the **Employees** worksheet.

<table>
<thead>
<tr>
<th><strong>Steps</strong></th>
<th><strong>Practice Data</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>1.</strong> Select the <strong>Data</strong> tab. <em>The Data tab is displayed.</em></td>
<td>Click <strong>Data</strong></td>
</tr>
<tr>
<td><strong>2.</strong> Select a cell in the column containing the entries you want to use for grouping. <em>The cell is selected.</em></td>
<td>Click cell D6</td>
</tr>
<tr>
<td><strong>3.</strong> Select the desired sort order from the buttons in the <strong>Sort &amp; Filter</strong> group. <em>The list is sorted based on the entries in the selected column.</em></td>
<td>Click <strong>Sort A to Z</strong></td>
</tr>
<tr>
<td><strong>4.</strong> Select the <strong>Subtotal</strong> button in the <strong>Outline</strong> group. <em>The Subtotal dialog box opens.</em></td>
<td>Click <strong>Subtotal</strong></td>
</tr>
<tr>
<td><strong>5.</strong> Select the <strong>At each change in</strong> list. <em>A list of column names is displayed.</em></td>
<td>Click <strong>At each change in</strong></td>
</tr>
<tr>
<td><strong>6.</strong> Select the name of the column you used to sort the list. <em>The column name appears in the At each change in box.</em></td>
<td>Click <strong>Department</strong></td>
</tr>
<tr>
<td><strong>7.</strong> Select the <strong>Use function</strong> list. <em>A list of functions is displayed.</em></td>
<td>Click <strong>Use function</strong></td>
</tr>
<tr>
<td><strong>8.</strong> Select the desired function. <em>The function appears in the Use function box.</em></td>
<td>Click <strong>Sum</strong></td>
</tr>
<tr>
<td><strong>9.</strong> Select the first column for which you want to calculate subtotals in the <strong>Add subtotal to</strong> list box. <em>A tick appears in the box beside the selected column name.</em></td>
<td>Click <strong>Salary</strong> to select it</td>
</tr>
<tr>
<td><strong>10.</strong> Select or deselect additional columns, as desired. <em>The columns are selected or deselected accordingly.</em></td>
<td>Click <strong>Raise</strong> to select it, if necessary</td>
</tr>
</tbody>
</table>
Steps | Practice Data
---|---
11. Select or deselect subtotal options, as desired. The options are selected or deselected accordingly. | Follow the instructions shown below the table before continuing on to the next step.
12. Select OK. The Subtotal dialog box closes, subtotals appear in new inserted rows below each group and outlining is applied to the list. | Click OK

Ensure that the following options are set to the default settings:

- Replace current subtotals - selected
- Page break between groups - deselected
- Summary below data - selected

Return to the table and continue on to the next step (step 12).

Practice the Concept: Scroll to the bottom of the list to view the Grand Total row. Widen column F, if necessary, to view the total. Scroll back to the top of the worksheet.

Select the level 2 outline level button to collapse the outline details. Notice that only the totals for each group and the grand total are displayed. Click the Show Detail group level button next to row 27 to expand the Production group. Redisplay all the details by selecting the level 3 outline level button.

Select any cell in the list. Click the Subtotal button in the Outline group and set the following options:

- At each change in - Department
- Use function - Average
- Add Subtotal to - Salary only (deselect Raise)
- Replace current subtotals - deselect
- Page break between groups - deselect

Click OK to apply the additional subtotals, then scroll the worksheet to view the results. Notice that the outline now has 4 levels. Collapse and expand outline levels as desired to observe the different views available. Click the level 4 outline level button to redisplay all levels.
**REMOVING SUBTOTALS FROM A LIST**

**Discussion**

You can remove the subtotals from a list when you no longer need the results. Removing the subtotals also removes the outlining and grand total information.

**Procedures**

1. Select a cell in the list containing the subtotals you want to remove.
2. Select the **Data** tab on the **Ribbon**.
3. Select **Subtotal** in the **Outline** group.
4. Select **Remove All**.

**Step-by-Step**

Remove subtotals from a list.

Display the **Employees** worksheet, if necessary.

<table>
<thead>
<tr>
<th><strong>Steps</strong></th>
<th><strong>Practice Data</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Select a cell in the list containing the subtotals you want to remove.</td>
<td>Click cell A6</td>
</tr>
<tr>
<td><em>The cell is selected.</em></td>
<td></td>
</tr>
<tr>
<td>Select the <strong>Data</strong> tab on the <strong>Ribbon.</strong></td>
<td>Click <strong>Data</strong></td>
</tr>
<tr>
<td><em>The <strong>Data</strong> tab is displayed.</em></td>
<td></td>
</tr>
<tr>
<td>Select the <strong>Subtotal</strong> button in the <strong>Outline</strong> group.</td>
<td>Click <strong>Subtotal</strong></td>
</tr>
<tr>
<td><em>The <strong>Subtotal</strong> dialog box opens.</em></td>
<td></td>
</tr>
<tr>
<td>Select the <strong>Remove All</strong> button. <em>The <strong>Subtotal</strong> dialog box closes</em></td>
<td>Click <strong>Remove All</strong></td>
</tr>
<tr>
<td>and the subtotals and outlining are removed from the list.</td>
<td></td>
</tr>
</tbody>
</table>
Close **OUTLINE.XLSX**.
EXERCISE

WORKING WITH OUTLINES

Task

Apply and use outlines and subtotals.

1. Open REGION19.XLSX.
2. Go to the Expenses worksheet, if necessary.
3. Select columns B through D and apply an outline to the columns.
4. Select rows 5 through 8 and apply an outline to the rows.
5. Collapse and expand the outline.
6. Display the Regional Sales worksheet.
7. Use Auto Outline to create an outline for the whole worksheet.
8. Collapse the outline to level 1 for both rows and columns.
9. Expand the detail rows for the Central and Southwest regions to view the weekly totals.
10. Clear the outline.
11. Display the Sales Summary worksheet.
12. Use the Sort dialog box to sort the list by Area, then by Product, then by Year, then by Period.
13. Create subtotals to sum the Sales at each change in Area.
14. Collapse the outline to level 2 to view the district totals, then expand to level 3.
15. Create additional subtotals to sum the Sales at each change in Product, without removing the existing subtotals.
16. Collapse the outline to level 3 to view the product totals, then expand to level 4.
17. Create additional subtotals to sum the Sales at each change in Year, without removing the existing subtotals.
18. Collapse the outline to level 4 to view the year totals.
19. Display the detail rows for any 2006 Total.
20. Remove all the subtotals.
21 Close the workbook without saving it.
In this lesson, you will learn how to:

- Add and remove gridlines
- Format gridlines
- Format an axis
- Change the axis scaling
- Format the data series
- Add data from different worksheets
- Use a secondary axis
- Change data series chart types
- Add a trendline
- Create a chart template
- Apply a chart template
ADDING AND REMOVING GRIDLINES

Discussion

Gridlines are the lines that start at the tickmarks on an axis and extend through the plot area. Gridlines are usually added for a value axis since they make it easier to read the value of a data series. You can use gridlines for a category axis to create separations in the data.

Excel includes two types of gridlines: major and minor. For a value axis, major gridlines appear along the numbers on the value axis and minor gridlines appear between the numbers. By default, only the major gridlines of the value axis are included in a chart.

Chart with major and minor horizontal gridlines

Procedures

1. Select the chart in which you want to add or remove gridlines.
2. Select the Chart Tools contextual Layout tab.
3. Select in the Axes group.
4. Select the desired orientation.
5. Select the desired gridline option.

Step-by-Step

From the Student Data directory, open CHART3.XLSX.
Add or remove gridlines in a chart.

If necessary, display the Chart1 worksheet.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the chart in which you want to add or remove gridlines. The chart is selected and the Chart Tools tabs appear on the Ribbon.</td>
<td>Click anywhere on the chart</td>
</tr>
<tr>
<td>2. Select the Chart Tools contextual Layout tab. The Layout tab is displayed.</td>
<td>Click Layout</td>
</tr>
<tr>
<td>3. Select the Gridlines button in the Axes group. The Gridlines menu opens.</td>
<td>Click</td>
</tr>
<tr>
<td>4. Select the desired orientation. The appropriate submenu opens accordingly.</td>
<td>Point to Primary Horizontal Gridlines</td>
</tr>
<tr>
<td>5. Select the desired gridline option. The selected gridline option is applied to the chart.</td>
<td>Click Major &amp; Minor gridlines</td>
</tr>
</tbody>
</table>
FORMATTING GRIDLINES

Discussion

You can change the line format of gridlines to differentiate between major and minor gridlines. The style of gridlines can be changed to dashed or dotted lines rather than solid lines. Additionally, you can change the color and weight (thickness) of gridlines.

![Minor gridlines formatted with a different line style](image)

When you change options in the Format dialog box of a chart element, the changes are applied immediately, which makes it easy to see the effect of the changes. However, there is no way to cancel the changes you have made. To remove changes made while the dialog box was open, close the dialog box then click the **Undo** button on the **Quick Access Toolbar**.

Procedures

1. Select the chart.
2. Select the **Chart Tools Layout** tab.
3. Select the arrow ▶ to the right of the Chart Elements box in the Current Selection group.

4. Select the chart element you want to format.

5. Select ✖ Format Selection in the Current Selection group.

6. Select the desired formatting component from the list in the left-hand pane.

7. Select the desired options in the right-hand pane.

8. Select Close.

Step-by-Step
Format gridlines.
If necessary, display the Chart1 sheet.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the chart. The chart is selected and the Chart Tools tabs appear on the Ribbon.</td>
<td>Click on the chart</td>
</tr>
<tr>
<td>2. Select the Chart Tools Layout tab. The Layout tab is displayed.</td>
<td>Click Layout</td>
</tr>
<tr>
<td>3. Select the arrow to the right of the Chart Elements box in the Current Selection group. A list of Chart Elements is displayed.</td>
<td>Click ▶ to the right of the Chart Elements box</td>
</tr>
<tr>
<td>4. Select the chart element you want to format. The element is selected and the name of the selected element appears in the Chart Elements box.</td>
<td>Click Vertical (Value) Axis Minor Gridlines</td>
</tr>
<tr>
<td>5. Select the Format Selection button in the Current Selection group. The Format Minor Gridlines dialog box opens.</td>
<td>Click Format Selection</td>
</tr>
</tbody>
</table>
**Steps** | **Practice Data**
---|---
6. Select the desired formatting component from the list in the left-hand pane. *The options for the component are displayed in the right-hand pane.* | Click **Line Style**
7. Select the desired options in the right-hand pane. *The desired options are applied to the chart element as you select them.* | Follow the instructions shown below the table before continuing on to the next step
8. Select **Close**. *The Format Minor Gridlines dialog box closes.* | Click **Close**

Click the **Dash type** list button and select **Long Dash** from the list (item 6 in the list). Select **Line Color** in the left pane, then click the **Color** list button in the right pane and select **Aqua, Accent 5** (first row, second from right).

*Return to the table and continue on to the next step (step 8).*

Click in a blank area of the chart to deselect the gridlines.

**FORMATTING AN AXIS**

**Discussion**

You can change the formatting of the X or Y axis in the Format Axis dialog box.

Using the **Line Color** and **Line Style** pages in the Format Axis dialog box, you can modify the style, color, and weight of the axis line. To display or hide tick marks, use the **Axis Options** page. Tick marks are small hatch lines that indicate the major and minor units on a Y axis or the categories on an X axis.

You can format the numbers on a scaled axis (usually the Vertical Axis) using the **Number** page. For example, if you want to display numbers on the Vertical Axis with a currency symbol and zero decimal places, you can use the **Number** page to select the desired number format. The alignment of the axis text can be controlled using options on the **Alignment** page.

- To change the **Font** or **Size** of axis text, right-click the text to display the **Mini** toolbar.
Procedures

1. Select the chart.
2. Select the Chart Tools Layout tab.
3. Select the arrow to the right of the Chart Elements box in the Current Selection group.
4. Select the chart element you want to format.
5. Select in the Current Selection group.
6. Select the desired formatting component from the list in the left-hand pane.
7. Select the desired options in the right-hand pane.
8. Select

Step-by-Step

Format an axis.

If necessary, display the Chart1 sheet.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the chart. &lt;br&gt; <em>The chart is selected and the Chart Tools tabs appear on the Ribbon.</em></td>
<td>Click on the chart</td>
</tr>
<tr>
<td>2. Select the Chart Tools Layout tab. &lt;br&gt; <em>The Layout tab is displayed.</em></td>
<td>Click Layout</td>
</tr>
<tr>
<td>3. Select the arrow to the right of the Chart Elements box in the Current Selection group. &lt;br&gt; <em>A list of Chart Elements is displayed.</em></td>
<td>Click to the right of the Chart Elements box</td>
</tr>
<tr>
<td>4. Select the chart element you want to format. &lt;br&gt; <em>The element is selected and the name of the selected element appears in the Chart Elements box.</em></td>
<td>Click Vertical (Value) Axis</td>
</tr>
</tbody>
</table>
**Steps** | **Practice Data**
---|---
5. Select the **Format Selection** button in the **Current Selection** group.  
*The Format Axis dialog box opens.* | Click ![Format Selection](Format_Selection.png)

6. Select the desired formatting component from the list in the left-hand pane.  
*The options for the component are displayed in the right-hand pane.* | Click **Number**

7. Select the desired options in the right-hand pane.  
*The desired options are applied to the chart element as you select them.* | Follow the instructions shown below the table before continuing on to the next step

8. Select **Close**.  
*The Format Axis dialog box closes.* | Click ![Close](Close.png)

Select **Currency** from the **Category** list. Change the number of decimal places to 0 and select the dollar sign ($) from the **Symbol** list, if necessary. Select **Axis Options** from the left-hand pane. Click the **Minor tick mark type** list and select **Outside**.

Return to the table and continue on to the next step (step 8).

**Practice the Concept:** Right-click any number on the Vertical Axis. Change the font size to 12.

Click in a blank area of the chart to deselect the axis.

---

**CHANGING THE AXIS SCALING**

**Discussion**

When you create a chart, Excel automatically creates a scale for the value axis based on the data in the chart. You can change this scaling, if desired.

By default, the options under **Axis Options** on the **Axis Options** page in the Format Axis dialog box are set to **Auto**, which overrides any manual settings. If you select **Fixed** for any of the scaling values, you can control the scale manually by entering the desired values. You can restore automatic scaling by selecting the **Auto** options.

The **Minimum** and **Maximum** options control the lowest and highest numbers on the axis, while the **Major unit** and **Minor unit** options control how the axis is divided between the minimum and maximum values and the frequency of major and minor gridlines. You can also set the value where the category axis crosses the value axis.
The default is 0, but you can change this to any value between the maximum and minimum values.

![A manually scaled axis](image)

### Procedures

1. Select the chart.
2. Select the **Chart Tools Layout** tab.
3. Select the arrow to the right of the **Chart Elements** box in the **Current Selection** group.
4. Select the axis you want to scale.
5. Select **Format Selection** in the **Current Selection** group.
6. Select **Axis Options** from the list in the left-hand pane.
7. Select the desired scaling option.
8. Triple-click the existing value in the number box to the right of selected scaling option.
9. Type the desired new value.
10. Continue changing the axis scale values as desired.
11. Select **Close**.
Step-by-Step

Change the axis scaling.

If necessary, display the Chart1 sheet.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the chart. <em>The chart is selected and the Chart Tools tabs appear on the Ribbon.</em></td>
<td>Click on the chart</td>
</tr>
<tr>
<td>2. Select the Chart Tools Layout tab. <em>The Layout tab is displayed.</em></td>
<td>Click Layout</td>
</tr>
<tr>
<td>3. Select the arrow to the right of the Chart Elements box in the Current Selection group. <em>A list of Chart Elements is displayed.</em></td>
<td>Click to the right of the Chart Elements box</td>
</tr>
<tr>
<td>4. Select the axis you want to scale. <em>The axis is selected and the name of the axis appears in the Chart Elements box.</em></td>
<td>Click Vertical (Value) Axis</td>
</tr>
<tr>
<td>5. Select the Format Selection button in the Current Selection group. <em>The Format Axis dialog box opens.</em></td>
<td>Click Format Selection</td>
</tr>
<tr>
<td>6. Select Axis Options from the list in the left-hand pane. <em>The options for the component are displayed in the right-hand pane.</em></td>
<td>Click Axis Options, if necessary</td>
</tr>
<tr>
<td>7. Select the desired scaling option. <em>The desired option is selected.</em></td>
<td>For the Maximum option, click Fixed</td>
</tr>
<tr>
<td>8. Triple-click the existing value in the number box to the right of selected scaling option. <em>The existing value is selected.</em></td>
<td>Triple-click 25000.0</td>
</tr>
<tr>
<td>9. Type the desired new value. <em>The value appears in the box.</em></td>
<td>Type 21000</td>
</tr>
<tr>
<td>10. Continue changing the axis scale values as desired. <em>The axis scale values change accordingly.</em></td>
<td>Follow the instructions shown below the table before continuing on to the next step</td>
</tr>
</tbody>
</table>
11. Select **Close**. The Format Axis dialog box closes and the chart appears with the new axis scaling.

Select **Fixed** for the **Minimum** option; leave the value as it is. Select **Fixed** for the **Major unit** option and set the value to 3000. Select **Fixed** for the **Minor unit** option so that Excel does not automatically change the minor units.

*Return to the table and continue on to the next step (step 11).*

Click in a blank area of the chart to deselect the Vertical (Value) Axis.

---

**FORMATTING THE DATA SERIES**

**Discussion**

You can change the appearance of the data series in a chart using the Format Data Series dialog box. The options available in the Format Data Series dialog box depend upon the type of chart object used to display the data series.

The **Fill** page contains options to change the color of a data series object. Different options appear for different chart types.

Other pages in the Format Data Series dialog box provide options to rotate a pie chart, change the overlap between columns, plot a data series on a secondary Y axis, add error bars to indicate a percentage of error in the data, and to add shadow and a 3-D format.
You can also format a single data point within a series. Select the series, then click on the single data point you want to format. When you click the **Format Selection** button, the Format Data Point dialog box opens instead of the Format Data Series dialog box.

You can use the **Data Labels** button in the **Labels** group on the **Layout** tab to display the exact value or name of a data series in the chart next to the graphic objects they represent. If a single series is selected before you click the **Data Labels** button, labels are added to just that series. If no series are selected, labels are added to all the series.

**Procedures**

1. Select the chart.
2. Select the **Chart Tools Layout** tab.
3. Select the arrow to the right of the **Chart Elements** box in the **Current Selection** group.
4. Select the data series you want to format.
5. Select \[\text{Format Selection}\] in the \textbf{Current Selection} group.

6. Select the desired formatting component from the list in the left-hand pane.

7. Select the desired options in the right-hand pane.

8. Select \[\text{Close}\].

### Step-by-Step

Format the data series in a chart.

If necessary, display the Chart1 sheet.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the chart. The chart is selected and the Chart Tools tabs appear on the Ribbon.</td>
<td>Click on the chart</td>
</tr>
<tr>
<td>2. Select the Chart Tools Layout tab. The Layout tab is displayed.</td>
<td>Click Layout</td>
</tr>
<tr>
<td>3. Select the arrow to the right of the Chart Elements box in the Current Selection group. A list of Chart Elements is displayed.</td>
<td>Click [\text{to the right of the Chart Elements box}]</td>
</tr>
<tr>
<td>4. Select the data series you want to format. The series is selected and the name of the series appears in the Chart Elements box.</td>
<td>Click \text{Series “Golf”}</td>
</tr>
<tr>
<td>5. Select the Format Selection button in the Current Selection group. The Format Data Series dialog box opens.</td>
<td>Click [\text{Format Selection}]</td>
</tr>
<tr>
<td>6. Select the desired formatting component from the list in the left-hand pane. The options for the component are displayed in the right-hand pane.</td>
<td>Click Fill</td>
</tr>
</tbody>
</table>
Steps | Practice Data
--- | ---
7. Select the desired options in the right-hand pane.  
_The desired options are applied to the data series as you select them._  
Follow the instructions shown below the table before continuing on to the next step  
8. Select Close.  
_The Format Data Series dialog box closes._  
Click ![Close](Close.png)

Select **Gradient fill**. Select the **Preset colors** list button and choose **Early Sunset** from the gallery (first option, first row). Notice the change to the data series in the chart. Select the **Type** list and click **Path**.

Select **Shadow** from the left-hand pane. Click the **Presets** list button and select **Inside Center** from the **Inner** section of the gallery.

_Return to the table and continue on to the next step (step 8)._  

**Practice the Concept:** Select the **Data Labels** button in the **Labels** group and choose **Outside End** from the menu that opens. Notice the value labels that appear above each bar in the series. Click on one of the labels. Notice that the **Chart Elements** box shows that **Series “Golf” Data Labels** has been selected. Click **Format Selection** to open the Format Data Labels dialog box. In the **Label Options** section, click **Category Name**, then **Close** the dialog box.

Click in a blank area of the chart to deselect the data labels.

## Adding Data from Different Worksheets

**Discussion**

You can add data series from different worksheets to the same chart by copying and pasting. This option is useful when you want to compare similar data from different locations. For example, you may want to compare the sales of similar products from different regions when each region’s data is kept on separate worksheets.

You should use the Paste Special dialog box if the data in the worksheet you are copying is arranged in the opposite direction of the data in the chart. The Paste Special dialog box contains options to specify rows or columns for plotting values and whether the series or category labels are included in the copied selection.
You can also add new data series to the chart by clicking the Select Data button in the Data group on the Design tab to open the Select Data Source dialog box, then clicking the Add button in the dialog box to open the Edit Series dialog box. In the Edit Series dialog box, you use the Series name box to select the cell containing the label that describes the series, then you use the Series values box to select the range containing the values that should appear in the chart.

You can change the series name that appears in the legend by selecting the Design tab and then the Select Data button. In the Legend Entries (Series) list, select the series name, then select Edit and type the name you want to appear in the legend in the Series Name box.

Procedures

1. Select the data you want to add to the chart as a new series.

2. Click the Copy button in the Clipboard group on the Home tab.

3. Display the sheet containing the chart.

4. Select the chart.

5. Click the top part of the Paste button in the Clipboard group on the Home tab.

Step-by-Step

Add a data series from a different worksheet.

Display the Retail worksheet.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the data you want to add to the chart as a new series. <em>The range is selected.</em></td>
<td>Drag to select A9:F9</td>
</tr>
<tr>
<td>2. Click the Copy button in the Clipboard group on the Home tab. <em>The range is copied to the Clipboard.</em></td>
<td>Click</td>
</tr>
</tbody>
</table>
### Steps

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
</table>
| 3. | Display the sheet containing the chart.  
*The sheet is displayed.* |
| 4. | Select the chart.  
*The chart is activated and the Chart Tools tabs appear on the Ribbon.* |
| 5. | Click the top part of the **Paste** button in the **Clipboard** group on the **Home** tab.  
*The new series appears in the chart and in the legend.* |
|   | Click the **Chart1** sheet tab  
|   | Click anywhere in the chart  
|   | Click  

Notice that the new series runs off the top of the chart; the fixed scale on the Vertical (Value) Axis is not appropriate for the data in the new series.

Click the **Chart Tools Layout** tab and select **Vertical (Value) Axis** from the **Chart Elements** list in the **Current Selection** group, then click the **Format Selection** button. In the **Axis Options** section of the Format Axis dialog box, set the **Minimum**, **Maximum**, **Major Unit**, and **Minor Unit** options to **Auto**, then click **Close**. Notice that although you can now see the whole **Sq Ft (Avg)** series bars, the bars in the other series are so small as to be unreadable and the **Vertical (Value) Axis** scale showing millions of dollars is not suitable for **Sq Ft (Avg)** values.

### Using a Secondary Axis

#### Discussion

When the values in one or more data series vary widely from the values in other data series, a single scale for the chart may not adequately display the values in all the series. For example, when the values in some of your series are all in the hundreds but values in other series are all in tens of thousands, a single scale that covers the whole range of values can make it nearly impossible to see any variation between values in the low number series. You can add a second scale to a chart and select which series are plotted against each scale; all the low number series can be plotted against one scale and all the high number series against the second scale.

Similarly, when some of your data series represent a different type of value from other series, a second scale greatly increases the clarity of the chart. For example, this applies when some of the series represent a monetary value in dollars and other series represent an area measurement in square feet.

When you add a second scale, known as the **Secondary Vertical (Value) Axis**, to a chart, the scale is displayed on the right-hand side of the plot area.
Procedures

1. Select the chart.
2. Select the Chart Tools Layout tab.
3. Select the arrow to the right of the Chart Elements box in the Current Selection group.
4. Select the data series you want to chart against the secondary axis.
5. Select in the Current Selection group.
6. Select Series Options from the list in the left-hand pane.
7. Select the Secondary Axis option under Plot Series On.
8. Select Close.

Step-by-Step

Use a secondary axis.

If necessary, display the Chart1 sheet.

The values in the Sq Ft (Avg) data series are so large that the other series are almost unreadable. Also, the Vertical (Value) Axis scale in millions of dollars is not suitable for the Sq Ft (Avg) data series. A Secondary Axis is needed to provide a different scale.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the chart.</td>
<td>Click on the chart</td>
</tr>
<tr>
<td><em>The chart is selected and the Chart Tools tabs appear on the Ribbon.</em></td>
<td></td>
</tr>
<tr>
<td>2. Select the Chart Tools Layout tab.</td>
<td>Click Layout</td>
</tr>
<tr>
<td><em>The Layout tab is displayed.</em></td>
<td></td>
</tr>
<tr>
<td>3. Select the arrow to the right of the</td>
<td>Click to the right of the</td>
</tr>
<tr>
<td>Chart Elements box in the Current Selection</td>
<td>Chart Elements box</td>
</tr>
<tr>
<td><em>A list of Chart Elements is displayed.</em></td>
<td></td>
</tr>
</tbody>
</table>
Steps | Practice Data
--- | ---
4. Select the data series you want to chart against the secondary axis. *The series is selected and the name of the series appears in the Chart Elements box.* | Click Series “Sq Ft (Avg)”
5. Select the Format Selection button in the Current Selection group. *The Format Data Series dialog box opens.* | Click 
6. Select Series Options from the list in the left-hand pane. *The options for the component are displayed in the right-hand pane.* | Click Series Options, if necessary
7. Select the Secondary Axis option under Plot Series On. *The Secondary Axis option is selected.* | Click Secondary Axis
8. Select Close. *The Format Data Series dialog box closes, the data series is plotted against the secondary axis and the secondary axis scale appears on the right of the plot area.* | Click Close

Click in a blank area to deselect the series.

Notice that the data series plotted against the secondary axis overlays the data series plotted against the primary axis. The secondary axis series needs to be plotted as a different chart type.

**Changing Data Series Chart Types**

**Discussion**

You can mix different chart types within a single chart to create a combination chart. For example, you can show the total sales for a product in a column format and, at the same time, show the number of retail outlets in a line format. Mixing chart types can help show the relationships between the data series more accurately and improves the chart’s overall appearance and clarity.
Using mixed chart types

Mixing different chart types is often used when a Secondary Axis has been added to a chart. Assigning all the series plotted against the Primary Axis to one chart type, such as Column, and all the series plotted against the Secondary Axis to another chart type, such as Line, greatly increases the clarity of the chart.

Procedures

1. Right-click the data series you want to change.
2. Select Change Series Chart Type from the shortcut menu.
3. Select the general chart type you want to use from the list in the left-hand pane of the dialog box.
4. Select the specific chart type you want to use from the gallery in the right-hand pane.
5. Select OK.
**Step-by-Step**

Change a data series chart type.

If necessary, display the Chart1 sheet.

The **Sq Ft (Avg)** data series plotted against the Secondary Axis overlays the data series plotted against the Primary Axis. The Secondary Axis series needs to be plotted as a different chart type.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Right-click the data series you want to change.  
A shortcut menu opens. | Right-click one of the bars in the **Sq Ft (Avg)** data series |
| 2. Select **Change Series Chart Type** from the shortcut menu. 
The **Change Chart Type** dialog box opens. | Click **Change Series Chart Type** |
| 3. Select the general chart type you want to use from the list in the left-hand pane of the dialog box. 
The general chart type is selected and the right-hand pane scrolls, as necessary, to the selected part of the gallery. | Click **Line** |
| 4. Select the specific chart type you want to use from the gallery in the right-hand pane. 
The specific chart type is selected. | Click **Line with Markers** (fourth option in the **Line** section), if necessary |
| 5. Select **OK**. 
The **Change Chart Type** dialog box closes and the selected data series changes to the new chart type. | Click **OK** |

Click the **Chart Tools Layout** tab and select **Series “Sq Ft (Avg)”** from the **Chart Elements** list in the **Current Selection** group. Click the **Format Selection** button to open the Format Data Series dialog box and select **Marker Options** from the list in the left-hand pane. Under **Marker Type**, click **Built-in**, then click the **Type** list and change the style of the marker to a diamond. Use the **Size** spin box to increase the size to 15. Select **Marker Fill** from the list in the left-hand pane and select the **Solid fill** option in the right-hand pane. Click the **Color** list button and select **Dark Blue, Text 2** (fourth option, first row under **Theme Colors**). Close the Format Data Series dialog box and click in a blank area to deselect the data series.
**ADDDING A TRENDLINE**

**Discussion**

Because of the varying height of the bars in a column chart, it is sometimes difficult to determine the general trend of the data. Adding a linear trendline to a data series lets you quickly see whether the overall trend of the data is rising or falling. Trendlines are commonly used for data charted over time.

Excel’s Trendline feature goes far beyond simple **Linear** trendlines. It is a powerful regression analysis tool that lets you add trendlines using a number of different regression types, such as **Exponential**, **Logarithmic**, **Polynomial**, **Power**, and **Moving Average**. Used correctly, these tools let you create forecast projections by extrapolating from existing data. Although the Trendline tool is simple to use, to create accurate forecasts you need to understand the principles involved in regression analysis and you must use sufficient historical data to make the results statistically significant. For example, forecasting on the basis of the five values shown in the chart in this topic would not produce a reliable forecast.

To delete a trendline, Use the **Chart Elements** list to select the trendline, then press **[Delete]**.
 Procedures

1. Select the chart.
2. Select the Chart Tools Layout tab.
3. Select the arrow to the right of the Chart Elements box in the Current Selection group.
4. Select the data series to which you want to add a trendline.
5. Select in the Analysis group.
6. Select the trendline type you want to use.

Step-by-Step

Add a trendline to a data series.

Select the Retail worksheet.

If necessary, scroll down to view the Retail Space by Quarters chart.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the chart. The chart is selected and the Chart Tools tabs appear on the Ribbon.</td>
<td>Click on the chart</td>
</tr>
<tr>
<td>2. Select the Chart Tools Layout tab. The Layout tab is displayed.</td>
<td>Click Layout</td>
</tr>
<tr>
<td>3. Select the arrow to the right of the Chart Elements box in the Current Selection group. A list of Chart Elements is displayed.</td>
<td>Click to the right of the Chart Elements box</td>
</tr>
<tr>
<td>4. Select the data series to which you want to add a trendline. The series is selected and the name of the series appears in the Chart Elements box.</td>
<td>Click Series “Central”</td>
</tr>
</tbody>
</table>
**Steps** | **Practice Data**
---|---
5. Select the **Trendline** button in the **Analysis** group.  
*The Trendline menu opens.*

<table>
<thead>
<tr>
<th></th>
<th><img src="chart.png" alt="Trendline" /></th>
</tr>
</thead>
<tbody>
<tr>
<td>Click</td>
<td><strong>Linear Trendline</strong></td>
</tr>
</tbody>
</table>

6. Select the trendline type you want to use.  
*The Trendline menu closes and the trendline is added to the chart.*

<table>
<thead>
<tr>
<th></th>
<th><strong>Practice Data</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Click</td>
<td>Linear Trendline</td>
</tr>
</tbody>
</table>

Select **Series “Central” Trendline 1** from the **Chart Elements** list in the **Current Selection** group and click the **Format Selection** button to open the Format Trendline dialog box. Select **Line Color** from the list in the left-hand pane. Select the **Gradient line** option. Click the **Preset colors** list button and select **Rainbow** (first column, fourth row). Select **Line Style** from the list in the left-hand pane. Use the **Width** spin button to increase the line width to **2 pt**. Close the Format Trendline dialog box.

Click in a blank area of the chart to deselect the trendline.

---

**CREATING A CHART TEMPLATE**

**Discussion**

When you have created a chart containing formatting and options that you may wish to use for future charts, you can save the chart layout as a template. The templates you create are added to the Templates section of the gallery of available chart types in both the Insert Chart and Change Chart Type dialog boxes. You can create as many different chart layouts as you need.

Saving your favorite chart layouts as templates enables you to create new charts complete with your preferred formatting more quickly.
The templates you create in Excel are also available when you create charts using Excel from within other Office 2007 programs such as Word and PowerPoint.

**Procedures**

1. Select the chart you want to save as a template.
2. Select the **Chart Tools Design** tab.
3. Select **Save As Template** in the **Type** group.
4. Type the desired name for the chart template.
5. Select **Save**.

**Step-by-Step**

Create a template from an existing chart.
Display the Retail sheet, if necessary.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the chart you want to save as a template. <em>The chart is selected and the Chart Tools tabs appear on the Ribbon.</em></td>
<td>Click on the Retail Space by Quarters chart</td>
</tr>
<tr>
<td>2. Select the Chart Tools Design tab. <em>The Design tab is displayed.</em></td>
<td>Click Design</td>
</tr>
<tr>
<td>3. Select the Save As Template button in the Type group. <em>The Save Chart Template dialog box opens with a suggested name for the template selected in the File name box.</em></td>
<td>Click Save As Template</td>
</tr>
<tr>
<td>4. Type the desired name for the chart template. <em>The new name replaces the suggested name in the File name box.</em></td>
<td>Type Column with Trendline</td>
</tr>
<tr>
<td>5. Select Save. <em>The Save Chart Template dialog box closes and the new template is added to the Templates section of the Insert Chart and Change Chart Type dialog boxes.</em></td>
<td>Click Save</td>
</tr>
</tbody>
</table>

Practice the Concept: Display the Chart1 sheet. Click on the chart to select it and to display the Chart Tools tabs on the Ribbon. Select the Design tab, if necessary, and save the chart as a new Template using the name Column and Line.

**APPLYING A CHART TEMPLATE**

**Discussion**

Any chart templates you save are available for you to use in the Templates section of both the Insert Chart and Change Chart Type dialog boxes. When you create a chart or change the chart type of an existing chart, you can select one of your templates from the Templates section of the dialog box, instead of using one of the standard chart types.
Applying a chart template

You can delete a template by opening either the Insert Chart dialog box or the Change Chart Type dialog box and selecting the Manage Templates button to display a list of your templates. Click the name of the template you want to delete and press [Delete], then select Yes to confirm the deletion.

Procedures

1. Select the range or ranges you want to use to create the chart.
2. Select the Insert tab.
3. Select the Charts launcher arrow.
4. Select Templates from the list in the left-hand pane of the dialog box.
5. To view the name of a template, point to the desired template in the My Templates section of the gallery.
6. Double-click the desired template.
7. To place the chart in a separate chart sheet, select in the Location group on the Chart Tools Design tab.

8. Select \(\text{New sheet}\).

9. Type the desired name for the new chart sheet.

10. Select \(\text{OK}\).

---

**Step-by-Step**

Create a new chart using a template.

Display the **European Sales** worksheet. You will create a combination chart using multiple ranges to show **European Product Sales** as columns and **Average Retail Space** as a line.

<table>
<thead>
<tr>
<th><strong>Steps</strong></th>
<th><strong>Practice Data</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Drag to select the first range you want to use in the chart. <em>The range is highlighted as you drag.</em></td>
<td>Drag to select A7:F11</td>
</tr>
<tr>
<td>2. Release the mouse button. <em>The range is selected.</em></td>
<td>Release the mouse button</td>
</tr>
<tr>
<td>3. Hold ([\text{Ctrl}]) and drag to select the non-adjacent range. <em>The non-adjacent range is highlighted.</em></td>
<td>Hold ([\text{Ctrl}]) and drag to select A23:F23</td>
</tr>
<tr>
<td>4. Release the mouse button, then release ([\text{Ctrl}]). <em>The range is added to the selection.</em></td>
<td>Release the mouse button, then release ([\text{Ctrl}])</td>
</tr>
<tr>
<td>5. Select the <strong>Insert</strong> tab. <em>The Insert tab is displayed.</em></td>
<td>Click <strong>Insert</strong></td>
</tr>
<tr>
<td>6. Select the <strong>Charts</strong> launcher arrow. <em>The Insert Chart dialog box opens.</em></td>
<td>Click (\text{Templates}) in the <strong>Charts</strong> group</td>
</tr>
</tbody>
</table>
| 7. Select **Templates** from the list in the left-hand pane of the dialog box. *A gallery of templates is displayed in the right-hand pane.* | Click \(\text{Templates}\) }
### Steps

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>8. Point to the desired template in the My Templates section of the gallery. The name of the template appears in a ScreenTip.</td>
<td>Point to Column and Line in the My Templates section</td>
</tr>
<tr>
<td>9. Double-click the desired template. The Insert Chart dialog box closes and the new chart appears in the worksheet with the template applied.</td>
<td>Double-click Column and Line</td>
</tr>
<tr>
<td>10. To place the chart in a separate chart sheet, select the Move Chart button in the Location group on the Chart Tools Design tab. The Move Chart dialog box opens with the name of the current worksheet selected in the Object in box and a suggested name displayed in the New sheet box.</td>
<td><img src="image" alt="Move Chart" /> Click</td>
</tr>
<tr>
<td>11. Select the New sheet option. The option is selected and the suggested name is highlighted.</td>
<td><img src="image" alt="New sheet" /> Click</td>
</tr>
<tr>
<td>12. Type the desired name for the new chart sheet. The new name replaces the suggested name.</td>
<td>Type EuroChart</td>
</tr>
<tr>
<td>13. Select OK. The Move Chart dialog box closes, the chart moves to the new chart sheet and the new chart sheet is displayed.</td>
<td><img src="image" alt="OK" /> Click</td>
</tr>
</tbody>
</table>

### Practice the Concept:
Display the European Sales sheet. Select the range A18:F22. Click the Insert tab and create a new chart using the Column with Trendline template. Drag the chart to place it beside the Retail Channel table.

Delete the chart templates by selecting the Change Chart Type button in the Type group on the Design tab. Click the Manage Templates button to display a list of your templates, then select each template and press [Delete]. Select Yes to confirm each deletion. Close the dialog box. Click Cancel to close the Change Chart Type dialog box.

Close CHART3.XLSX.
EXERCISE

USING ADVANCED CHARTING FEATURES

Task

Modify chart options and create and apply a template.

1. Open CHTFMTEX.XLSX.
2. Go to the Q1 Chart sheet, if necessary.
3. Add Minor Gridlines to the Value Axis of the chart.
4. Change the Line Style of the value axis minor gridlines to Square Dot.
5. Change the gridlines for the value axis of the chart to display Major and Minor Gridlines.
6. Change the scale for the Value Axis to display Minor units at intervals of 500.
7. Change the number format for the Value Axis scale to Currency using a dollar sign and no decimal places.
8. Change the color of the Feb data series to a Gradient fill using the Preset colors named Fire.
9. Change the Chart Type for the whole chart to Clustered Column. (Hint: Click in a blank area of the chart to deselect any series before changing the chart type.)
10. Display the 1st Qtr worksheet. Copy the percent figures including the column heading (I3:I9) and paste them into the chart on the Q1 Chart sheet.
11. Select the Sales as % of Qtr 1 data series and plot it against the Secondary Axis.
12. Change the Chart Type for the Sales as % of Qtr 1 data series to Line with Markers.
13. Change the Marker Type to a Triangle and its Size to 12.
14. Save the chart as a Template with the name Quarter Sales.
15. Display the 2nd Qtr worksheet.
16. Select the range A3:D9, hold [Ctrl] and add the range I3:I9 to the selection.
17. Insert a new chart using the **Quarter Sales** template.

18. Move the chart to a new sheet named **Q2 Chart**.

19. Change the chart title to **Second Quarter Sales**.

20. Select the **Manage Templates** button in the Change Chart Type dialog box and delete the **Quarter Sales** template.

21. Close the workbook without saving it.
LESSON 6 - USING CONDITIONAL AND CUSTOM FORMATS

In this lesson, you will learn how to:

- Apply conditional formats
- Change a conditional format
- Add a conditional format
- Create a custom conditional format
- Use data bars
- Delete a conditional format
- Create a custom number format
APPLYING CONDITIONAL FORMATS

Discussion

Excel lets you quickly apply Conditional Formatting to help you explore and analyze data visually, detect critical issues and identify patterns and trends.

A conditional format changes the appearance of a cell range based on a condition or criteria. In previous versions of Excel, only the first conditional format was applied even if more than one condition was true. Now you can apply an unlimited number of conditions and may also be able to use Conditional Formatting in place of a chart. You can use the Highlight Cells Rules, Top/Bottom Rules, Data Bars, Color Scales or Icon Sets options to visualize data easily, highlight interesting cells or ranges of cells and emphasize unusual values.

You can also create your own rules. Select the Conditional Formatting button in the Styles group on the Home tab, then select the New Rule option.

A number of formatting options are made available. If you want to create your own, however, select the Custom Format option, and then specify the desired formatting in the Format Cells dialog box.
Procedures

1. Drag to select the range of cells to which you wish to apply a conditional format.
2. Release the mouse button.
3. Select the Conditional Formatting button in the Styles group on the Home tab.
4. Point to the Highlight Cells Rules or the Top/Bottom Rules option.
5. Select the desired option.
6. Enter the value(s) you want use as the criteria in the appropriate box(es), if applicable.
7. Select the formatting list on the right of the dialog box.
8. Select the desired formatting option.
9. Select OK.

Step-by-Step

From the Student Data directory, open CONDFMT.XLSX. Apply the Highlight Cells Rules or Top/Bottom Rules options in Conditional Formatting.

If necessary, display the Qtr1 worksheet.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Drag to select the range of cells to which you wish to apply a conditional format. The range of cells is highlighted as you drag.</td>
<td>Drag across B3:D6</td>
</tr>
<tr>
<td>2. Release the mouse button. The range of cells is selected.</td>
<td>Release the mouse button</td>
</tr>
</tbody>
</table>
Steps | Practice Data
---|---
3. Select the **Conditional Formatting** button in the **Styles** group on the **Home** tab. *The Conditional Formatting menu opens.* | ![Conditional Formatting](image)
4. Point to the **Highlight Cells Rules** or the **Top/Bottom Rules** option. *The appropriate submenu opens.* | Click ![Highlight Cells Rules](image)
5. Select the desired option. *The appropriate dialog box opens.* | ![Greater Than](image)
6. Enter the value(s) you want use as the criteria in the appropriate box(es), if applicable. *The criteria appear in the boxes.* | Type **2000** in the **Format cells that are GREATER THAN** box
7. Select the formatting list on the right of the dialog box. *A list of available options is displayed.* | ![Light Red Fill](image)
8. Select the desired formatting option. *The formatting option is selected.* | ![OK](image)
9. Select **OK**. *The dialog box closes, and the conditional formatting is applied to the selected cells.* | ![OK](image)

Click in any cell to deselect the range. Notice that the cells with values greater than 2000 are displayed with a light red fill color.

**Practice the concept:** Change the number in cell B6 to **2105** and press **[Enter]**. The cell’s fill color changes to red because the number is now greater than 2000.

---

**CHANGING A CONDITIONAL FORMAT**

**Discussion**

The Conditional Formatting Rules Manager is new in Excel. It helps you to create, change, edit, save and remove rules for your conditional formats.
Editing a conditional format

To edit the formatting of the rule, select the **Format** button in the Edit Formatting Rule dialog box, and then specify the desired formatting in the Format Cells dialog box.

Excel does not check to make sure that your conditions are logically consistent, so you need to be sure that you enter your conditions correctly.

**Procedures**

1. Drag to select the range of cells that you wish to edit.
2. Release the mouse button.
3. Select the **Conditional Formatting** button in the Styles group on the **Home** tab.
4. Select the **Manage Rules** option.
5. Select the rule you want to change.
6. Select the **Edit Rule** button.

7. If you wish to change the condition, select the condition list ▼.

8. Select the new condition.

9. If you wish to change the criterion, select the current criterion.

10. Enter the new criterion.

11. Select **OK**.

12. Select **OK**.

---

### Step-by-Step

Edit a Conditional Formatting rule.

If necessary, display the **Qtr1** worksheet.

<table>
<thead>
<tr>
<th><strong>Steps</strong></th>
<th><strong>Practice Data</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Drag to select the range of cells that you wish to edit. <em>The range of cells is highlighted as you drag.</em></td>
<td>Drag across B3:D6</td>
</tr>
<tr>
<td>2. Release the mouse button. <em>The range of cells is selected.</em></td>
<td>Release the mouse button</td>
</tr>
<tr>
<td>3. Select the <strong>Conditional Formatting</strong> button in the <strong>Styles</strong> group on the <strong>Home</strong> tab. <em>The Conditional Formatting menu opens.</em></td>
<td><img src="image" alt="Conditional Formatting" /> Click <strong>Conditional Formatting</strong> ▼</td>
</tr>
<tr>
<td>4. Select the <strong>Manage Rules</strong> option. <em>The Conditional Formatting Rules Manager dialog box opens.</em></td>
<td><img src="image" alt="Manage Rules" /> Click <strong>Manage Rules</strong></td>
</tr>
<tr>
<td>5. Select the rule you want to change. <em>The selected rule is highlighted.</em></td>
<td><img src="image" alt="Cell Value" /> Click <strong>Cell Value &gt; 2000</strong></td>
</tr>
<tr>
<td>6. Select the <strong>Edit Rule</strong> button. <em>The Edit Formatting Rule dialog box opens.</em></td>
<td><img src="image" alt="Edit Rule" /> Click <strong>Edit Rule...</strong></td>
</tr>
</tbody>
</table>
**Steps** | **Practice Data**
---|---
7. If you wish to change the condition, select the condition list. 
* A list of available options is displayed. | Click the second ▼ (currently greater than)
8. Select the new condition. 
* The new condition appears in the box. | Click less than
9. If you wish to change the criterion, select the current criterion. 
* The condition or criterion is selected. | Double-click 2000
10. Enter the new criterion. 
* The new criterion appears in the box. | Type 1800
11. Select OK. 
* The Edit Formatting Rule dialog box closes. | Click OK
12. Select OK. 
* The Conditional Formatting Rules Manager dialog box closes. The edited conditional formatting rule is applied to the selected cells. | Click OK

Click any cell to deselect the range. Notice that the fill color of cells with values less than 1800 is light red.

**ADDITIONAL A CONDITIONAL FORMAT**

**Discussion**

You can have more than one conditional format for a range of cells. For instance, you can make the fill color red for cells with values less than $1800 but add a further condition that will show a different format for cells with values greater than $2100.

**Procedures**

1. Drag to select the range of cells to which you wish to apply a second conditional format.
2. Release the mouse button.
3. Select the **Conditional Formatting** button in the **Styles** group on the **Home** tab.

4. Point to the **Highlight Cells Rules** or the **Top/Bottom Rules** option.

5. Select the desired option.

6. Enter the value(s) you want use as the criteria in the appropriate box(es), if applicable.

7. Select the formatting list on the right of the dialog box.

8. Select the desired formatting option.

9. Select **OK**.

---

### Step-by-Step

Add a second conditional format to a range.

If necessary, display the **Qtr1** worksheet.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Drag to select the range of cells to which you wish to apply a second conditional format. <em>The range of cells is highlighted as you drag.</em></td>
<td>Drag across B3:D6</td>
</tr>
<tr>
<td>2. Release the mouse button. <em>The range of cells is selected.</em></td>
<td>Release the mouse button</td>
</tr>
<tr>
<td>3. Select the <strong>Conditional Formatting</strong> button in the <strong>Styles</strong> group on the <strong>Home</strong> tab. <em>The Conditional Formatting menu opens.</em></td>
<td>Click <strong>Conditional Formatting</strong></td>
</tr>
<tr>
<td>4. Point to the <strong>Highlight Cells Rules</strong> or the <strong>Top/Bottom Rules</strong> option. <em>The appropriate submenu opens.</em></td>
<td>Point to <strong>Highlight Cells Rules</strong></td>
</tr>
<tr>
<td>5. Select the desired option. <em>The appropriate dialog box opens.</em></td>
<td>Click <strong>Greater Than</strong></td>
</tr>
</tbody>
</table>
### Steps | Practice Data
--- | ---
6. Enter the value(s) you want use as the criteria in the appropriate box(es), if applicable. *The criteria appear in the boxes.* | Type 2100 in the **Format cells that are GREATER THAN** box
7. Select the formatting list on the right of the dialog box. *A list of available options is displayed.* | Click ↓
8. Select the desired formatting option. *The formatting option is selected.* | Click **Green Fill with Dark Green Text**
9. Select **OK**. *The dialog box closes, and the conditional formatting is applied to the selected cells.* | Click **OK**

Click any cell to deselect the range. Notice that the font color of cells with values greater than 2100 is dark green and the cells have a light green fill. The existing conditional formatting, of the light red fill color for cells with values less than 1800, still applies.

---

**CREATING A CUSTOM CONDITIONAL FORMAT**

#### Discussion

Excel enables you to create your own customized conditional formats in addition to using the preset formats. By using the **Custom Format** option you are able to select number formats; font style, size and color; border styles and colors; and fill colors and patterns.

#### Procedures

1. Drag to select the range of cells to which you wish to apply a custom conditional format.
2. Release the mouse button.
3. Select the **Conditional Formatting** button in the **Styles** group on the **Home** tab.
4. Point to the **Highlight Cells Rules** or the **Top/Bottom Rules** option.

5. Select the desired option.

6. Enter the value(s) you want use as the criteria in the appropriate box(es), if applicable.

7. Select the formatting list on the right of the dialog box.

8. Select the **Custom Format** option.

9. Select the required tab.

10. Select the formatting, as desired.

11. Select **OK**.

12. Select **OK**.

---

### Step-by-Step

Creating customized conditional formats.

If necessary, display the Qtr1 worksheet.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Drag to select the range of cells to which you wish to apply a custom conditional format. <em>The range of cells is highlighted as you drag.</em></td>
<td>Drag across B3:D6</td>
</tr>
<tr>
<td>2. Release the mouse button. <em>The range of cells is selected.</em></td>
<td>Release the mouse button</td>
</tr>
<tr>
<td>3. Select the <strong>Conditional Formatting</strong> button in the <strong>Styles</strong> group on the <strong>Home</strong> tab. <em>The Conditional Formatting menu opens.</em></td>
<td><img src="image" alt="Conditional Formatting" /></td>
</tr>
<tr>
<td>4. Point to the <strong>Highlight Cells Rules</strong> or the <strong>Top/Bottom Rules</strong> option. <em>The appropriate submenu opens.</em></td>
<td><img src="image" alt="Top/Bottom Rules" /></td>
</tr>
<tr>
<td>5. Select the desired option. <em>The appropriate dialog box opens.</em></td>
<td><img src="image" alt="Top 10 Items" /></td>
</tr>
</tbody>
</table>
### Steps

<table>
<thead>
<tr>
<th></th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>6.</td>
<td>Enter the value(s) you want use as the criteria in the appropriate box(es), if applicable. <em>The criteria appear in the boxes.</em></td>
</tr>
<tr>
<td>7.</td>
<td>Select the formatting list on the right of the dialog box. <em>A list of available options is displayed.</em></td>
</tr>
<tr>
<td>8.</td>
<td>Select the <strong>Custom Format</strong> option. <em>The Format Cells dialog box opens.</em></td>
</tr>
<tr>
<td>9.</td>
<td>Select the required tab. <em>The required tab is displayed.</em></td>
</tr>
<tr>
<td>10.</td>
<td>Select the formatting, as desired. <em>The desired formatting is selected.</em></td>
</tr>
<tr>
<td>11.</td>
<td>Select <strong>OK</strong>. <em>The Format Cells dialog box closes.</em></td>
</tr>
<tr>
<td>12.</td>
<td>Select <strong>OK</strong>. <em>The dialog box closes, and the customized conditional formatting is applied to the selected cells.</em></td>
</tr>
</tbody>
</table>

Click any cell to deselect the range. Notice that the cells containing the five highest values now have a bold font style. Also, the existing conditional formatting still applies.

### Using Data Bars

#### Discussion

Excel 2007 enables you to create three new types of conditional formats: data bars, color scales and icon sets. These formats are all visually powerful. For example, data bars display a band of color across the cell; the band’s width depends on the value of the cell in relation to other cells in the selected range.
In Excel you can preview a conditional formatting option before selecting it. By hovering the mouse pointer over a conditional formatting option you can immediately see how it will affect the range of cells that you have selected.

**Procedures**

1. Drag to select the range of cells to which you wish to apply a conditional format.
2. Release the mouse button.
3. Select the **Conditional Formatting** button in the **Styles** group on the **Home** tab.
4. Point to the **Data Bars** option.
5. Select the desired option.
Step-by-Step

Using data bars.

If necessary, display the Qtr1 worksheet.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Drag to select the range of cells to which you wish to apply a conditional format. The range of cells is highlighted as you drag.</td>
<td>Drag across F3:F6</td>
</tr>
<tr>
<td>2. Release the mouse button. The range of cells is selected.</td>
<td>Release the mouse button</td>
</tr>
<tr>
<td>3. Select the Conditional Formatting button in the Styles group on the Home tab. The Conditional Formatting menu opens.</td>
<td>Click</td>
</tr>
<tr>
<td>4. Point to the Data Bars option. The Data Bars gallery opens.</td>
<td>Point to Data Bars</td>
</tr>
<tr>
<td>5. Select the desired option. The gallery closes, and the selected conditional formatting is applied to the selected cells.</td>
<td>Click Red Data Bar (first row, third column)</td>
</tr>
</tbody>
</table>

Click in any cell to deselect the range. Notice that the red data bars in the cells vary in width depending on the value of the data in the cells. The higher the value, the wider the data bar.

Practice the concept: Select cells G3:G6 and apply green data bars to the range.

Select cells I3:I6. Display the Icon Sets gallery, then apply the 3 Flags icon set (second row, first column) to the range.

Click in any cell to deselect the range.

DELETING A CONDITIONAL FORMAT

Discussion

You can clear existing rules from selected cells or from the entire worksheet by using the Clear Rules option in the Conditional Formatting menu. If you have more than
one range with conditional formatting applied, you can select multiple ranges before clearing the rules.

If more than one rule applies to the selected cells, and you do not want to clear them all, then open the Conditional Formatting Rules Manager, and use the Delete Rule button to clear one rule at a time.

Procedures

1. Drag to select the range of cells from which you wish to clear the conditional formatting.
2. Release the mouse button.

3. Select the Conditional Formatting button in the Styles group on the Home tab.
4. Point to the Clear Rules option.
5. Select the desired option.

Step-by-Step

Clearing conditional formatting rules.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Drag to select the range of cells from which you wish to clear the conditional formatting. <em>The range of cells is highlighted as you drag.</em></td>
<td>Drag across F3:G6</td>
</tr>
<tr>
<td>2. Release the mouse button. <em>The range of cells is selected.</em></td>
<td>Release the mouse button</td>
</tr>
</tbody>
</table>
### Steps

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>3. Select the <strong>Conditional Formatting</strong> button in the <strong>Styles</strong> group on the <strong>Home</strong> tab. <em>The Conditional Formatting menu opens.</em></td>
<td>Click <strong>Conditional Formatting</strong> button</td>
</tr>
<tr>
<td>4. Point to the <strong>Clear Rules</strong> option. <em>The Clear Rules submenu opens.</em></td>
<td>Point to <strong>Clear Rules</strong> option</td>
</tr>
<tr>
<td>5. Select the desired option. <em>The menu closes and all conditional formatting rules are cleared from the selected cells or the worksheet.</em></td>
<td>Click <strong>Clear Rules from Selected Cells</strong></td>
</tr>
</tbody>
</table>

Click in any cell to deselect the range. Notice that the data bars no longer appear.

**Practice the concept:** Select cells B3:D6. Open the Conditional Formatting Rules Manager. Select the **Top 5** rule, then click the **Delete Rule** button. Click **OK**.

Click in any cell to deselect the range. Notice that the bold font style no longer applies to the five highest values.

## Creating a Custom Number Format

### Discussion

You can format a number with a format that does not exist in Excel by creating a custom number format. Custom number formats can contain text, hyphens, and symbols. For example, in a sales worksheet, you can create a custom number format that will display the text *per lb* to the right of any number entered into the cell, and then apply that format to the desired cells.

When you create a custom number format, you can base it on an existing format. Custom number formats use the following conventions:

1. A number sign (#) indicates a placeholder and can be used, for example, to indicate at what position to place a comma.

2. A zero (0) is used when a number should always be displayed. For example, if there is no number at the specified position, Excel will display a 0, such as 0.5.
3. The format can contain four sections separated by semi-colons: the first section controls the appearance of positive numbers; the second section controls the appearance of negative numbers; the third section controls the appearance of zero values; and the fourth section controls the appearance of text. If only two sections exist, the first controls positive numbers and zero values and the second controls negative numbers.

4. Each section can be displayed in a different color by specifying the color in brackets at the beginning of the section (e.g., [RED]).

5. Text in number formats must be surrounded by quotes (" ").

The following number format [CYAN] #,##0.0 "per lb";[RED](#,##0.0)"per lb";"N/A" displays positive numbers in cyan, with a comma thousands separator and one decimal place, followed by the text per lb. Negative numbers are red, enclosed in parentheses, with a comma thousands separator and one decimal place, followed by the text per lb. The text N/A will appear for zero values.

You can access a custom number format by selecting Custom from the Category list on the Number page in the Format Cells dialog box; all custom number formats will then appear in the Type list box.
Procedures

1. Select the cells to which you want to apply a custom number format.

2. Select the Format button in the Cells group on the Home tab.

3. Select the Format Cells option.

4. Select the Number tab.

5. Select Custom from the Category list.

6. Select the format in the Type list box that most closely resembles the format you want to create.

7. Place the insertion point at the desired location in the Type box.

8. Customize the format as desired.

9. Select OK.

Step-by-Step

Create a custom number format.

Display the Bonus worksheet. You will create a custom currency format that displays the text N/A for zero values.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the cells to which you want to apply a custom number format. The active cell moves accordingly.</td>
<td>Click cell C4</td>
</tr>
<tr>
<td>2. Select the Format button in the Cells group on the Home tab. The Format menu opens.</td>
<td>Click <img src="#" alt="Format" /></td>
</tr>
<tr>
<td>3. Select the Format Cells option. The Format Cells dialog box opens.</td>
<td>Click Format Cells</td>
</tr>
<tr>
<td>4. Select the Number tab. The Number page is displayed.</td>
<td>Click the Number tab, if necessary</td>
</tr>
<tr>
<td>5. Select Custom from the Category list. A list of available custom formats is displayed in the Type list box.</td>
<td>Click Custom</td>
</tr>
</tbody>
</table>
**Steps** | **Practice Data**
--- | ---
6. Select the format in the **Type** list box that most closely resembles the format you want to create. *The format appears in the **Type** box.* | Scroll as necessary and click $#,##0_);($#,##0) (tenth format from the top)
7. Place the insertion point at the desired location in the **Type** box. *The insertion point appears at the desired location in the **Type** box.* | Click at the end of the text in the **Type** box
8. Customize the format as desired. *The changes appear in the **Type** box.* | Type ;"N/A"
9. Select **OK**. *The Format Cells dialog box closes, and the custom format is applied to the selection.* | Click ![OK button]

Use the Format Painter (in the **Clipboard** group) to apply the newly created custom format to the range C5:C7.

Click any cell to deselect the range.
Close **CONDFMT.XLSX**.
EXERCISE

USING CONDITIONAL AND CUSTOM FORMATS

Task

Use conditional formatting and custom formats in a worksheet.

1. Open REGION25.XLSX.

2. Apply conditional formatting to the range B5:E9; have cells with values greater than $45,000 display in Red Text. Then clear the rule you have just created.

3. Create a new rule for the same range B5:E9; have cells with values less than $45,000 display with a Light Red Fill with Dark Red Text.

4. Add a second conditional format to B5:E9; have cells with values greater than $50,000 display in Green Fill with Dark Green Text.

5. Delete the conditional format for cells with values less than $45,000. (Hint: Use the Conditional Formatting Rules Manager.)

6. Apply purple Data Bars to the range F5:F9.

7. Select H5 and create a custom number format that displays positive numbers in blue, with the currency format and no decimal places, and negative numbers in red, with parentheses, the currency format, and no decimal places. (Hint: Use the $#,##0_);[Red]($#,##0) custom format and add the color blue to the positive numbers.)


9. Close the workbook without saving it.
LESSON 7 - USING TEMPLATES

In this lesson, you will learn how to:

- Work with templates
- Save a workbook as a template
- Use a template
- Edit a template
- Insert a new worksheet
- Delete a template
- Create default templates
- Find online templates
WORKING WITH TEMPLATES

Discussion

A template is a special type of workbook you can use as a model for creating new workbooks. Anything that can be saved in a workbook can be included in a template. For example, if you create a weekly budget report that contains standard text and formulas, you can save the workbook as a template and then use the template to create your weekly budget reports. Thereafter, you will not need to enter the standard text and formulas each time you create the weekly budget report.

Templates are a great time saver when you are creating workbooks that have the same general look, even if they contain different data and different functionality. Templates can help ensure a consistent appearance throughout similar workbooks.

SAVING A WORKBOOK AS A TEMPLATE

Discussion

To create a template, you must first design a workbook that contains the formulas, cell attributes, and text that you want to appear in all workbooks based on the template. After you have saved this workbook as a template, you can use it as the basis for future workbooks. For example, you can create a standard workbook that contains the column and row headings, formulas, and formats you use every week in a weekly budget review. After saving this workbook as a template, you can use it for all future weekly budget worksheets.

You can save: text; formatting; styles; formulas; macros; graphics; custom toolbars; and page, worksheet, calculation, and display settings in a template. You can format a new, unsaved workbook and save it as a template, or you can save an existing workbook as a template.
By default, templates you create are stored in the `C:\Users\<your name>\AppData\Roaming\Microsoft\Templates` folder and appear on the My Templates page in the New Workbook dialog box.

You can store your custom templates on a separate page in the Templates dialog box by creating a new folder within the Templates folder. Your custom templates will then appear in the Templates dialog box on a page with the same name as the new folder.

Procedures

1. Select the Office button.
2. Point to the Save As option.
3. Select the Other Formats option.
4. Type the name for the template.
5. Select the Save as type list.
7. Select Save.

Step-by-Step

From the Student Data directory, open BYWEEK.XLSX.

Save a workbook as a template.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Office button. The Office menu opens.</td>
<td>Click</td>
</tr>
<tr>
<td>2. Point to the Save As option. The Save As page is displayed.</td>
<td>Point to Save As</td>
</tr>
<tr>
<td>3. Select the Other Formats option. The Save As dialog box opens,</td>
<td>Click Other Formats</td>
</tr>
<tr>
<td>with the text in the File name box selected.</td>
<td></td>
</tr>
<tr>
<td>4. Type the name for the template. The text appears in the File</td>
<td>Type WEEKLY</td>
</tr>
<tr>
<td>name box.</td>
<td></td>
</tr>
<tr>
<td>5. Select the Save as type list. A list of available file types is</td>
<td>Click Save as type</td>
</tr>
<tr>
<td>displayed.</td>
<td></td>
</tr>
<tr>
<td>6. Select Excel Template. Excel Template appears in the Save</td>
<td>Click Excel Template</td>
</tr>
<tr>
<td>as type box, and the contents of the Templates folder are</td>
<td></td>
</tr>
<tr>
<td>displayed.</td>
<td></td>
</tr>
<tr>
<td>7. Select Save. The Save As dialog box closes, and the file is</td>
<td>Click</td>
</tr>
<tr>
<td>saved as a template in the Templates folder.</td>
<td></td>
</tr>
</tbody>
</table>

Close WEEKLY.XLTX.

**Using a Template**

**Discussion**

You can use a template when you want to create a workbook based on a standard model. For example, if you create a weekly budget report, you can use a weekly budget template each time you create the report.
When you create a workbook from a template, a copy of the template opens as a new workbook with a default name assigned by Excel (e.g., SAMPLE1). When you then save the workbook, you can use the default name, or you can type a new one. Saving changes made to the new workbook does not affect the template itself.

Once you have used a template to create a workbook, Excel adds a new Recently used templates section to the New Workbook task pane with links to the templates you have used.

Procedures

1. Select the Office button.
2. Select the New option.
3. Select the My templates... option under Templates.
4. Select the desired tab.
5. Select the desired template.
6. Select OK.
7. Add the desired data to the workbook.
8. Select the Save button on the Quick Access Toolbar.
9. Type the desired file name.
10. Select the double arrow at the left of the Address bar.
11. Select the drive where you want to save the workbook.
12. Select the folder where you want to save the workbook.
13. Select Save.

Step-by-Step

Use a template to create a workbook.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Office button.</td>
<td>Click</td>
</tr>
<tr>
<td>The Office menu opens.</td>
<td></td>
</tr>
<tr>
<td>Steps</td>
<td>Practice Data</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>---------------------------------------------------</td>
</tr>
<tr>
<td>2. Select the <strong>New</strong> option.</td>
<td>Click <strong>New</strong></td>
</tr>
<tr>
<td><em>The New Workbook dialog box opens.</em></td>
<td></td>
</tr>
<tr>
<td>3. Select the <strong>My templates</strong>... option under <strong>Templates</strong>.</td>
<td>Click <strong>My templates</strong></td>
</tr>
<tr>
<td><em>The New dialog box opens.</em></td>
<td></td>
</tr>
<tr>
<td>4. Select the desired tab.</td>
<td>Click the <strong>My Templates</strong> tab, if necessary</td>
</tr>
<tr>
<td><em>The corresponding page is displayed.</em></td>
<td></td>
</tr>
<tr>
<td>5. Select the desired template.</td>
<td>Scroll as necessary and click <strong>WEEKLY</strong></td>
</tr>
<tr>
<td><em>A preview of the template appears in the <strong>Preview</strong> box, if available.</em></td>
<td></td>
</tr>
<tr>
<td>6. Select <strong>OK</strong>.</td>
<td>Click <strong>OK</strong></td>
</tr>
<tr>
<td><em>The New dialog box closes, and a new workbook based on the template opens.</em></td>
<td></td>
</tr>
<tr>
<td>7. Add the desired data to the workbook.</td>
<td>Follow the instructions shown below the table before continuing on to the next step</td>
</tr>
<tr>
<td><em>The data appears in the workbook.</em></td>
<td></td>
</tr>
<tr>
<td>8. Select the <strong>Save</strong> button on the <strong>Quick Access Toolbar</strong>.</td>
<td>Click <strong>Save</strong></td>
</tr>
<tr>
<td><em>The Save As dialog box opens with the text in the <strong>File name</strong> box selected.</em></td>
<td></td>
</tr>
<tr>
<td>9. Type the desired file name.</td>
<td>Type <strong>WEEK2</strong></td>
</tr>
<tr>
<td><em>The text appears in the <strong>File name</strong> box.</em></td>
<td></td>
</tr>
<tr>
<td>10. Select the double arrow at the left of the <strong>Address</strong> bar.</td>
<td>Click «</td>
</tr>
<tr>
<td><em>A list of available drives and common folders is displayed.</em></td>
<td></td>
</tr>
<tr>
<td>11. Select the drive where you want to save the workbook.</td>
<td>Click the student data drive</td>
</tr>
<tr>
<td><em>A list of available folders is displayed.</em></td>
<td></td>
</tr>
<tr>
<td>12. Select the folder where you want to save the workbook.</td>
<td>Click the student data folder</td>
</tr>
<tr>
<td><em>A list of available folders and files is displayed.</em></td>
<td></td>
</tr>
<tr>
<td>13. Select <strong>Save</strong>.</td>
<td>Click <strong>Save</strong></td>
</tr>
<tr>
<td><em>The Save As dialog box closes, and the new workbook based on the template is saved.</em></td>
<td></td>
</tr>
</tbody>
</table>
Enter the following information into the indicated worksheet cells:

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
</tr>
</thead>
<tbody>
<tr>
<td>4</td>
<td>Week</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Wk 1</td>
<td>300</td>
</tr>
<tr>
<td>6</td>
<td>Wk 2</td>
<td>350</td>
</tr>
<tr>
<td>7</td>
<td>Wk 3</td>
<td>250</td>
</tr>
<tr>
<td>8</td>
<td>Wk 4</td>
<td>400</td>
</tr>
</tbody>
</table>

Return to the table and continue on to the next step (step 8).
Close WEEK2.XLSX.

EDITING A TEMPLATE

Discussion

You can change the content and formats of a template. For example, if you create and save a template for your weekly budgets and you need to add an additional line item, you can open, modify, and resave the template with the new line item. In addition, you can modify or update the default templates provided by Excel.

Changes to a template affect only new workbooks created from that template; workbooks created from the template before the changes were made to it are not updated.

Procedures

1. Select the Office button.
2. Select the New option.
3. Select the My templates... option under Templates.
4. Select the desired tab.
5. Select the desired template.
6. Select OK.
7. Make the desired changes.
8. Click the Save button on the Quick Access Toolbar.
9. Type the name for the template.
10. Select the **Save as type** list.

11. Select **Excel Template**.

12. Select **Save**.

13. Select **Yes**.

---

**Step-by-Step**

Edit a template.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the <strong>Office</strong> button.</td>
<td><strong>Practice Data</strong></td>
</tr>
<tr>
<td><em>The Office menu opens.</em></td>
<td><em>Click</em></td>
</tr>
<tr>
<td>2. Select the <strong>New</strong> option.</td>
<td><strong>Click New</strong></td>
</tr>
<tr>
<td><em>The New Workbook dialog box opens.</em></td>
<td></td>
</tr>
<tr>
<td>3. Select the <strong>My templates</strong>... option</td>
<td><strong>Click My templates</strong></td>
</tr>
<tr>
<td>under <strong>Templates</strong>.</td>
<td></td>
</tr>
<tr>
<td><em>The New dialog box opens.</em></td>
<td></td>
</tr>
<tr>
<td>4. Select the desired tab.</td>
<td><strong>Click the My Templates</strong> tab, if necessary</td>
</tr>
<tr>
<td><em>The corresponding page is displayed.</em></td>
<td></td>
</tr>
<tr>
<td>5. Select the desired template.</td>
<td>**Scroll as necessary and click <strong>WEEKLY</strong></td>
</tr>
<tr>
<td><em>A preview of the template appears in the Preview box, if available.</em></td>
<td></td>
</tr>
<tr>
<td>6. Select <strong>OK</strong>.</td>
<td><strong>Click OK</strong></td>
</tr>
<tr>
<td><em>The New dialog box closes, and a new workbook based on the template opens.</em></td>
<td></td>
</tr>
<tr>
<td>7. Make the desired changes.</td>
<td><em>Follow the instructions shown below the table before continuing on to the next step</em></td>
</tr>
<tr>
<td><em>The contents or formatting of the workbook are changed as applicable.</em></td>
<td></td>
</tr>
<tr>
<td>8. Click the <strong>Save</strong> button on the <strong>Quick Access Toolbar</strong>.</td>
<td><strong>Click</strong></td>
</tr>
<tr>
<td><em>The Save As dialog box opens, with the text in the <strong>File name</strong> box selected.</em></td>
<td></td>
</tr>
<tr>
<td>9. Type the name for the template.</td>
<td>**Type <strong>WEEKLY</strong></td>
</tr>
<tr>
<td><em>The text appears in the <strong>File name</strong> box.</em></td>
<td></td>
</tr>
</tbody>
</table>
### Steps

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>10. Select the <strong>Save as type</strong> list.</td>
<td>Click <strong>Save as type</strong></td>
</tr>
<tr>
<td>11. Select <strong>Excel Template</strong>.</td>
<td>Click <strong>Excel Template</strong></td>
</tr>
<tr>
<td>12. Select <strong>Save</strong>.</td>
<td>Click <strong>Save</strong></td>
</tr>
<tr>
<td>13. Select <strong>Yes</strong>.</td>
<td>Click <strong>Yes</strong></td>
</tr>
</tbody>
</table>

Click cell A2 and press **[Delete]**.

Return to the table and continue on to the next step (step 8).

Close the template.

**Practice the Concept:** Create a new workbook from the **Weekly** template. Notice that the subtitle in cell A2 no longer appears. Then, close the new workbook without saving it.

### INSERTING A NEW WORKSHEET

#### Discussion

When you insert a worksheet into the current workbook, you can base it on an existing template, or you can select it from any available template; if the template you select contains more than one worksheet, all the worksheets in the template are inserted. For example, if you are working on a quarterly workbook, you can insert a worksheet based on the weekly budget template.

Excel automatically assigns a name to an inserted worksheet. You can change the default name, as desired.
### Procedures

1. Right-click the tab before which you want to insert a worksheet.
2. Select the **Insert** option in the shortcut menu.
3. Select the desired tab.
4. Select the desired template.
5. Select **OK**.

### Step-by-Step

From the Student Data directory, open **WEEK2a.XLSX**.

Insert a new worksheet based on a template.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Right-click the tab before which you want to insert a worksheet.  
  *A shortcut menu opens.* | Right-click the **Sheet1** tab         |
Steps | Practice Data
--- | ---
2. Select the **Insert** option. The Insert dialog box opens. | Click **Insert**
3. Select the desired tab. The corresponding page is displayed. | Click the **General** tab, if necessary
4. Select the desired template. A preview of the template appears in the **Preview** box, if available. | Scroll as necessary and click **WEEKLY**
5. Select **OK**. The Insert dialog box closes, and a worksheet based on the selected template appears in the workbook. | Click **OK**

Close **WEEK2a.XLSX**.

**DELETING A TEMPLATE**

Discussion

You can delete a template you no longer use. Deleting unwanted templates prevents your Templates folder becoming overcrowded.
If you accidentally delete a template, you can restore it from the Recycle Bin to its original location.

Procedures

1. Select the Office button.
2. Select the New option.
3. Select the My templates option under Templates.
4. Select the tab containing the template you want to delete.
5. Right-click the template you want to delete.
6. Select the Delete option from the shortcut menu.
7. Select Yes.
8. Select Cancel.
9. Select Cancel.

Step-by-Step

Delete a template.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Office button.</td>
<td>Click</td>
</tr>
<tr>
<td><em>The Office menu opens.</em></td>
<td>Click New</td>
</tr>
<tr>
<td>2. Select the New option.</td>
<td></td>
</tr>
<tr>
<td><em>The New Workbook dialog box opens.</em></td>
<td></td>
</tr>
<tr>
<td>3. Select the My templates... option under</td>
<td>Click My templates</td>
</tr>
<tr>
<td>Templates.</td>
<td></td>
</tr>
<tr>
<td><em>The New dialog box opens.</em></td>
<td></td>
</tr>
<tr>
<td>4. Select the tab containing the template</td>
<td></td>
</tr>
<tr>
<td>you want to delete.</td>
<td></td>
</tr>
<tr>
<td><em>The corresponding page opens.</em></td>
<td></td>
</tr>
</tbody>
</table>
### CREATING DEFAULT TEMPLATES

#### Discussion

Whenever you create a new workbook or insert a worksheet without selecting a template, Excel uses the default Workbook template and the default Worksheet template, respectively.

You can create your own default workbook template. For example, if you always use a specific header and footer in your workbooks, you can create a template that contains your desired header and footer and save it as the default template. If you want Excel to use your custom template as the default workbook template, you must store it in the XLSTART folder. In addition, the default workbook template must be named Book, with the template file extension .xltx, since Excel recognizes the default workbook template by its file name. If a Book template exists in the XLSTART folder, then Excel will use it whenever you click the New button.

Similarly, you can create a default worksheet template in the XLSTART folder named Sheet.xltx. If a Sheet template exists in the XLSTART folder, Excel will use it whenever you insert a new worksheet. (The Worksheet icon in the Insert dialog box is a link; selecting it will insert the default Sheet template if one exists; otherwise, selecting it will insert a blank worksheet.)
The XLSTART folder for users is located in the 
C: \ Users \ <your name> \ AppData \ Roaming \ Microsoft \ Excel folder. There is also an XLSTART folder located in the Microsoft Office folder containing Excel. The template in the Users \ <your name> folder takes precedent over the template in the Microsoft Office folder.

If the Sheet template contains more than one worksheet, all of the worksheets (including any blank worksheets) will be inserted when you insert a worksheet.

FINDING ONLINE TEMPLATES

Discussion

Templates can also be found at Microsoft Office Online, if you have an Internet connection. You can search Office Online for a template by entering one or more keywords into the Search Microsoft Office Online for a template box in the New Workbook dialog box. You can select a template to view it and use the Download link to download it to your computer. Another option is to use the Microsoft Office Online links that list the templates available from Office Online by category.

You must have the rights to install new programs on your computer to be able to download new templates.

You can use the Previous and Next links in the Template Preview window to browse through other templates.

The first time you download a template, a Microsoft Office Genuine Advantage message appears to validate your copy of Microsoft Office. Click Continue to proceed with the download.

Procedures

1. Select the Office button 
2. Select the New option.
3. Select the Search Microsoft Office Online for a template box.
4. Type one or more keywords relating to the template you want to find.

5. Press [Enter].

6. Select the desired template from the Search Results task pane.

7. Select Download to download the current template.

8. Select Yes to download links to help topics in the Template Help task pane, or No if you do not want to download the links.

**Step-by-Step**

Find online templates.

**Note:** You will need an Internet connection to complete this step-by-step.

If necessary, open the New Workbook dialog box by selecting the Office button and the New option.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Search Microsoft Office Online for a template box. The insertion point appears in the Search Microsoft Office Online for a template text box.</td>
<td>Click the Search Microsoft Office Online for a template box</td>
</tr>
<tr>
<td>2. Type one or more keywords relating to the template you want to find. The text appears in the Search Microsoft Office Online for a template text box.</td>
<td>Type work schedule</td>
</tr>
<tr>
<td>3. Press [Enter]. The Search Results task pane displays the templates that match the keywords.</td>
<td>Press [Enter]</td>
</tr>
<tr>
<td>4. Select the desired template from the Search Results task pane. The Template Preview window opens displaying a preview of the template.</td>
<td>Click Weekly work schedule</td>
</tr>
<tr>
<td>Steps</td>
<td>Practice Data</td>
</tr>
<tr>
<td>-------</td>
<td>---------------</td>
</tr>
<tr>
<td>5. Select <strong>Download</strong> to download the current template. Excel creates a new workbook based on the template and a Microsoft Office Online message box opens asking if you want to display links to help topics in the Template Help task pane.</td>
<td>Click <strong>Download</strong></td>
</tr>
<tr>
<td>6. Select <strong>Yes</strong> to download links to help topics in the Template Help task pane, or <strong>No</strong> if you do not want to download the links. The links are downloaded or not downloaded accordingly.</td>
<td>Click <strong>Yes</strong></td>
</tr>
</tbody>
</table>

Close the Template Help task pane and close the Weekly work schedule1 workbook without saving the changes.
EXERCISE

USING TEMPLATES

Task

Create and use templates.

1. Open TENNTMP.XLSX.
2. Save the workbook as a template called TENNIS. Close the template.
3. Use the TENNIS template to create a new workbook.
4. In the new workbook, change the months to Apr, May, and Jun in the range B7:D7.
5. Change the title in cell A3 to read Second Quarter Sales - Southeast.
6. Save the workbook as a template named TENNIS2Q. Then, close it.
7. Create a new workbook based on the TENNIS template.
8. Insert a new worksheet based on the TENNIS2Q template.
9. Close the workbook without saving it.
10. Delete both the TENNIS and the TENNIS2Q templates.
11. Close the New Workbook dialog box.
LESSON 8 -
USING PASTE SPECIAL

In this lesson, you will learn how to:

- Work with Paste Special
- Copy values between worksheets
- Copy formulas between worksheets
- Perform mathematical operations
WORKING WITH PASTE SPECIAL

Discussion

When you copy the contents of a cell or a range of cells, any formatting that has been applied is copied as well as the cell contents. When you subsequently paste the copied data, an exact copy of both the contents and its formatting is pasted.

There may be times when you want to paste only certain aspects of the copied data (such as formulas, values, or formats). For example, you may want to copy and paste all the formulas in a worksheet, but not their formatting. The Paste Special feature allows you to specify which aspect of the copied data you want to paste; you can paste all cell attributes or only selected ones.

The Column widths option pastes the width of the corresponding columns into the paste range.

The All except borders option is useful for maintaining the borders in the paste area, such as when you copy a formula from a cell that has a right border to a cell formatted with no borders. If you used the normal Paste option in this situation, the right border would be incorrectly added to each of the cells in the paste range.

In addition to specifying paste options, you can add the values of the copied cells to the values of the existing cells in the paste range.

You can use the Paste button in the Clipboard group on the Home tab to display a menu of paste options, including the Paste Special option which opens the Paste Special dialog box.

COPYING VALUES BETWEEN WORKSHEETS

Discussion

There may be times when you want to copy the results of a formula, but not the formula itself. For example, you may want to copy the totals from quarterly worksheets (in which each total is the result of a formula) to a summary worksheet (in which you only need the formula results or totals). To perform this task, you can use the Paste Values feature.
Pasting the values only

You can also select the Values option under Paste in the Paste Special dialog box to perform this task.

Procedures

1. Select the range containing the values you want to copy.
2. Select the Copy button in the Clipboard group on the Home tab.
3. Select the worksheet into which you want to paste the values.
4. Select the cell in the upper, left corner of the paste range.
5. Select the lower part of the Paste button in the Clipboard group.
6. Select the Paste Values option.

Step-by-Step

From the Student Data directory, open ADDSAL1.XLSX. Copy values between worksheets.
If necessary, display the Qtr 1 worksheet.

### Steps | Practice Data
--- | ---
1. Select the range containing the values you want to copy. The range is selected. | Drag across E7:G7, then release the mouse button
2. Select the Copy button in the Clipboard group on the Home tab. A blinking marquee appears around the copied selection. | Click
3. Select the worksheet into which you want to paste the values. The worksheet is displayed. | Click the Annual tab
4. Select the cell in the upper, left corner of the paste range. The cell is selected. | Click cell B3
5. Select the lower part of the Paste button in the Clipboard group. The Paste menu opens. | Click Paste
6. Select the Paste Values option. The Paste menu closes, and only the values are pasted into the paste range. | Click Paste Values

**Practice the Concept:** Copy the values in the range E7:G7 from the Qtr 2, Qtr 3, and Qtr 4 worksheets to the corresponding cells in the Annual worksheet.

### Copying Formulas Between Worksheets

#### Discussion

You can copy a cell and paste just the formula from the cell, not its format or the specific formula results. This option is useful if you do not want to overwrite existing formatting in the paste range, or if you want to apply the same formula to different data.

When you paste a formula, relative cell references in the formula adjust to the formula’s new location. Absolute cell references, however, do not adjust; they will always refer to the absolute cell address.

You can also select the Formulas option under Paste in the Paste Special dialog box to perform this task.
Procedures

1. Select the range containing the formulas you want to copy.
2. Select the Copy button in the Clipboard group on the Home tab.
3. Select the worksheet into which you want to paste the formulas.
4. Select the cell in the upper, left corner of the paste range.
5. Select the lower part of the Paste button in the Clipboard group.
6. Select the Formulas option.

Step-by-Step

Copy formulas between worksheets.

Display the Qtr 1 worksheet.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the range containing the formulas you want to copy. Drag across E7:G7, then release the mouse button</td>
<td></td>
</tr>
<tr>
<td>2. Select the Copy button in the Clipboard group on the Home tab. Click</td>
<td></td>
</tr>
<tr>
<td>3. Select the worksheet into which you want to paste the formulas. Click the Annual tab</td>
<td></td>
</tr>
<tr>
<td>4. Select the cell in the upper, left corner of the paste range. Click cell B7</td>
<td></td>
</tr>
<tr>
<td>5. Select the lower part of the Paste button in the Clipboard group. Click</td>
<td></td>
</tr>
</tbody>
</table>
Steps | Practice Data
--- | ---
6. Select the **Formulas** option. The **Paste** menu closes, and only the formulas are pasted into the paste range. The cells in the paste range display formula results based on the relevant data. | Click **Formulas**

The results of the pasted formulas should be total sales of $94,613.98, total expenses of $21,604.00, and net profits of $73,009.98.

**PERFORMING MATHEMATICAL OPERATIONS**

**Discussion**

You can use the Paste Special feature to perform mathematical operations. When you paste values or formulas, you can add to, subtract from, multiply by, or divide by the existing values. This feature allows you to consolidate figures. For example, in an annual workbook, you can create an annual total that consolidates the numbers from all the quarterly worksheets.
Unlike formulas, consolidated figures will not update automatically. The consolidated figures are fixed values, so you must perform the same actions again if you need to update them.

Procedures

1. Select the worksheet containing the values or formulas you want to copy.
2. Select the range you want to copy.
3. Select the Copy button in the Clipboard group on the Home tab.
4. Select the worksheet into which you want to paste the values or formulas.
5. Select the cell in the upper, left corner of the paste range.
6. Select the lower part of the Paste button in the Clipboard group.
7. Select the Paste Values option.
8. Select the worksheet containing the values you want to add to those in the paste range.
9. Select the range you want to copy.
10. Click the Copy button in the Clipboard group on the Home tab.
11. Select the worksheet into which you want to add the values or formulas.
12. Select the cell in the upper, left corner of the paste range.
13. Select the lower part of the Paste button in the Clipboard group.
14. Select the Paste Special option.
15. Under Paste, select the Values option.
16. Under Operation, select the desired mathematical operation.
17. Select OK.
Step-by-Step

Perform a mathematical operation using the Paste Special feature.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the worksheet containing the values or formulas you want to copy. <em>The worksheet is displayed.</em></td>
<td>Click the <strong>Qtr 1</strong> tab</td>
</tr>
<tr>
<td>2. Select the range you want to copy. <em>The range is selected.</em></td>
<td>Drag across G3:G6, then release the mouse button</td>
</tr>
<tr>
<td>3. Select the <strong>Copy</strong> button in the <strong>Clipboard</strong> group on the <strong>Home</strong> tab. <em>A blinking marquee appears around the copied selection.</em></td>
<td>Click</td>
</tr>
<tr>
<td>4. Select the worksheet into which you want to paste the values or formulas. <em>The worksheet is displayed.</em></td>
<td>Click the <strong>By Rep</strong> tab</td>
</tr>
<tr>
<td>5. Select the cell in the upper, left corner of the paste range. <em>The cell is selected.</em></td>
<td>Click cell C3</td>
</tr>
<tr>
<td>6. Select the lower part of the <strong>Paste</strong> button in the <strong>Clipboard</strong> group. <em>The Paste menu opens.</em></td>
<td>Click</td>
</tr>
<tr>
<td>7. Select the <strong>Paste Values</strong> option. <em>The Paste menu closes, and the values are pasted into the paste range.</em></td>
<td>Click <strong>Paste Values</strong></td>
</tr>
<tr>
<td>8. Select the worksheet containing the values you want to add to those in the paste range. <em>The worksheet is displayed.</em></td>
<td>Click the <strong>Qtr 2</strong> tab</td>
</tr>
<tr>
<td>9. Select the range you want to copy. <em>The range is selected.</em></td>
<td>Drag across G3:G6, then release the mouse button</td>
</tr>
<tr>
<td>10. Select the <strong>Copy</strong> button in the <strong>Clipboard</strong> group on the <strong>Home</strong> tab. <em>A blinking marquee appears around the copied selection.</em></td>
<td>Click</td>
</tr>
<tr>
<td>11. Select the worksheet into which you want to add the values or formulas. <em>The worksheet is displayed.</em></td>
<td>Click the <strong>By Rep</strong> tab</td>
</tr>
</tbody>
</table>
Excel 2007 - Lvl 3

Lesson 8 - Using Paste Special

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>12. Select the cell in the upper, left corner of the paste range. <em>The cell is selected.</em></td>
<td>Click cell C3</td>
</tr>
<tr>
<td>13. Select the lower part of the Paste button in the Clipboard group. <em>The Paste menu opens.</em></td>
<td>Click Paste</td>
</tr>
<tr>
<td>14. Select the Paste Special option. <em>The Paste Special dialog box opens.</em></td>
<td>Click Paste Special</td>
</tr>
<tr>
<td>15. Under Paste, select the Values option. <em>The Values option is selected.</em></td>
<td>Click Values</td>
</tr>
<tr>
<td>16. Under Operation, select the desired mathematical operation. <em>The desired option is selected.</em></td>
<td>Click Add</td>
</tr>
<tr>
<td>17. Select OK. <em>The Paste Special dialog box closes, and the copied values are added to the existing values in the paste range.</em></td>
<td>Click OK</td>
</tr>
</tbody>
</table>

**Practice the Concept:** Add the values in G3:G6 on the Qtr 3 and Qtr 4 worksheets to the paste range in the By Rep worksheet.

The total in C7 should be **$73,009.98**.
Close **ADDSAL1.XLSX**.
EXERCISE

USING PASTE SPECIAL

Task

Use the Paste Special feature.

1. Open REGION16.XLSX.
2. Copy the range B9:D9 on the Northeast worksheet and paste the values only to cell B5 on the Totals worksheet.
3. Copy the range B9:D9 on the Southeast worksheet and paste the values only to cell B6 on the Totals worksheet.
4. Copy the range B9:D9 on the Central worksheet and paste the values only to cell B7 on the Totals worksheet.
5. Copy cell E5 on the Expenses worksheet and paste the formula only to the range E5:E7 on the Totals worksheet.
6. Copy the range D5:D8 on the Northeast worksheet and paste the values only to the range D5:D8 on the By Week worksheet.
7. Copy the range D5:D8 on the Southeast worksheet; add the values to the range D5:D8 on the By Week worksheet.
8. Copy the range D5:D8 on the Central worksheet; add the values to the range D5:D8 on the By Week worksheet.
9. Close the workbook without saving it.
LESSON 9 -
CUSTOMIZING EXCEL PREFERENCES

In this lesson, you will learn how to:

- Set Edit options
- Set Display options
- Set manual calculation
- Reset automatic calculation
- Set Popular options
### Setting Edit Options

#### Discussion

You can use the options in the **Editing options** section on the **Advanced** page of the Excel Options dialog box to control basic copying, editing, and data entry tasks.

For example, the default direction of the active cell after pressing the [Enter] key is down. When you enter data into a cell and press the [Enter] key, the active cell moves down one row. However, if you are entering data across a row, instead of down a column, it would be more efficient to have the active cell move to the right. You can change the direction of the active cell movement to up, down, right, or left.

![Setting Edit options](image)

#### Procedures

1. Select the **Office** button.
2. Select the **Excel Options** button.
3. Select the **Advanced** option.
4. Select or deselect the desired options.
5. Select OK.

**Step-by-Step**

From the Student Data directory, open CUSTOPT.XLSX. Set edit options.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Office button. The Office menu opens.</td>
<td>Click</td>
</tr>
<tr>
<td>2. Select the Excel Options button. The Excel Options dialog box opens.</td>
<td>Click ExcelOptions</td>
</tr>
<tr>
<td>3. Select the Advanced option. The Advanced page is displayed.</td>
<td>Click Advanced</td>
</tr>
<tr>
<td>4. Select or deselect the desired options. The options are selected or deselected.</td>
<td>Follow the instructions shown below the table before continuing on to the next step</td>
</tr>
<tr>
<td>5. Select OK. The Excel Options dialog box closes, and the editing options are applied or disabled accordingly.</td>
<td>Click OK</td>
</tr>
</tbody>
</table>

The option **After pressing Enter, move selection** should already be selected. Display the **Direction** list underneath it, and select **Right**.

*Return to the table and continue on to the next step (step 5).*

Type 12 in cell B8 and press [Enter]. The active cell should move to cell C8. In C8 and D8, enter the data **TM34** and **12.50**, pressing [Enter] after each entry. Notice that the active cell moves to the right each time you press [Enter].

Open the Excel Options dialog box and change the active cell direction back to **Down**.

**SETTING DISPLAY OPTIONS**

**Discussion**

You can use the options in the **Display** section on the **Advanced** page of the Excel Options dialog box to choose which elements appear in and around the worksheet.
window. For example, you can control the display of the formula bar and function ScreenTips, and decide how comments appear.

If you select the **Show formulas in cells instead of their calculated results** option, the formulas themselves appear in cells (where applicable) instead of their results. This option is valuable when you are auditing a worksheet for errors.

By default, gridlines appear on the screen to define each cell in a worksheet. Deselecting the **Show gridlines** option hides the screen gridlines. When the gridlines are hidden, you can use borders instead to define specific areas in a worksheet.

When a formula calculates to zero (0), the default setting is that a zero appears in the cell. You can suppress the display of zeroes by deselecting the **Show a zero in cells that have zero value** option. Thereafter, all cells containing a zero value will be blank, even though the formula remains in the cell and is not affected.

Some display options apply throughout Excel, while some only apply to the current workbook or worksheet. The options are grouped accordingly on the **Advanced** page.
Procedures

1. Select the Office button.
2. Select the Excel Options button.
3. Select the Advanced option.
4. Scroll as necessary to view the various Display options.
5. Select or deselect the desired options.
6. Select OK.

Step-by-Step

Set display options.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Office button.</td>
<td>Click</td>
</tr>
<tr>
<td><em>The Office menu opens.</em></td>
<td></td>
</tr>
<tr>
<td>2. Select the Excel Options button.</td>
<td>Click</td>
</tr>
<tr>
<td><em>The Excel Options dialog box opens.</em></td>
<td></td>
</tr>
<tr>
<td>3. Select the Advanced option.</td>
<td>Click Advanced</td>
</tr>
<tr>
<td><em>The Advanced page is displayed.</em></td>
<td></td>
</tr>
<tr>
<td>4. Scroll as necessary to view the various</td>
<td>Scroll to view Display options for this worksheet</td>
</tr>
<tr>
<td>Display options.</td>
<td></td>
</tr>
<tr>
<td><em>The Display options are displayed.</em></td>
<td></td>
</tr>
<tr>
<td>5. Select or deselect the desired options.</td>
<td>Click Show gridlines to deselect it</td>
</tr>
<tr>
<td><em>The options are selected or deselected.</em></td>
<td></td>
</tr>
<tr>
<td>6. Select OK.</td>
<td>Click</td>
</tr>
<tr>
<td><em>The Excel Options dialog box closes,</em></td>
<td></td>
</tr>
<tr>
<td>and the display options are applied or</td>
<td></td>
</tr>
<tr>
<td>disabled accordingly.*</td>
<td></td>
</tr>
</tbody>
</table>

Notice that the gridlines no longer appear in the window, and the borders surrounding the areas of data are more visually effective.

Open the Excel Options dialog box and enable the gridlines.
**SETTING MANUAL CALCULATION**

**Discussion**

When you change any value or number in a worksheet, all formulas that refer to that value are automatically recalculated. You can configure the worksheet to recalculate manually instead. Manual recalculation allows you to change values as needed and then recalculate the worksheet only when desired. This option can save time when you are working in large, complex worksheets.

When recalculation is set to manual, the **Calculate** indicator appears on the status bar when values have changed and formulas need to be recalculated. Therefore, when the **Calculate** indicator is showing on the status bar, the workbook figures are probably not accurate. For this reason, it is a good idea to always recalculate before you print a worksheet.

Calculation options are system settings rather than workbook settings. Consequently, once you have enabled manual calculation, all worksheets will have to be manually recalculated until you change the calculation back to automatic.

When calculation is set to manual, workbooks will still automatically recalculate each time you save them, if the **Recalculate workbook before saving** option is selected on the **Formulas** page in the Excel Options dialog box. This is the default setting.
You can recalculate the current workbook by pressing the [F9] key, or by clicking the **Calculate Now** button in the **Calculation** group on the **Formulas** tab.

You can recalculate only the current worksheet by pressing the [Shift+F9] keys, or by clicking the **Calculate Sheet** button in the **Calculation** group on the **Formulas** tab.

## Procedures

1. Select the **Office** button.

2. Select the **Excel Options** button.

3. Select the **Formulas** option.

4. Under **Calculation options**, select the **Manual** option.

5. Select **OK**.

## Step-by-Step

Set manual calculation.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the **Office** button. 
*The Office menu opens.*     | Click                                              |
| 2. Select the **Excel Options** button. 
*The Excel Options dialog box opens.* | Click **Excel Options**                           |
| 3. Select the **Formulas** option. 
*The Formulas page is displayed.* | Click **Formulas**                                |
| 4. Under **Calculation options**, select the **Manual** option. 
*The Manual option is selected.* | Click **Manual**                                  |
| 5. Select **OK**. 
*The Excel Options dialog box closes, and calculation is set to manual.* | Click **OK**                                      |
Select cell B8, type 25, and press [Enter]. Notice that the formulas in the Totals column do not recalculate and that the Calculate indicator appears on the status bar.

Press [F9] to recalculate the workbook. Notice that cell E8 changes from $150.00 to $312.50, and the Gross, Discount and Less Disc. prices also recalculate. The Calculate indicator no longer appears on the status bar.

### Resetting Automatic Calculation

**Discussion**

Calculation options are system settings rather than workbook settings. As a result, if you select manual recalculation for one workbook, you will have to manually recalculate all workbooks until you change the calculation back to automatic.

**Procedures**

1. Select the Office button.
2. Select the Excel Options button.
3. Select the Formulas option.
4. Under Calculation options, select the Automatic option.
5. Select OK.

**Step-by-Step**

Set automatic calculation.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the Office button.  
*The Office menu opens.* | Click |
| 2. Select the Excel Options button.  
*The Excel Options dialog box opens.* | Click |
| 3. Select the Formulas option.  
*The Formulas page is displayed.* | Click Formulas |
**Steps** | **Practice Data**
--- | ---
4. Under **Calculation options**, select the **Automatic** option.  
*The Automatic option is selected.* | Click [Automatic]**

5. Select **OK**.  
*The Excel Options dialog box closes, and calculation is set to automatic.* | Click [OK]**

Select cell B8, type **15**, and press [Enter]. Notice that all the formulas now recalculate automatically. 
Close **CUSTOPT.XLSX**.

---

**SETTING POPULAR OPTIONS**

**Discussion**

Excel provides several customizable options on the **Popular** page in the Excel Options dialog box.

For example, when you create a new workbook, it contains three worksheets by default and the font and font size are predefined. You can change the default number of worksheets in a new workbook as well as the default standard font and font size to suit your needs. Changes made to the standard font and font size will not take effect until you close and restart Excel. Existing workbooks will not be affected by the change.
Procedures

1. Select the Office button.
2. Select the Excel Options button.
3. Select or deselect the desired options on the Popular page.
4. Click OK.

Step-by-Step

Set popular options.

If necessary, create a new, blank workbook. Notice that the new workbook contains three worksheets.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Office button. The Office menu opens.</td>
<td>Click</td>
</tr>
<tr>
<td>2. Select the Excel Options button. The Excel Options dialog box opens, with the Popular page displayed.</td>
<td>Click Excel Options</td>
</tr>
<tr>
<td>3. Select or deselect the desired options. The options are selected or deselected accordingly.</td>
<td>Click Include this many sheets to 1</td>
</tr>
<tr>
<td>4. Select OK. The Excel Options dialog box closes, and the popular options are applied or disabled accordingly.</td>
<td>Click OK</td>
</tr>
</tbody>
</table>

Create another new, blank workbook. Notice that the new workbook contains only one worksheet.

Open the Excel Options dialog box and change the number of default sheets to 3. Then, close all open workbooks without saving them.
EXERCISE

CUSTOMIZING EXCEL PREFERENCES

Task

Customize Excel preferences.

1. Open CUSTOPTX.XLSX.

2. Hide the gridlines and zero values for the Invoice sheet.

3. Change the After pressing Enter, move selection option so that the active cell moves to the right after pressing [Enter].

4. Enter the following information into row 9, pressing [Enter] after typing each entry.

<table>
<thead>
<tr>
<th>QTY</th>
<th>PART #</th>
<th>UNIT PRICE</th>
</tr>
</thead>
<tbody>
<tr>
<td>5</td>
<td>LT460</td>
<td>45.95</td>
</tr>
</tbody>
</table>

5. Change the number of sheets in a new workbook to 5.

6. Create a new workbook. The workbook should contain five worksheets.

7. Save the new workbook to the student data folder as REGTENQ2.XLSX.

8. Reset the After pressing Enter, move selection option to Down. Reset the number of sheets in a new workbook to 3.

9. Set the calculation to manual.

10. On the Saturday Hours sheet of CUSTOPTX.XLSX, select cell D6, type 4, and press [Enter]. Notice the current value in cell G6. Then, recalculate the worksheet manually. Notice that cell G6 is updated.

11. Reset the calculation to automatic.

12. Close all open workbooks without saving them.
LESSON 10 -
USING WORKSHEET PROTECTION

In this lesson, you will learn how to:

- Unlock cells in a worksheet
- Protect a worksheet
- Unprotect a worksheet
- Create allow-editing ranges
- Delete allow-editing ranges
- Protect workbook windows
- Unprotect workbook windows
- Assign a password
- Open a password-protected file
- Remove a password
**UNLOCKING CELLS IN A WORKSHEET**

**Discussion**

You can control access to a worksheet by locking or unlocking individual cells in it. If worksheet protection is activated, you cannot change the contents of any locked cell. If you want to allow changes to some cells, however, you can unlock those cells before you activate worksheet protection.

As a rule, the cells you want to use for data entry are unlocked, and the cells that have formulas in them are locked so that the formulas cannot be changed. For example, you can lock all cells in a sales worksheet, except for those cells in which sales figures need to be entered. You can also lock cells containing text.

> Although cells are locked by default, this setting has no effect on a worksheet unless the worksheet is protected.
Procedures

1. Select the cells you want to unlock.

2. Select the **Format** button in the **Cells** group on the **Home** tab.

3. Select the **Lock Cell** option to deselect it.

Step-by-Step

From the Student Data directory, open **PROJ3.XLSX**.
Unlock cells in a worksheet.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the cells you want to unlock. <em>The cells are selected.</em></td>
<td>Drag across E3:E4, and release the mouse button</td>
</tr>
<tr>
<td>2. Select the <strong>Format</strong> button in the <strong>Cells</strong> group on the <strong>Home</strong> tab. <em>The Format menu opens.</em></td>
<td>Click <strong>Format</strong></td>
</tr>
<tr>
<td>3. Select the <strong>Lock Cell</strong> option to deselect it. <em>The cells are unlocked.</em></td>
<td>Click <strong>Lock Cell</strong></td>
</tr>
</tbody>
</table>

Click anywhere in the worksheet to deselect the range.

**Protecting a Worksheet**

Discussion

Once you have unlocked cells, you can prevent changes to the rest of the worksheet by protecting it. Protecting a worksheet prevents unauthorized or accidental changes to formulas or other content. For example, you can unlock only cells E3 and E4, leaving the rest of the cells in the worksheet locked; if you then protect the worksheet, you will be able to enter data in cells E3 and E4, but you will not be able to access any other cells.

You can assign an optional password to a protected worksheet. Passwords are case-sensitive. A password is any combination of letters, numbers, symbols, and spaces, and can be up to 255 characters long. For example, **CLASS** is a different password than **class**.
You can select what features and functions of the worksheet you want to protect. For example, you can allow users to select locked or unlocked cells, or format, insert, or delete cells, columns, and rows.

![Protect Sheet](image)

**Protecting a worksheet**

- Many Excel features, such as formatting, become unavailable in a protected worksheet.

- You can protect the worksheet structure from being deleted, hidden, or moved or the worksheet window from being hidden, moved, or resized by assigning a password to the workbook in the Protect Workbook dialog box. To open the Protect Workbook dialog box, select the **Protect Workbook** button in the **Changes** group on the **Review** tab, then select the **Protect Structure and Windows** option.

- If you forget the password for a protected worksheet, you cannot unprotect the worksheet. There is no way of recovering the password.
Procedures

1. Select the Format button in the Cells group on the Home tab.
2. Select the Protect Sheet option.
3. Type a password, if desired.
4. Select OK.
5. Type the password again, if necessary.
6. Select OK, if necessary.

Step-by-Step

Protect a worksheet.

If necessary, unlock cells E3 and E4.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Format button in the Cells group on the Home tab. The Format menu opens.</td>
<td>Click [Format]</td>
</tr>
<tr>
<td>2. Select the Protect Sheet option. The Protect Sheet dialog box opens with the insertion point in the Password to unprotect sheet box.</td>
<td>Click Protect Sheet</td>
</tr>
<tr>
<td>3. Type a password, if desired. Black dots appear in the Password to unprotect sheet box representing each character you type.</td>
<td>Type class</td>
</tr>
<tr>
<td>4. Select OK. If you typed a password, the Confirm Password dialog box opens with the insertion point in the Reenter password to proceed box.</td>
<td>Click [OK]</td>
</tr>
<tr>
<td>5. Type the password again, if necessary. Black dots appear in the Reenter password to proceed box representing each character you type.</td>
<td>Type class</td>
</tr>
</tbody>
</table>
Select cell D8 and type the word **test**. A Microsoft Office Excel warning box opens, informing you that the cell is protected and you cannot edit it. Close the warning box.

Type **20** in cell E3 and **15** in cell E4. Notice that you can change the content of these cells since they are unlocked. Also, notice that the formula results in the locked cells update to reflect the change in data, even though you cannot change the formulas themselves.

### Unprotecting a Worksheet

#### Discussion

You can unprotect a protected worksheet. If you used a password to protect the worksheet, however, you must know the password to be able to unprotect it. After you have unprotected the worksheet, you can make changes to any cell in it.

#### Procedures

1. Select the **Format** button in the **Cells** group on the **Home** tab.
2. Select the **Unprotect Sheet** option.
3. Type the required password, if necessary.
4. Select **OK**.

#### Step-by-Step

Unprotect a worksheet.
**Steps** | **Practice Data**
--- | ---
1. Select the **Format** button in the **Cells** group on the **Home** tab.  
*The Format menu opens.* | Click **Format**
2. Select the **Unprotect Sheet** option.  
*The Unprotect Sheet dialog box opens with the insertion point in the **Password to unprotect sheet** box.* | Click **Unprotect Sheet**
3. Type the required password, if necessary.  
*Black dots appear in the **Password** box representing each character you type.* | Type **class**
4. Select **OK**.  
*The Unprotect Sheet dialog box closes, and the worksheet is unprotected.* | Click **OK**

Select cell D8 and type the word **test**. Notice that, since the worksheet is now unprotected, you can type in the cell. Then, delete the word **test**.

### CREATING ALLOW-EDITING RANGES

**Discussion**

If you want only certain users to be able to access specified cells in a worksheet, you can identify those cells as an allow-editing range. You control access to this range by first locking the cells in it and then assigning a password to it. After activating worksheet protection, users are prompted for the assigned password when they select any cell in the allow-editing range. If the correct password is entered, the range is unlocked for editing; the allow-editing range is not locked again, however, until the workbook is closed.
Remember to unlock the cells you want all users to be able to edit before enabling worksheet protection.

You can select the allow-editing range before you open the Allow Users to Edit Ranges dialog box; the range will then appear in the New Range dialog box when it opens.

Procedures

1. Select the Review tab.
2. Select the Allow Users to Edit Ranges button in the Changes group.
3. Select the New button.
4. Enter a name for the allow-editing range in the Title box, if desired.
5. Click the Collapse Dialog button in the Refers to cells box.
6. Select the range in which you want to allow editing.
7. Click the Expand Dialog button in the New Range dialog box.
8. Select the Range password box.
9. Type the desired password.
10. Select OK.
11. Type the password again.
12. Select OK.
13. Select the Protect Sheet button.
14. Type the desired password.
15. Select OK.
16. Type the password again.
17. Select OK.

![Step-by-Step](Image)

**Step-by-Step**
Create allow-editing ranges in a worksheet.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the Review tab.  
The Review tab is displayed. | Click Review |
| 2. Select the Allow Users to Edit Ranges button in the Changes group.  
The Allow Users to Edit Ranges dialog box opens. | Click Allow Users to Edit Ranges |
| 3. Select the New button.  
The New Range dialog box opens with the text in the Title box selected. | Click New... |
| 4. Enter a name for the allow-editing range in the Title box, if desired.  
The name appears in the Title box. | Type Actual |
| 5. Click the Collapse Dialog button in the Refers to cells box.  
The New Range dialog box collapses so that you can access the worksheet. | Click |
| 6. Select the range in which you want to allow editing.  
The range is selected. | Drag across B3:B4, and then release the mouse button |
### Steps

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>7. Click the <strong>Expand Dialog</strong> button in the New Range dialog box.</td>
<td>Click</td>
</tr>
<tr>
<td>The New Range dialog box expands, and the range reference appears in</td>
<td></td>
</tr>
<tr>
<td>the <strong>Refers to cells</strong> box.</td>
<td></td>
</tr>
<tr>
<td>8. Select the <strong>Range password</strong> box.</td>
<td>Click in the <strong>Range password</strong> box</td>
</tr>
<tr>
<td>The insertion point appears in the <strong>Range password</strong> box.</td>
<td></td>
</tr>
<tr>
<td>9. Type the desired password.</td>
<td>Type <strong>password</strong></td>
</tr>
<tr>
<td>Black dots appear in the <strong>Range password</strong> box representing each</td>
<td></td>
</tr>
<tr>
<td>character you type.</td>
<td></td>
</tr>
<tr>
<td>10. Select <strong>OK</strong>.</td>
<td>Click <strong>OK</strong></td>
</tr>
<tr>
<td>The Confirm Password dialog box opens with the insertion point in</td>
<td></td>
</tr>
<tr>
<td>the <strong>Reenter password to proceed</strong> box.</td>
<td></td>
</tr>
<tr>
<td>11. Type the password again.</td>
<td>Type <strong>password</strong></td>
</tr>
<tr>
<td>Black dots appear in the <strong>Reenter password to proceed</strong> box</td>
<td></td>
</tr>
<tr>
<td>representing each character you type.</td>
<td></td>
</tr>
<tr>
<td>12. Select <strong>OK</strong>.</td>
<td>Click <strong>OK</strong></td>
</tr>
<tr>
<td>The Confirm Password and New Range dialog boxes close, and the new</td>
<td></td>
</tr>
<tr>
<td>range name and reference appear in the <strong>Allow Users to Edit Ranges</strong></td>
<td></td>
</tr>
<tr>
<td>dialog box.</td>
<td></td>
</tr>
<tr>
<td>13. Select the <strong>Protect Sheet</strong> button.</td>
<td>Click <strong>Protect Sheet...</strong></td>
</tr>
<tr>
<td>The Protect Sheet dialog box opens with the insertion point in the</td>
<td></td>
</tr>
<tr>
<td><strong>Password to unprotect sheet</strong> box.</td>
<td></td>
</tr>
<tr>
<td>14. Type the desired password.</td>
<td>Type <strong>class</strong></td>
</tr>
<tr>
<td>Black dots appear in the <strong>Password to unprotect sheet</strong> box</td>
<td></td>
</tr>
<tr>
<td>representing each character you type.</td>
<td></td>
</tr>
<tr>
<td>15. Select <strong>OK</strong>.</td>
<td>Click <strong>OK</strong></td>
</tr>
<tr>
<td>The Confirm Password dialog box opens with the insertion point in</td>
<td></td>
</tr>
<tr>
<td>the <strong>Reenter password to proceed</strong> box.</td>
<td></td>
</tr>
<tr>
<td>16. Type the password again.</td>
<td>Type <strong>class</strong></td>
</tr>
<tr>
<td>Black dots appear in the <strong>Reenter password to proceed</strong> box</td>
<td></td>
</tr>
<tr>
<td>representing each character you type.</td>
<td></td>
</tr>
</tbody>
</table>
Select cell B4 and type 3. The Unlock Range dialog box opens with the insertion point in the **Enter the password to change this cell** box. Type the password **password** and select **OK** to close the dialog box. Then, type **310853** in cell B4. Notice that you can now edit cell B4 because the allow-editing range has been unlocked.

### DELETING ALLOW-EDITING RANGES

#### Discussion

When a worksheet no longer needs an allow-editing range, it can be removed from the worksheet. The worksheet must first be unprotected before you can remove the unlocked range.

#### Procedures

1. Select the **Review** tab.

2. Select the **Unprotect Sheet** button in the **Changes** group.

3. Type the required password.

4. Select **OK**.

5. Select the **Allow Users to Edit Ranges** button in the **Changes** group.

6. Select the range you want to delete from the **Ranges unlocked by a password when sheet is protected** box.

7. Select **Delete**.

8. Select **OK**.
Step-by-Step

Delete allow-editing ranges.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the **Review** tab.  
   *The Review tab is displayed.* | Click **Review** |
| 2. Select the **Unprotect Sheet** button in the **Changes** group.  
   *The Unprotect Sheet dialog box opens.* | Click **Unprotect Sheet** |
| 3. Type the required password.  
   *Black dots appear in the **Password** box representing each character you type.* | Type **class** |
| 4. Select **OK**.  
   *The Unprotect Sheet dialog box closes and the password protection is removed from the worksheet.* | Click **OK** |
| 5. Select the **Allow Users to Edit Ranges** button in the **Changes** group.  
   *The Allow Users to Edit Ranges dialog box opens.* | Click **Allow Users to Edit Ranges** |
| 6. Select the range you want to delete from the **Ranges unlocked by a password when sheet is protected** box.  
   *The range is selected.* | Click **Actual** |
| 7. Select the **Delete** button.  
   *The range is removed from the **Ranges unlocked by a password when sheet is protected** box.* | Click **Delete** |
| 8. Select **OK**.  
   *The Allow Users to Edit Ranges dialog box closes.* | Click **OK** |
PROTECTING WORKBOOK WINDOWS

Discussion

You can protect workbook windows. When you protect a workbook window, the Minimize, Maximize, Restore, and Close buttons are removed; as a result, the window cannot be moved or resized. This option is useful if you have arranged the windows in a particular way and want to prevent them from being rearranged.

In addition to protecting a window, you can prevent structural changes to a workbook. For example, if a workbook structure is protected, you cannot insert, delete, or move worksheets contained in it.

You can assign an optional password. Passwords are case-sensitive. For example, CLASS is a different password than class.

If you forget the password for a protected workbook, you cannot unprotect the workbook. There is no way of recovering the password.

Procedures

1. Select the Review tab.

2. Select the Protect Workbook button in the Changes group.
3. Select the **Protect Structure and Windows** option.

4. Type a password, if desired.

5. Under **Protect workbook for**, select or deselect the options, as desired.

6. Select **OK**.

7. Type the password again, if necessary.

8. Select **OK**.

### Step-by-Step

Protect workbook windows.

Click the workbook **Restore Window** button to display the current workbook in a window within the workbook pane.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the **Review** tab.  
  *The Review tab is displayed.* | Click **Review** |
| 2. Select the **Protect Workbook** button in the **Changes** group.  
  *The Protect Workbook menu opens.* | Click **Protect Workbook** |
| 3. Select the **Protect Structure and Windows** option.  
  *The Protect Structure and Windows dialog box opens with the insertion point in the **Password (optional)** box.* | Click **Protect Structure and Windows** |
| 4. Type a password, if desired.  
  *Black dots appear in the **Password** box representing each character you type.* | Type **class** |
| 5. Under **Protect workbook for**, select or deselect the options, as desired.  
  *The options are selected or deselected.* | Click **Windows**, to select it |
| 6. Select **OK**.  
  *If you typed a password, the Confirm Password dialog box opens with the insertion point in the **Reenter password to proceed** box.* | Click **OK** |
Steps | Practice Data
--- | ---
7. Type the password again, if necessary. *Black dots appear in the Reenter password to proceed box representing each character you type.* | Type *class*
8. Select OK. *The Confirm Password and Protect Structure and Windows dialog boxes close, and the workbook window is protected.* | Click ![OK button]

Notice that the Minimize, Maximize, Restore, and Close buttons no longer appear on the workbook window title bar. Try to resize the window by dragging. Notice that you are unable to perform this task.

**UNPROTECTING WORKBOOK WINDOWS**

**Discussion**

When you unprotect a workbook window, the Maximize, Minimize, Restore, and Close buttons are restored, and the window can be resized. You can also perform structural changes (such as inserting, deleting, or moving worksheets) in an unprotected workbook.

If a password has been used to protect a workbook, you must know the password to unprotect it.

* If you forget the password, you cannot unprotected the workbook. There is no way of recovering the password.

**Procedures**

1. Select the Review tab.

2. Select the Protect Workbook button in the Changes group.

3. Select the Protect Structure and Windows option.
4. Type the password, if requested.

5. Select \[ \text{OK} \].

### Step-by-Step

Unprotect workbook windows.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the **Review** tab.  
*The Review tab is displayed.* | Click **Review** |
| 2. Select the **Protect Workbook** button in the **Changes** group.  
*The Protect Workbook menu opens.* | Click **Protect Workbook** |
| 3. Select the **Protect Structure and Windows** option.  
*The Unprotect Workbook dialog box opens with the insertion point in the Password box* | Click **Protect Structure and Windows** |
| 4. Type the password, if requested.  
*Black dots appear in the Password box representing each character you type.* | Type **class** |
| 5. Select **OK**.  
*The Unprotect Workbook dialog box closes, and the workbook window is no longer protected.* | Click **OK** |

Notice that the **Minimize**, **Maximize**, **Restore**, and **Close** buttons appear again on the workbook window title bar. Maximize the window, if necessary.

### Assigning a Password

#### Discussion

Passwords are used to protect a file. You can assign one password to open a file, and a different password to modify a file. If you assign both types of passwords to a file, only those users who know the open password can open the file, and only those users who know both the open and modify passwords can save changes to it.
Passwords are case-sensitive and can be any combination of letters, numbers, symbols, and spaces, up to 15 characters long. After a password has been assigned, you will be prompted for the password each time you open the workbook or each time you try to save it, depending on the type of password.

Passwords are often assigned to files that contain sensitive data, such as salaries or bonuses. They can also be used to secure files stored on a network.

⚠️ If you forget an assigned password, you cannot open or save the file. There is no way to recover the password.

### Procedures

1. Select the **Office** button.
2. Select the **Save As** option.
3. Select **Tools** button.
4. Select the **General Options** option.
5. Type the desired password.
6. Select **OK**.
7. Type the password again.
8. Select **OK**.
9. Select **Save**.
10. Select **Yes**.

### Step-by-Step

Assign a password to a file.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the <strong>Office</strong> button. <strong>The Office menu opens.</strong></td>
<td>Click</td>
</tr>
</tbody>
</table>
### Steps

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
</table>
| **2.** | Select the **Save As** option.  
*The Save As dialog box opens.* |
| **3.** | Select the **Tools** button.  
*The Tools menu opens.* |
| **4.** | Select the **General Options** option.  
*The General Options dialog box opens with the insertion point in the **Password to open** box.* |
| **5.** | Type the desired password.  
*Black dots appear in the **Password to open** box representing each character you type.* |
| **6.** | Select **OK.**  
*The Confirm Password dialog box opens with the insertion point in the **Reenter password to proceed** box.* |
| **7.** | Type the password again.  
*Black dots appear in the **Reenter password to proceed** box representing each character you type.* |
| **8.** | Select **OK.**  
*The Confirm Password and General Options dialog boxes close.* |
| **9.** | Select **Save.**  
*A Microsoft Office Excel warning box opens, prompting you to overwrite the existing file.* |
| **10.** | Select **Yes.**  
*The Microsoft Office Excel warning box and the Save As dialog box close, and the file is saved with the assigned password.* |

---

### Practice Data

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>2.</strong></td>
<td>Click <strong>Save As</strong></td>
</tr>
<tr>
<td><strong>3.</strong></td>
<td>Click <strong>Tools</strong></td>
</tr>
<tr>
<td><strong>4.</strong></td>
<td>Click <strong>General Options</strong></td>
</tr>
<tr>
<td><strong>5.</strong></td>
<td>Type <strong>class</strong></td>
</tr>
<tr>
<td><strong>6.</strong></td>
<td>Click <strong>OK</strong></td>
</tr>
<tr>
<td><strong>7.</strong></td>
<td>Type <strong>class</strong></td>
</tr>
<tr>
<td><strong>8.</strong></td>
<td>Click <strong>OK</strong></td>
</tr>
<tr>
<td><strong>9.</strong></td>
<td>Click <strong>Save</strong></td>
</tr>
<tr>
<td><strong>10.</strong></td>
<td>Click <strong>Yes</strong></td>
</tr>
</tbody>
</table>

---

Close **PROJ3.XLSX**.
OPENING A PASSWORD-PROTECTED FILE

Discussion

Once a file is password-protected, you must know the password to open it. Whenever you try to open a password-protected file, the Password dialog box prompts you to enter the assigned password.

The Password dialog box

If you forget the assigned password, you cannot open the file. There is no way to recover the password.

Procedures

1. Select the Office button.
2. Select the Open option.
3. Select the double arrow at the left of the Address bar.
4. Select the drive where the file is stored.
5. Select the folder where the file is stored.
6. Select the file you want to open.
7. Select the left-hand part of the Open button.
8. Type the required password.
9. Select OK.
### Step-by-Step

Open a password-protected file.

<table>
<thead>
<tr>
<th><strong>Steps</strong></th>
<th><strong>Practice Data</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the <strong>Office</strong> button. &lt;br&gt;The <strong>Office</strong> menu opens.</td>
<td>Click</td>
</tr>
<tr>
<td>2. Select the <strong>Open</strong> option. &lt;br&gt;The <strong>Open</strong> dialog box opens.</td>
<td>Click <strong>Open</strong></td>
</tr>
<tr>
<td>3. Select the double arrow at the left of the <strong>Address</strong> bar. &lt;br&gt;A list of available drives and common folders is displayed.</td>
<td>Click <strong>&lt;&lt;</strong></td>
</tr>
<tr>
<td>4. Select the drive where the file is stored. &lt;br&gt;A list of available folders opens.</td>
<td>Click the student data drive, if necessary</td>
</tr>
<tr>
<td>5. Select the folder where the file is stored. &lt;br&gt;A list of available folders and files opens.</td>
<td>Click the student data folder, if necessary</td>
</tr>
<tr>
<td>6. Select the file you want to open. &lt;br&gt;The file is selected.</td>
<td>Click <strong>PROJ4.XLSX</strong> or the file indicated by your instructor</td>
</tr>
<tr>
<td>7. Select the left-hand part of the <strong>Open</strong> button. &lt;br&gt;The <strong>Open</strong> dialog box closes, and the <strong>Password</strong> dialog box opens with the insertion point in the <strong>Password</strong> box.</td>
<td>Click <strong>Open</strong></td>
</tr>
<tr>
<td>8. Type the required password. &lt;br&gt;Black dots appear in the <strong>Password</strong> box representing each character you type.</td>
<td>Type <strong>class</strong></td>
</tr>
<tr>
<td>9. Select <strong>OK</strong>. &lt;br&gt;The <strong>Password</strong> dialog box closes, and the file opens.</td>
<td>Click <strong>OK</strong></td>
</tr>
</tbody>
</table>
REMOVING A PASSWORD

Discussion

If a password is no longer needed, you can remove it from a file. You can then open the file at any time without a password. When you remove a password, you must save the file to replace the protected version.

Procedures

1. Select the Office button.
2. Select the Save As option.
3. Select the Tools button.
4. Select the General Options option.
5. Press [Delete] to remove the current password.
6. Select OK.
7. Select Save.
8. Select Yes.

Step-by-Step

Remove a password from a file.

If necessary, type class in the Password dialog box to open the file.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Office button.</td>
<td>Click</td>
</tr>
<tr>
<td>The Office menu opens.</td>
<td></td>
</tr>
<tr>
<td>2. Select the Save As option.</td>
<td>Click Save As</td>
</tr>
<tr>
<td>The Save As dialog box opens.</td>
<td></td>
</tr>
<tr>
<td>3. Select the Tools button.</td>
<td>Click Tools</td>
</tr>
<tr>
<td>The Tools menu opens.</td>
<td></td>
</tr>
<tr>
<td>Steps</td>
<td>Practice Data</td>
</tr>
<tr>
<td>-------</td>
<td>---------------</td>
</tr>
<tr>
<td>4. Select the <strong>General Options</strong> option. &lt;br&gt;The General Options dialog box opens with the current password selected. Each black dot represents a character in the password.</td>
<td>Click <strong>General Options</strong></td>
</tr>
<tr>
<td>5. Press [Delete] to remove the current password. &lt;br&gt;The password is deleted.</td>
<td>Press [Delete]</td>
</tr>
<tr>
<td>6. Select <strong>OK</strong>. &lt;br&gt;The General Options dialog box closes.</td>
<td>Click <strong>OK</strong></td>
</tr>
<tr>
<td>7. Select <strong>Save</strong>. &lt;br&gt;A Microsoft Office Excel warning box opens, prompting you to overwrite the existing file.</td>
<td>Click <strong>Save</strong></td>
</tr>
<tr>
<td>8. Select <strong>Yes</strong>. &lt;br&gt;The Microsoft Office Excel warning box and the Save As dialog box close, and the file is saved without a password.</td>
<td>Click <strong>Yes</strong></td>
</tr>
</tbody>
</table>

Close **PROJ4.XLSX**.
EXERCISE

USING WORKSHEET PROTECTION

Task

Use worksheet protection.

1. Open **PROTECT.XLSX**.

2. Unlock the range D6:D12.

3. Protect the worksheet, assigning a password of **protect**.

4. Change cell D11 to **3**. Change cell E11 to **4**. Then, close the Microsoft Office Excel warning box.

5. Unprotect the worksheet. Then, change the type of time in cell E11 to **4**.

6. Select the range C15:E17 and create an allow-editing range named **Rates**. Assign the password **special** to the allow-editing range and the password **class** to the worksheet.

7. Change the rate in C17 from **5.50** to **6.00**. Enter the password when prompted.

8. Delete the allow-editing range. *(Hint: First unprotect the worksheet.)*

9. Protect both the workbook structure and windows; assign a password of **workbook**. Notice that the window buttons for the workbook are no longer available.

10. Unprotect the workbook.

11. Assign a password to open the workbook; type **save** as the password. Then, close the workbook.

12. Reopen **PROTECT.XLSX**. Notice that you must enter the assigned password.

13. Remove the password from the workbook.

14. Close the workbook without saving it.
LESSON 11 - USING MULTIPLE WORKBOOKS

In this lesson, you will learn how to:

- Open multiple workbook windows
- Cascade open workbook windows
- Activate cascaded workbook windows
- Tile open workbook windows
- Activate tiled workbook windows
- Compare workbooks side by side
- Copy data between workbooks
- Save a workspace
- Close all open workbooks
- Open a workspace
- Link workbooks
- Open linked workbooks
OPENING MULTIPLE WORKBOOK WINDOWS

Discussion

You can open more than one workbook at a time. This option is useful for comparing data or moving and copying information between workbooks. For example, you could open files from several regional sales representatives and then consolidate and compare the data in the workbooks.

When you open multiple workbooks, each workbook appears in its own window. You can arrange the windows in the workspace so that you can view the data in each, if desired. The name of each open workbook appears as a button on the Windows taskbar.

No matter how many workbooks are open, only one can be active at a time. The title bar of the active workbook is highlighted. Any command you execute or data you enter affects only the active workbook.

Files listed consecutively can be selected by clicking the first file in the series, holding the [Shift] key, and clicking the last file in the series.

Procedures

1. Select the Office button.
2. Select the Open option from the Office menu.
3. Select the double arrow at the left of the Address bar.
4. Select the drive in which the workbook you want to open is located.
5. Select the folder in which the workbook you want to open is located.
6. Select the name of the first file you want to open.
7. Hold [Ctrl] and select the name of the second file you want to open.
8. Hold [Ctrl] and select the name of the third file you want to open, and so on, until you have selected all the files you want to open.
9. Select the left-hand part of the Open button.

Step-by-Step

Open multiple workbooks at one time.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the **Office** button.  
*The Office menu opens.* | Click |
| 2. Select the **Open** option from the **Office** menu.  
*The Open dialog box opens.* | Click |
| 3. Select the double arrow at the left of the **Address** bar.  
*A list of available drives and common folders is displayed.* | Click |
| 4. Select the drive in which the workbook you want to open is located.  
*A list of available folders is displayed.* | Click the student data drive |
| 5. Select the folder in which the workbook you want to open is located.  
*A list of available folders and files is displayed.* | Click the student data folder |
| 6. Select the first file you want to open.  
*The file is selected.* | Click **Q1CENTRL.XLSX** |
| 7. Hold [Ctrl] and select the name of the second file you want to open.  
*The files are selected.* | Hold [Ctrl] and click **Q1NEAST.XLSX** |
| 8. Hold [Ctrl] and select the name of the third file you want to open, and so on, until you have selected all the files you want to open.  
*The files are selected.* | Hold [Ctrl] and click **Q1SEAST.XLSX** |
| 9. Select the left-hand part of the **Open** button.  
*The Open dialog box closes, and all selected workbooks open.* | Click |

Notice that the name of each workbook appears as a button on the Windows taskbar.
CASCADING OPEN WORKBOOK WINDOWS

Discussion

Excel provides several different methods of arranging multiple workbook windows in the workspace. One method is to cascade the windows. Cascaded windows are stacked, with only the title bar of each inactive window visible. The active window appears at the front of the stack.

Cascading windows allows you to move easily from one to another and still display a large portion of the active window. For example, you can cascade workbooks containing sales data from several regional representatives so that you can move easily between the workbooks when comparing and contrasting data.

Cascaded open workbook windows

Procedures

1. Select the View tab.
2. Select the Arrange All button in the Window group.
3. Select the Cascade option.
4. Select OK.
Step-by-Step

Cascade open workbook windows.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the View tab.  
*The View tab is displayed.* | Click View |
| 2. Select the Arrange All button in the Window group.  
*The Arrange Windows dialog box opens.* | Click Arrange All |
| 3. Select the Cascade option.  
*The Cascade option is selected.* | Click Cascade |
| 4. Select OK.  
*The Arrange Windows dialog box closes, and the workbook windows are cascaded.* | Click OK |

ACTIVATING CASCADED WORKBOOK WINDOWS

Discussion

In Excel, only one window can be active at a time. You can click in any portion of a window to activate it. At times, however, the window you want to activate may not be visible.

Excel maintains a list of all open workbooks in the Switch Windows menu available from the View tab on the Ribbon. You can activate any workbook window by selecting its name from this list. For example, if you have multiple workbooks open, you can activate the workbook containing the data with which you want to work.

- You can also activate any workbook window by clicking its associated button on the Windows taskbar.
- You can disable the option that displays all open workbooks on the taskbar by deselecting the Show all windows in the Taskbar option under Display on the Advanced page in the Excel Options dialog box.
Procedures

1. Select the View tab, if necessary.

2. Select the Switch Windows button in the Window group.

3. Select the workbook you want to view.

Step-by-Step

Activate cascaded workbook windows.

If necessary, cascade the open workbook windows.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the View tab, if necessary.  
*The View tab is displayed.* | Click View, if necessary |
| 2. Select the Switch Windows button in the Window group.  
*The Switch Windows menu opens.* | Click Switch Windows |
| 3. Select the workbook you want to view.  
*The workbook window is activated.* | Click Q1CENTRL |

Practice the Concept: Use the Switch Windows menu to activate the Q1SEAST workbook.

TILING OPEN WORKBOOK WINDOWS

Discussion

Tiling workbook windows arranges open windows so that they are all visible in the workspace. In order to accomplish this, the windows must be resized to fit in the workspace. For example, you can tile all the open workbooks so that you can view at
least some portion of each workbook. When windows are tiled, you can click in any window to activate it.

Excel provides three tiling options. The Tiled option arranges the windows in a grid in the workspace and places the active window in the upper left corner. The Horizontal option places the windows top-to-bottom in the workspace. The Vertical option places the windows side-by-side in the workspace.

![Workbook windows tiled vertically](image)

To untile windows, double-click the title bar of the window you want to activate or click the Maximize button in its title bar.

### Procedures

1. Select the View tab.

2. Select the Arrange All button in the Window group.

3. Select the Tiled, Horizontal or Vertical option, as desired.

4. Select OK.
**Step-by-Step**

Tile open workbook windows.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the View tab. The View tab is displayed.</td>
<td>Click View</td>
</tr>
<tr>
<td>2. Select the Arrange All button in the Window group. The Arrange</td>
<td>Click [Arrange All]</td>
</tr>
<tr>
<td>Windows dialog box opens. The option is selected.</td>
<td></td>
</tr>
<tr>
<td>3. Select the Tiled, Horizontal or Vertical option, as desired. The</td>
<td>Click [Tiled]</td>
</tr>
<tr>
<td>option is selected.</td>
<td></td>
</tr>
<tr>
<td>4. Select OK. The Arrange Windows dialog box closes, and the workbook</td>
<td>Click [OK]</td>
</tr>
<tr>
<td>windows are tiled accordingly.</td>
<td></td>
</tr>
</tbody>
</table>

**ACTIVATING TILED WORKBOOK WINDOWS**

**Discussion**

When windows are tiled, you can see at least a portion of each open workbook; you can click in any window to activate it. For example, you may want to activate a single workbook out of many open workbooks containing data from regional sales representatives so that you can work on the data it contains.

To untile windows, double-click the title bar of the window you want to activate or click the Maximize button in its title bar.

**Procedures**

1. Open multiple workbook windows.
2. Tile the open workbook windows.
3. Click the workbook window you want to activate.

**Step-by-Step**

Activate a tiled workbook window.

If necessary, tile the open workbook windows.

<table>
<thead>
<tr>
<th><strong>Steps</strong></th>
<th><strong>Practice Data</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Click the workbook window you want to activate. <em>The window is activated.</em></td>
<td>Click in the Q1NEAST window</td>
</tr>
</tbody>
</table>

Use the arrows on the vertical scroll bar to scroll the Q1NEAST window down and then up. Notice that only the active window scrolls.

---

**COMPARING WORKBOOKS SIDE BY SIDE**

**Discussion**

Excel includes the ability to compare two workbooks side-by-side. The View Side by Side feature horizontally tiles two open workbooks.

Excel arranges side-by-side windows in a horizontal layout with synchronized scrolling enabled. With synchronized scrolling, scrolling a window horizontally or vertically automatically scrolls the other window at the same time. You can disable synchronized scrolling if you want to scroll the workbooks independently.

When you enable side-by-side viewing, the active workbook appears in the top window while the other open workbook appears in the bottom window. You can click in the top or bottom window to activate it. Scrolls bar only appear in the active window. If you wish, you can reverse the positions of the windows by activating the workbook in the bottom window and selecting the **Reset Window Position** button.

The View Side by Side feature can only compare two workbooks, both of which must be open before starting the feature. If you have more than two workbooks open, Excel assumes you want to use the current workbook and prompts you to select a second workbook from a list of the open workbooks.

You can return to a single window view by selecting the **View Side by Side** button on the **View** tab.
Comparing side by side workbooks

If both workbooks are open in different views or zoom levels, Excel applies the view of the current workbook to both of the side-by-side windows. However, split or frozen panes in the active workbook are not duplicated in the second workbook; you must enable those manually.

You can cut, copy, paste, and use the Format Painter between the side-by-side windows. In addition, task panes and toolbars are available to both open windows.

Procedures

1. Select the View tab, if necessary.

2. Select the View Side by Side button in the Window group.

3. If more than two workbooks are open, select the workbook you want to compare in the Compare Side by Side dialog box.

4. Select .

5. To vertically scroll both windows at the same time, use the vertical scroll bar in the active window.
6. To horizontally scroll both windows at the same time, use the horizontal scroll bar in the active window.

7. To reverse the windows, select the bottom window to activate it.

8. Click the **Reset Window Position** button in the *Window* group.

9. To scroll each window independently, click the **Synchronous Scrolling** button in the *Window* group.

10. Scroll each window as desired.

11. To enable synchronous scrolling, click the **Synchronous Scrolling** button in the *Window* group.

12. Continue scrolling the windows as desired.

13. Select the **View Side by Side** button in the *Window* group to return to a single window view.

---

**Step-by-Step**

Compare workbooks side-by-side.

Maximize the Q1CENTRL workbook window and display the *Projected Annual* worksheet. Display the *Projected Annual* worksheet for the Q1SEAST workbook.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the View tab, if necessary. <em>The View tab is displayed.</em></td>
<td>Click View, if necessary</td>
</tr>
<tr>
<td>2. Select the View Side by Side button in the Window group. <em>If more than two workbooks are open, the Compare Side by Side dialog box opens.</em></td>
<td>Click</td>
</tr>
<tr>
<td>3. If more than two workbooks are open, select the workbook you want to compare in the Compare Side by Side dialog box. <em>The workbook is selected.</em></td>
<td>Click Q1CENTRL, if necessary</td>
</tr>
<tr>
<td>4. Select OK. <em>The Compare Side by Side dialog box closes, and the two workbooks appear in top and bottom windows.</em></td>
<td>Click OK</td>
</tr>
</tbody>
</table>
Steps | Practice Data
--- | ---
5. To vertically scroll both windows at the same time, use the vertical scroll bar in the active window. *The windows scroll together vertically.* | Drag the vertical scroll bar in the top window down to the bottom and then back to the top.

6. To horizontally scroll both windows at the same time, use the horizontal scroll bar in the active window. *The windows scroll together horizontally.* | Drag the horizontal scroll bar in the top window to the right and then back to the left.

7. To reverse the windows, select the bottom window to activate it. *The bottom window is activated.* | Click in the bottom window.

8. Click the **Reset Window Position** button in the **Window** group. *The windows switch positions.* | Click ![image](image)

9. To scroll each window independently, click the **Synchronous Scrolling** button in the **Window** group. *Synchronized scrolling is disabled.* | Click ![image](image) to deselect it

10. Scroll each window as desired. *The window scrolls independently of the other window.* | Drag the vertical scroll box in the top window to display row 16

11. To enable synchronous scrolling, click the **Synchronous Scrolling** button in the **Window** group. *Synchronized scrolling is enabled.* | Click ![image](image)

12. Continue scrolling the windows as desired. *The windows scroll to the desired positions.* | Follow the instructions shown below the table before continuing on to the next step

13. Select the **View Side by Side** button in the **Window** group to return to a single window view. *The side-by-side view closes and the active window is maximized in the workspace.* | Click ![image](image) to deselect it

Drag the vertical scroll bar down. Notice that even though different rows display for each workbook, the worksheets are scrolling together. Drag the scroll bar to the top to display row 1 in the top window.

*Return to the table and continue on to the next step (step 13).*
Display the Q1 Tennis worksheet for the Q1CENTRL and Q1SEAST workbooks.

COPYING DATA BETWEEN WORKBOOKS

Discussion

You can copy data between open workbooks in the same way you copy data between worksheets in a single workbook. For example, you can copy data from several workbooks containing regional sales data to a single consolidation workbook. By default, the cell format is copied as well as the data.

You can also drag to copy data to another workbook.

Information copied in another Office application (such as Microsoft Word or PowerPoint) can be pasted into Excel, and information copied in Excel can be pasted into other Office applications.

Procedures

1. Open multiple workbook windows.
2. Select the workbook window containing the data you want to copy.
3. Select the data you want to copy.
4. Select the Copy button in the Clipboard group on the Home tab.
5. Select the workbook in which you want to paste the data.
6. Select the paste range.
7. Select the top part of the Paste button in the Clipboard group.

Step-by-Step

Copy data from one workbook to another workbook.
If necessary, display the **Q1 Tennis** sheet for the **Q1CENTRL.XLSX**, **Q1NEAST.XLSX** and **Q1SEAST.XLSX** workbooks.

Vertically tile the open workbook windows.

<table>
<thead>
<tr>
<th><strong>Steps</strong></th>
<th><strong>Practice Data</strong></th>
</tr>
</thead>
</table>
| 1. Select the workbook window containing the data you want to copy.  
*The window is activated.* | Click in the **Q1CENTRL.XLSX** window |
| 2. Select the data you want to copy.  
*The range is selected.* | Drag across A1:A2, then release the mouse button |
| 3. Select the **Copy** button in the **Clipboard** group on the **Home** tab.  
*A blinking marquee appears around the copied range.* | Click |
| 4. Select the workbook in which you want to paste the data.  
*The window is activated.* | Click in the **Q1NEAST.XLSX** window |
| 5. Select the paste range.  
*The paste range is selected.* | Click cell A1, if necessary |
| 6. Select the top part of the **Paste** button in the **Clipboard** group.  
*The data appears in the paste range.* | Click |

Press [Esc] to hide the **Paste Options** button and deselect the copied range.

Save the **Q1NEAST.XLSX** workbook.

### Saving a Workspace

**Discussion**

You can save multiple, open workbooks as a workspace. A workspace saves information about which workbooks are open, as well as their size and the positions they occupy in the workspace.

Workspaces are useful when you have several, related workbooks. If you save related workbooks as a workspace, you can open the workspace instead of having to open each workbook individually, and the workbooks will open in the configuration saved with the workspace. For example, if you usually open separate workbooks provided by several regional sales representatives and work with them simultaneously, you can arrange the workbooks in the desired screen configuration and save them as a workspace.
When a workspace is open, you can make changes as needed to any of the workbooks and then save the changes in the usual manner. If you make changes to the appearance of the workspace, however, you must use the **Save Workspace** button on the View tab to save the workspace; you will not be prompted to save it. For instance, if you decide to tile the workbooks in a workspace horizontally instead of vertically, you must manually save the workspace in order to save its new configuration.

![Saving a workspace](image)

**Procedures**

1. Select the View tab.

2. Select the **Save Workspace** button in the Window group.

3. Type the desired workspace name in the **File name** box.

4. Select the double arrow at the left of the Address bar.

5. Select the drive where you want to save the workbook.

6. Select the folder where you want to save the workbook.

7. Select **Save**.
Step-by-Step

Save a workspace.

If necessary, vertically tile the open workbook windows and save any changes made to individual workbooks.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the <strong>View</strong> tab. The <strong>View</strong> tab is displayed.</td>
<td>Click <strong>View</strong></td>
</tr>
<tr>
<td>2. Select the <strong>Save Workspace</strong> button in the <strong>Window</strong> group. The <strong>Save Workspace</strong> dialog box opens with the text in the <strong>File name</strong> box selected.</td>
<td>![Save Workspace] Click <strong>Save Workspace</strong></td>
</tr>
<tr>
<td>3. Type the desired workspace name in the <strong>File name</strong> box. The workspace name appears in the <strong>File name</strong> box.</td>
<td>Type <strong>Regions</strong></td>
</tr>
<tr>
<td>4. Select the double arrow at the left of the <strong>Address</strong> bar. A list of available drives and common folders is displayed.</td>
<td>![Double Arrow] Click <strong>Double Arrow</strong></td>
</tr>
<tr>
<td>5. Select the drive where you want to save the workspace. A list of available folders is displayed.</td>
<td>Click the student data drive</td>
</tr>
<tr>
<td>6. Select the folder where you want to save the workspace. A list of available folders and files is displayed.</td>
<td>Click the student data folder</td>
</tr>
<tr>
<td>7. Select the <strong>Save</strong> button. The <strong>Save Workspace</strong> dialog box closes and the new workspace is saved to the selected drive and folder.</td>
<td>Click <strong>Save</strong></td>
</tr>
</tbody>
</table>
CLOSING ALL OPEN WORKBOOKS

Discussion

You can use the Close All button to close all open workbooks at one time. If you have made changes to any workbook since it was last saved, Excel will prompt you to save or reject the changes.

Closing all workbooks at once can save time when you have multiple workbooks open.

The Close All button is not, by default, included on the Quick Access Toolbar. However, adding the button by customizing the Quick Access Toolbar will ensure the Close All button is always available.

You can close the active window only by selecting the red Close button at the top right of the Excel window; if there is only one workbook open, this will also close Excel. Alternatively, you can close the active workbook by selecting the Close button in the title bar of the active workbook window.

Procedures

1. If necessary, add the Close All button to the Quick Access Toolbar.
2. Open multiple workbook windows.
3. Select the Close All button in the Quick Access Toolbar.

Step-by-Step

Close all open workbooks at once.

If necessary, add the Close All button to the Quick Access Toolbar.
Steps | Practice Data
--- | ---
1. Select the Close All button in the Quick Access Toolbar. *All open workbooks are closed.* | Click ![Click](image)

If Excel prompts you to save changes made to any workbook, select **Yes**.

## OPENING A WORKSPACE

### Discussion

When you open a workspace, all the workbooks stored in it open in the defined workspace configuration.

A workspace stores information regarding the location of the workbooks, as well as their size and position in the workspace. Consequently, a workspace can open the workbooks even if they are stored in different folders. If you move a workbook saved in a workspace, however, Excel will not be able to locate and open the workbook with the workspace. In this case, the workspace opens only the workbooks it can find.

### Procedures

1. Select the **Office** button ![Office](image).
2. Select ![Open](image).
3. Select the double arrow `«` at the left of the **Address** bar.
4. Select the drive where the workspace you want to open is located.
5. Select the folder in which the workspace you want to open is located.
6. Select the file name of the workspace you want to open.
7. Select the left-hand part of the **Open** button ![Open](image).

### Step-by-Step

Open a workspace.
**Steps** | **Practice Data**
---|---
1. Select the **Office** button.  
*The Office menu opens.* | Click
2. Select the **Open** option.  
*The Open dialog box opens.* | Click
3. Select the double arrow at the left of the **Address** bar.  
*A list of available drives and common folders is displayed.* | Click
4. Select the drive where the workspace you want to open is located.  
*A list of available folders is displayed.* | Click the student data drive
5. Select the folder in which the workspace you want to open is located.  
*A list of available folders and files is displayed.* | Click the student data folder
6. Select the file name of the workspace you want to open.  
*The file name is highlighted in the list and appears in the **File name** box.* | Scroll as necessary and click **REGIONS.XLW**
7. Select the left-hand part of the **Open** button.  
*The Open dialog box closes and the workspace opens.* | Click

**LINKING WORKBOOKS**

**Discussion**

Linking workbooks allows one workbook to retrieve data saved in another. You can create a linked formula that calculates results using data in other workbooks. For instance, if you have the first quarter sales of three regional offices in three separate workbooks, you can create formulas in a fourth summary workbook to calculate and display the summarized data from the three regional workbooks.

The workbooks that contain the original data are called the source files. The easiest way to create a linked formula is to open all the workbooks that contain the data you need, as well as the workbook that will contain the linked formula. Then, you can select the cells you want to calculate as you create the formula. When you create a
formula linked to other workbooks, each reference includes the path to the workbook’s location, the workbook name in square brackets, the worksheet name, an exclamation point, and then the cell reference.

When changes are made to linked data, Excel automatically updates the links with the new information; linked files do not need to be open for the links to be updated. In addition, Excel automatically updates links when the workbook is opened.

A linked formula

Linked references are created as absolute references. If you want to copy the formula to other cells, you can edit the formula to remove the absolute references, if desired.

You can also use the Paste Link feature to copy linked data to another workbook.

You can also create a linked formula by typing the formula. If the source workbook is not open, you must also include its path. The path, workbook name, and worksheet name must be enclosed in a set of single quotation marks.
### Procedures

1. Open all workbooks you want to link, and activate the workbook in which you want to create a linked formula.
2. Select the cell in which you want to create the linked formula.
3. Type an equal sign (=) to start the formula.
4. Activate the window containing the first cell reference.
5. Select the data you want to link.
6. Complete the formula.
7. Press [Enter].

### Step-by-Step

From the Student Data directory, open EQPSUM1.XLSX. Link workbooks by creating a linked formula.

Tile the open workbooks.

If necessary, activate the EQPSUM1.XLSX window.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the cell in which you want to create a linked formula. &lt;br&gt; <em>The cell is selected.</em></td>
<td>Scroll as necessary and click cell B7 in the EQPSUM1.XLSX window</td>
</tr>
<tr>
<td>2. Type an equal sign (=) to start the formula. &lt;br&gt; <em>An equal sign (=) appears in the cell and on the formula bar.</em></td>
<td>Type =</td>
</tr>
<tr>
<td>3. Activate the workbook containing the first cell reference. &lt;br&gt; <em>The workbook window is activated.</em></td>
<td>Click the Q1NEAST.XLSX window</td>
</tr>
<tr>
<td>4. Select the data you want to link. &lt;br&gt; <em>The linked reference appears in the cell and on the formula bar.</em></td>
<td>Scroll as necessary and click cell B12 in the Q1NEAST.XLSX window</td>
</tr>
</tbody>
</table>
Steps | Practice Data
--- | ---
5. Complete the formula. The formula appears in the cell and on the formula bar. | Follow the instructions shown below the table before continuing on to the next step
6. Press [Enter]. The result of the formula appears in the cell. | Press [Enter]

Type a plus sign (+), select cell B12 in the Q1SEAST.XLSX window, type a plus sign (+), and then select cell B12 in the Q1CENTRL.XLSX window.

Return to the table and continue on to the next step (step 6).

The total for tennis equipment in Q1 should be $91,831. Select cell B11 in the Q1NEAST.XLSX workbook (currently 3,567), type 5500, and press [Enter]. The total in the EQPSUM1.XLSX workbook should change to $93,764.

Save the Q1NEAST.XLSX workbook. Close the Q1NEAST.XLSX, Q1SEAST.XLSX, and Q1CENTRL.XLSX workbooks. Leave the EQPSUM1.XLSX workbook open.

OPENING LINKED WORKBOOKS

Discussion

Excel allows you to link data and consolidate information stored in other workbooks. The workbooks containing the data are called the source files. When you open a workbook with a linked formula, you can use the Edit Links dialog box to open the source file links.

In addition, the Edit Links dialog box can be used to: update links, if necessary; designate a different source file; or change the location of a source file.
The Edit Links dialog box can be used to replace one source file with another or to select the new location of a source file that has been moved.

You can use the [Shift] and [Ctrl] keys in the Links dialog box to select multiple source files.

Procedures

1. Select the Data tab.
2. Select the Edit Links button in the Connections group.
3. Select the source files you want to open.
4. Select the Open Source button.

Step-by-Step

Open linked workbooks.

Maximize the EQPSUM1.XLSX workbook. Select cell B7; notice that the formula includes the path name of all linked files.
## Steps

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the <strong>Data</strong> tab. <strong>The Data tab is displayed.</strong></td>
<td>Click <strong>Data</strong></td>
</tr>
<tr>
<td>2. Select the <strong>Edit Links</strong> button in the <strong>Connections</strong> group. <strong>The Edit Links dialog box opens.</strong></td>
<td>Click <strong>Edit Links</strong></td>
</tr>
<tr>
<td>3. Select the source files you want to open. <strong>The files are selected.</strong></td>
<td>Hold [Ctrl], click to select all three files, and release [Ctrl]</td>
</tr>
<tr>
<td>4. Select the <strong>Open Source</strong> button. <strong>The linked files open.</strong></td>
<td>Click <strong>Open Source</strong></td>
</tr>
</tbody>
</table>

Notice that all three linked files were opened.

Close all open workbooks without saving them.
EXERCISE

USING MULTIPLE WORKBOOKS

Task

Use multiple workbooks.

1. Open the QTR1.XLSX, QTR2.XLSX, QTR3.XLSX, and QTR4.XLSX workbooks.
2. Close any blank workbooks that are open and then cascade all the QTR workbook windows.
3. Select each workbook window one at a time. Notice that the QTR4.XLSX workbook is missing a title in cell A1.
4. Tile the workbook windows.
5. Copy the title from cell A1 in QTR1.XLSX to cell A1 in QTR4.XLSX.
7. Save the open workbooks as a workspace; name the workspace QUARTER. Save workbook changes as well, when you are prompted.
8. Use the Close All button to close all open workbooks.
9. Open the QUARTER.XLW workspace.
10. Open QTRLINK.XLSX. With the QTRLINK.XLSX window active, tile all the open workbooks.
11. Select cell B7 in the QTRLINK.XLSX workbook and create a formula that adds cells F3 in each of the QTR1.XLSX, QTR2.XLSX, QTR3.XLSX and QTR4.XLSX workbooks.
12. Close the QTR1.XLSX and QTR2.XLSX workbooks.
13. Use the Edit Links dialog box to reopen the QTR1.XLSX and QTR2.XLSX workbooks.
14. Close all open workbooks without saving them.
15. Open the REGN1.XLSX and REGN2.XLSX workbooks and compare the two workbooks side-by-side.
16. Scroll the workbooks vertically and horizontally. Reset the windows by placing the bottom window on top. Turn off synchronized scrolling and scroll the top window.

17. Enable synchronized scrolling and close the side-by-side windows.

18. Close REGN1.XLSX and REGN2.XLSX.
LESSON 12 - SHARING WORKBOOKS

In this lesson, you will learn how to:

- Use shared workbooks
- Save a shared workbook
- View users sharing a workbook
- View shared workbook changes
- Change the update frequency
- Highlight changes
- Manage conflicting changes
- Resolve conflicting changes
- Set change history options
- Add a History worksheet
- Review tracked changes
- Merge shared workbook files
USING SHARED WORKBOOKS

Discussion

In Excel, more than one user can review or edit a workbook at the same time. For example, in a worksheet tracking orders, it may be necessary for several people to enter, review, and edit data (perhaps including a data entry person, an inventory manager, a purchasing manager, and the shipping department).

Shared workbooks allow more than one person to access the information stored in a workbook at the same time. Shared workbooks are placed on a shared network resource, such as a network drive or folder.

Using a shared workbook is similar to using an exclusive workbook; certain Excel features, however, are not available in shared workbooks. When a workbook is shared, you cannot perform the following tasks:

- Delete worksheets
- Merge or split cells
- Define or apply conditional formats and data validation
- Insert and delete blocks of cells
- Add or edit charts, pictures, objects, or hyperlinks
- Use the Drawing tools
- Assign, change, or remove passwords in individual worksheets or in the workbook itself, although existing passwords remain in effect
- Work with scenarios
- Group or outline data
- Insert automatic subtotals
- Create data tables
- Create or modify Pivot Tables
- Work with macros
- Change dialog boxes or menus
You can also share a workbook with other team members by saving it to a shared document workspace on a web site running Microsoft Windows SharePoint Services. You and your team members can access a workbook saved to a SharePoint site through a web browser or by using the Document Workspace task pane in Excel.

---

**SAVING A SHARED WORKBOOK**

**Discussion**

You can share workbooks with other users. For example, after you have created an order entry workbook, you can share the workbook with other users who need to enter orders.

A shared workbook must be stored on a shared network drive or in a shared folder. Any individual with access to the shared drive or folder can access the file. If you want to limit access to a shared workbook, you can assign a password to it before you share it. Then, only those users who know the password can open the workbook.

After saving a workbook as a shared file, the text [Shared] appears next to the workbook name on the title bar.

**Procedures**

1. Select the **Review** tab.

2. Select the **Share Workbook** button in the **Changes** group.

3. Select the **Editing** tab, if necessary.

4. Select the **Allow changes by more than one user at the same time** option.

5. Select **OK**.

6. Select **OK**.
Step-by-Step

From the Student Data directory, open SHIPPING.XLSX. Save a workbook as a shared file.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the <strong>Review</strong> tab. <em>The Review tab is displayed.</em></td>
<td>Click <strong>Review</strong></td>
</tr>
<tr>
<td>2. Select the <strong>Share Workbook</strong> button in the <strong>Changes</strong> group. <em>The Share Workbook dialog box opens.</em></td>
<td>![Share Workbook]</td>
</tr>
<tr>
<td>3. Select the <strong>Editing</strong> tab, if necessary. <em>The Editing page is displayed.</em></td>
<td>Click <strong>Editing</strong> tab, if necessary</td>
</tr>
<tr>
<td>4. Select the <strong>Allow changes by more than one user at the same time</strong> option. <em>The Allow changes by more than one user at the same time option is selected.</em></td>
<td>Click <strong>Allow changes by more than one user at the same time</strong></td>
</tr>
<tr>
<td>5. Select <strong>OK</strong>. <em>The Share Workbook dialog box closes, and a Microsoft Office Excel warning box opens, prompting you to verify the save.</em></td>
<td>Click <strong>OK</strong></td>
</tr>
<tr>
<td>6. Select <strong>OK</strong>. <em>The Microsoft Office Excel warning box closes, and the workbook is saved as a shared file.</em></td>
<td>Click <strong>OK</strong></td>
</tr>
</tbody>
</table>

Notice that the text [**Shared**] appears on the title bar. Close SHIPPING.XLSX.

**VIEWING USERS SHARING A WORKBOOK**

**Discussion**

More than one user can use a shared workbook at the same time. For example, in an order entry worksheet, the order entry user can be entering orders at the same time as
the shipping user is entering shipping dates. In the Share Workbook dialog box, you can see which users are working on a shared workbook at any given time.

![Image of Share Workbook dialog box]

**Viewing users sharing a workbook**

Excel lists users by their user name. You can change your user name in the **User name** box on the **Popular** page in the Excel Options dialog box.

---

**Procedures**

1. Select the **Review** tab, if necessary.

2. Select the **Share Workbook** button in the **Changes** group.

3. Select the **Editing** tab, if necessary, to view the **Who has this workbook open now** box.

4. Select **OK** to close the dialog box.
**Step-by-Step**

From the Student Data directory, open **SHIPPNG2.XLSX**.
View the users sharing a workbook.

Note: Students should pair off to share a single workbook. If necessary, copy the shared **SHIPPNG2.XLSX** file from the student data folder to a shared folder that both students can access. Both students should open the same **SHIPPNG2.XLSX** workbook.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the <strong>Review</strong> tab, if necessary.</td>
<td>Click <strong>Review</strong></td>
</tr>
<tr>
<td><em>The Review tab is displayed.</em></td>
<td></td>
</tr>
<tr>
<td>2. Select the <strong>Share Workbook</strong> button in the <strong>Changes</strong> group.</td>
<td><img src="image" alt="Share Workbook" /></td>
</tr>
<tr>
<td><em>The Share Workbook dialog box opens.</em></td>
<td>Click <strong>Share Workbook</strong></td>
</tr>
<tr>
<td>3. Select the <strong>Editing</strong> tab, if necessary.</td>
<td>Click the <strong>Editing</strong> tab, if</td>
</tr>
<tr>
<td><em>The Editing page is displayed, with the current users listed in the</em></td>
<td>necessary</td>
</tr>
<tr>
<td><em>Who has this workbook open now box.</em></td>
<td></td>
</tr>
<tr>
<td>4. Select <strong>OK</strong> to close the dialog box.</td>
<td>Click <strong>OK</strong></td>
</tr>
<tr>
<td><em>The Share Workbook dialog box closes.</em></td>
<td></td>
</tr>
</tbody>
</table>

**VIEWING SHARED WORKBOOK CHANGES**

**Discussion**

When more than one user is sharing a workbook, each user works in a separate copy of the workbook. When one user saves changes, the changes are saved to the single shared workbook on the shared resource. Before you save your copy of the shared workbook, you can view the changes made by other users. For example, if the data entry person added and saved an order while you are working in the order entry workbook, you can view the changes when you save the worksheet.

Changes appear in a different color for each user; a colored border appears around each changed cell and a triangular comment marker appears in the upper, left corner of each changed cell. When accessed, each comment box indicates the date and time of the change, the user who made the change, and the actual change itself. For example, if a change was made to a projected shipping date, you can view the user who made the change, when the change was made, and what the change entailed. As
soon as you modify the workbook, however, the change indicators are removed from it.

Excel can only highlight those changes made to cell contents, including moving and pasting cell contents and inserting or deleting rows and columns. Other changes, such as formatting, are not highlighted.

- Changes made by all users since you last used a workbook appear when you open the workbook.
- If a comment is attached to a changed cell, both the comment and the details of the change appear in a single comment box.

**Procedures**

1. Click the **Save** button on the **Quick Access Toolbar**.
2. Select **OK**.
3. Point to any cell with a colored border and a comment mark.

**Step-by-Step**

View the changes made to a shared workbook.

One student from each pair should now change the data in cell F4 to **6/7/2007** and save the workbook file. The other student then performs the following step-by-step.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Click the <strong>Save</strong> button on the <strong>Quick Access Toolbar</strong>. <em>If the shared file has been changed by another user, a Microsoft Office Excel message box informs you that it has been changed.</em></td>
<td>Click</td>
</tr>
</tbody>
</table>
### Steps

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
</table>
| 2. | Select **OK**.  
*The Microsoft Office Excel message box closes, and the changed cells appear with an indicator in the upper left corner and a colored border around each cell.* |
|   |   |
| 3. | Point to any cell with a colored border and a comment mark.  
*The comment appears.* |

<table>
<thead>
<tr>
<th></th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Click [OK]</td>
</tr>
<tr>
<td></td>
<td>Point to cell F4</td>
</tr>
</tbody>
</table>

**Practice the Concept:** The students in each pair should now reverse roles. One student from each pair should now change the data in cell F5 to **6/10/2007** and save the workbook file. The other student then performs the above step-by-step.

---

### Changing the Update Frequency

#### Discussion

You can determine how often changes made by other users are updated to a shared workbook. By default, saved changes are updated each time you save the workbook. You can, however, specify that changes be updated at timed intervals, from 5 to 1440 minutes. For example, if Friday is a major shipping day and you are working in the order entry workbook, you can update changes every fifteen minutes to see which orders have been shipped.

If you have configured a shared workbook to be updated at a timed interval, you can also have Excel save the file at the same time.
Procedures

1. Select the Review tab, if necessary.

2. Select the Share Workbook button in the Changes group.

3. Select the Advanced tab.

4. Under Update changes, select the Automatically every option.

5. Enter the time interval in the minutes spin box at which you want changes to appear in the open workbook.

6. Select other options as desired.

7. Select OK.

Step-by-Step

Change the update frequency for a shared workbook.
### Steps

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the **Review** tab, if necessary.  
*The Review tab is displayed.* | Click **Review** |
| 2. Select the **Share Workbook** button in the **Changes** group.  
*The Share Workbook dialog box opens.* | ![Share Workbook](image)  
Click **Share Workbook** |
| 3. Select the **Advanced** tab.  
*The Advanced page is displayed.* | Click **Advanced** |
| 4. Under **Update changes**, select the **Automatically every** option.  
*The **Automatically every** option is selected and the **minutes** spin box is activated.* | Click **Automatically every** |
| 5. Enter the time interval in the **minutes** spin box at which you want changes to appear in the open workbook.  
*The number appears in the **minutes** spin box.* | Type **25** |
| 6. Select other options as desired.  
*The options are selected.* | Click **Save my changes and see others’ changes**, if necessary |
| 7. Select **OK**.  
*The Share Workbook dialog box closes, and the new update frequency is saved.* | Click **OK** |

### Highlighting Changes

#### Discussion

By default, all changes made and saved by other users are highlighted when a shared workbook is updated. You can control which changes you want to appear. For example, in an order entry workbook, you may want to view only those changes made by the order entry user since the beginning of the week.

You can use the following options in the Highlight Changes dialog box to specify which changes to highlight in the shared workbook:
Option | Highlights
--- | ---
When | Changes made since the last save, all changes, tracked changes not yet reviewed, or changes made since a specific date
Who | Changes made by everyone, everyone but yourself, or a specific user

The **Where** option allows you to define the range in which you want changes to be highlighted.

![The Highlight Changes dialog box](image)

The boxes around highlighted cells print when you print the shared workbook. To hide the highlighting for printing, deselect the **Highlight changes on screen** option in the Highlight Changes dialog box.

### Procedures

1. Select the **Review** tab, if necessary.
2. Select the **Track Changes** button in the **Changes** group.
3. Select the **Highlight Changes** option.
4. Select the **Track changes while editing ...** option.
5. Select the **When** list.
6. Select the desired option.
7. Select the **Who** list.
8. Select the desired option.
9. Click the **Collapse Dialog** button in the **Where** box.
10. Select the range in which you want to view changes.
11. Click the **Expand Dialog** button.
12. Select the **Highlight changes on screen** option, if necessary.
13. Select **OK**.

---

**Step-by-Step**

Highlight changes.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the **Review** tab, if necessary.  
*The Review tab is displayed.* | Click **Review**, if necessary |
| 2. Select the **Track Changes** button in the **Changes** group.  
*The Track Changes menu opens.* | Click **Track Changes** |
| 3. Select the **Highlight Changes** option.  
*The Highlight Changes dialog box opens.* | Click **Highlight Changes** |
| 4. Select the **Track changes while editing ...** option.  
*The Track changes while editing ... option is selected.* | Click **Track changes while editing..., if necessary** |
| 5. Select the **When** list.  
*A list of available options is displayed.* | Click **When** |
| 6. Select the desired option.  
*The selected option appears in the **When** box.* | Click **All** |
| 7. Select the **Who** list.  
*A list of available options is displayed.* | Click **Who** |
Excel 2007 - Lvl 3

Lesson 12 - Sharing Workbooks

**Steps** | **Practice Data**
--- | ---
8. Select the desired option. The selected option appears in the **Who** box. | Click **Everyone**
9. Click the **Collapse Dialog** button in the **Where** box. The Highlight Changes dialog box collapses. | Click **Where**
10. Select the range in which you want to view changes. The range is highlighted as you drag. | Drag across B2:I16, then release the mouse button
11. Click the **Expand Dialog** button. The Highlight Changes dialog box expands, and the selected range appears in the **Where** box. | Click **Expand Dialog**
12. Select the **Highlight changes on screen** option, if necessary. The **Highlight changes on screen** option is selected. | Click **Highlight changes on screen**, if necessary
13. Select **OK**. The Highlight Changes dialog box closes, and all changed cells in the defined range are outlined in varying colors, according to the user who made the change. | Click **OK**

---

**MANAGING CONFLICTING CHANGES**

**Discussion**

If more than one user is working in a shared workbook, and each user is saving changes, the changes made may conflict with one another. Conflicting changes refer to changes made to the same cell by two different users and come into play when more than one user saves changes to the shared workbook. For example, in an order entry workbook, two shipping employees may both enter and save conflicting shipping dates for the same item.

You can decide how you want to resolve conflicting changes: you can review the conflicting changes, or you can have your changes override the conflicting changes saved previously.
Each user can independently set conflicting changes options. All users, however, have the same priority; consequently, the user who saves the shared workbook last can have his or her changes override all conflicting changes.

Procedures

1. Select the Review tab, if necessary.

2. Select the Share Workbook button in the Changes group.

3. Select the Advanced tab.

4. Under Conflicting changes between users, select the desired option.

5. Select OK.

Step-by-Step

Manage conflicting changes.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Review tab, if necessary. The Review tab is displayed.</td>
<td>Click Review</td>
</tr>
<tr>
<td>2. Select the Share Workbook button in the Changes group. The Share Workbook dialog box opens.</td>
<td>Click Share Workbook</td>
</tr>
<tr>
<td>3. Select the Advanced tab. The Advanced page is displayed.</td>
<td>Click Advanced, if necessary</td>
</tr>
<tr>
<td>4. Under Conflicting changes between users, select the desired option. The option is selected.</td>
<td>Click Ask me which changes win, if necessary</td>
</tr>
<tr>
<td>5. Select OK. The Share Workbook dialog box closes, and the conflicting change option is saved.</td>
<td>Click OK</td>
</tr>
</tbody>
</table>
Save the workbook.

RESOLVING CONFLICTING CHANGES

Discussion

Conflicting changes refer to changes made to the same cell by two different users and come into play when more than one user saves changes to the shared workbook.

If you have opted to review conflicting changes, the Resolve Conflicts dialog box opens whenever you save a file with a conflicting change made by another user. For example, if you change a projected shipping date that has already been changed by another user, you are asked to resolve the conflict.

The Resolve Conflicts dialog box displays information about the conflicting changes. You can choose to keep your change, or you can accept the change made by the other user.

The Resolve Conflicts dialog box

You can also use the Accept All Mine button or the Accept All Others button to resolve all conflicts in one step.

Procedures

1. Save a shared workbook with conflicting changes.

2. Select Accept Mine or Accept Other in the Resolve Conflicts dialog box, as appropriate.
3. Select [OK], if necessary.

### Step-by-Step

Resolve conflicting changes.

In each student pair, one student should now change the date in cell F7 to **6/11/2007** and save the shared workbook. The second student should then change the date in cell F7 to **6/12/2007** and save the file. The Resolve Conflicts dialog box will open when the second student saves the workbook.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select **Accept Mine** or **Accept Other** in the Resolve Conflicts dialog box, as appropriate.  
*If there are no additional conflicting changes, your changes are saved and the Resolve Conflicts dialog box closes.* | Click [Accept Mine] |

**Practice the Concept:** The students should now reverse roles. The second student in each pair should select cell F9; change the date to **6/12/2007**; and then save the file, selecting **OK** to close the Microsoft Office Excel message box, if necessary.

The first student should then change the date in cell F9 to **6/13/2007**; save the workbook; and resolve the conflict by selecting **Accept Other** and selecting **OK** to close the Microsoft Office Excel message box, if necessary.

### Setting Change History Options

**Discussion**

When Excel tracks changes in a workbook, it creates a change history. The change history tracks the details of each change made to a shared workbook.

You can specify the number of days you want to maintain the change history. For example, if the turn-around time for an order in an order entry workbook is forty-five days, you can modify the change history to track changes for forty-five days, thereby synchronizing it with the shipping cycle.
 Procedures

1. Select the Review tab, if necessary.

2. Select the Share Workbook button in the Changes group.

3. Select the Advanced tab.

4. Under Track changes, select the Keep change history for option.

5. Enter the number of days you want to maintain the change history in the days spin box.

6. Select OK.

 Step-by-Step

Set change history options.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Review tab, if necessary.</td>
<td>Click Review</td>
</tr>
<tr>
<td><em>The Review tab is displayed.</em></td>
<td></td>
</tr>
<tr>
<td>2. Select the Share Workbook button in the Changes group.</td>
<td>Click Share Workbook</td>
</tr>
<tr>
<td><em>The Share Workbook dialog box opens.</em></td>
<td></td>
</tr>
<tr>
<td>3. Select the Advanced tab.</td>
<td>Click Advanced, if necessary</td>
</tr>
<tr>
<td><em>The Advanced page is displayed.</em></td>
<td></td>
</tr>
<tr>
<td>4. Under Track changes, select the Keep change history for option.</td>
<td>Click Keep change history for, if necessary</td>
</tr>
<tr>
<td><em>The Keep change history for option is selected.</em></td>
<td></td>
</tr>
<tr>
<td>5. Enter the number of days you want to maintain the change history in the days spin box.</td>
<td>Click days to 25</td>
</tr>
<tr>
<td><em>The number appears in the days spin box.</em></td>
<td></td>
</tr>
</tbody>
</table>
Steps

6. Select OK.
The Share Workbook dialog box closes, and the change history options are saved.

Practice Data

Click OK

ADDITIONA HISTORY WORKSHEET

Discussion

You can display the change history in a separate worksheet. A History worksheet is added to the end of the shared workbook and displays the following information:

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Action Number</td>
<td>A number assigned to the change</td>
</tr>
<tr>
<td>Date</td>
<td>The date the change was made</td>
</tr>
<tr>
<td>Time</td>
<td>The time the change was made</td>
</tr>
<tr>
<td>Who</td>
<td>The name of the user who made the change</td>
</tr>
<tr>
<td>Change</td>
<td>The type of change made (e.g., cell change, inserted row, etc.)</td>
</tr>
<tr>
<td>Sheet</td>
<td>The sheet on which the change was made</td>
</tr>
<tr>
<td>Range</td>
<td>The cell or range in which the change was made</td>
</tr>
<tr>
<td>New Value</td>
<td>The new cell value</td>
</tr>
<tr>
<td>Old Value</td>
<td>The replaced cell value</td>
</tr>
<tr>
<td>Action Type</td>
<td>Displays Won if a later change discarded an existing change</td>
</tr>
<tr>
<td>Losing Action</td>
<td>Displays the row number in the History worksheet of the discarded or losing action</td>
</tr>
</tbody>
</table>

AutoFilter arrows allow you to filter the information in the History worksheet.

The History worksheet is removed from the workbook as soon as you save or close the workbook.
The changes displayed on the History worksheet depend on the When, Who, and Where options selected in the Highlight Changes dialog box.

### Procedures

1. Select the Review tab, if necessary.
2. Select the Track Changes button in the Changes group.
3. Select the Highlight Changes option.
4. Select the Track changes while editing... option, if necessary.
5. Select the List changes on a new sheet option.
6. Select OK.

### Step-by-Step

Add a History worksheet to a shared workbook.
**Steps** | **Practice Data**
---|---
1. Select the **Review** tab, if necessary. *The Review tab is displayed.* | Click **Review**, if necessary
2. Select the **Track Changes** button in the **Changes** group. *The Track Changes menu opens.* | Click **Track Changes**
3. Select the **Highlight Changes** option. *The Highlight Changes dialog box opens.* | Click **Highlight Changes**
4. Select the **Track changes while editing...** option, if necessary. *The Track changes while editing... option is selected.* | Click **Track Changes while editing...**, if necessary
5. Select the **List changes on a new sheet** option. *The List changes on a new sheet option is selected.* | Click **List changes on a new sheet**
6. Select **OK**. *The Highlight Changes dialog box closes, and a History worksheet is added to the workbook.* | Click **OK**

---

**REVIEWING TRACKED CHANGES**

**Discussion**

You can review changes made to a shared workbook and accept or reject them as desired. For example, if a user entered incorrect information in a data entry workbook, you can reject all changes made by that user.

When you review changes, all changes meeting the selected criteria appear. You can then either accept or reject changes individually or all at one time.
Accepting or rejecting tracked changes

If the file is not saved or has unresolved conflicts when you review changes, Excel first prompts you to save the file and resolve the conflicts.

Procedures

1. Select the Review tab, if necessary.

2. Select the Track Changes button in the Changes group.

3. Select the Accept/Reject Changes option.

4. Select the When list.

5. Select the desired option.

6. Select the Who list.

7. Select the desired option.

8. Click the Collapse Dialog button in the Where box.

9. Select the desired range.
10. Click the **Expand Dialog** button.

11. Select **OK**.

12. Select **Accept, Reject, Accept All, or Reject All**, as desired.

13. Accept or reject any remaining changes, if necessary.

### Step-by-Step

Review tracked changes.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the <strong>Review</strong> tab, if necessary. <em>The Review tab is displayed.</em></td>
<td>Click <strong>Review</strong></td>
</tr>
<tr>
<td>2. Select the <strong>Track Changes</strong> button in the <strong>Changes</strong> group. <em>The Track Changes menu opens.</em></td>
<td>Click <strong>Track Changes</strong></td>
</tr>
<tr>
<td>3. Select the <strong>Accept/Reject Changes</strong> option. <em>The Select Changes to Accept or Reject dialog box opens.</em></td>
<td>Click <strong>Accept/Reject Changes</strong></td>
</tr>
<tr>
<td>4. Select the <strong>When</strong> list. <em>A list of available options is displayed.</em></td>
<td>Click <strong>When</strong></td>
</tr>
<tr>
<td>5. Select the desired option. <em>The option appears in the <strong>When</strong> box.</em></td>
<td>Click <strong>Not yet reviewed</strong></td>
</tr>
<tr>
<td>6. Select the <strong>Who</strong> list. <em>A list of available options is displayed.</em></td>
<td>Click <strong>Who</strong></td>
</tr>
<tr>
<td>7. Select the desired option. <em>The option appears in the <strong>Who</strong> box.</em></td>
<td>Click <strong>Everyone</strong></td>
</tr>
<tr>
<td>8. Click the <strong>Collapse Dialog</strong> button in the <strong>Where</strong> box. <em>The Select Changes to Accept or Reject dialog box collapses.</em></td>
<td>Click <strong>Where</strong></td>
</tr>
<tr>
<td>9. Select the desired range. <em>The range is selected.</em></td>
<td>Drag across B2:I16, then release the mouse button, if necessary</td>
</tr>
</tbody>
</table>
Steps | Practice Data
---|---
10. Click the **Expand Dialog** button. The Select Changes to Accept or Reject dialog box expands, and the selected range appears in the **Where** box. | Click ![Image]

11. Select **OK**. The Select Changes to Accept or Reject dialog box closes, and the Accept or Reject Changes dialog box opens with the first change displayed. | Click ![Image]

12. Select **Accept**, **Reject**, **Accept All**, or **Reject All**, as desired. The change is accepted or rejected, and the next change is displayed. | Click ![Image]

13. Accept or reject any remaining changes, if necessary. The Accept or Reject Changes dialog box closes when all changes have been reviewed. | Click ![Image]

Close **SHIPPNG2.XLSX**.

**MERGING SHARED WORKBOOK FILES**

**Discussion**

You can save one or more copies of a shared workbook with different file names and distribute those copies to other users so that they can review and edit the workbook. After all users have finished editing the workbook, you can merge the revised copies back into the shared workbook.

In order to merge workbook files, they must meet the following criteria:

- All files must be copies of the same workbook.
- Each copy must have a different file name.
- None of the workbook files can be password-protected.
- The original workbook must be a shared file.
- The change history options must be enabled and the length of time between creating the file copies and merging them cannot be greater than the number of days the change history is maintained.
Changes in the workbook file from which you are merging replace any conflicting changes in the workbook file into which you are merging. If you are merging more than one workbook file, the files are merged in the order in which they appear in the Select Files to Merge Into Current Workbook dialog box. After merging the workbooks, you can use the Accept or Reject Changes dialog box to decide which changes you want to keep or discard.

The **Compare and Merge Workbooks** button is not, by default, on the **Quick Access Toolbar**. However, adding the button by customizing the **Quick Access Toolbar** will ensure the **Compare and Merge Workbooks** button is always available.

When you merge copies, the original workbook is automatically saved with the merged changes.

**Procedures**

1. Save the workbook file into which you want to merge files, if necessary.

2. Select the **Compare and Merge Workbooks** button on the **Quick Access Toolbar**.

3. Select the double arrow at the left of the **Address bar**.

4. Select the drive where the workbook you want to merge is located.

5. Select the folder where the workbook you want to merge is located.

6. Select the workbook you want to merge.

7. To merge additional workbooks, hold [Ctrl] and select the other workbooks you want to merge.

8. Select **OK**.

**Step-by-Step**

From the Student Data directory, open **MERGE.XLSX**. Merge shared workbook files.
If necessary, save the open workbook.

If necessary, add the Compare and Merge Workbooks button to the Quick Access Toolbar.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the Compare and Merge Workbooks button on the Quick Access Toolbar. The Select Files to Merge Into Current Workbook dialog box opens. | Click ![button](image)
| 2. Select the double arrow at the left of the Address bar. A list of available drives and common folders is displayed. | Click ![arrow](image)
| 3. Select the drive where the workbook you want to merge is located. A list of available folders is displayed. | Click the student data drive
| 4. Select the folder where the workbook you want to merge is located. A list of available folders and files is displayed. | Click the student data folder
| 5. Select the workbook you want to merge. The file name is selected. | Scroll as necessary and click MERGE1
| 6. To merge additional workbooks, hold [Ctrl] and select the other workbooks you want to merge. The file names are selected. | Hold [Ctrl] and click MERGE2
| 7. Select OK. The Select Files to Merge Into Current Workbook dialog box closes, and all selected workbooks are merged into the current workbook. | Click ![OK button](image)

Open the Highlight Changes dialog box (select the Highlight Changes option from the Track Changes menu). Enable change tracking for all changes made by everyone (set the When to All and the Who to Everyone).

Notice that all cells changed by the merge are outlined and have change indicators; NTB in the Sales Rep column has been changed to ESK and Net 30 in the Terms column has been changed to Net 45.
Open the Accept or Reject Changes dialog box (select the **Accept or Reject Changes** option from the **Track Changes** menu and select **OK** to review the changes that were not yet reviewed by everyone). Reject the first three changes then accept all changes.

Close **MERGE.XLSX**.
Exercise

Sharing Workbooks

Task

Share workbooks.

Note: This exercise requires students to pair up and access a shared file from a shared folder.

1. Open Q2NEASTX.XLSX.

2. Share the workbook and select options to automatically update changes every 10 minutes, to keep the change history for 45 days, and to review conflicting changes.

3. Pair off with another student as Student1 and Student2. Student1 should save the workbook to a shared folder while Student2 closes his copy of Q2NEASTX.XLSX. Student2 should now open Q2NEASTX.XLSX from the shared folder. Both students in a pair must have the same shared workbook open.

4. Student1 should add 100 to each of the values in the May column and then save the file.

5. Student2 should add 100 to each of the values in the Jun column and then save the file.

6. Both students should save their copy again. Then both students should highlight tracked changes for all changes not yet reviewed, by everyone, and for the entire worksheet.

7. Student2 should change the Apr, Week1 figure to 3700 and save the file.

8. Student1 should change the Apr, Week1 figure to 3650 and save the file. Student1 should then accept the other student’s changes in the Resolve Conflicts dialog box.

9. Add a History worksheet to the workbook, for all changes made by all users. Then, review the History worksheet.

10. Open MERGEX.XLSX and merge MERGEX1.XLSX into MERGEX.XLSX. View the comment for the change indicator.

11. Close all open workbooks without saving them.
INDEX

Advanced filters
  copying filtered data, 62, 63, 64
  creating a criteria range, 50, 51
  showing all data, 54, 55
  using a criteria range, 52, 53
  using an And condition, 56, 57, 58
  using an Or condition, 59, 60, 61
  using comparison criteria, 55
  using database functions, 66, 67, 68
Allow-editing ranges
  creating, 221, 222, 223
  deleting, 225, 226
Automatic Calculation
  resetting, 210
Calculation
  automatic, 210
  manual, 208, 209
  pasting, 194
Cells
  unlocking in a worksheet, 216, 217
Charts
  adding a data series from a different worksheet, 138, 139
  adding a trendline, 145, 146
  adding data labels, 135, 136, 137
  adding gridlines, 126, 127
  applying a chart template, 149, 150, 151
  changing data series chart types, 142, 143, 144
  changing the axis scaling, 132, 133, 134
  creating a chart template, 147, 148
  formatting an axis, 130, 131
  formatting gridlines, 128, 129
  formatting the data series, 135, 136, 137
  removing gridlines, 126, 127
  using a secondary axis, 140, 141
Column widths
  pasting, 194
Conditional formats
  adding, 161, 162
Conditional Formatting
  clear rules, 167, 168
  color scales, 165, 166, 167
  customized, 163, 164
  data bars, 165, 166, 167
  delete rules, 167, 168
  editing a rule, 158, 159, 160
  highlight cells rules, 156, 157
icon sets, 165, 166, 167
Rules Manager, 158, 159, 160
top/bottom rules, 156, 157

Custom number formats
creating, 169, 171

Data
changing external data range properties, 85, 86, 87
copying between workbooks, 251
creating subtotals in, 116, 117, 118
exporting to other applications, 76, 77
importing dynamic data from the Web, 95, 97
importing from Access, 79, 80
importing from other applications, 88, 89, 90
importing from text files, 82, 83
pasting, 194
removing subtotals from, 120
removing the query definition, 94

Data validation
creating a custom error message, 41, 42
removing, 44
using, 35, 36
using a validation list, 38, 39

Database functions
using, 66, 67, 68

Exporting
data to other applications, 76, 77

Formats
adding conditional, 161, 162
creating custom number formats, 169, 171
pasting, 194

Formulas
copying between worksheets, 196, 197
pasting, 194

Gridlines
adding to a chart, 126, 127
removing from a chart, 126, 127

Importing
changing external data range properties, 85, 86, 87
data from other applications, 88, 89, 90
dynamic data from the Web, 95, 97
removing the query definition, 94

Manual Calculation, 208, 209

Opening a workspace, 256, 257

Outlines
applying, 106, 107
clearing, 114, 115
collapsing, 108, 109, 110
expanding, 108, 109, 110
modifying settings, 110, 111
ungrouping outline levels, 114, 115
using Auto Outline, 112, 113
Passwords
  adding to a worksheet, 217, 219
  assigning, 230, 231
  opening a password-protected file, 233, 234
  protecting workbook windows, 227, 228
  removing, 235
  unprotecting a worksheet, 220
  unprotecting workbook windows, 229, 230
Paste Special, 194
  copying formulas between worksheets, 196, 197
  copying values between worksheets, 194, 195, 196
  performing mathematical operations, 198, 199, 200
Preferences
  setting display options, 205, 207
  setting editing options, 204, 205
  setting popular options, 211, 212
Ranges
  unlocking for editing, 221, 222, 223
Side by Side feature, 247, 248, 249
Subtotals
  creating, 116, 117, 118
  removing, 120
Tables
  adding new rows and columns, 14, 16
  calculated columns, 18, 19
  changing table style options, 8, 9, 10
  changing the table name, 5, 6
  changing the table style, 6, 7, 8
  clearing an advanced filter, 54, 55
  copying filtered data, 62, 63, 64
  copying from web pages, 99, 100, 101
  creating a criteria range, 50, 51
  creating a custom error message, 41, 42
  creating from existing data, 2, 4
  finding unique records, 69, 70
  inserting and deleting rows and columns, 17
  manually resizing, 15
  moving, 24, 25
  overview, 2
  removing data validation, 44
  removing duplicate records, 71, 72
  selecting all the table data, 21, 22, 23
  selecting column data, 21, 22
  selecting table columns, 21, 22
  selecting table rows, 21, 22
  selecting the entire table, 21, 22, 23
  sorting by multiple levels, 25, 26, 27
  using a criteria range, 52, 53
  using an And condition in advanced filters, 56, 57, 58
  using an Or condition in advanced filters, 59, 60, 61
  using comparison criteria, 55
using data validation, 35, 36
using database functions, 66, 67, 68
using number filters, 32, 33, 34
using text filters, 29, 30, 31
using the total row, 11, 13
validating data using a list, 38, 39

Templates, 176
creating default, 187
deleting, 185, 186
editing, 181, 182
finding online, 188, 189
inserting a new worksheet, 183
saving a workbook as, 176, 177, 178
using to create a workbook, 178, 179
worksheet, 184

Tracked changes
highlighting, 274, 275, 276
managing conflicting, 277, 278
resolving conflicting, 279, 280
reviewing, 284, 285, 286
setting change history options, 280, 281

Trendlines
adding to a data series, 145, 146

Values
copying between worksheets, 194, 195, 196
pasting, 194

View Side by Side
comparing workbooks, 247, 248, 249

Web pages
copying a table from, 99, 100, 101

Windows
activating cascaded workbooks, 243, 244
activating tiled workbooks, 246, 247
cascading open workbooks, 242, 243
closing all open workbooks, 255
opening multiple workbooks, 240, 241
protecting workbook, 227, 228
tiling open workbooks, 244, 245, 246
unprotecting workbook, 229, 230

Workbooks
activating cascaded windows, 243, 244
activating tiled windows, 246, 247
adding a History worksheet, 282, 283
cascading open windows, 242, 243
changing the update frequency for shared, 272, 273
closing all open, 255
copying data between, 251
highlighting changes, 274, 275, 276
linking, 257, 259
managing conflicting changes, 277, 278
merging shared, 287, 288
opening linked, 260, 261
opening multiple windows, 240, 241
resolving conflicting changes, 279, 280
reviewing tracked changes, 284, 285, 286
saving as a template, 176, 177, 178
saving as a workspace, 252, 253, 254
saving shared, 267, 268
setting change history options, 280, 281
sharing, 266
tiling open windows, 244, 245, 246
viewing shared changes, 270, 271
viewing side by side, 247, 248, 249
viewing users sharing, 268, 269, 270

Worksheets
adding History, 282, 283
copying formulas between, 196, 197
copying values between, 194, 195, 196
inserting based on a template, 183, 184
protecting, 217, 219
unlocking a range for editing, 221, 222, 223
unlocking cells, 216, 217
unprotecting, 220

Workspaces
opening, 256
saving, 252, 253, 254

World Wide Web
importing dynamic data, 95, 97