Modifying Tables
Setting Field Properties
Using Operators in Queries
Designing Advanced Queries
Creating Action Queries
Using Advanced Query Wizards
Using Advanced Database Features
Using Controls and Layouts
Manipulating Form Controls in Design View
Using Design View
Using Advanced Form Design
Using Editing Tools
Using Advanced Report Design
ABOUT ONDEMAND SOFTWARE

The OnDemand Software Division of Global Knowledge is the worldwide leader of software solutions that enable rapid adoption, broad acceptance and increased accuracy in the use of enterprise applications related to enterprise resource planning, supply chain management, procurement, e-commerce and customer relationship management.

The flagship product, OnDemand Personal Navigator™, provides one synchronized documentation, training and performance support platform. Founded in 1986, the OnDemand Software Division has over 850 Global 2000 customers in 12 countries. The OnDemand Software Division of Global Knowledge, a Welsh, Carson, Anderson and Stowe portfolio company, is headquartered in King of Prussia, Pennsylvania, with offices located worldwide. Additional information can be found at http://www.ondemandgk.com.

COPYRIGHT

Copyright © Global Knowledge Software LLC. 2008. All rights reserved. Information in this document is subject to change without notice and does not represent a commitment on the part of Global Knowledge.

No part of this publication, including interior design, cover design, icons or content may be reproduced by any means, be it transmitted, transcribed, photocopied, stored in a retrieval system, or translated into any language in any form, without the prior written permission of Global Knowledge Network, Inc.

Products mentioned herein, including SAP R/3, PeopleSoft, Siebel Systems, Microsoft Windows, Microsoft Office, Microsoft FrontPage, Microsoft Outlook, Macromedia Flash, Adobe Acrobat, and JavaScript are trademarks or registered trademarks of their respective owners.

OnDemand Personal Navigator and Courseware Express are trademarks of Global Knowledge Software LLC. CustomDOC and Knowledge Pathways are registered trademark of Global Knowledge Software LLC. Global Knowledge and the Global Knowledge logo are trademarks of Global Knowledge, Inc.

DISCLAIMER

Global Knowledge has taken every effort to ensure the accuracy of this manual. If you should discover any discrepancies, please notify us immediately.

Global Knowledge Software LLC.
OnDemand Software Division
475 Allendale Road
King of Prussia, PA 19406
(610) 337-8878
www.ondemandgk.com
ABOUT ONDEMAND SOFTWARE .......................................................... I
COPYRIGHT ....................................................................................... I
DISCLAIMER ..................................................................................... I

LESSON 1 - MODIFYING TABLES ............................................................ 1
  Inserting a Column into a Table ....................................................... 2
  Changing a Column Name ............................................................... 3
  Deleting a Column ......................................................................... 5
  Inserting a Lookup Column .............................................................. 6
  Inserting a Hyperlink Column .......................................................... 10
  Creating a Many-to-Many Relationship ........................................... 11
  Exercise ......................................................................................... 15
  Modifying Tables ......................................................................... 15

LESSON 2 - SETTING FIELD PROPERTIES ............................................ 17
  Using Field Properties .................................................................... 18
  Limiting Field Size ........................................................................ 19
  Setting Number Formats ................................................................. 21
  Setting Date/Time Formats ............................................................... 24
  Setting Yes/No Formats .................................................................. 26
  Setting Default Values ................................................................... 28
  Setting Validation Rules ................................................................. 30
  Creating an Input Mask - Wizard ....................................................... 32
  Creating an Input Mask Manually ..................................................... 35
  Creating a Custom Input Mask ......................................................... 37
  Typing a Lookup List ...................................................................... 40
  Modifying Lookup Properties ......................................................... 44
  Exercise ......................................................................................... 46
  Setting Field Properties ................................................................ 46

LESSON 3 - USING OPERATORS IN QUERIES ........................................ 49
  Using Comparison Operators ........................................................... 50
  Using an And Condition .................................................................. 52
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Linking Data to an Access Table</td>
<td>115</td>
</tr>
<tr>
<td>Using the Linked Table Manager</td>
<td>117</td>
</tr>
<tr>
<td>Exporting Data</td>
<td>120</td>
</tr>
<tr>
<td>Converting Files</td>
<td>123</td>
</tr>
<tr>
<td>Printing a Relationship Document</td>
<td>124</td>
</tr>
<tr>
<td>Compacting a Database</td>
<td>126</td>
</tr>
<tr>
<td>Using Name AutoCorrect</td>
<td>127</td>
</tr>
<tr>
<td>Backing Up a Database</td>
<td>130</td>
</tr>
<tr>
<td>Exercise</td>
<td>132</td>
</tr>
<tr>
<td>Using Advanced Database Features</td>
<td>132</td>
</tr>
</tbody>
</table>

**LESSON 8 - USING CONTROLS AND LAYOUTS** .................................. 133

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Switching Views</td>
<td>134</td>
</tr>
<tr>
<td>Using Controls</td>
<td>135</td>
</tr>
<tr>
<td>Using Control Layouts</td>
<td>136</td>
</tr>
<tr>
<td>Using a Stacked Layout</td>
<td>137</td>
</tr>
<tr>
<td>Using a Tabular Layout</td>
<td>138</td>
</tr>
<tr>
<td>Removing a Control from a Layout</td>
<td>140</td>
</tr>
<tr>
<td>Moving Controls</td>
<td>141</td>
</tr>
<tr>
<td>Viewing the Properties of an Object</td>
<td>142</td>
</tr>
<tr>
<td>Changing a Control Property</td>
<td>144</td>
</tr>
<tr>
<td>Exercise</td>
<td>148</td>
</tr>
<tr>
<td>Manipulating Controls</td>
<td>148</td>
</tr>
</tbody>
</table>

**LESSON 9 - MANIPULATING FORM CONTROLS IN DESIGN VIEW** ............ 149

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Selecting Non-adjacent Controls</td>
<td>150</td>
</tr>
<tr>
<td>Selecting Adjacent Controls</td>
<td>151</td>
</tr>
<tr>
<td>Deleting Controls</td>
<td>153</td>
</tr>
<tr>
<td>Sizing a Control by Dragging</td>
<td>154</td>
</tr>
<tr>
<td>Sizing Controls Automatically</td>
<td>155</td>
</tr>
<tr>
<td>Setting Control Margins</td>
<td>157</td>
</tr>
<tr>
<td>Setting Control Padding</td>
<td>158</td>
</tr>
<tr>
<td>Hiding the Ruler</td>
<td>159</td>
</tr>
<tr>
<td>Disabling the Snap to Grid Feature</td>
<td>160</td>
</tr>
<tr>
<td>Displaying the Field List</td>
<td>161</td>
</tr>
<tr>
<td>Adding a Field</td>
<td>163</td>
</tr>
</tbody>
</table>
Adding a Field from Another Table ..............................................164
Moving Part of a Paired Control .......................................................166
Aligning Controls ......................................................................167
Spacing Controls ......................................................................169
Exercise ......................................................................................171
  Manipulating Form Controls in Design View ...............................171

LESSON 10 - USING DESIGN VIEW .....................................................173
Adding a Label ...............................................................................174
Adding an Image ...........................................................................175
Adding a Rectangle ......................................................................177
Adding a Line ...............................................................................178
Editing an Unbound Control .........................................................180
Using Multiple Undo/Redo in Design View .....................................181
Exercise ......................................................................................184
  Using Design View ......................................................................184

LESSON 11 - USING ADVANCED FORM DESIGN.................................185
Using Forms in Design View ..........................................................186
Creating a Combo Box ................................................................187
Editing List Items .........................................................................191
Creating a List Box ......................................................................192
Creating an Option Group .............................................................196
Adding a Logic Control ................................................................200
Setting the Tab Order Automatically ..............................................203
Setting the Tab Order Manually ......................................................204
Adding a Form Header and Footer ................................................205
Creating a Blank Form ................................................................207
Exercise ......................................................................................209
  Using Advanced Form Design ..................................................209

LESSON 12 - USING EDITING TOOLS................................................211
Changing the Font .........................................................................212
Changing the Font Size .................................................................214
Changing the Character Format .....................................................215
Changing the Font Color ...............................................................217
Changing Fill and Background Colors ............................................218
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Formatting Lines and Borders</td>
<td>220</td>
</tr>
<tr>
<td>Applying Special Effects</td>
<td>222</td>
</tr>
<tr>
<td>Using Conditional Formatting</td>
<td>224</td>
</tr>
<tr>
<td>Using the Format Painter</td>
<td>226</td>
</tr>
<tr>
<td>Using AutoFormat</td>
<td>227</td>
</tr>
<tr>
<td>Using Error Checking</td>
<td>228</td>
</tr>
<tr>
<td>Running the Spelling Checker</td>
<td>230</td>
</tr>
<tr>
<td>Setting AutoCorrect Options</td>
<td>233</td>
</tr>
<tr>
<td>Adding AutoCorrect Entries</td>
<td>235</td>
</tr>
<tr>
<td>Exercise</td>
<td>239</td>
</tr>
<tr>
<td>Using Editing Tools</td>
<td>239</td>
</tr>
</tbody>
</table>

**LESSON 13 - USING ADVANCED REPORT DESIGN** ................................................. 241

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adding Report Sections in Design View</td>
<td>242</td>
</tr>
<tr>
<td>Creating a Calculated Control</td>
<td>244</td>
</tr>
<tr>
<td>Creating a Running Summary</td>
<td>246</td>
</tr>
<tr>
<td>Inserting a Date/Time Control</td>
<td>247</td>
</tr>
<tr>
<td>Inserting a Page Break</td>
<td>249</td>
</tr>
<tr>
<td>Changing the Report Margins</td>
<td>250</td>
</tr>
<tr>
<td>Using the Label Wizard</td>
<td>252</td>
</tr>
<tr>
<td>Creating a Report without Using a Wizard</td>
<td>256</td>
</tr>
<tr>
<td>Exercise</td>
<td>259</td>
</tr>
<tr>
<td>Using Advanced Report Design</td>
<td>259</td>
</tr>
</tbody>
</table>

**INDEX** ............................................................................................................. 261
LESSON 1 -
MODIFYING TABLES

In this lesson, you will learn how to:

- Insert a column into a table
- Change a column name
- Delete a column
- Insert a lookup column
- Insert a hyperlink column
- Create a many-to-many relationship
INSERTING A COLUMN INTO A TABLE

Discussion

You may find it necessary to add fields to a table. One way of doing this is to insert one or more columns into the table. Inserting a column automatically adds a new field to the table.

Columns are inserted to the left of the currently selected column; consequently, you can position a new field in the desired location. Although Access sets a default field width, provides a default field name, and assigns a default data type (Text), you can change any of these default settings as desired.

You can also insert a column by right-clicking any column heading and selecting Insert Column.

After adding a column, you should change the default field name to one that clearly identifies its contents.

Procedures

1. Open the desired table in Datasheet view.
2. Click in the column to the left of which the new column is to be inserted.
3. Select the Datasheet tab on the Ribbon.
4. Select the Insert button in the Fields & Columns group.

Step-by-Step

From the Student Data directory, open MODTAB1.ACCDB.
Insert a column into a table.

Open the Items table in Datasheet view.
Steps | Practice Data
--- | ---
1. Click in the column to the left of which the new column is to be inserted. *The insertion point appears in the column.* | Click in the **Unit Price** column
2. Select the **Datasheet** tab on the **Ribbon**. *The Datasheet tab is displayed.* | Click **Datasheet**
3. Select the **Insert** button in the **Field & Columns** group. *A blank column appears in the table, to the left of the selected column.* | Click **Insert**

### CHANGING A COLUMN NAME

#### Discussion

A column name should clearly indicate the information contained in the column in order to make working with data easier. When you rename a column, you are also changing the corresponding field name; keep in mind that you cannot create duplicate field names.

Column names can be up to 64 characters long, but shorter names are recommended.

Renaming a column
You can also rename a column by right-clicking its heading and selecting **Rename Column**.

Column names can contain spaces, numbers, and many special characters; a column name, however, cannot include a period (.), an exclamation point (!), or square brackets ([ ]).

The column heading is also called the field selector.

**Procedures**

1. Open the desired table in **Datasheet** view.
2. Double-click the heading of the column you want to rename.
3. Type the desired column name.
4. Press [Enter].

**Step-by-Step**

Change a column name.

If necessary, open the **Items** table in **Datasheet** view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Double-click the heading of the column you want to rename.  
  *The column heading is selected.* | Double-click the **Field1** column heading |
| 2. Type the desired column name.  
  *The text appears in the column heading.* | Type **Vendor**                     |
| 3. Press [Enter].  
  *Both the column and its corresponding fields are renamed.* | Press [Enter]                      |
DELETING A COLUMN

Discussion

You can delete a column from a table. When a column is deleted, the columns to the right of it automatically adjust.

In addition, if other database objects (such as lookup tables) contain references to a deleted field, the appropriate error messages will be generated.

- You can also delete a column by right-clicking its heading and selecting Delete Column.
- You cannot delete a field that has a relationship to another table unless you first delete the relationship.
- All data contained in a deleted column is permanently deleted as well, and you cannot undo the deletion.

Procedures

1. Open the desired table in Datasheet view.
2. Click in the column you want to delete.
3. Select the Datasheet tab on the Ribbon.
4. Select the Delete button in the Fields & Columns group.
5. Select Yes to confirm the deletion.

Step-by-Step

Delete a column in a table.

If necessary, open the Items table in Datasheet view.
**Lesson 1 - Modifying Tables**

**Steps** | **Practice Data**
---|---
1. Click in the column you want to delete. *The insertion point appears in the column.* | Click anywhere in the **Vendor** column
2. Select the **Datasheet** tab on the **Ribbon**. *The Datasheet tab is displayed.* | Click **Datasheet**
3. Select the **Delete** button in the **Fields & Columns** group. *A Microsoft Office Access warning box asks you to confirm the deletion.* | Click **Delete**
4. Select **Yes** to confirm the deletion. *The Microsoft Office Access warning box closes, and the column is deleted.* | Click **Yes**

Close the **Items** table.

---

**INSERTING A LOOKUP COLUMN**

---

**Discussion**

A lookup column looks up data stored in another data source, thereby eliminating the need to search for information when you add a record. In addition, a lookup column saves time because it reduces the amount of information you must type and increases accuracy because a list of available data values is provided.

The Lookup Wizard can assist you in creating a lookup column. The values in a lookup column can come from another table or a query, or you can create your own list. For example, you may have a list of customers in one table and a list of customer types and information related to each customer type in another; you can use a lookup column in the customer table to look up customer type data in the customer type table; choosing the customer type from a list helps ensure the accuracy of the data.

During data entry, a lookup column displays a drop-down arrow. You can use the arrow to access the available list of values, or you can type the desired value into the column.
Using the Lookup Wizard

- You can also insert a lookup column by right-clicking the column heading to the left of which you want to insert the lookup column and then selecting **Lookup Column**.

- You can click at the right side of a lookup column to automatically display the lookup list.

- You can also use the Lookup Wizard in **Design** view to create a lookup for an existing field by selecting **Lookup Wizard...** from the **Data Type** drop-down list to the right of the field in which you want to create the lookup. If the field happens to be a join field, you may have to delete the join before creating the lookup.

**Procedures**

1. Open the desired table in **Datasheet** view.
2. Click anywhere in the column to the left of which you want to insert the lookup column.
3. Select the **Datasheet** tab on the **Ribbon**.
4. Select the **Lookup Column** button in the **Fields & Columns** group.
5. Select the option that specifies how you want the lookup column to get its values.
6. Select **Next >**.
7. Select the table or query that will provide the values for the lookup column.
8. Select

9. Double-click the field containing the values you want to look up to move it from the **Available Fields** list to the **Selected Fields** list.

10. Select

11. Select the desired sorting options.

12. Select

13. Double-click the separator line to the right of any column header to automatically adjust the corresponding column width.

14. Select

15. Type the desired label for the lookup column.

16. Select

---

**Step-by-Step**

Insert a lookup column in a table.

Open the **Customers** table in **Datasheet** view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Click anywhere in the column to the left of which you want to insert the lookup column. <em>The insertion point appears in the column.</em></td>
<td>Scroll as necessary and click in the <strong>Sales Rep</strong> column</td>
</tr>
<tr>
<td>2. Select the <strong>Datasheet</strong> tab on the <strong>Ribbon</strong>. <em>The Datasheet tab is displayed.</em></td>
<td>Click <strong>Datasheet</strong></td>
</tr>
<tr>
<td>3. Select the <strong>Lookup Column</strong> button in the <strong>Fields &amp; Columns</strong> group. <em>The Lookup Wizard opens.</em></td>
<td>Click <strong>Lookup Column</strong></td>
</tr>
<tr>
<td>4. Select the option that specifies how you want the lookup column to get its values. <em>The option is selected.</em></td>
<td>Click <strong>I want the lookup column to look up the values in a table or query</strong>, if necessary</td>
</tr>
<tr>
<td>Steps</td>
<td>Practice Data</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>------------------------</td>
</tr>
</tbody>
</table>
| 5. Select **Next**.  
*The next page of the Lookup Wizard is displayed.* | Click ![Next >](Next.png) |
| 6. Select the table or query that will provide the values for the lookup column.  
*The table or query is selected.* | Click **Table: Customer Type**, if necessary |
| 7. Select **Next**.  
*The next page of the Lookup Wizard is displayed.* | Click ![Next >](Next.png) |
| 8. Double-click the field containing the values you want to look up to move it from the **Available Fields** list to the **Selected Fields** list.  
*The fields appear in the **Selected Fields** list.* | Double-click **Description** |
| 9. Select **Next**.  
*The next page of the Lookup Wizard is displayed.* | Click ![Next >](Next.png) |
| 10. Select **Next**.  
*The next page of the Lookup Wizard is displayed.* | Click ![Next >](Next.png) |
| 11. Double-click the separator line to the right of any column header to automatically adjust the corresponding column width.  
*The column width is adjusted.* | Double-click the separator line to the right of the **Description** column header |
| 12. Select **Next**.  
*The next page of the Lookup Wizard appears, with the text in the **What label would you like for your lookup column?** box selected.* | Click ![Next >](Next.png) |
| 13. Type the desired label for the lookup column.  
*The text appears in the **What label would you like for your lookup column?** box.* | Type **Market Type** |
| 14. Select **Finish**.  
*The Lookup Wizard closes, and the lookup column is inserted.* | Click ![Finish](Finish.png) |
Use the lookup column to enter data. Click in the **Market Type** column for the first record and then click the drop-down arrow that appears. Select **large metro markets**; then, double-click the separator line to the right of the **Market Type** column heading to widen the **Market Type** column as needed.

Click at the right side of the **Market Type** column for the second record; notice that the drop-down list automatically appears. Select **medium markets**.

---

**INSERTING A HYPERLINK COLUMN**

- **Discussion**

You can insert a hyperlink column into a table; a hyperlink field contains a path to another location, such as a network server or a page on the Internet. When you insert a hyperlink column, its name defaults to **Field1**; you can rename the hyperlink column as desired.

After inserting a hyperlink column, you can type the hyperlink text for each record directly into the column, and each record can contain a different hyperlink address. Hyperlinks are underlined and appear in a different color.

- After inserting a hyperlink column, you should change the default field name to one that clearly identifies its contents.

---

- **Procedures**

1. Open the desired table in **Datasheet** view.
2. Click in the column to the left of which the hyperlink column is to be inserted.
3. Select the **Insert button** in the **Fields & Columns** group on the **Datasheet** tab.
4. Select the arrow in the **Data Type box in the Data Type & Formatting group.**
5. Select **Hyperlink**.
Step-by-Step

Insert a hyperlink column.

If necessary, open the Customers table in Datasheet view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Click in the column to the left of which the hyperlink column is to be inserted. <em>The insertion point appears in the column.</em></td>
<td>Scroll as necessary and click in the Address column.</td>
</tr>
<tr>
<td>2. Select the Insert button in the Fields &amp; Columns group on the Datasheet tab. <em>A blank column is inserted.</em></td>
<td>Click</td>
</tr>
<tr>
<td>3. Select the arrow in the Data Type box in the Data Type &amp; Formatting group. <em>A list of Data Types is displayed.</em></td>
<td>Click</td>
</tr>
<tr>
<td>4. Select Hyperlink. <em>The column Data Type is updated.</em></td>
<td>Click</td>
</tr>
</tbody>
</table>

Change the hyperlink column name to Web Address. Then, type www.shoes.com into the Web Address field for the Athletic Supplies Co. record. Widen the column as necessary. Notice that the entry is underlined and its text is blue.

Close the Customers table, saving the changes.

CREATING A MANY-TO-MANY RELATIONSHIP

Discussion

Although one-to-many relationships are more common by far, there are times when you may need to create a many-to-many relationship. In a many-to-many relationship, a record in one table can have many matching records in another table and vice versa. Many-to-many relationships often apply to order and product relationships, in which an order can include many products and a product can appear in many orders.

This type of relationship is made possible through the use of a third table, called a junction table, that includes its own primary key field and two foreign key fields, one from each of the two tables being related. A many-to-many relationship is really two one-to-many relationships, linked by the junction table.
The Show Table dialog box opens automatically if no tables have been added to the Relationships window.

You can also create relationships in the Show Table dialog box by selecting the tables you want to relate and pressing the [Enter] key.

Procedures

1. Select the **Database Tools** tab, if necessary.

2. Click the **Relationships** button on the **Database Tools** tab.

3. Click the **Show Table** button on the **Design** tab, if necessary.

4. Select the tables you want to join.

5. Select **Add**.

6. Select **Close** in the Show Table dialog box.

7. Drag the desired field for the first join from the junction table field list to the corresponding field in the related table field list.

8. Select the **Enforce Referential Integrity** option.

9. Select **Create**.

10. Drag the desired field for the second join from the junction table field list to the corresponding field in the second related field list.

11. Select the **Enforce Referential Integrity** option.

12. Select **Create**.


14. Select **Yes** to save the changes.
Step-by-Step

Create a many-to-many relationship.

If necessary, display the Database Tools tab.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Click the Relationships button on the Database Tools tab. The Relationships window opens and the Design contextual tab is displayed.</td>
<td>Click</td>
</tr>
<tr>
<td>2. Click the Show Table button on the Design tab, if necessary. The Show Table dialog box opens.</td>
<td>Click , if necessary</td>
</tr>
<tr>
<td>3. Select the tables you want to join. The table names are selected.</td>
<td>Follow the instructions shown below the table before continuing on to the next step</td>
</tr>
<tr>
<td>4. Select Add. The tables appear in the Relationships window.</td>
<td>Click</td>
</tr>
<tr>
<td>5. Select Close in the Show Table dialog box. The Show Table dialog box closes.</td>
<td>Click</td>
</tr>
<tr>
<td>6. Drag the desired field for the first join from the junction table field list to the corresponding field in the related table field list. The Edit Relationships dialog box opens.</td>
<td>Drag Product ID in the Order Details field list to Product ID in the Items field list</td>
</tr>
<tr>
<td>7. Select the Enforce Referential Integrity option. The Enforce Referential Integrity option is selected.</td>
<td>Click Enforce Referential Integrity</td>
</tr>
<tr>
<td>8. Select Create. The Edit Relationships dialog box closes, and a join line appears between the field lists.</td>
<td>Click</td>
</tr>
<tr>
<td>Steps</td>
<td>Practice Data</td>
</tr>
<tr>
<td>-------</td>
<td>---------------</td>
</tr>
<tr>
<td>9. Drag the desired field for the second join from the junction table field list to the corresponding field in the second related table field list. <em>The Edit Relationships dialog box opens.</em></td>
<td>Drag <strong>Order Number</strong> in the <strong>Order Details</strong> field list to <strong>Order Number</strong> in the <strong>Orders</strong> field list</td>
</tr>
<tr>
<td>10. Select the <strong>Enforce Referential Integrity</strong> option. <em>The <strong>Enforce Referential Integrity</strong> option is selected.</em></td>
<td>Click <strong>[Enforce Referential Integrity]</strong></td>
</tr>
<tr>
<td>11. Select <strong>Create</strong>. <em>The Edit Relationships dialog box closes, and a join line appears between the field lists.</em></td>
<td>Click <strong>Create</strong></td>
</tr>
<tr>
<td>12. Close the Relationships window. <em>A Microsoft Office Access warning box asks if you want to save the changes.</em></td>
<td>Click <strong>Close</strong></td>
</tr>
<tr>
<td>13. Select <strong>Yes</strong> to save the changes. <em>The Microsoft Office Access warning box and the Relationships window close, and the tables are related.</em></td>
<td>Click <strong>Yes</strong></td>
</tr>
</tbody>
</table>

Hold [Ctrl] and click the **Items**, **Order Details**, and **Orders** tables.

*Return to the table and continue on to the next step (step 4).*

Close **MODTAB1.ACCDB**.
EXERCISE

MODIFYING TABLES

Task

Modify the appearance of a table.

1. Open MODTABX.ACCDB.
2. Open the Trainer table in Datasheet view.
3. Insert a hyperlink column to the right of the Home Phone column; name the hyperlink column E-Mail.
4. Select the E-Mail field of the Andrew Williams record, type awilliams@aol.com, and press [Enter]. Widen the E-Mail column as necessary; notice that the new entry is formatted as a hyperlink. Then, close the Trainer table, saving the changes.
5. Open the Payment table in Datasheet view.
6. Insert a lookup column to the left of the Trainer Initials column.
7. Have the lookup column get its values from the Types table and the Payment Type field, do not adjust the column width, and label the column Type of Payment.
8. Make sure the Payment table is sorted in ascending order by the Project ID field. Then, enter the following values for the first eight records into the Type of Payment column:

<table>
<thead>
<tr>
<th>Project ID</th>
<th>Type of Payment</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>MONEY ORDER</td>
</tr>
<tr>
<td>1</td>
<td>MONEY ORDER</td>
</tr>
<tr>
<td>2</td>
<td>VISA</td>
</tr>
<tr>
<td>3</td>
<td>CHECK</td>
</tr>
<tr>
<td>3</td>
<td>CHECK</td>
</tr>
<tr>
<td>4</td>
<td>MASTER CARD</td>
</tr>
<tr>
<td>5</td>
<td>VISA GOLD</td>
</tr>
<tr>
<td>6</td>
<td>CASH</td>
</tr>
</tbody>
</table>

9. Widen the Type of Payment column as necessary. Then, delete the Trainer Initials and Credit Rating columns.
10. Close the Payment table, saving the changes.

11. Open the Relationships window and add the Client, Project, and Trainer tables.

12. Create a join between the Client and Project tables on the Client ID field; enforce referential integrity.

13. Create a second join between the Trainer Initials and Initials fields in the Project and Trainer tables respectively; enforce referential integrity.

14. Close the Relationships window, saving the changes.

15. Close the database file.
In this lesson, you will learn how to:

- Use field properties
- Limit field size
- Set number formats
- Set date/time formats
- Set yes/no formats
- Set default values
- Set validation rules
- Create an input mask - wizard
- Create an input mask manually
- Create a custom input mask
- Type a lookup list
- Modify Lookup properties
USING FIELD PROPERTIES

Discussion

Each field has a set of properties that control the way it stores, handles, and displays data. Since forms and reports you create use the fields in your tables, setting field properties in the early stages of building a database can save you time later on; you will have less design work to do in later stages if you set the desired field properties before you create any forms and reports.

You normally set field properties when you create a table in Design view. If you have created and saved a table using default field properties, you can open the table in Design view to change its property settings.

The properties available in the Field Properties pane depend on the data type assigned to the selected field. Some of the property types you can set are listed in the following table:

<table>
<thead>
<tr>
<th>Property type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Field Size</td>
<td>Limits a Text field to a specific number of characters; limits a Number field to a specific type of number</td>
</tr>
<tr>
<td>Format</td>
<td>Controls the way values appear in Datasheet view</td>
</tr>
<tr>
<td>Decimal Places</td>
<td>Available for Number and Currency fields only, determines how many decimal places will appear in the field; this property type has no effect on Number fields using the General format</td>
</tr>
<tr>
<td>Input Mask</td>
<td>Creates a pattern for data entered into the field (such as adding hyphens within a telephone number)</td>
</tr>
<tr>
<td>Caption</td>
<td>Creates a label other than the field name; the caption will appear in the table and on forms and reports</td>
</tr>
<tr>
<td>Default Value</td>
<td>Specifies the value you want to appear in the selected field in all new records</td>
</tr>
<tr>
<td>Validation Rule</td>
<td>Forces data entered into the selected field to meet a specified requirement; for example, you can specify that the Credit Limit field not be over $10,000</td>
</tr>
<tr>
<td>Validation Text</td>
<td>Creates an error message to appear when the data entered violates a validation rule</td>
</tr>
<tr>
<td>Required</td>
<td>Specifies that the field cannot be left empty</td>
</tr>
<tr>
<td>Property type</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Allow Zero Length</td>
<td>Determines whether or not you can enter quotation marks (“ ”) in a Text, Memo or Hyperlink field to indicate that there is no data for that field</td>
</tr>
<tr>
<td>Indexed</td>
<td>Speeds up retrieval of data in a field; all primary key fields are automatically indexed</td>
</tr>
</tbody>
</table>

If a table has reports or forms associated with it, you may want to apply changes you make to field property settings in a particular table to the corresponding property settings, or bound controls, in the joined forms or reports. You can do this by selecting the Property Update Options button that appears next to the field when the property is changed. You can then select the Update Format everywhere <field name> is used command and then select Yes in the Update Properties dialog box to apply the settings to the bound controls.

LIMITING FIELD SIZE

Discussion

Setting a field size limits the number of characters or the type of characters you can enter into a field. After typing the maximum number of characters allowed, further keystrokes are not permitted. The Field Size property is available only for Text, Number, and AutoNumber data types; all other data types have default sizes that are set automatically.

For a Text field, the field size is the maximum number of characters you want to allow in the field, up to the maximum of 255 characters allowed by Access. For a Number field, you can select one of the following Field Size options:

<table>
<thead>
<tr>
<th>Field Size</th>
<th>Size Range</th>
<th>Decimal Places</th>
</tr>
</thead>
<tbody>
<tr>
<td>Byte</td>
<td>0 to 255 (no fractions)</td>
<td>None; data is rounded</td>
</tr>
<tr>
<td>Integer</td>
<td>-32768 to 32767 (no fractions)</td>
<td>None; data is rounded</td>
</tr>
<tr>
<td>Long Integer</td>
<td>-2,147,483,648 to 2,147,483,647 (no fractions)</td>
<td>None; data is rounded</td>
</tr>
<tr>
<td>Single</td>
<td>-3.4x10^38 to 3.4x10^38</td>
<td>Up to 7</td>
</tr>
<tr>
<td>Field Size</td>
<td>Size Range</td>
<td>Decimal Places</td>
</tr>
<tr>
<td>--------------</td>
<td>--------------------------</td>
<td>----------------</td>
</tr>
<tr>
<td>Double</td>
<td>-1.797x10^{308} to 1.797x10^{308}</td>
<td>Up to 15</td>
</tr>
<tr>
<td>Replication ID</td>
<td>Globally unique identifier</td>
<td>Not available</td>
</tr>
<tr>
<td>Decimal</td>
<td>-10^{28} to 10^{28}</td>
<td>Up to 28</td>
</tr>
</tbody>
</table>

For an **AutoNumber** field, only the **Long Integer** and **Replication ID** options are available.

The default field size for **Number** fields is **Long Integer**, which is also the largest field size. You should use the smallest possible field size whenever possible, however, so that the database uses less storage space and can be processed more quickly.

A brief description of the selected property appears in the **Field Properties** pane.

You may lose existing data if you decrease the size of a field. In addition, you cannot undo design changes after you have saved the table.

### Procedures

1. Open the desired table in **Design** view.
2. Select the field for which you want to set the field size property.
3. Select the **General** tab in the **Field Properties** pane, if necessary.
4. Select the **Field Size** property.
5. Select the **Field Size** list, or type the desired value.
6. Select the desired option, if applicable.

### Step-by-Step

From the Student Data directory, open **FIELDS1.ACCDB**.

Limit the size of a field.
Open the Customers table in Design view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the field for which you want to set the field size property. <em>The field is selected.</em></td>
<td>Scroll as necessary and click in the Credit Limit field</td>
</tr>
<tr>
<td>2. Select the General tab in the Field Properties pane, if necessary. <em>The General tab is displayed.</em></td>
<td>Click the General tab, if necessary</td>
</tr>
<tr>
<td>3. Select the Field Size property. <em>A drop-down arrow appears in the Field Size box.</em></td>
<td>Click in the Field Size box</td>
</tr>
<tr>
<td>4. Select the Field Size list, or type the desired value. <em>A list of available options is displayed.</em></td>
<td>Click Field Size ▼</td>
</tr>
<tr>
<td>5. Select the desired option, if applicable. <em>The option appears in the Field Size box.</em></td>
<td>Click Double</td>
</tr>
</tbody>
</table>

Save the changes to the table.

**Practice the Concept:** Change the size of the Postal Code field to 8.

Save the table; a Microsoft Office Access warning box will warn you that some data may be lost. Since there are currently no entries in that field with more than seven characters, you can select Yes. If there had been more than eight characters in any existing record, the extra characters would have been deleted.

Close the Customers table.

**SETTING NUMBER FORMATS**

**Discussion**

The Format property affects how data appears in Datasheet view, not how it is stored in the table nor how it is used in calculations. If a Number data type field is formatted with 0 decimal places, for example, a value of 1.5 would appear as 2 in the datasheet; if the value is multiplied by 2 in a calculation, however, the answer would be 3, not 4.

The available formats for fields with Number data types are listed in the following table:
<table>
<thead>
<tr>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>General Number</strong></td>
<td>Displays a number exactly as it is entered; this is the default format</td>
</tr>
<tr>
<td><strong>Currency</strong></td>
<td>Displays a dollar sign, a thousands separator, and two decimal places; the defaults for this format are determined by the system settings</td>
</tr>
<tr>
<td><strong>Euro</strong></td>
<td>Displays a euro sign, a thousands separator, and two decimal places; the defaults for this format are determined by the system settings</td>
</tr>
<tr>
<td><strong>Fixed</strong></td>
<td>Displays at least one digit and is rounded to the default number of decimal places; the defaults for this format are determined by the system settings</td>
</tr>
<tr>
<td><strong>Standard</strong></td>
<td>Displays a thousands separator and is rounded to the default number of decimal places; the defaults for this format are determined by the system settings</td>
</tr>
<tr>
<td><strong>Percent</strong></td>
<td>Multiplies the number by 100, displays a percent sign (%), and is rounded to the default number of decimal places; the defaults for this format are determined by the system settings</td>
</tr>
<tr>
<td><strong>Scientific</strong></td>
<td>Expresses numbers in standard scientific notation (as multiples of exponents of 10)</td>
</tr>
</tbody>
</table>

The **Format** property list displays how a number will be formatted for format types other than **Text** and **Memo**.
If a table has reports or forms associated with it, you may want to apply changes you make to field property settings in a particular table to the corresponding property settings, or bound controls, in the joined forms or reports. You can do this by selecting the **Property Update Options** button that appears next to the field when the property is changed. You can then select the **Update Format everywhere <field name> is used** command and then select **Yes** in the Update Properties dialog box to apply the settings to the bound controls.

### Procedures

1. Open the desired table in **Design** view.
2. Select the field for which you want to set a number format.
3. Select the **General** tab in the **Field Properties** pane, if necessary.
4. Select the **Format** property.
5. Select the **Format** list.
6. Select the desired format.

### Step-by-Step

Set a number format.

Display **All Access Objects** in the Navigation Pane. Notice the **Customers** table has a **Customers** form and a **Customers** report associated with it. Open the **Customers** report and the **Customers** form and notice the formatting in the **Credit Limit** fields. Then open the **Customers** table in **Datasheet** view and notice the formatting in the **Credit Limit** field. Close the **Customers** table.

Open the **Customers** table in **Design** view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the field for which you want to set a number format.  
*The field is selected.* | Scroll as necessary and click in the **Credit Limit** field |
| 2. Select the **General** tab in the **Field Properties** pane, if necessary.  
*The General tab is displayed.* | Click the **General** tab, if necessary |
Steps | Practice Data
--- | ---
3. Select the **Format** property. A drop-down arrow appears in the **Format** box. | Click in the **Format** box
4. Select the **Format** list. A list of available formats is displayed. | Click **Format**
5. Select the desired format. The format appears in the **Format** box and the **Property Update Options** button appears, if appropriate. | Click **Currency**

Click the **Property Update Options** button next to the **Format** property and select the **Update Format everywhere Credit Limit is used** command. In the **Update Properties** dialog box, select **Yes** to update the associated form and report so that the number format setting is applied to the corresponding bound controls.

Save your changes; then, switch to **Datasheet** view. Scroll to the **Credit Limit** column. Notice that the values are now formatted as currency.

Close the **Customers** table. Open the **Customers** form and the **Customers** report and notice the changes to the formatting in the **Credit Limit** field.

**SETTING DATE/TIME FORMATS**

**Discussion**

You can also change the format of a **Date/Time** field to change the way the date or time appears in the table. The available formats for **Date/Time** fields are listed in the following table:

<table>
<thead>
<tr>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Date</td>
<td>The default format; if the value is only a date, no time appears; if the value is only a time, no date appears</td>
</tr>
<tr>
<td>Long Date</td>
<td>The day and month names are spelled out (e.g., Tuesday, July 4, 1995)</td>
</tr>
<tr>
<td>Medium Date</td>
<td>The month name is abbreviated, and the name of the day is omitted (e.g., 04-Jul-95)</td>
</tr>
<tr>
<td>Short Date</td>
<td>The date appears as numbers separated by slashes (e.g., 7/4/95)</td>
</tr>
<tr>
<td>Long Time</td>
<td>The time is displayed as hours, minutes, and seconds, separated by colons, and followed by an AM or a PM indicator (e.g., 6:30:15 PM)</td>
</tr>
</tbody>
</table>
### Procedures

1. Open the desired table in **Design** view.
2. Select the field for which you want to set a date/time format.
3. Select the **General** tab in the **Field Properties** pane, if necessary.
4. Select the **Format** property.
5. Select the **Format** list.
6. Select the desired format.

### Step-by-Step

Set a date/time format.

Open the **Customers** table in **Design** view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the field for which you want to set a date/time format. <em>The field is selected.</em></td>
<td>Scroll as necessary and click in the <strong>Contract Date</strong> field</td>
</tr>
<tr>
<td>2. Select the <strong>General</strong> tab in the <strong>Field Properties</strong> pane, if necessary. <em>The General tab is displayed.</em></td>
<td>Click the <strong>General</strong> tab, if necessary</td>
</tr>
<tr>
<td>3. Select the <strong>Format</strong> property. <em>A drop-down arrow appears in the Format box.</em></td>
<td>Click in the <strong>Format</strong> box</td>
</tr>
<tr>
<td>4. Select the <strong>Format</strong> list. <em>A list of available formats is displayed.</em></td>
<td>Click <strong>Format</strong> ▼</td>
</tr>
</tbody>
</table>
### Setting Yes/No Formats

#### Discussion

A Yes/No field is limited to either a positive or a negative response and can be displayed as a text box, a check box, or a combo box. You select the display of the field on the Lookup page in the Field Properties pane.

If the Yes/No field displays its values in a text box, you can select one of three Yes/No data type formats: True/False, Yes/No, and On/Off. Regardless of the format selected, the positive responses of True, Yes, and On are equivalent, just as the negative responses of False, No, and Off are equivalent. Consequently, if the Yes/No field is set to the True/False format and a user enters Yes, Access automatically converts it to True.

When a Yes/No field displays a check box, a selected check box indicates a positive response and a deselected check box indicates a negative response. The check box is the default setting for a Yes/No field.

---

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>5. Select the desired format. The format appears in the Format box.</td>
<td>Click <strong>Medium Date</strong></td>
</tr>
</tbody>
</table>

Save the table and switch to Datasheet view. Scroll as necessary to the **Contract Date** field; notice its format.

Switch back to Design view.

Selecting a Display Control property
If no format is set, an entry of Yes, True, or On displays a field value of -1, and an entry of No, False, or Off displays a field value of 0.

Procedures

1. Open the desired table in **Design** view.
2. Select the field for which you want to set a yes/no format.
3. Select the **General** tab in the **Field Properties** pane, if necessary.
4. Select the **Format** property.
5. Select the **Format** list.
6. Select the desired yes/no format.
7. Select the **Lookup** tab.
8. Select the **Display Control** list.
9. Select the desired yes/no control.

Step-by-Step

Set a yes/no format.

If necessary, open the **Customers** table in **Design** view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the field for which you want to set a yes/no format.</td>
<td>Scroll as necessary and click in the <strong>Catalog Sent</strong> field</td>
</tr>
<tr>
<td><em>The field is selected.</em></td>
<td></td>
</tr>
<tr>
<td>2. Select the <strong>General</strong> tab in the <strong>Field Properties</strong> pane, if</td>
<td>Click the <strong>General</strong> tab, if necessary</td>
</tr>
<tr>
<td>necessary. <em>The General tab is displayed.</em></td>
<td></td>
</tr>
<tr>
<td>3. Select the <strong>Format</strong> property. *A drop-down arrow appears in the</td>
<td>Click in the <strong>Format</strong> box</td>
</tr>
<tr>
<td><strong>Format</strong> box.*</td>
<td></td>
</tr>
<tr>
<td>4. Select the <strong>Format</strong> list. *A list of available formats is</td>
<td>Click <strong>Format</strong></td>
</tr>
<tr>
<td>displayed.*</td>
<td></td>
</tr>
<tr>
<td>Steps</td>
<td>Practice Data</td>
</tr>
<tr>
<td>-------</td>
<td>---------------</td>
</tr>
</tbody>
</table>
| 5. Select the desired yes/no format.  
*The format appears in the Format box.* | Click Yes/No, if necessary |
| 6. Select the Lookup tab.  
*The Lookup tab is displayed, with the Display Control box selected.* | Click the Lookup tab |
| 7. Select the Display Control list.  
*A list of available options is displayed.* | Click Display Control |
| 8. Select the desired yes/no control.  
*The option appears in the Display Control box.* | Click Text Box |

Save the table, and switch to Datasheet view. Scroll to the Catalog Sent field; notice the text values. Click in any field with a Yes value; notice that the actual stored value is -1.

Click in any field with a No value; notice that the actual stored value is 0. Then, double-click the 0 value, type true, and press the [Down] key. Notice that the true entry changes to a Yes.

**Practice the Concept:** Switch to Design view and display the Lookup tab. Change the Display Control property of the Catalog Sent field back to Check Box. Then, save the table.

---

**SETTING DEFAULT VALUES**

---

**Discussion**

When you set a default value for a field, that value automatically appears in the field for all new records. You can, however, modify the default field value as needed when entering a new record.

A default value can save you time when entering data. For example, if a table stores the names and addresses of clients and most of the clients have addresses in New York, you can set the default value of the State field to NY. If you then enter a new record for a client in Connecticut, or if a client moves out of New York, you can change the value in the State field just for that individual record. Setting a default value for an established table, however, does not modify existing records.

You can set a default value by entering the desired value or expression in the Default Value box. An expression consists of operators (i.e., =, +, -, *, /) and/or values.

If you create a default value for a Text field, the default text must be enclosed in quotation marks (" "); for example, "Net 30". Values for Date fields must be
You cannot set a default value for fields with AutoNumber or OLE object data types.

You can also use the Expression Builder to create a default value.

Procedures

1. Open the desired table in Design view.
2. Select the field for which you want to set a default value.
3. Select the General tab in the Field Properties pane.
4. Select the Default Value box.
5. Create the desired default property.
6. Press [Enter].

Step-by-Step

Set a default value.

If necessary, open the Customers table in Design view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the field for which you want to set a default value.  
*The field is selected.* | Scroll as necessary and click in the Catalog Sent field |
| 2. Select the General tab in the Field Properties pane.  
*The General tab is displayed.* | Click the General tab |
| 3. Select the Default Value property.  
*The insertion point appears in the Default Value box, and the Build button appears.* | Click in the Default Value box |
**Steps** | **Practice Data**
--- | ---
4. Type the desired default value. *The text appears in the Default Value box.* | Type *yes*
5. Press [Enter]. *The default value is saved.* | Press [Enter]

Save the table and switch to **Datasheet** view. Scroll to display the **Catalog Sent** column in the new record row; notice that the **Catalog Sent** field for the new record is checked.

Then, switch back to **Design** view.

**SETTING VALIDATION RULES**

**Discussion**

Databases can contain incorrect information due to data entry errors. One method of controlling the accuracy of data is to impose restrictions on the values entered into a field.

You can impose restrictions on data entered into your table by creating validation rules in the **Validation Rule** box of one or more fields. When you enter data into a new record or modify data in an existing record, Access checks each field for existing validation rules. If an entry does not meet the conditions of the corresponding validation rule, a warning box notifies you of the error. When you set a validation rule, you use the **Validation Text** box to specify the text you want to appear in the warning box.

Setting a validation rule is different from setting the data type or field size properties. Access uses data type and field size properties to determine that the correct type of data is being entered. Validation rules are more specific in their restrictions. For example, you can create a validation rule to ensure that numbers entered in a particular field are between 500 and 1000.
Creating a validation rule with validation text

- You can also use the Expression Builder to set a validation rule.

Procedures

1. Open the desired table in **Design** view.
2. Select the field for which you want to set a validation rule.
3. Select the **General** tab in the **Field Properties** pane, if necessary.
4. Select the **Validation Rule** property.
5. Enter the desired validation rule.
6. Select the **Validation Text** property.
7. Enter the desired validation text.

Step-by-Step

Set a validation rule.

If necessary, open the **Customers** table in **Design** view.
Steps | Practice Data
--- | ---
1. Select the field for which you want to set a validation rule. The field is selected. | Scroll as necessary and click in the Credit Limit field.
2. Select the General tab in the Field Properties pane, if necessary. The General tab is displayed. | Click the General tab, if necessary.
3. Select the Validation Rule property. The insertion point appears in the Validation Rule box, and the Build button appears. | Click in the Validation Rule box.
4. Enter the desired validation rule. The text appears in the Validation Rule box. | Type <=10000
5. Select the Validation Text property. The insertion point appears in the Validation Text box. | Click in the Validation Text box.
6. Enter the desired validation text. The text appears in the Validation Text box. | Type The Credit Limit may not exceed $10,000.

Save the table; a Microsoft Office Access warning box informs you that data integrity rules have been changed. Select Yes.

Switch back to Datasheet view. Create a new record; scroll as necessary, enter 15000 in the Credit Limit field, and press [Enter]. Select OK.

Press [Esc] twice to delete the new record and switch back to Design view.

**CREATING AN INPUT MASK - WIZARD**

**Discussion**

Input masks control how data is entered into a table, as well as the format in which it is stored. You can use an input mask to control how many characters are entered into a field; define each individual character as numeric, text, or either; and specify each individual character as mandatory or optional, as well as add literal characters to format the entry. Since the input mask controls the values users can enter into a field, it often makes data entry easier.

You can create an input mask by entering the criteria directly into the Input Mask box. However, it is often easier to use the Input Mask Wizard to set the property for you. The Input Mask Wizard offers several predefined input masks for items such as
dates and times, ZIP codes, telephone numbers, etc. In addition, you can modify any predefined input mask to meet your needs.

An input mask only affects new entries; data that has already been entered into a field is not affected if an input mask is created later.

Procedures

1. Open the desired table in Design view.
2. Select the field to which you want to apply an input mask.
3. Select the General tab in the Field Properties pane, if necessary.
4. Select the Input Mask property.
5. Click the Build button.
6. Select the desired option from the Input Mask list.
7. Select Next >.
8. Select the Placeholder character list.
9. Select the desired placeholder.
10. Select Next >.
11. Select the desired option for storing the data.
12. Select Next >.

Step-by-Step

Create an input mask.

If necessary, open the Customers table in Design view.
Lesson 2 - Setting Field Properties

Steps | Practice Data
--- | ---
1. Select the field to which you want to apply an input mask. The field is selected. | Scroll as necessary and click in the **Phone Number** field.
2. Select the **General** tab in the **Field Properties** pane, if necessary. *The General tab is displayed.* | Click the **General** tab, if necessary.
3. Select the **Input Mask** property. *The Build button appears to the right of the Input Mask box.* | Click in the **Input Mask** box.
4. Click the **Build** button. *The Input Mask Wizard opens.* | Click **Build** button.
5. Select the desired option from the **Input Mask** list. *The input mask option is selected.* | Click **Phone Number**, if necessary.
6. Select **Next**. *The next page of the Input Mask Wizard is displayed.* | Click **Next**.
7. Select the **Placeholder character** list. *A list of available placeholders is displayed.* | Click **Placeholder character**.
8. Select the desired placeholder. *The placeholder appears in the Placeholder character box.* | Click **_**
9. Select **Next**. *The next page of the Input Mask Wizard is displayed.* | Click **Next**.
10. Select the desired option for storing the data. *The option is selected.* | Click **Without the symbols in the mask, like this:**.
11. Select **Next**. *The next page of the Input Mask Wizard is displayed.* | Click **Next**.
12. Select **Finish**. *The Input Mask Wizard closes, and the input mask appears in the Input Mask box.* | Click **Finish**.

Save the table and switch to **Datasheet** view. Create a new record and tab to the **Phone Number** field; type **12345678910**; notice that the input mask controls how the number is entered, as well as how it is formatted.
Press [Esc] twice to delete the new record and close the Customers table.

**CREATING AN INPUT MASK MANUALLY**

**Discussion**

An input mask controls what values you can enter in a field, as well as how the data will appear. Although it is usually easier to use the Input Mask Wizard, you may need to create an input mask that is not included in the list of predefined masks in the Input Mask Wizard. Access allows you to create an input mask by entering criteria directly into the Input Mask box.

When you create an input mask manually, you use special characters to define it. These special characters act as placeholders, controlling the type of character that can be entered into each position, as well as which characters are required. For example, the (999) 000-0000 input mask allows you to enter only digits, and the area code is not required; consequently, both ( ) 555-6545 and (804) 555-6545 are valid entries for this input mask.

The following table defines some of the special characters that can be used in an input mask. To define a literal character, enter any character other than one of those shown in the table. If you want to define a character listed in the table as a literal character, you must precede that character with a backslash (\).

<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>A required numeric entry (0-9); plus and minus signs are not allowed</td>
</tr>
<tr>
<td>9</td>
<td>An optional numeric entry (0-9) or space; plus and minus signs are not allowed</td>
</tr>
<tr>
<td>#</td>
<td>An optional numeric entry (0-9) or space; plus and minus signs are allowed</td>
</tr>
<tr>
<td>L</td>
<td>A required alphabetic entry (A-Z)</td>
</tr>
<tr>
<td>?</td>
<td>An optional alphabetic entry (A-Z)</td>
</tr>
<tr>
<td>A</td>
<td>A required alphabetic (A-Z) or numeric (0-9) entry</td>
</tr>
<tr>
<td>a</td>
<td>An optional alphabetic (A-Z) or numeric (0-9) entry</td>
</tr>
<tr>
<td>&amp;</td>
<td>Any character or space; entry required</td>
</tr>
<tr>
<td>C</td>
<td>Any character or space; entry optional</td>
</tr>
<tr>
<td>&lt;</td>
<td>Causes all characters that follow to be converted to lowercase</td>
</tr>
<tr>
<td>&gt;</td>
<td>Causes all characters that follow to be converted to uppercase</td>
</tr>
<tr>
<td>Character</td>
<td>Description</td>
</tr>
<tr>
<td>-----------</td>
<td>--------------------------------------</td>
</tr>
<tr>
<td>!</td>
<td>Enters the input mask from right to left, instead of from left to right</td>
</tr>
<tr>
<td>\</td>
<td>Causes the character that follows to be displayed as a literal character</td>
</tr>
</tbody>
</table>

The **Input Mask** property can be set in **Design** view of any table, query, or form. Most of the time, you will want to apply an input mask to a field in table **Design** view, because it will then be automatically applied to the field in queries, forms, and reports.

The Input Mask Wizard can only be used for **Text** and **Date/Time** fields. You must manually enter an input mask for **Number** and **Currency** fields.

### Procedures

1. Open the desired table in **Design** view.
2. Select the field to which you want to apply an input mask.
3. Select the **General** tab in the **Field Properties** pane, if necessary.
4. Select the **Input Mask** box.
5. Type the desired input mask.

### Step-by-Step

Create an input mask manually.

If necessary, open the **Reps** table in **Design** view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the field to which you want to apply an input mask. <em>The field is selected.</em></td>
<td>Click in the <strong>INITIALS</strong> field, if necessary</td>
</tr>
</tbody>
</table>
Steps | Practice Data
---|---
2. Select the **General** tab in the **Field Properties** pane, if necessary.  
*The General tab appears.* | Click the **General** tab, if necessary.
3. Select the **Input Mask** box.  
*The insertion point appears in the Input Mask box.* | Click in the **Input Mask** box.
4. Type the desired input mask.  
*The text appears in the Input Mask box.* | Type >LLL

Save the changes to the table and switch to **Datasheet** view. Create a new record, select the **INITIALS** field (if necessary), type **abc**, and press [**Enter**]; notice that the completed entry is formatted as all caps.

Press [**Esc**] to delete the new record and close the **Reps** table.

---

**CREATING A CUSTOM INPUT MASK**

**Discussion**

The Input Mask Wizard provides a list of predefined input masks. If you frequently use an input mask that is not included with the predefined masks in the Input Mask Wizard, however, you may want to create a custom input mask. You may want to use an input mask, for example, to ensure that product numbers are always correctly entered.

You can create and save a custom input mask in the Input Mask Wizard, where it is available to tables and forms at any time. In this way, you will only need to create a custom input mask once.

---

**Input masks are saved to your user profile on your system, not to the individual database file. If you create a new mask, or modify a default one using the Customize Input Mask Wizard dialog box, the changes are permanently saved to your system settings.**
Procedures

1. Open the desired table in **Design** view.
2. Select the field to which you want to apply a custom input mask.
3. Select the **General** tab in the **Field Properties** pane.
4. Select the **Input Mask** box.
5. Click the **Build** button.
6. Select the **Edit List** button.
7. Select the **New** button.
8. Type the desired description for the custom input mask.
9. Select the **Input Mask** box.
10. Type the custom input mask.
11. Select the **Placeholder** box.
12. Type the desired placeholder.
13. Select the **Sample Data** box.
14. Type some sample data.
15. Select **Close**.
16. Select the custom input mask from the **Input Mask** list.
17. Select **Finish**.

Step-by-Step

Create a custom input mask.

Open the **Items** table in **Design** view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the field to which you want apply a custom input mask. <em>The field is selected.</em></td>
<td>Click in the <strong>Product ID</strong> field, if necessary</td>
</tr>
<tr>
<td>Steps</td>
<td>Practice Data</td>
</tr>
<tr>
<td>-------</td>
<td>---------------</td>
</tr>
</tbody>
</table>
| 2. Select the **General** tab in the **Field Properties** pane, if necessary.  
*The General tab is displayed.* | Click the **General** tab, if necessary |
| 3. Select the **Input Mask** box.  
*The Build button appears to the right of the Input Mask box.* | Click in the **Input Mask** box |
| 4. Click the **Build** button.  
*The Input Mask Wizard opens.* \[Click [Build] \] | Click [Build] |
| 5. Select **Edit List.**  
*The Customize Input Mask Wizard dialog box opens.* | Click [Edit List] |
| 6. Select the **New** button.  
*A blank form is displayed.* | Click [New] |
| 7. Type the desired description for the custom input mask.  
*The text appears in the **Description** box.* | Type **Product Number** |
| 8. Select the **Input Mask** box.  
*The insertion point appears in the Input Mask box.* | Press [Tab] |
| 9. Type the custom input mask.  
*The text appears in the Input Mask box.* | Type **!00-0000** |
| 10. Select the **Placeholder** box.  
*The insertion point appears in the Placeholder box.* | Press [Tab] |
| 11. Type the desired placeholder.  
*The character appears in the Placeholder box.* | Type **_** |
| 12. Select the **Sample Data** box.  
*The insertion point appears in the Sample Data box.* | Press [Tab] |
| 13. Type some sample data.  
*The characters appear in the Sample Data box.* | Type **346278** |
| 14. Select **Close.**  
*The Customize Input Mask Wizard dialog box closes, and the custom input mask appears in the Input Mask list.* | Click [Close] |
### Steps

<table>
<thead>
<tr>
<th>Step</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>15. Select the custom input mask from the <strong>Input Mask</strong> list. The custom input mask is selected.</td>
<td>Scroll as necessary and click <strong>Product Number</strong></td>
</tr>
<tr>
<td>16. Select <strong>Finish</strong>. The Input Mask Wizard dialog box closes, and the custom input mask appears in the <strong>Input Mask</strong> box.</td>
<td>Click <img src="image" alt="Finish" /></td>
</tr>
</tbody>
</table>

Save the changes to the table and switch to **Datasheet** view. Create a new record, type **153434** into the **Product ID** field, and press **[Enter]**; notice the custom input mask.

Press **[Esc]** to delete the new record and close the **Items** table.

---

**Typing a Lookup List**

- **Discussion**

You can increase data accuracy by adding a lookup field to a table. The user can then select the desired value from the lookup list, rather than having to type it. The values in a lookup list are usually stored in a field in a different table. If you want the initials of the sales representative to appear in the **Sales Rep** field of the **Customer** table, for example, you can create a lookup to the **Initials** field in the **Reps** table. If the desired data is not stored elsewhere, you can type the lookup list values.

The Lookup Wizard creates a combo box field for the lookup list; a combo box field displays a drop-down list that displays all of the available data values. By default, a lookup field does not limit input to values on the lookup list; the user can type an entry not on the list if desired. However, you can limit a field to only those values on the lookup list.

A lookup list can contain multiple columns. If you are typing a new list of values, you can designate the number of columns desired and then type the desired values into each column. In addition, you can add a second field to a lookup list. For example, if you are creating a lookup list in the **Customer** table, you can add both the **Initials** and the **Last Name** fields from the **Reps** table to the lookup list.
Using the Lookup Wizard

If you are creating a lookup list for a field that is the related field in a join, you must delete the join before using the Lookup Wizard.

Procedures

1. Open the desired table in Design view.
2. Click in the Data Type column of the field for which you want to create a lookup list.
3. Select the Data Type arrow.
4. Select Lookup Wizard.
5. Select the desired lookup source.
6. Select Next >.
7. Enter the desired number of lookup columns.
8. Select the box below the Col1 heading.
9. Type the first desired lookup value.
10. Enter additional lookup values as desired.
11. Select Next >.
12. Select the column that contains the values you want to store or use.
13. Select **Next >**.

14. Rename the label for the Lookup column, if necessary.

15. Select **Finish**.

### Step-by-Step

Create a lookup list.

Open the *Orders* table in *Design* view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Click in the **Data Type** column of the field for which you want to create a lookup list.  
* A drop-down arrow appears in the **Data Type** column. | Click in the **Data Type** column of the **Shipping Method** field |
| 2. Select the **Data Type** arrow.  
* A list of available data types is displayed. | Click **Text** |
| 3. Select **Lookup Wizard**...  
* The Lookup Wizard opens. | Click **Lookup Wizard**... |
| 4. Select the desired lookup source.  
* The option is selected. | Click **I will type in the values that I want.** |
| 5. Select **Next**.  
* The next page of the Lookup Wizard appears, with the **Number of columns** box selected. | Click **Next >** |
| 6. Enter the desired number of lookup columns.  
* The number appears in the **Number of columns** box. | Type **2** |
| 7. Select the box below the **Col1** heading.  
* The insertion point appears in the first row of the **Col1** column, and the specified number of columns appears. | Press **[Tab]** |
| 8. Type the first desired lookup value.  
* The text appears in the first **Col1** box. | Type **1** |
### Steps

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 9. Enter additional lookup values as desired.  
*The text appears in the columns.* | Follow the instructions shown below the table before continuing on to the next step. |
| 10. Select **Next**.  
*The next page of the Lookup Wizard is displayed.* | Click ![Next >](https://example.com) |
| 11. Select the column that contains the values you want to store or use.  
*The column is selected.* | Click **Col1**, if necessary |
| 12. Select **Next**.  
*The next page of the Lookup Wizard is displayed.* | Click ![Next >](https://example.com) |
| 13. Rename the label for the Lookup Column, if necessary and select **Finish**.  
*The Lookup Wizard dialog box closes.* | Click ![Finish](https://example.com) |

Type the following values into the lookup list, pressing the [Tab] key to move to the next column or row as needed:

<table>
<thead>
<tr>
<th>Col1</th>
<th>Col2</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>UPS</td>
</tr>
<tr>
<td>2</td>
<td>DHL</td>
</tr>
<tr>
<td>3</td>
<td>FedEx</td>
</tr>
<tr>
<td>4</td>
<td>US Mail</td>
</tr>
<tr>
<td>5</td>
<td>Emery</td>
</tr>
</tbody>
</table>

*Return to the table and continue on to the next step (step 10).*

Save the table and switch to **Datasheet** view. Select the **Shipping Method** field for the first record; then, select 1 **UPS** from the lookup list. Press [Down], type 1 into the **Shipping Method** field of the second record, and press [Down] again. For the third record, type 2 and press [Down]. For the fourth record, type 3 and press [Enter].

Switch back to **Design** view.
MODIFYING LOOKUP PROPERTIES

Discussion

You can use the Lookup page in the Field Properties pane to modify the properties of a lookup list.

If the lookup list was manually typed, you can use the Row Source property to edit it or add to it. Column values are separated by semi-colons (;) and text entries are enclosed in quotation marks ("').

The Bound Column property indicates which lookup column is used to store field values. For instance, if the lookup list consists of two columns, and column 1 is the bound column, the data in column 1 will be stored in the lookup field.

Although you may want the values in the bound column to be stored in the field, they may be confusing and uninformative to the user; the descriptive text in an unbound field may have more meaning. You can suppress the display of the bound column and display only the descriptive text in the unbound column of a lookup list by changing the width of the bound column to zero (0") in the Column Width box.

By default, a lookup field allows the user to add data values to the lookup list simply by typing them into the field. You can limit data entry to just those values on the lookup list by selecting Yes in the Limit to List box; the default value of No allows free entry.

Procedures

1. Open the desired table in Design view.
2. Select the lookup field you want to modify.
3. Select the Lookup tab in the Field Properties pane.
4. Select the property you want to modify.
5. Modify the property as desired.

Step-by-Step

Modify Lookup properties.

If necessary, open the Orders table in Design view.
**Steps** | **Practice Data**
--- | ---
1. Select the lookup field you want to modify.  
_The field is selected._ | Click in the **Shipping Method** field, if necessary
2. Select the **Lookup** tab in the **Field Properties** pane.  
_The **Lookup** page is displayed._ | Click the **Lookup** tab, if necessary
3. Select the property you want to modify.  
_The insertion point appears in the corresponding property box._ | Click in the **Column Widths** box
4. Modify the property as desired.  
_The **Lookup** properties are modified accordingly._ | Follow the instructions below to complete this step

Change the text in the **Column Widths** property to 0",1". Then, change the **Limit To List** property to **Yes**.

Save the table and switch to **Datasheet** view. Notice that all entries in the **Shipping Method** field now display the text values. Select the next record in which the **Shipping Method** field is blank and select **Emery** from the lookup list. Press [Down], type the letter **u**, and press [Down] again. Notice that Access completes the entry.

Type **Post Office**, and press [Down]; a Microsoft Office Access message box informs you that the text entered is not on the list. Select **OK** and press [Esc] twice.

Although text values appear in the field, the data actually stored in it is the numeric values in the bound column. Right-click any field in the **Shipping Method** column, select **Text Filters**, then select **Equals...**, type **UPS**, and press [Enter]. Notice that no records are found; even though **UPS** appears in several fields in the datasheet, it is not the actual data stored in the field. Click the **Toggle Filter** button on the **Home** tab to display all records.

Now right-click any field in the **Shipping Method** column, select **Text Filters**, then select **Equals...**, type **1**, and press [Enter]. The filter now works, because you filtered for data actually stored in the field. Click the **Toggle Filter** button to display all records.

Save the **Orders** table and close it.  
Close **FIELDS1.ACCDB**.
EXERCISE

SETTING FIELD PROPERTIES

Task

Set field properties.

1. Open FIELDS1X.ACCDB.
2. Open the Payment table in Design view.
3. Set the Format property for the Payment Date field to Short Date.
4. Set the Format property for the Amount Paid field to Currency.
5. Set a validation rule for the Amount Paid field, so that it can only contain values greater than ten dollars. (*Hint: Type >10.*) Then, enter the following validation text: The amount paid must be greater than ten dollars.
6. Set the Format property for the Recorded field to Yes/No.
7. Set a default value of “CHECK” for the Type of Payment field.
8. Switch to Datasheet view, saving the changes. Select Yes to any Microsoft Office Access warning boxes. Notice the formats of the Payment Date and Amount Paid fields. Scroll to the new record row; notice that the default value of CHECK appears in the Type of Payment field. Create a new record with a Project ID of 11, a Payment Date of 4/1/03, and an Amount Paid of 5. Select OK when prompted with the validation text and replace the 5 with 25 in the Amount Paid field. Then, close the Payment table.
9. Open the Reps table in Design view.
10. Select the Initials field and create the following input mask: >LL. (This mask will require the data to be two letters and will automatically format them as uppercase.)
11. Switch to Datasheet view, saving the changes. Then, add the following new record:

   Initials
   pj

   (Notice that Access automatically capitalizes the entry in the Initials field.)
12. Switch to **Design** view and use the Input Mask Wizard to apply the **Phone Number** mask to the **Home Phone** field. Then, save the table.

13. Select the **Zip** field and open the Input Mask Wizard. Add a new input mask named **Short Zip**. *(Hint: Use the **Edit List** button and create a new mask using the **New Record** button.)* Type the following input mask: `!00000` with a sample data zip code of `11111`. Then, apply the **Short Zip** input mask to the **Zip** field.

14. Switch to **Datasheet** view, saving the changes. Tab to the **Zip** field for the first record row and type `12345`. Notice the input mask.

15. Tab to the **Home Phone** field, type `1234567890`, and press [Enter]; notice that the phone number is automatically formatted according to the input mask. Close the **Reps** table.

16. Open the **Project** table in **Design** view. Create a new field below the **Trainer Initials** field; name it **Sales Rep** and make it a lookup field. *(Hint: Select **Lookup Wizard** from the **Data Type** list.)* Select the option to type in the values. Then, type the following values for the lookup column: `PJ`, `RJ`, `KM`, and `SH`. Finish the Lookup Wizard.

17. Switch to **Datasheet** view, saving the changes. Add the following values to the **Sales Rep** column for the first four records:

<table>
<thead>
<tr>
<th>Project ID</th>
<th>Sales Rep</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>RJ</td>
</tr>
<tr>
<td>2</td>
<td>SH</td>
</tr>
<tr>
<td>3</td>
<td>PJ</td>
</tr>
<tr>
<td>4</td>
<td>KM</td>
</tr>
</tbody>
</table>

18. Switch back to **Design** view. Add a new sales representative to the **Sales Rep** value list by typing `;"JW"` after the last entry in the **Row Source** box. Then, change the value in the **List Rows** box to 5. *(Hint: Use the **Lookup tab.**)*

19. Switch to **Datasheet** view, saving the changes. Select the first empty **Sales Rep** field (in the **Project ID 5** row) and select **JW** from the drop-down list.

20. Close the **Project** table.

LESSON 3 - USING OPERATORS IN QUERIES

In this lesson, you will learn how to:

- Use comparison operators
- Use an And condition
- Use an Or condition
- Use the Between And operator
- Use the Expression Builder
- Use a wildcard character
Using Comparison Operators

Discussion

You can add criteria to a query in order to limit the number of records in the recordset. The simplest criterion is to find all records matching a single value.

You can also use comparison operators to limit the recordset to a group of records. Comparison operators are symbols that represent conditions recognized by Access. The following comparison operators are available in Access:

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;</td>
<td>less than</td>
</tr>
<tr>
<td>&lt;=</td>
<td>less than or equal to</td>
</tr>
<tr>
<td>&gt;</td>
<td>greater than</td>
</tr>
<tr>
<td>&gt;=</td>
<td>greater than or equal to</td>
</tr>
<tr>
<td>=</td>
<td>equal to</td>
</tr>
<tr>
<td>&lt;&gt;</td>
<td>not equal to</td>
</tr>
<tr>
<td>Not</td>
<td>reverses logic</td>
</tr>
</tbody>
</table>

You can use one or more comparison operators to compare a specified value to all the values in a field. For example, you may want to find all customers with credit limits of less than $1000 or all customers with a contract date on or before January 2001; you can use a combination of comparison operators and field values to write an expression defining the desired criteria (e.g., <1000 or <=1/1/01, respectively).

When you run the query, only those records with values meeting the specified criteria appear in the recordset.
Access automatically inserts number symbols (#) around date values and quotation marks (" ") around alphanumeric values. Access does not insert any symbols or characters around numeric values.

You can also use the Expression Builder to add criteria to a query. To open the Expression Builder, select the Criteria row in the field to which you want to add criteria and click the Builder button in the Query Setup group on the Design tab on the Ribbon.

**Procedures**

1. Open the desired query in Design view.
2. Select the Criteria row in the field to which you want to add criteria.
3. Type the desired comparison operator and value.
4. Press [Enter].

**Step-by-Step**

From the Student Data directory, open OPERATE.ACCDB. Use comparison operators in a query.
Display All Access Objects on the Navigation Pane, if necessary. Open the CSales Query query in Design view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the Criteria row in the field to which you want to add criteria.  
The insertion point appears in the Criteria row of the corresponding field. | Scroll as necessary and click in the Criteria row of the Credit Limit field |
| 2. Type the desired comparison operator and value.  
The criterion appears in the Criteria row. | Type <=5000                                                                   |
| 3. Press [Enter].  
The criterion is entered into the design grid. | Press [Enter]                                                                |

Run the query. Notice that only records with a credit limit of $5,000 or less appear in the recordset.

**Practice the Concept:** Return to Design view and delete the criterion. Find all records of customers with contract dates on or after January 1, 2002, by adding >=1/1/02 to the Criteria row of the Contract Date field and pressing [Enter]. Notice that Access inserts number symbols (#) around the value to indicate a date value. Run the query. Notice that only those records that match the criterion appear in the recordset.

Return to Design view and delete the criterion.

**USING AN AND CONDITION**

**Discussion**

Many times, a query requires more than one condition to obtain the desired result. If you want to find all customers in PA with sales to date of over $10,000, for example, you need two conditions: State=PA and Sales to Date>10000. The records must meet both conditions in order to be included in the recordset. When two or more criteria must be met, you are creating an And condition. An And condition is created using the And logical operator.

You can create an And condition by adding multiple criteria to a single field. In order to do this, you must use the And operator to find records that fall within a range. For example, to find customers whose contract dates fall between 9/1/02 and 9/30/02, you
would type both criteria on a single line in the **Criteria** row of the appropriate field (i.e., \( \geq 9/1/02 \) And \( \leq 9/30/02 \) in the **Contract Date** field).

An And condition is assumed when you enter conditions in the same **Criteria** row of two or more different fields; in this case, the **And** operator is unnecessary. For example, to find customers in PA with sales to date of over \$10,000, you would type each criterion in the same **Criteria** row of the appropriate fields (i.e., \( =\text{PA} \) in the first **Criteria** row of the **State/Province** field and \( >10000 \) in the first **Criteria** row of the **Sales to Date** field).

Criteria entered in the same row of the design grid create an And condition, and criteria entered in different rows create an Or condition.

You can also use the Expression Builder by selecting select the **Criteria** row and clicking the **Builder** button in the **Query Setup** group on the **Design** tab on the **Ribbon**.

**Procedures**

1. Open the desired query in **Design** view.

2. Select the **Criteria** row of the desired field.

3. Type the desired criterion.

4. Type the **And** operator and an additional criterion in the same **Criteria** row and field, or type additional criteria in the same **Criteria** row of one or more other fields.

5. Press [Enter].

**Step-by-Step**

Use an And condition in a query.

If necessary, open the **CSales Query** query in **Design** view and delete any previous criteria.
Steps | Practice Data
--- | ---
1. Select the **Criteria** row of the desired field. 
*The insertion point appears in the **Criteria** row of the corresponding field.* | Click in the **Criteria** row of the **Credit Limit** field.

2. Type the desired criterion. 
*The criterion appears in the design grid.* | Type \( \geq 6000 \)

3. Type the **And** operator and an additional criterion in the same **Criteria** row and field, or type additional criteria in the same **Criteria** row of one or more other fields. 
*The additional criterion appears in the design grid.* | Type \( \text{and} \leq 8000 \)

4. Press [Enter]. 
*The And condition is entered into the design grid.* | Press [Enter]

Run the query. Notice that only records that match the And condition appear in the recordset.

**Practice the Concept:** Return to Design view and delete the criteria. To find all records of customers with contract dates on or after 1/1/02 and sales to date of $4,000 or more, type \( \geq 1/1/02 \) in the first **Criteria** row of the **Contract Date** field and \( \geq 4000 \) in the first **Criteria** row of the **Sales to Date** field. Run the query. Notice that only records that match both And conditions appear in the recordset.

Return to Design view and delete the criteria.

**USING AN OR CONDITION**

**Discussion**

There are times you may want to find records that meet only one of several specified conditions. This is called an Or condition. If you want to find all customers in PA or all customers with sales to date of over $10,000, for example, you would need two conditions: State=PA and Sales to Date>10000. A record needs to meet only one of the conditions in order to be included in the recordset.

You can create an Or condition in a single field by entering criteria in different **Criteria** rows of that field. You can also create an Or condition by typing criteria in different **Criteria** rows of two or more fields. For example, to find all customers with...
contract dates on or before January 1, 2003 or all those customers with credit limits above $3,000, you would type \( \leq 1/1/03 \) in the **Criteria** row of the **Contract Date** field and \( >3000 \) in the **or** row of the **Credit Limit** field.

You can create additional Or and And conditions by typing criteria into the **Criteria** row, the **or** row, or any row below the **or** row. Any criteria entered into the same **Criteria** row creates an And condition, any criteria entered into different rows creates an Or condition, and you can even create a combination of And and Or conditions.

![Creating an Or condition](image)

### Procedures

1. Open the desired query in **Design** view.
2. Select the **Criteria** row of the desired field.
3. Type the desired criterion.
4. Select the or row of the desired field.
5. Type the second criterion.
6. Press [Enter].

**Step-by-Step**

Use an Or condition in a query.

If necessary, open the CSales Query query in Design view and delete any previous criteria.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Criteria row of the desired field. &lt;br&gt; <em>The insertion point appears in the corresponding Criteria row.</em></td>
<td>Click in the Criteria row of the Sales Rep field</td>
</tr>
<tr>
<td>2. Type the desired criterion. &lt;br&gt; <em>The criterion appears in the Criteria row.</em></td>
<td>Type sj$s$</td>
</tr>
<tr>
<td>3. Select the or row of the desired field. &lt;br&gt; <em>The insertion point appears in the or row.</em></td>
<td>Click in the or row of the Region field</td>
</tr>
<tr>
<td>4. Type the second criterion. &lt;br&gt; <em>The second criterion appears in the or row.</em></td>
<td>Type southeast</td>
</tr>
<tr>
<td>5. Press [Enter]. &lt;br&gt; <em>The Or condition is entered into the design grid.</em></td>
<td>Press [Enter]</td>
</tr>
</tbody>
</table>

Run the query. Notice that records matching either Or condition appear in the recordset.

Return to Design view and delete all criteria.
USING THE BETWEEN AND OPERATOR

Discussion

You can use the **Between And** operator to find data that includes or falls between two stated values. To find all records of customers with credit limits between 1000 and 2000, for example, you would enter **Between 1000 And 2000** in the **Criteria** row of the **Credit Limit** field.

The **Between And** operator can be used in text, numeric, or date fields.

- The **Between And** operator is inclusive; all records with values that include or fall between the stated criteria are included in the recordset.

- You can also use the Expression Builder by selecting the **Criteria** row and clicking the **Builder** button in the **Query Setup** group on the **Design** tab on the **Ribbon**.

- Spaces must be included between the criteria and the words **Between** and **And**. If you do not include the proper spacing, the **Data type mismatch in criteria expression** error message will appear.

Procedures

1. Open the desired query in **Design** view.
2. Select the **Criteria** row of the desired field.
3. Type **Between**, the first value in the range, **And**, and the last value in the range.
4. Press [Enter].

Step-by-Step

Use the **Between And** operator in a query.
If necessary, open the CSales Query query in Design view and delete any previous criteria.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Criteria row of the desired field. <em>The insertion point appears in the corresponding Criteria row.</em></td>
<td>Click in the Criteria row of the Credit Limit field</td>
</tr>
<tr>
<td>2. Type Between, the first value in the range, And, and the last value in the range. <em>The operator and the criteria appear in the Criteria row.</em></td>
<td>Type between 1000 and 2000</td>
</tr>
<tr>
<td>3. Press [Enter]. <em>The Between And operator and the criteria are entered into the design grid.</em></td>
<td>Press [Enter]</td>
</tr>
</tbody>
</table>

Run the query. Notice that only records matching the criteria appear in the recordset.

Return to Design view and delete the criteria.

**USING THE EXPRESSION BUILDER**

**Discussion**

When you enter criteria, you are actually creating an expression. Expressions are calculations and can include database objects, operators, and values. Objects range from table fields to controls in a form. Operators are standard mathematical operators used in calculations (such as +, -, *, /, (), <>). Values can be numbers, dates, text, and built-in functions, as well as field, control, and property identifiers.

You can create an expression by typing the expression elements, or you can use the Expression Builder. The Expression Builder is a tool that provides all the elements needed to build the expression.

The Expression Builder displays the Expression box in its top pane, a row of operator buttons below the Expression box, and three lower panes that display categories, subcategories, and values, respectively.

New expressions appear in the Expression box. You can use a combination of methods to build a new expression. You can type some elements of the expression and select others (such as operators, functions, and values) from the element panes. If you make a mistake, the Undo button allows you to undo previous actions, one at a time.
Additionally, you can select and delete any elements you want to remove from the Expression box.

![Using the Expression Builder](image)

The Expression Builder is available in Design view for any database object for which you need to create an expression. For example, you can use the Expression Builder to create a validation rule for a table field.

You can insert an element from an element pane into the Expression box by double-clicking the element or by selecting it and clicking the Paste button in the Expression Builder.

Be careful to single-click when expanding a subcategory; double-clicking a subcategory inserts the first subcategory value.

### Procedures

1. Open the desired query in Design view.
2. Select the Criteria row under the desired field.
3. Click the Builder button on the Design tab.
4. Expand categories in the lower, left pane as necessary, and then click any category to display its subcategories in the center pane.

5. Click the desired subcategory in the center pane.

6. Double-click a subcategory in the center pane or a value in the right pane to insert it into the Expression box.

7. To enter a value, select existing text or position the insertion point as needed in the Expression box.

8. Type the desired value.

9. Complete the expression.

10. Select OK.

**Step-by-Step**

Use the Expression Builder.

If necessary, open the CSales Query query in Design view and delete any previous criteria.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Criteria row of the desired field. &lt;br&gt;The insertion point appears in the corresponding Criteria row.</td>
<td>Click in the Criteria row of the Contract Date field</td>
</tr>
<tr>
<td>2. Click the Builder button on the Design tab. &lt;br&gt;The Expression Builder opens.</td>
<td>Click Builder</td>
</tr>
<tr>
<td>3. Expand categories in the lower, left pane as necessary, and then click any category to display its subcategories in the center pane. &lt;br&gt;The corresponding subcategories appear in the center pane.</td>
<td>Click Operators</td>
</tr>
<tr>
<td>4. Click the desired subcategory in the center pane. &lt;br&gt;The corresponding values appear in the right pane.</td>
<td>Click Comparison</td>
</tr>
</tbody>
</table>
**Steps** | **Practice Data**
---|---
5. Double-click a subcategory in the center pane or a value in the right pane to insert it into the **Expression** box. *The element appears in the Expression box.* | Double-click **Between** in the right pane

6. To enter a value, select existing text or position the insertion point as needed in the **Expression** box. *The text in the Expression box is selected.* | Double-click the first `<Expr>` in the **Expression** box

7. Type the desired value. *The text appears in the Expression box.* | Type **6/1/01**

8. Complete the expression. *The expression appears in the Expression box.* | Follow the instructions shown below the table before continuing on to the next step

9. Select **OK**. *The Expression Builder dialog box closes, and the expression appears in the Criteria row.* | Click ![OK](ok.png)

Replace the second `<Expr>` element with **6/30/03**.

*Return to the table and continue on to the next step (step 9).*

Run the query. Notice that only records matching the criteria appear in the recordset.

*Return to **Design** view and delete the criteria.*

## Using a Wildcard Character

### Discussion

You can use a wildcard in a query in place of one or several characters. Wildcard characters are helpful when you want to find criteria with a pattern (such as all last names beginning with M), or if you are not sure exactly how values you want to find appear (such as the correct spelling—Kline or Klein).

The two most common wildcards are listed in the following table:
Lesson 3 - Using Operators in Queries

<table>
<thead>
<tr>
<th>Wildcard</th>
<th>Used for</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>?</td>
<td>Any single letter or number</td>
<td>Sm?th finds Smith and Smyth, whereas ?andy finds Sandy, Randy, etc.</td>
</tr>
<tr>
<td>*</td>
<td>One or more letters or numbers</td>
<td>M* finds all records that start with M; 8/*/00 finds all dates in August, 2000; and <em>ball</em> finds all records that have the text ball anywhere in the field</td>
</tr>
</tbody>
</table>

- Wildcards are not case-sensitive (for example, *ill finds Bill and bill).

- When you use wildcard characters (?, and *), Access automatically inserts the word Like before the criteria and quotation marks (" ") around text.

Procedures

1. Open the desired query in Design view.
2. Select the Criteria row of the desired field.
3. Type the desired criteria, using wildcards as appropriate.
4. Press [Enter].

Step-by-Step

Use a wildcard character in a query.

If necessary, open the CSales Query query in Design view and delete any previous criteria.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Criteria row of the desired field.</td>
<td>Click in the Criteria row of the Store Name field</td>
</tr>
<tr>
<td>The insertion point appears in the corresponding Criteria row.</td>
<td></td>
</tr>
<tr>
<td>Steps</td>
<td>Practice Data</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>--------------------------</td>
</tr>
<tr>
<td>2. Type the desired criteria, using wildcards as appropriate.</td>
<td>Type <em>sport</em></td>
</tr>
<tr>
<td><em>The text appears in the <strong>Criteria</strong> row.</em></td>
<td></td>
</tr>
<tr>
<td>3. Press [Enter].</td>
<td>Press [Enter]</td>
</tr>
<tr>
<td><em>The criteria is entered into the design grid.</em></td>
<td></td>
</tr>
</tbody>
</table>

Run the query. Notice that only records matching the criteria appear in the recordset.

Return to **Design** view and delete all criteria.

Then, close the query, saving the changes. Close **OPERATE.ACCDB**.
EXERCISE

USING OPERATORS IN QUERIES

Task

Use operators in queries.

1. Open OPERATEX.ACCDB.
2. Open the Course Query query in Design view.
3. Set criteria to find only projects with a cost of more than $150. 
   (Hint: Try using the > operator.)
4. Run the query; the criteria should find 16 records. Then, return to Design view and delete the criterion.
5. Use wildcards and an Or condition to find only records with the text excel or word occurring anywhere in the course name. (Hint: Use asterisks both before and after each criterion.)
6. Run the query; the criteria should find 7 records. Then, return to Design view and delete the criteria from the query.
7. Use the Expression Builder to find only records with a start date between 4/1/2003 and 6/30/2003. (Hint: Select Operators from the left pane, Comparison from the center pane, and Between from the right pane. Then, replace the <Expr> expressions with the appropriate dates.)
8. Run the query; the criteria should find 24 records. Then, switch back to Design view and delete the criteria.
9. Find all records with trainer initials of DF and a cost of $175 or more. The criteria should find 3 records.
10. Close the query, saving the changes.
LESSON 4 -
DESIGNING ADVANCED QUERIES

In this lesson, you will learn how to:

- Set top values in a query
- Create a calculated field
- Format a calculated field
- Display a Totals Row in a query
- Create a function query
- Create a parameter query
- Use Multivalued fields
- Create a concatenation in a query
- Filter a query


**Setting Top Values in a Query**

**Discussion**

You can limit the results of a query so that only the highest or lowest values in a field appear in the recordset. For example, you can set the return of a **Quantity Sold** field to 10 to find the top ten best-selling products.

You can also limit the number of records to a specific number or percentage of all records being queried (e.g., the top 25%). The field for which you are setting the top or bottom values must be sorted. If the field is sorted in descending order (Z to A, 9 to 0), the top values will be found. If the field is sorted in ascending order (A to Z, 0 to 9), the bottom values will be found.

If other fields in the query are sorted, they must appear to the right of the field for which you are finding top or bottom values in the design grid.

You can also type a value into the **Return** box on the **Design** tab.
Procedures

1. Open the desired query in Design view.
2. Select the Sort row of the desired field.
3. Select the Sort list.
4. Select the desired sort order.
5. Select the Return list on the Design tab.
6. Select the desired option.

Step-by-Step

From the Student Data directory, open ADVQUE1.ACCDB. Set top values in a query.

Display All Access Objects, if necessary. Open the CSales Query query in Design view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Sort row of the desired field. A drop-down arrow appears in the Sort field.</td>
<td>Scroll as necessary and click in the Sort row of the Sales to Date field</td>
</tr>
<tr>
<td>2. Select the Sort list. A list of available sort orders is displayed.</td>
<td>Click Sort ▼</td>
</tr>
<tr>
<td>3. Select the desired sort order. The sort order appears in the Sort row.</td>
<td>Click Descending</td>
</tr>
<tr>
<td>4. Select the Return list on the Design tab. A list of available options is displayed.</td>
<td>Click Return ▼</td>
</tr>
<tr>
<td>5. Select the desired option. The top value appears in the Top Values box.</td>
<td>Click 5</td>
</tr>
</tbody>
</table>

Run the query. If necessary, scroll to view the Sales to Date field. Notice that the top five sales to date are listed in descending order.
**Practice the Concept:** Return to **Design** view. Set the top values back to **All** and remove the sort from the **Sales to Date** field. Then, close the query, saving the changes.

**CREATING A CALCULATED FIELD**

**Discussion**

Access allows you to create expressions that calculate new field values; for example, you can create an expression that multiplies the value in the **Quantity** field by the value in the **Price** field to calculate total sales. You can also create an expression that adjusts a value in a single field, such as doubling a **Wholesale Price** field to calculate values for a **Retail Price** field.

In expressions, field names are enclosed in square brackets ([ ]); numbers are not. For example, to calculate 20% of sales and display the results in a column named **Commission**, you would enter **Commission:.2*[Sales]** in the design grid. (The colon separates the column name from the expression.)

Calculated fields are created in queries. You can also use criteria to remove nonessential records, thereby allowing the query to run faster. The results of your query can then be used to generate a report.

![Creating a calculated field](image)

**The field names used in an expression must be the same as the field names that appear in the table.**
You can also use the Expression Builder to create a calculated field by selecting any blank Field row and clicking the Builder button on the Design tab.

Procedures

1. Open the desired query in Design view.
2. Select any blank Field row.
3. Type the desired field name and a colon (:).
4. Type the expression required to perform the calculation.
5. Press [Enter].

Step-by-Step

Create a calculated field in a query.

Open the Reps Pay Query query in Design view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select any blank Field row.</td>
<td>Click in the Field row to the right of Commission Rate</td>
</tr>
<tr>
<td>The insertion point appears in the</td>
<td></td>
</tr>
<tr>
<td>corresponding Field row.</td>
<td></td>
</tr>
<tr>
<td>2. Type the desired field name and a</td>
<td>Type Commission:</td>
</tr>
<tr>
<td>colon (:).</td>
<td></td>
</tr>
<tr>
<td>The text appears in the Field row.</td>
<td></td>
</tr>
<tr>
<td>3. Type the expression required to</td>
<td>Type [ord tot]* [commission rate]</td>
</tr>
<tr>
<td>perform the calculation.</td>
<td></td>
</tr>
<tr>
<td>The expression appears in the Field row.</td>
<td></td>
</tr>
<tr>
<td>4. Press [Enter].</td>
<td>Press [Enter]</td>
</tr>
<tr>
<td>The calculated field is entered into the</td>
<td></td>
</tr>
<tr>
<td>design grid.</td>
<td></td>
</tr>
</tbody>
</table>

Run the query. Notice that the Commission field displays the results of the value in the Ord Tot field multiplied by the percentage in the Commission Rate field.

Save the query and switch back to Design view.
FORMATTING A CALCULATED FIELD

Discussion

Once you have created a calculated field, you can change its properties as you would any other field on the design grid. The Format property determines how data appears in Datasheet view. For example, you can change the properties of a calculated field so that the field values display as currency.

You can also change the format of a calculated field by right-clicking anywhere in it and selecting Properties.

Procedures

1. Open the desired query in Design view.
2. Select the calculated field you want to format.
3. Select the Property Sheet button on the Design tab.
4. Select the General page in the Field Properties box in the Property Sheet pane.
5. Select the Format box.
6. Select the Format list.
7. Select the desired format.

Step-by-Step

Format a calculated field in a query.

If necessary, open the Reps Pay Query query in Design view.
Steps | Practice Data
---|---
1. Select the calculated field you want to format. The insertion point appears in the field. | Scroll as necessary and click anywhere in the Commission:[ord tot]*[commission rate] field
2. Select the **Property Sheet** button on the **Design** tab. The **Property Sheet pane opens.** | Click **Property Sheet**
3. Select the **General** page in the Field Properties box in the Property Sheet pane. The **General** page appears. | Click the **General** tab, if necessary
4. Select the **Format** box. A drop-down arrow appears in the **Format** box. | Click in the **Format** box
5. Select the **Format** list. A list of available formats appears. | Click **Format**
6. Select the desired format. The format appears in the **Format** box. | Scroll as necessary and click **Currency**

If necessary, close the Property Sheet pane. Then, run the query. Notice that the **Commission** field is now formatted as currency.

Close the query, saving the changes.

**DISPLAYING A TOTALS ROW IN A QUERY**

**Discussion**

You can now perform calculations in a query using aggregate functions, such as displaying a totals row. Access queries support the aggregate functions shown in the following table:

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Sum</strong></td>
<td>Calculates the total of the values in a field.</td>
</tr>
<tr>
<td><strong>Avg</strong></td>
<td>Calculates the average of the values in a field.</td>
</tr>
<tr>
<td><strong>Count</strong></td>
<td>Calculates the number of values in a field, not counting Null (blank) values.</td>
</tr>
<tr>
<td><strong>Min</strong></td>
<td>Calculates the lowest value in a field.</td>
</tr>
<tr>
<td><strong>Max</strong></td>
<td>Calculates the highest value in a field.</td>
</tr>
<tr>
<td>Function</td>
<td>Description</td>
</tr>
<tr>
<td>----------</td>
<td>-------------</td>
</tr>
<tr>
<td>StDev</td>
<td>Calculates the standard deviation of the values in a field.</td>
</tr>
<tr>
<td>Var</td>
<td>Calculates the variance of the values in a field.</td>
</tr>
</tbody>
</table>

### Procedures

1. Open the desired query in **Datasheet** view.
2. Select the **Home** tab on the **Ribbon**, if necessary.
3. Select the **Totals** button in the **Records** group.
4. In the totals row, select the field you want to total.
5. Select the arrow.
6. Select the desired function.

### Step-by-Step

Display a totals row in a query.

Open the **Region Totals** query in datasheet view

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the **Home** tab on the **Ribbon**, if necessary.  
*The Home tab appears.* | Click **Home** |
| 2. Select the **Totals** button in the **Records** group.  
*The Show Tables dialog box appears.* | Click **Totals** |
| 3. In the totals row, select the field you want to total.  
*The arrow appears.* | In the totals row, click in the **Sales to Date** field |
| 4. Select the arrow  
*The aggregate function list appears.* | Click **▼** |
Steps | Practice Data
--- | ---
5. Select the desired function. *Access displays the desired aggregate function result.* | Click Sum

Click the Totals button again. Notice that the Totals Row is removed from the query.

**CREATING A FUNCTION QUERY**

**Discussion**

Access allows you to create a query that groups records by a selected field and then applies a function that calculates a value within the grouped fields. For example, you could group records by state and then select the Count function to find out how many customers (records) are in each state (field), or you could group records by customer name and then calculate the Sum of each customer’s orders.

Access allows you to perform more than one calculation on a field. For example, you can group records by weekly sales and then find both the minimum and maximum values.

There are several types of functions from which you can choose. The most commonly used functions are listed in the following table:

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sum</td>
<td>Totals the values in the calculated field</td>
</tr>
<tr>
<td>Average</td>
<td>Averages the values in the calculated field</td>
</tr>
<tr>
<td>Count</td>
<td>Counts the number of records in the calculated field</td>
</tr>
<tr>
<td>Max</td>
<td>Finds the highest value in the calculated field</td>
</tr>
<tr>
<td>Min</td>
<td>Finds the lowest value in the calculated field</td>
</tr>
</tbody>
</table>

To perform more than one calculation on a field, you must add the field to the design grid a second time and create the desired expression.
Procedures

1. Open the desired query in Design view.

2. Select the Totals button in the Show/Hide group on the Design tab.

3. Select the Total row in the field you want to calculate.

4. Select the Group By list.

5. Select the desired function.

Step-by-Step

Create a function query.

Open the Region Totals query in Design view. Run the query; notice that a Sales to Date field appears for each customer in the region. Then, switch back to Design view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Totals button in the Show/Hide group on the Design tab. A Total row appears in the design grid.</td>
<td>Click Totals</td>
</tr>
<tr>
<td>3. Select the Total row in the field you want to calculate. A drop-down arrow appears in the corresponding Total field.</td>
<td>Click in the Total row in the Sales to Date field</td>
</tr>
<tr>
<td>4. Select the Group By list. A list of available functions is displayed.</td>
<td>Click Group By</td>
</tr>
<tr>
<td>5. Select the desired function. The function appears in the Total row.</td>
<td>Click Sum</td>
</tr>
</tbody>
</table>

Run the query. Widen the SumOfSales to Date column as necessary. Notice that the records are now grouped by region, and the sum of the sales to date for each region appears in the new SumOfSales to Date field.

Close and save the query.
Creating a Parameter Query

Discussion

You can create a query to which you add different criteria each time you run it; such a query is called a parameter query. A parameter query is designed to prompt the user for input each time it is run; Access then runs the query based on the criterion (parameter) entered. A parameter query allows you to quickly and easily change query criteria without having to redesign the query.

Creating a parameter query

You can add multiple parameters to a query; when you run the query, a prompt will appear for each parameter in it.

Procedures

1. Open the desired query in Design view.
2. Select the Criteria row in the desired field.
3. Type an open bracket ([), the desired prompt, a colon, and the close bracket (]).
4. Press [Enter].
Step-by-Step

Create a parameter query.

Open the Customer Addresses query in Design view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Criteria row in the desired field. <em>The insertion point appears in the corresponding Criteria row.</em></td>
<td>Scroll as necessary and click in the Criteria row of the Region field</td>
</tr>
<tr>
<td>2. Type an open bracket ([), the desired prompt, a colon, and the close bracket (]). <em>The text appears in the Criteria row.</em></td>
<td>Type [Enter the Region:]</td>
</tr>
<tr>
<td>3. Press [Enter]. <em>The parameter is added to the query.</em></td>
<td>Press [Enter]</td>
</tr>
</tbody>
</table>

Run the parameter query. At the prompt, type northeast and select OK. Notice that only records matching the criteria appear in the recordset.

Switch back to Design view and run the parameter query again. This time at the prompt, type southeast and select OK.

Close and save the query.

**Using Multivalued Fields**

**Discussion**

When using a multivalued field in a query, you can choose whether to retrieve the entire multivalued field containing all the values separated by commas, or a separate row for each value.

**Procedures**

1. Open the desired table.
2. Select the Create tab on the Ribbon, if necessary.
3. Select the **Query Design** button in the **Other** group.

4. Select the table that contains the multivalued field.

5. Select Add.


7. Drag the multi-valued field into the query grid.

8. Release the mouse button.

9. Drag any other desired fields into the query grid.

10. Release the mouse button.

11. Select the **Design** tab on the **Ribbon**.

12. Select the **Run** button in the **Results** group.

---

**Step-by-Step**

Create a multivalued field in a query.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the <strong>Create</strong> tab on the <strong>Ribbon</strong>, if necessary.</td>
<td>Click <strong>Create</strong></td>
</tr>
<tr>
<td><em>The Datasheet tab is displayed.</em></td>
<td></td>
</tr>
<tr>
<td>2. Select the <strong>Query Design</strong> button in the <strong>Other</strong> group.</td>
<td>Click <strong>Design</strong></td>
</tr>
<tr>
<td><em>The Show Table dialog box opens.</em></td>
<td></td>
</tr>
<tr>
<td>3. Select the table that contains the multivalued field.</td>
<td>Click <strong>Items 2</strong></td>
</tr>
<tr>
<td><em>The desired table is selected.</em></td>
<td></td>
</tr>
<tr>
<td>4. Select <strong>Add</strong>.</td>
<td>Click <strong>Add</strong></td>
</tr>
<tr>
<td><em>The desired table is added to the query.</em></td>
<td></td>
</tr>
</tbody>
</table>
**Steps** | **Practice Data**
---|---
5. Select **Close**.  
*The Show Table dialog box closes.* | Click ![Close](Close.png)
6. Drag the multivalued field into the query grid.  
*The multivalued field is selected.* | Drag the **Color** field into the query grid
7. Release the mouse button.  
*The multivalued field is added to the query grid.* | Release the mouse button
8. Drag any other desired fields into the query grid.  
*The desired field is selected.* | Drag **Product Description** into the query grid
9. Release the mouse button.  
*The desired field is added to the query grid.* | Release the mouse button
10. Select the **Design** tab on the Ribbon.  
*The Design tab is displayed.* | Click **Design**, if necessary
11. Select the **Run** button in the **Results** group.  
*The query result is displayed.* | Click ![Run](Run.png)

The query result appears with one column displaying the multivalued field (**Color**), and the second column displaying **Product Description** field.

Close the Query.

---

**CREATING A CONCATENATION IN A QUERY**

### Discussion

A concatenation query allows you to combine two or more text fields into one field. In other words, concatenation enables you to append one text string to another. In addition, you can insert characters between the text strings as needed. For example, you can concatenate the **City**, **State**, and **Postal Code** fields and store the concatenated text string in a fourth field, the **Address** field, adding commas and spaces between the text strings as needed.

When typing a concatenation expression, the first part of the expression defines the name of the new field and the second part of the expression defines the fields which are to be concatenated. All field names must be surrounded by brackets. The concatenation character (the ampersand - `&`) appears between field names, and you must enclose any additional characters in double quotes. For example, the expression
Names: [Last Name]&", ",&[First Name] concatenates the Last Name and First Name fields and inserts the concatenated text string into a field called Names. The new field displays the last name, a comma, a space, and the first name for each record in the table.

Creating a concatenation expression

You can also use concatenation to create text strings in forms and reports.

To use the Expression Builder to concatenate text, select any blank Field row and click the Builder button on the Design tab.

Procedures

1. Open the desired query in Design view.
2. Select any blank Field row in the design grid.
3. Type the desired concatenation expression.
4. Press [Enter].

Step-by-Step

Create a concatenation query.
Open the Rep Orders query in Design view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select any blank Field row in the design grid. The insertion point appears in the corresponding Field row.</td>
<td>Click in the blank Field row to the right of Customer ID</td>
</tr>
<tr>
<td>2. Type the desired concatenation expression. The concatenation expression appears in the Field row.</td>
<td>Type Sales Rep: [first_name]&amp;&quot; &quot;&amp; [last_name]</td>
</tr>
<tr>
<td>3. Press [Enter]. The concatenation field is added to the design grid.</td>
<td>Press [Enter]</td>
</tr>
</tbody>
</table>

Run the query. Widen the Sales Rep column as necessary to display all the characters in it. Notice that the Sales Rep column displays the first and last name, separated by a space.

Close and save the query.

FILTERING A QUERY

Discussion

You can filter a query in the same way you filter a table or form. Since the data you want to filter sometimes appears in two or more tables, you might need to create a multiple table query. Once the query has been created, you can apply a filter to temporarily isolate the records you want to view.

The Filter By Selection feature allows you to quickly and easily filter a query to display only those records in which the selected value appears. Conversely, the Filter Excluding Selection feature filters out the selected value, leaving only those records that do not contain the selected value.

The Filter By Form feature allows you to create more complex filters by filtering on multiple values and/or by creating filter expressions. In the Filter by Form window, for example, you can create And and Or filters, use wildcards, and filter by ranges.
Procedures

1. Open the desired query in Datasheet view.
2. Select the value by which you want to filter.
3. Select the Filter Selection button on the Home tab.
4. Select the desired filter options.

Step-by-Step

Filter a query.

Open the Store Shipping Dates 2 query in Datasheet view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the value by which you want to</td>
<td>Click in any field</td>
</tr>
<tr>
<td>filter.</td>
<td>containing the text</td>
</tr>
<tr>
<td></td>
<td>Athletic Supplies Co.</td>
</tr>
<tr>
<td>2. Click the Filter Selection button in the</td>
<td>Click</td>
</tr>
<tr>
<td>Sort &amp; Filter group on the Home tab.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>3. Select the desired filter options.</td>
<td>Click Equals “Athletic</td>
</tr>
<tr>
<td></td>
<td>Supplies Co.”</td>
</tr>
</tbody>
</table>

Remove the filter by clicking the Toggle Filter button on the Home tab.

Close Datasheet view without saving the changes.
Close ADVQUE1.ACCDB.
**Exercise**

**Designing Advanced Queries**

**Task**

Design advanced queries.

1. Open ADVQUE1X.ACCDB.
2. Open the Project Sales query in Design view.
3. Create a new calculated field named Total Sales that multiplies the number of students to be trained (Students field in the Project table) by the per student cost of the course (Cost field in the Courses table). (*Hint: Use the format Total Sales: [students]*[cost].*)
4. Run the query to view the results. Close the query and save it.
5. Open the Trainer Pay query in Design view. (*Hint: Right Click and select Design View*
6. Create a new field that concatenates the first and last names of each trainer. Name the field Trainer Name and use the Last Name, First Name format. (*Hint: Use the format Trainer Name: [last name] & " & [first name].*)
7. Run the query and widen the Trainer Name column to view the text. Then, return to Design view.
8. Trainers are paid fifteen percent of the total sale for each project. Create a calculated field named Pay that calculates the trainer's pay for each project. (*Hint: Use the format Pay: [students]*[cost]*.15.*)
9. Format the Pay field as currency. Run the query to view the results. Then, return to Design view.
10. Find the three trainers with the highest pay. (*Hint: Sort the Pay field in Descending order and type 3 into the Return box on the toolbar.*) Run the query to view the results. Then, return to Design view.
11. Reset the Pay field back to (not sorted) and the top values back to All; then, remove the Total row. (*Hint: Use the Totals button on the Query Design toolbar.*)
12. Run the query again. Use the Filter by Selection button to display only those records for George Edwards.
13. Close the query, saving the changes.
14. Open the **Sales by Rep** query in **Design** view. Add a parameter to the **Criteria** row of the **Sales Rep** field that prompts you to enter the initials of the sales representative each time the query is run. *(Hint: Remember to use both opening and closing brackets.)*

15. Run the query, typing *sh* when prompted. Notice that only records that match the criteria appear in the recordset.

16. Close the query, saving the changes.

17. Close the database file.
LESSON 5 -
CREATING ACTION QUERIES

In this lesson, you will learn how to:

- Create a make-table query
- Create an update query
- Create an append query
- Create a delete query
Creating a Make-Table Query

Discussion

A make-table query creates a new table from data in existing tables and queries. Make-table queries have many uses. The new table can be a duplicate of an existing table, to serve as a data backup. You can then delete old records from the original table, for example, leaving them stored in the backup table.

Make-table queries can create a compact version of an existing table, displaying only those fields you want to see. They can also bring fields from many tables into one table, making reports and queries based on the new, single table run faster.

You can limit both records and fields in a new table. If you use criteria in a make-table query, only those records that meet the criteria will be added to the new table.

![Creating a make-table query](image)

The fields in the new table retain the data type and field size properties assigned to them in the source tables.

Procedures

1. Display All Access Objects in the Navigation Pane.
2. Select the Create tab on the Ribbon.
3. Select the Query Design button.
4. Add the desired tables to the query.
5. Close the Show Table dialog box.
6. Add the first desired field to the design grid.
7. Add additional fields to the query as desired.
8. Select the desired **Criteria** row.
9. Type the desired criteria.

10. Select the **Make Table** button.
11. Type the desired table name in the **Table Name** box.
12. Select **OK**.
13. Run the query.
14. Select **Yes**.

---

**Step-by-Step**

From the Student Data directory, open **ACTION1.ACCDB**. Create a make-table query.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the <strong>Create</strong> tab on the <strong>Ribbon</strong>. The <strong>Create</strong> tab is displayed.</td>
<td>Click <strong>Create</strong></td>
</tr>
<tr>
<td>2. Select the <strong>Query Design</strong> button. A blank query opens in <strong>Design View</strong>.</td>
<td><img src="image" alt="Query Design" /> Click <strong>Query Design</strong></td>
</tr>
<tr>
<td>3. Add the desired tables to the query. The corresponding field list is added to the query.</td>
<td>Double-click <strong>Packing Slip</strong></td>
</tr>
<tr>
<td>4. Close the Show Table dialog box. The <strong>Show Table</strong> dialog box closes.</td>
<td><img src="image" alt="Close" /> Click <strong>Close</strong></td>
</tr>
<tr>
<td>5. Add the first desired field to the design grid. The field appears in the design grid.</td>
<td>Double-click the <strong>Ord Num</strong> field in the <strong>Packing Slip</strong> field list</td>
</tr>
</tbody>
</table>
### Lesson 5 - Creating Action Queries

#### Access 2007 - Lvl 2

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>6. Add additional fields to the query as desired.</td>
<td>Follow the instructions shown below the table before continuing on to the next step.</td>
</tr>
<tr>
<td><em>The fields appear in the design grid.</em></td>
<td></td>
</tr>
<tr>
<td>7. Select the desired <strong>Criteria</strong> row.</td>
<td>Scroll as necessary and click in the <strong>Criteria</strong> row of the <strong>Ord Date</strong> field.</td>
</tr>
<tr>
<td><em>The insertion point appears in the corresponding <strong>Criteria</strong> row.</em></td>
<td></td>
</tr>
<tr>
<td>8. Type the desired criteria.</td>
<td>Type <strong>between 1/1/02 and 12/31/02</strong></td>
</tr>
<tr>
<td><em>The criteria appears in the <strong>Criteria</strong> row.</em></td>
<td></td>
</tr>
<tr>
<td>9. Select the <strong>Make Table</strong> button.</td>
<td><img src="image" alt="Make Table" /></td>
</tr>
<tr>
<td><em>The Make Table dialog box opens, with the insertion point in the <strong>Table Name</strong> box.</em></td>
<td>Click</td>
</tr>
<tr>
<td>10. Type the desired table name in the <strong>Table Name</strong> box.</td>
<td>Type <strong>CurrentSlip</strong></td>
</tr>
<tr>
<td><em>The text appears in the <strong>Table Name</strong> box.</em></td>
<td></td>
</tr>
<tr>
<td>11. Select <strong>OK</strong>.</td>
<td><img src="image" alt="OK" /></td>
</tr>
<tr>
<td><em>The Make Table dialog box closes.</em></td>
<td>Click</td>
</tr>
<tr>
<td>12. Run the query.</td>
<td><img src="image" alt="Run" /></td>
</tr>
<tr>
<td><em>A Microsoft Office Access warning box advises you that you cannot undo your changes.</em></td>
<td>Click</td>
</tr>
<tr>
<td>13. Select <strong>Yes</strong>.</td>
<td><img src="image" alt="Yes" /></td>
</tr>
<tr>
<td><em>The Microsoft Office Access warning box closes, and Access runs the make-table query, pasting the selected records into the new <strong>CurrentSlip</strong> table.</em></td>
<td></td>
</tr>
</tbody>
</table>

Add the following fields to the query: **Ord Date**, **Prod ID**, **Qty**, **Unit Price**, and **Ord Tot**.

*Return to the table and continue on to the next step (step 7).*

Close the query, saving it as **Current**.

Open the **CurrentSlip** table in **Datasheet** view to verify that it was created with the selected records. Then, close the **CurrentSlip** table.
Creating an Update Query

Discussion

An update query is used to change data values in an existing table. Update queries save time because they allow you to update a large number of records at one time. You can use an update query, for example, to increase all the values in a Unit Price field by 10%.

You can also use an update query to calculate and enter values in a table field. You could, for example, use an update query to multiply the value in the Unit Price field by 75% and place the result of the calculation in the Sale Price field of the same record.

If you do not want to update all the records in the table, you can use criteria to select only those records you want to update. For example, you can add criteria to an update query to increase the unit price on only one product line, rather than on all products.

Not all table fields have to be included in an update query. You need to include only those fields you want to update and those to which you want to add criteria.

When you use field names in any expression, they must be enclosed in square brackets ( [ ] ).

An update query permanently alters field values; make sure that the correct records are selected and that the expression in the Update To row of the design grid is correct.

Procedures

1. Display All Access Objects in the Navigation Pane.
2. Select the Create tab on the Ribbon.
3. Select the Query Design button
4. Add the desired tables to the query.
5. Select the **Update Query** button.

6. Add the field you want to update to the design grid.

7. Select the **Update To** row in the field you want to update.

8. Type the desired update expression.

9. Run the query.

10. Select **Yes**.

---

### Step-by-Step

Create an update query.

Open the **CurrentSlip 2** table in **Datasheet** view. Notice that the first three values in the **Unit Price** field are $1.75, $40.99, and $3.82. Close the **CurrentSlip 2** table and display the **Queries** object list.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the **Create** tab on the **Ribbon**.  
   *The Create tab is displayed.* | Click **Create** |
| 2. Select the **Query Design** button.  
   *A blank query opens in Design View.* | Click **Query Design** |
| 3. Add the desired tables to the query.  
   *The corresponding field list is added to the query.* | Double-click **CurrentSlip 2** |
| 4. Close the Show Table dialog box.  
   *The Show Table dialog box closes.* | Click **Close** |
| 5. Select the **Update Query** button.  
   *An Update To row is added to the design grid.* | Click **Update** |
| 6. Add the first desired field to the design grid.  
   *The field appears in the design grid.* | Scroll as necessary and double-click the **Unit Price** field in the **Current Slip 2** field list |
### Steps | Practice Data
--- | ---
7. Select the **Update To** row in the desired field. *The insertion point appears in the corresponding Update To row.* | Click in the **Update To** row of the **Unit Price** field
8. Type the desired update expression. *The criteria appears in the Criteria row.* | Type `[unit price] * 1.06`
9. Run the query. *A Microsoft Office Access warning box advises you that you cannot undo your changes.* | Click
10. Select **Yes**. *The Microsoft Office Access warning box closes, and Access runs the make-table query, pasting the selected records into the new **CurrentSlip** table.* | Click **Yes**

Close the query, saving it as **Update Slips**.

Open the **Current Slip 2** table in **Datasheet** view to verify that the records were updated. Notice that the unit prices have been increased by 6%, then close the table.

---

### CREATING AN APPEND QUERY

#### Discussion

An append query copies records from one table or query and adds them to the end of a different table. Append queries are useful in transferring data from one table to another.

You can also use an append query to archive some or all table data. If you have two tables, **Current Orders** and **Old Orders**, for example, you can use an append query to copy records from the **Current Orders** table and add them to the **Old Orders** table, eliminating the need to manually type the records into the **Old Orders** table.

If the fields in both tables have the same names, the copied data is automatically appended. If the fields have different names, however, you must specify the fields to which you want to append the data.

You can use criteria to select the records you want to append. Only those records that meet the criteria are appended to the table.
Procedures

1. Display All Access Objects in the Navigation Pane.
2. Select the Create tab on the Ribbon.
3. Select the Query Design button.
4. Add the desired tables to the query.
5. Close the Show Table dialog box.
6. Select the Append button.
7. Type the name of the table to which you want to append data in the Table Name box.
8. Select OK.
9. Add the fields you want to append to the design grid.
10. Select the Append To row under an unmatched field, if necessary.
11. Select the Append To list.
12. Select the matching field.
13. Select the desired Criteria row.
14. Type the desired criteria.
15. Run the query.
16. Select Yes.

Step-by-Step

Create an append query.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Create tab on the Ribbon. The Create tab is displayed.</td>
<td>Click Create</td>
</tr>
<tr>
<td>Steps</td>
<td>Practice Data</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>---------------</td>
</tr>
<tr>
<td>2. Select the <strong>Query Design</strong> button.</td>
<td>Click</td>
</tr>
<tr>
<td>A blank query opens in <strong>Design View</strong>.</td>
<td></td>
</tr>
<tr>
<td>3. Add the desired tables to the query.</td>
<td>Double-click <strong>Packing Slip</strong></td>
</tr>
<tr>
<td>The corresponding field list is added to the query.</td>
<td></td>
</tr>
<tr>
<td>4. Close the Show Table dialog box.</td>
<td>Click</td>
</tr>
<tr>
<td>The Show Table dialog box closes.</td>
<td></td>
</tr>
<tr>
<td>5. Select the <strong>Append</strong> button.</td>
<td>Click</td>
</tr>
<tr>
<td>The Append dialog box opens, with the insertion point in the <strong>Table Name</strong> box.</td>
<td></td>
</tr>
<tr>
<td>6. Type the name of the table to which you want to append data in the <strong>Table Name</strong> box.</td>
<td>Type <strong>CurrentSlip 2</strong></td>
</tr>
<tr>
<td>The name appears in the <strong>Table Name</strong> box.</td>
<td></td>
</tr>
<tr>
<td>7. Select <strong>OK</strong>.</td>
<td>Click</td>
</tr>
<tr>
<td>The Append dialog box closes and an <strong>Append To</strong> row is added to the design grid.</td>
<td></td>
</tr>
<tr>
<td>8. Add the first field you want to append to the design grid.</td>
<td>Double-click the <strong>Ord Num</strong> field in the <strong>Packing Slip</strong> field list</td>
</tr>
<tr>
<td>The corresponding field appears in the design grid.</td>
<td></td>
</tr>
<tr>
<td>9. Add additional fields to the design grid as desired.</td>
<td>Follow the instructions shown below the table before continuing on to the next step</td>
</tr>
<tr>
<td>The corresponding fields appear in the design grid.</td>
<td></td>
</tr>
<tr>
<td>10. Select the <strong>Append To</strong> row under an unmatched field, if necessary.</td>
<td>Click in the <strong>Append To</strong> row of the <strong>Ord Num</strong> field</td>
</tr>
<tr>
<td>The insertion point appears in the corresponding <strong>Append To</strong> row and a drop-down arrow appears.</td>
<td></td>
</tr>
<tr>
<td>11. Select the <strong>Append To</strong> list.</td>
<td>Click <strong>Append To</strong></td>
</tr>
<tr>
<td>A list of available fields is displayed.</td>
<td></td>
</tr>
<tr>
<td>12. Select the matching field.</td>
<td>Click the <strong>Order Number</strong> field</td>
</tr>
<tr>
<td>The field is added to the design grid.</td>
<td></td>
</tr>
</tbody>
</table>
Lesson 5 - Creating Action Queries

Steps | Practice Data
--- | ---
13. Select the desired **Criteria** row.  
*The insertion point appears in the corresponding **Criteria** row.* | Click in the **Criteria** row of the **Ord Date** field
14. Type the desired criteria.  
*The text appears in the **Criteria** row.* | **Type between 1/1/03 and 12/31/03**
15. Run the query.  
*A Microsoft Office Access warning box advises that the changes cannot be undone.* | Click
16. Select **Yes**.  
*The Microsoft Office Access warning box closes, and Access runs the query, appending records to the table accordingly.* | Click **Yes**

Add the following fields to the query: **Ord Date**, **Prod ID**, **Qty**, **Unit Price**, and **Ord Tot**.

*Return to the table and continue on to the next step (step 10).*

Close the query; save it as **Append Slips**. Open the **CurrentSlip 2** table in **Datasheet** view. Notice that the **CurrentSlip 2** table now has 166 records. Then, close the **CurrentSlip 2** table.

### CREATING A DELETE QUERY

#### Discussion

You can use delete queries to maintain the appearance, usefulness, and efficiency of tables in a database. When records have been appended or archived to a secondary table, or they are simply no longer of use to you, it is a good idea to delete them. Deleting records saves disk space and makes tables more efficient; the more data there is in a table, the more time it takes to save, sort, and query a table.

Delete queries enable you to apply criteria to select and delete groups of records at one time.

* A delete query always deletes entire records; you cannot use one to delete data only in specific fields.
The records deleted by a delete query are not retrievable. Therefore, you should always preview the selected records by first running a select query. Only after you have confirmed that the selected records are correct should you run the delete query.

Procedures

1. Display All Access Objects in the Navigation Pane.
2. Select the Create tab on the Ribbon.
3. Select the Query Design button.
4. Add the desired tables to the query.
5. Close the Show Table dialog box.
6. Add any fields to which you want to add criteria to the design grid.
7. Select the desired Criteria row.
8. Type the desired criteria.
9. Select the Delete button.
10. Run the query.
11. Select Yes.

Step-by-Step

Create a delete query.

Open the Packing Slip table in Datasheet view; notice that the order dates start in 1999. Then, close the Packing Slip table and display All Access Objects in the Navigation Pane, if necessary.
Steps | Practice Data
---|---
1. Select the Create tab on the Ribbon. The Create tab is displayed. | Click Create
2. Select the Query Design button. A blank query opens in Design View. | ![Query Design](image)
3. Add the desired tables to the query. The corresponding field list appears in the query. | Double-click Packing Slip
4. Close the Show Table dialog box. The Show Table dialog box closes. | Click ![Close](image)
5. Add any fields to which you want to add criteria to the design grid. The corresponding fields appear in the design grid. | Double-click the Ord Date field in the Packing Slip field list
6. Select the desired Criteria row. The insertion point appears in the corresponding Criteria row. | Click in the Criteria row of the Ord Date field
7. Type the desired criteria. The text appears in the Criteria row under the appropriate field. | Type between 1/1/99 and 12/31/01
8. Select the Delete button. A Delete row is added to the design grid. | ![Delete](image)
9. Run the query. A Microsoft Office Access warning box advises you that the changes cannot be undone. | Click ![Run](image)
10. Select Yes. The Microsoft Office Access warning box closes, and Access runs the delete query, removing the corresponding records from the table. | Click ![Yes](image)

Close the query; save it as Delete Old Slips.

Open the Packing Slip table in Datasheet view to verify that the records between January 1, 1999 and December 31, 2001 have been deleted. Then, close the Packing Slip table. Close ACTION1.ACCDB.
EXERCISE

CREATING ACTION QUERIES

Task

Create action queries.

1. Open ACTION1X.ACCDB.
2. Create a query in Design view. Add the Client Balance Due query and the Client, Courses, and Project tables.
3. Add the following fields to the design grid, in the order listed:

<table>
<thead>
<tr>
<th>Table/Query</th>
<th>Field</th>
</tr>
</thead>
<tbody>
<tr>
<td>Client</td>
<td>Client Name</td>
</tr>
<tr>
<td>Client</td>
<td>Address</td>
</tr>
<tr>
<td>Client</td>
<td>City</td>
</tr>
<tr>
<td>Client</td>
<td>State</td>
</tr>
<tr>
<td>Client</td>
<td>Zip</td>
</tr>
<tr>
<td>Courses</td>
<td>Course Name</td>
</tr>
<tr>
<td>Client Balance Due</td>
<td>Balance Due</td>
</tr>
</tbody>
</table>

4. Enter criteria in the Balance Due field to select only those records with an outstanding balance. (Hint: >0.)
5. Create a Make-Table Query. Name the table Invoice. Then, run the make-table query, selecting Yes at the prompt.
6. Close the make-table query, saving it as Create Invoice.
7. Open the Invoice table in Datasheet view; notice that the table contains all the information you need to send an invoice. Then, close the Invoice table.
8. Create a query in Design view. Add the Invoice table and then add the Balance Due field to the design grid.
9. Create an Update Query. Then use the Update To row to increase the values in the Balance Due field by five percent. (Hint: Try using [Balance Due]*1.05.) Run the query, selecting Yes at the prompt.
10. Close the update query, saving it as Surcharge.
11. Open the Invoice table in Datasheet view; notice that the Balance Due field has been updated. Then, close the Invoice table.
12. Create a query in **Design** view. Add the **Interviews** table, and then add each field to the design grid, in the same order as in the table. Run the query and scroll to view the **Hire?** field. Then, return to **Design** view.

13. Have the query select only those records that have the **Hire?** field check box selected. *(Hint: Use a criteria of **true**.)* Run the query to view the results. Then, return to **Design** view.

14. Create an **Append Query** to the **Trainer** table. Then, run the append query. Select **Yes** to append the records.

15. Close the append query, saving it as **New Trainers**.

16. Open the **Trainer** table in **Datasheet** view to verify that the new records were added. Then, close the **Trainer** table.

17. Create a new query to remove all the newly hired trainers from the **Interviews** table, since they are now listed in the **Trainer** table. Add only the **Interviews** table to the query, and then add only the **Hire?** field to the design grid.

18. Add a criterion of **true** to the **Hire?** field. Create a delete query. Then, run the query, selecting **Yes** at the prompt.

19. Close the delete query, saving it as **Delete Hires**.

20. Open the **Interviews** table in **Datasheet** view to verify that the records were deleted. Then, close the **Interviews** table.

LESSON 6 -
USING ADVANCED QUERY WIZARDS

In this lesson, you will learn how to:

- Use the Crosstab Query Wizard
- Use the Find Duplicates Query Wizard
- Use the Find Unmatched Query Wizard
USING THE CROSSTAB QUERY WIZARD

Discussion

Crosstab queries are used to group and summarize information in a spreadsheet format. Crosstab queries make it easier to read and analyze selected data. The Crosstab Query Wizard provides a step by step process to help you quickly create a crosstab query, allowing you to enter information about the tables and fields you want to add to your query.

You must have three fields in a crosstab query. The values in the first field appear as row headings in the resultant spreadsheet, the values in the second field appear as column headings, and the calculation is performed on the values in the third field.

A crosstab query can display, for example, products sold (row headings) by sales representative (column headings); the number of products sold by each sales representative would appear at the intersection of the corresponding row and column.

A crosstab query recordset

You should select the field with the fewest values for the column headings; your resultant spreadsheet will have a less cluttered appearance.
Procedures

1. Display All Access Objects in the Navigation Pane.

2. Select the Query Wizard button in the Other group on the Create tab.


4. Select OK.

5. Select the desired table or query from the Which table or query contains the fields you want for the crosstab query results? list.

6. Select Next >.

7. Add the desired field you want to use as row headings to the Selected Fields list.

8. Select Next >.

9. Add the field you want to use as column headings from the Which field’s values do you want as column headings? list.

10. Select Next >.

11. Select the field on which you want to calculate from the Fields list.

12. Select the desired function from the Functions list.

13. Select Next >.

14. Type the desired query name.

15. Select Finish.

Step-by-Step

From the Student Data directory, open QWIZARD.ACCDB.
Create a crosstab query.

If necessary, display the All Access Objects in the Navigation Pane.
### Steps

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the <strong>Query Wizard</strong> button in the Other group on the Create tab. The New Query dialog box opens.</td>
<td>Click <strong>Query Wizard</strong></td>
</tr>
<tr>
<td>2. Select Crosstab Query Wizard. Crosstab Query Wizard is selected.</td>
<td>Click <strong>Crosstab Query Wizard</strong></td>
</tr>
<tr>
<td>3. Select OK. The New Query dialog box closes, and the Crosstab Query Wizard opens.</td>
<td>Click <strong>OK</strong></td>
</tr>
<tr>
<td>4. Select the desired table or query from the <strong>Which table or query contains the fields you want for the crosstab query results?</strong> list. The table or query is selected.</td>
<td>Click <strong>Table: Packing Slip</strong></td>
</tr>
<tr>
<td>5. Select Next. The next page of the Crosstab Query Wizard is displayed.</td>
<td>Click <strong>Next &gt;</strong></td>
</tr>
<tr>
<td>6. Add the field you want to use to as row headings to the <strong>Selected Fields</strong> list. The field is previewed.</td>
<td>Double-click <strong>Prod ID</strong></td>
</tr>
<tr>
<td>7. Select Next. The next page of the Crosstab Query Wizard is displayed.</td>
<td>Click <strong>Next &gt;</strong></td>
</tr>
<tr>
<td>8. Add the field you want to use as column headings from the <strong>Which field’s values do you want as column headings?</strong> list. The field is previewed in the Sample box.</td>
<td>Click <strong>Sales Rep</strong></td>
</tr>
<tr>
<td>9. Select Next. The next page of the Crosstab Query Wizard is displayed.</td>
<td>Click <strong>Next &gt;</strong></td>
</tr>
<tr>
<td>10. Select the field on which you want to calculate from the <strong>Fields</strong> list. The field is previewed and the corresponding functions appear in the <strong>Functions</strong> list.</td>
<td>Click <strong>Qty</strong></td>
</tr>
<tr>
<td>11. Select the desired function from the <strong>Functions</strong> list. The function appears in the preview.</td>
<td>Click <strong>Sum</strong></td>
</tr>
<tr>
<td>Steps</td>
<td>Practice Data</td>
</tr>
<tr>
<td>-------</td>
<td>---------------</td>
</tr>
</tbody>
</table>
| 12. Select Next.  
*The next page of the Crosstab Query Wizard appears, with the text in the What do you want to name your query? box selected.* | Click Next > |
| 13. Type the desired query name.  
*The name appears in the What do you want to name your query? box.* | Type Product Sales by Rep |
*The Crosstab Query Wizard closes, and the Crosstab Query recordset appears in Datasheet view.* | Click Finish |

Close Datasheet view.

### USING THE FIND Duplicates Query Wizard

#### Discussion

You can use the Find Duplicates Query Wizard to find duplicate records in a table. For instance, there may be identical records stored in a table, when only one record is necessary. The Find Duplicates Query Wizard will find the duplicate records so that you can delete them from the table.

#### Procedures

1. Display All Access Objects in the Navigation Pane.

2. Select the Query Wizard button in the Other group on the Create tab.


4. Select OK.

5. Select the desired table or query from the Which table or query do you want to search for duplicate field values? list.

6. Select Next >
7. Add the desired fields to the **Duplicate-value fields** list.

8. Select [Next >](#).

9. Add the desired fields to the **Additional query fields** list.

10. Select [Next >](#).

11. Type the desired query name.

12. Select [Finish](#).

---

**Step-by-Step**

Use the Find Duplicates Query Wizard.

If necessary, display **All Access Objects** in the Navigation Pane.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the **Query Wizard** button in the **Other** group on the **Create** tab.  
*The New Query dialog box opens.* | ![Query Wizard](#)  
Click |
| 2. Select Find Duplicates Query Wizard.  
*Find Duplicates Query Wizard is selected.* | ![Find Duplicates Query Wizard](#)  
Click |
| 3. Select **OK**.  
*The New Query dialog box closes, and the Find Duplicates Query Wizard opens.* | ![OK](#)  
Click |
| 4. Select the desired table or query from the **Which table or query do you want to search for duplicate field values?** list.  
*The table or query is selected.* | ![Table: Customers](#)  
Click |
| 5. Select **Next**.  
*The next page of the Find Duplicates Query Wizard is displayed.* | ![Next >](#)  
Click |
| 6. Add the desired fields to the **Duplicate-value fields** list.  
*The field appears in the **Duplicate-value fields** list.* | Double-click **Store Name** |
### Steps

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
</table>
| 7. | Select **Next**.  
*The next page of the Find Duplicates Query Wizard is displayed.*  
Click [Next >](#)  
| Practice Data |
|---|---|
|   |   |
| 8. | Add the desired fields to the **Additional query fields** list.  
*The fields appear in the Additional query fields list.*  
Follow the instructions shown below the table before continuing on to the next step  
|   |
| 9. | Select **Next**.  
*The next page of the Find Duplicates Query Wizard appears, with the text in the What do you want to name your query? box selected.*  
Click [Next >](#)  
|   |
| 10. | Type the desired query name.  
*The text appears in the What do you want to name your query? box.*  
Type **Duplicate Customers**  
|   |
| 11. | Select **Finish**.  
*The Find Duplicates Query Wizard closes, the query runs, and the recordset appears in Datasheet view.*  
Click [Finish](#)  
|   |

Add the following fields to the query: **Customer Number**, **Contact Name**, and **Phone Number**.

*Return to the table and continue on to the next step (step 9).*

Notice that four records appear in the recordset; there are two duplicate records in the **Customers** table. Then, close Datasheet view.

### Using the Find Unmatched Query Wizard

#### Discussion

The Find Unmatched Query Wizard helps you manage data in related tables. This wizard finds records that are “orphans,” meaning that they have no corresponding records in the related table. Suppose, for example, that you have deleted the records of inactive customers from a **Customers** table. Two years later, one of those customers places an order, which is entered into the **Orders** table. Because the **Customers** and **Orders** tables are related, however, having an order without the corresponding customer data will cause problems. You can use the Find Unmatched Query Wizard to correct the problem by updating the **Customers** table.
Unmatched records cannot occur if referential integrity is enforced in the table relationship.

Procedures

1. Display All Access Objects in the Navigation Pane.

2. Select the Query Wizard button in the Other group on the Create tab.


4. Select .

5. Select the desired table or query from the Which table or query contains records you want in the query results? list.

6. Select .

7. Select the related table or query from the Which table or query contains the related records? list.

8. Select .

9. Select the desired field in the Fields in list on the left.

10. Select the matching field in the Fields in list on the right.

11. Click the <= button .

12. Select .

13. Add the desired fields to the Selected fields list.

14. Select .

15. Type the desired query name.

Step-by-Step

Use the Find Unmatched Query Wizard.

If necessary, display All Access Objects in the Navigation Pane.
<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the **Query Wizard** button in the **Other** group on the **Create** tab.  
*The New Query dialog box opens.* | ![Query Wizard](Click) |
| 2. Select Find Unmatched Query Wizard.  
*Find Unmatched Query Wizard is selected.* | ![Find Unmatched Query Wizard](Click) |
| 3. Select **OK**.  
*The New Query dialog box closes, and the Find Unmatched Query Wizard opens.* | ![OK](Click) |
| 4. Select the desired table or query from the **Which table or query contains records you want in the query results?** list.  
*The table or query is selected.* | ![Table: Orders](Click) |
| 5. Select **Next**.  
*The next page of the Find Unmatched Query Wizard is displayed.* | ![Next >](Click) |
| 6. Select the related table or query from the **Which table or query contains the related records?** list.  
*The table or query is selected.* | ![Table: Customers](Click) |
| 7. Select **Next**.  
*The next page of the Find Unmatched Query Wizard is displayed.* | ![Next >](Click) |
| 8. Select the desired field in the **Fields in list** on the left.  
*The field is selected.* | ![Customer ID](Click), if necessary |
| 9. Select the matching field in the **Fields in list** on the right.  
*The field is selected.* | ![Customer Number](Click), if necessary |
| 10. Click the **<>** button.  
*The fields are matched.* | ![<>](Click) |
| 11. Select **Next**.  
*The next page of the Find Unmatched Query Wizard is displayed.* | ![Next >](Click) |
### Lesson 6 - Using Advanced Query Wizards

#### Access 2007 - Lvl 2

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>12. Add the desired fields to the <strong>Selected fields</strong> list.</td>
<td>Follow the instructions shown below the table before continuing on to the next step</td>
</tr>
<tr>
<td><em>The fields appear in the Selected fields list.</em></td>
<td></td>
</tr>
<tr>
<td>13. Select <strong>Next</strong>.</td>
<td>Click [Next &gt;]</td>
</tr>
<tr>
<td><em>The next page of the Find Unmatched Query Wizard appears, with the text in the What would you like to name your query? box selected.</em></td>
<td></td>
</tr>
<tr>
<td>14. Type the desired query name.</td>
<td>Type <strong>Unmatched Orders</strong></td>
</tr>
<tr>
<td><em>The text appears in the What would you like to name your query? box.</em></td>
<td></td>
</tr>
<tr>
<td>15. Select <strong>Finish</strong>.</td>
<td>Click [Finish]</td>
</tr>
<tr>
<td><em>The Find Unmatched Query Wizard closes, the query runs, and the recordset appears in Datasheet view.</em></td>
<td></td>
</tr>
</tbody>
</table>

Add the following fields to the query: **Customer ID**, **Order Number**, and **Order Date**.

*Return to the table and continue on to the next step (step 13).*

**Note:** If you were running this query in a working or live database, the records that appear in this query would need to be corrected to ensure database integrity.

Close **Datasheet** view.
Close **QWIZARD.ACCDB**.
EXERCISE

USING ADVANCED QUERY WIZARDS

Task

Use advanced query wizards.

1. Open QWIZARD1X.ACCDB.

2. Create a crosstab query from the existing Sales by Rep query. Use the Client ID field for the row headings and the Sales Rep field for the column headings. Have the calculated value be the sum of the Total Sales field.

3. Name the query Total Sales by Sales Rep, and select the option to view the query. After you have viewed the recordset, close the query.

4. Use the Find Duplicates Query Wizard to locate any duplicate records in the Client table. Select the Client Name, Address, and City fields as possible duplicate-value fields. Do not select any additional fields to show in the query.

5. Name the query Find Duplicate Clients and select the option to view the query. Notice that two duplicate records were found. Close the query.

6. Use the Find Unmatched Query Wizard to find any projects in the Project table that have no record of payment in the Payment table. Select the Project ID field as the matching field for the two tables, if necessary. Then, have the Client ID, Course Name, and End Date fields also display in the query.

7. Name the query No Record of Payment and select the option to view the results. After you have viewed the recordset, close the query.

LESSON 7 - USING ADVANCED DATABASE FEATURES

In this lesson, you will learn how to:

- Import data
- Link data to an Access table
- Use the Linked Table Manager
- Export data
- Convert files
- Print a relationship document
- Compact a database
- Use Name AutoCorrect
- Back up a database
IMPORTING DATA

Discussion

You can import data from one or more external data sources. The external data source can be another Access database, a database created in a different program (such as dBASE or Excel), ASCII text, or an HTML data table.

When you import data from a spreadsheet, another type of database, or ASCII text, a wizard opens to step you through the process. The format of the data in the external data source does not change. You can use Access to add, edit, or delete the data.

If the external data source is an Access database, you can also import database objects such as queries, reports, and forms. This option allows you to copy a query from one database to another and modify it as necessary, rather than creating a new one. In addition, you can easily copy standard reports and forms between databases.

Using the Import Text Wizard

If the table you import has a lookup field, you should also import the source of the information for the lookup field.
Procedures

1. Select the **External Data** tab on the **Ribbon**.
2. Select the desired file type button from the **Import** group.
3. Select the **Browse** button.
4. Select the drive where the source data is stored.
5. Open the folder where the source data is stored.
6. Select the file containing the source data.
7. Select **OK**.
8. Select the appropriate data format.
9. Select **Next >**.
10. Select the appropriate delimiter.
11. Select the **First Row Contains Field Names** option, if applicable.
12. Select **Next >**.
13. Modify field options as desired, and select **Next >**.
14. Select the desired primary key option.
15. Select **Next >**.
16. Enter the desired table name.
17. Select **Finish**.
18. Select **Close**.

Step-by-Step

From the Student Data directory, open **ADVDAT1.ACCDB**.
Import data from an external data source into the current database.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the **External Data** tab on the **Ribbon**.  
*The External Data tab is displayed.* | Click **External Data** |
<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>2. Select the desired file type button from the <strong>Import</strong> group. The Get External Data - &lt;data source name&gt; dialog box opens.</td>
<td>Click <img src="" alt="Text File" /></td>
</tr>
<tr>
<td>3. Select the <strong>Browse</strong> button. A list of available drives is displayed.</td>
<td>Click <img src="" alt="Browse..." /></td>
</tr>
<tr>
<td>4. Select the drive where the source data is stored. A list of available folders is displayed.</td>
<td>Click the student data drive</td>
</tr>
<tr>
<td>5. Open the folder where the source data is stored. A list of available folders and files is displayed.</td>
<td>Double-click the student data folder</td>
</tr>
<tr>
<td>6. Select the file containing the source data. The file is selected.</td>
<td>Click STORENAM.TXT</td>
</tr>
<tr>
<td>7. Select <strong>OK</strong>. The Get External Data - &lt;data source name&gt; dialog box closes, and the Import Text Wizard dialog box opens.</td>
<td>Click <img src="" alt="OK" /></td>
</tr>
<tr>
<td>8. Select the appropriate data format. The data format is selected.</td>
<td>Click <img src="" alt="Delimited, if necessary" /></td>
</tr>
<tr>
<td>9. Select <strong>Next</strong>. The next page of the Import Text Wizard is displayed.</td>
<td>Click <img src="" alt="Next &gt;" /></td>
</tr>
<tr>
<td>10. Select the appropriate delimiter. The delimiter is selected.</td>
<td>Click <img src="" alt="Comma, if necessary" /></td>
</tr>
<tr>
<td>11. Select the <strong>First Row Contains Field Names</strong> option, if applicable. The <strong>First Row Contains Field Names</strong> option is selected.</td>
<td>Click <img src="" alt="First Row Contains Field Names" /></td>
</tr>
<tr>
<td>12. Select <strong>Next</strong>. The next page of the Import Text Wizard is displayed.</td>
<td>Click <img src="" alt="Next &gt;" /></td>
</tr>
<tr>
<td>13. Modify field options as desired, and select <strong>Next</strong>. The options are modified accordingly, and the next page of the Import Text Wizard appears.</td>
<td>Click <img src="" alt="Next &gt;" /></td>
</tr>
</tbody>
</table>
### Steps

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>14. Select the desired primary key option.</td>
<td>Click ☐ No primary key.</td>
</tr>
<tr>
<td><em>The primary key option is selected.</em></td>
<td></td>
</tr>
<tr>
<td>15. Select Next.</td>
<td>Click Next &gt;</td>
</tr>
<tr>
<td><em>The next page of the Import Text Wizard appears with the insertion point in the Import to Table box.</em></td>
<td></td>
</tr>
<tr>
<td>16. Enter the desired table name.</td>
<td>Type Store Name by Rep</td>
</tr>
<tr>
<td><em>The text appears in the Import to Table box.</em></td>
<td></td>
</tr>
<tr>
<td>17. Select Finish.</td>
<td>Click Finish</td>
</tr>
<tr>
<td><em>The Import Text Wizard message box notifies you when it has completed importing the file.</em></td>
<td></td>
</tr>
<tr>
<td>18. Select Close.</td>
<td>Click Close</td>
</tr>
<tr>
<td><em>The Import Text Wizard and the Import Text Wizard message box close.</em></td>
<td></td>
</tr>
</tbody>
</table>

Open the Store Name by Rep table in Datasheet view. Then, close the table.

---

## LINKING DATA TO AN ACCESS TABLE

### Discussion

You can link to an external data source, such as another Access database or a database created in a different program (e.g., dBASE or Excel). You can also link to HTML data tables on a network server or on the Internet.

When you link to an external data source, the format of the data in the data source does not change, although you can use Access to add, edit, or delete the data.

A linked table displays a special icon in the Database window. A table linked to another Access database has an arrow to the left of the icon. A table linked to a source created in a different program displays an arrow and the initials of the source program (e.g., Px for Paradox).

Linking tables is useful when you want to share data on a network. If you link to a table on a network, the link ensures that the data you are viewing is always the latest available.
When you delete a linked table, you are deleting the icon and the link to the source table, not the source table itself.

Procedures

1. Select the External Data tab.
2. Select the desired link button in the Import group.
3. Select Browse...
4. Select the drive where the source data is stored.
5. Open the folder where the source data is stored.
6. Select the file containing the source data.
7. Select the desired link option.
8. Select OK.
9. Select the table containing the source data.
10. Select OK.

Step-by-Step

Link to an Access table.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the External Data tab.  
The External Data tab is displayed. | Click External Data                                |
| 2. Select the Access button in the Import group.  
The Get External Data - <data source name> dialog box opens. | Click Access                                      |
| 3. Select Browse.  
A list of available drives is displayed. | Click Browse...                                    |
| 4. Select the drive where the source data is stored.  
A list of available folders is displayed. | Click the student data drive                       |
### Steps

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>5. Open the folder where the source data is stored.</td>
<td>Double-click the student data folder</td>
</tr>
<tr>
<td>A list of available folders and files is displayed.</td>
<td></td>
</tr>
<tr>
<td>6. Select the file containing the source data.</td>
<td>Double-click EXTERNAL.ACCDB</td>
</tr>
<tr>
<td>The file is selected.</td>
<td></td>
</tr>
<tr>
<td>7. Select the desired link option.</td>
<td>Click <img src="image" alt="Link to the data source by creating a linked table" /></td>
</tr>
<tr>
<td>The desired option is selected</td>
<td></td>
</tr>
<tr>
<td>8. Select <strong>OK</strong>.</td>
<td>Click <img src="image" alt="OK" /></td>
</tr>
<tr>
<td>The Get External Data - <code>&lt;data source name&gt; dialog box closes, and the Link Tables dialog box opens.</code></td>
<td></td>
</tr>
<tr>
<td>9. Select the table containing the source data.</td>
<td>Click <img src="image" alt="Store Location" /></td>
</tr>
<tr>
<td>The table is selected.</td>
<td></td>
</tr>
<tr>
<td>10. Select <strong>OK</strong>.</td>
<td>Click <img src="image" alt="OK" /></td>
</tr>
<tr>
<td>The Link Tables dialog box closes, and the linked table appears in the Navigation pane.</td>
<td></td>
</tr>
</tbody>
</table>

Open the **Store Location** table in **Datasheet** view to view its data. Then, close the table.

### Using the Linked Table Manager

#### Discussion

You can use the Linked Table Manager to view, refresh, or correct the file name and/or path of a linked table. If the structure of a linked table changes, for example, you can use the Linked Table Manager to refresh the link. In addition, if a linked table is moved to a different location, you can use the Linked Table Manager to correct the path and reestablish the link.
The Linked Table Manager does not physically move database files or tables; it only refreshes or corrects the link information.

If you change the name of a table after it has been linked, the Linked Table Manager will not be able to refresh the links. In this case, you must delete the link and create a new one.

Procedures

1. Select the Database Tools tab on the Ribbon.

2. Select the Linked Table Manager button in the Database Tools group.

3. Select the linked table you want to update.

4. Select OK.

5. Select the drive where the file is stored.

6. Open the folder where the file is stored.

7. Select the name of the file containing the linked table.

8. Select Open.

9. Select OK.
10. Select Close.

**Step-by-Step**

Use the Linked Table Manager to correct the path of a linked table.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the **Database Tools** tab on the **Ribbon**.  
*The Database Tools tab is displayed.* | Click **Database Tools** |
| 2. Select the **Linked Table Manager** button in the **Database Tools** group.  
*The Linked Table Manager opens, displaying all linked tables with their corresponding paths.* | Click **Linked Table Manager** |
| 3. Select the linked table you want to update.  
*The table is selected.* | Click **Packing Slip** |
| 4. Select **OK**.  
*The Select New Location of <table name> dialog box opens.* | Click **OK** |
| 5. Select the drive where the file is stored.  
*A list of available folders is displayed.* | Click the student data drive. |
| 6. Open the folder where the file is stored.  
*A list of available folders and files is displayed.* | Double-click the student data folder |
| 7. Select the name of the file containing the linked table.  
*The file is selected.* | Click **WORLDLNK.ACCDB** |
| 8. Select **Open**.  
*The Select New Location of <table name> dialog box closes, and a Linked Table Manager message box informs you that all linked tables have been successfully refreshed.* | Click **Open** |
| 9. Select **OK**.  
*The Linked Table Manager message box closes.* | Click **OK** |
### EXPORTING DATA

#### Discussion

You can export data and database objects to a variety of supported databases, programs, and file formats. For example, you can export data to another program (such as dBASE or Excel), to ASCII text, or to an HTML data table. You can also export most database objects from a Microsoft Access database to another Access database. The process of exporting data and database objects is very similar in functionality to copying and pasting.

The following table lists some of the data formats to which you can export:

<table>
<thead>
<tr>
<th>Application</th>
<th>Supported Version or Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft Access database</td>
<td>Access 2.0, 7.0/95, 8.0/97, 9.0/2000, 10.0/Access 2002, and Access 2003</td>
</tr>
<tr>
<td>dBase</td>
<td>III, IV and 5, (Requires Borland Database Engine 4.x or later)</td>
</tr>
<tr>
<td>Paradox, Paradox for Windows</td>
<td>3.x, 4.x, 5.0, 7.0 and 8.0 (Requires Borland Database Engine 4.x or later)</td>
</tr>
<tr>
<td>Microsoft Excel</td>
<td>3.0, 4.0, 5.0, 7.0/95, 8.0/97, 9.0/2000, 10.0/Excel 2002, and Excel 2003</td>
</tr>
<tr>
<td>Microsoft Word, Rich Text Format</td>
<td>All</td>
</tr>
<tr>
<td>Lotus 1-2-3</td>
<td>wk1 and .wk3</td>
</tr>
<tr>
<td>Delimited text files</td>
<td>All</td>
</tr>
<tr>
<td>XML document</td>
<td>All</td>
</tr>
</tbody>
</table>

When exporting database objects to another database, you can only export one object at a time. If you need to export multiple objects to a database, it may be more efficient to open the database to which you want to export and import the objects.
When you export an object to another database, it might be helpful to export all related objects to ensure full functionality. For example, a report is usually based on a query, and a query is based on one or more tables.

Procedures

1. Select All Access Objects on the Navigation Pane, if necessary.
2. Select the database object you want to export.
3. Select the External Data tab on the Ribbon.
4. Select the desired export button in the Export group.
5. Select Browse...
6. Select the drive where the file to which you want to export is stored.
7. Open the folder where the desired file is stored.
8. Double-click the desired file.
9. Select OK.
10. Enter the desired name for the database object.
11. Select OK.

Step-by-Step

Export a table to another Access database.

If necessary, display the All Access Objects on the Navigation pane.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the database object you want to export. The database object is selected.</td>
<td>Click the Reps table</td>
</tr>
<tr>
<td>2. Select the External Data tab on the Ribbon. The External Data tab is displayed.</td>
<td>Click External Data</td>
</tr>
</tbody>
</table>
### Steps

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 3.   | Select the **More** button in the **Export** group.  
      *A list of export options is displayed.* | Click ![More button](image) |
| 4.   | Select the desired export option.  
      *The desired export dialog box opens.* | Click ![Export button](image) |
| 5.   | Select **Browse**.  
      *A list of available drives is displayed.* | Click ![Browse button](image) |
| 6.   | Select the drive where the file to which you want to export is stored.  
      *A list of available folders is displayed.* | Click the student data drive |
| 7.   | Open the folder where the desired file is stored.  
      *A list of available folders and files is displayed.* | Double-click the student data folder |
| 8.   | Select the desired file.  
      *The file is selected.* | Double-click **EMPLOYEE.ACCDB** |
| 9.   | Select **OK**.  
      *The Export Access Database dialog box closes and the Export dialog box opens.* | Click ![OK button](image) |
| 10.  | Enter the desired name for the database object.  
      *The text appears in the **Export Reps to** box.* | Type **Names** |
| 11.  | Select **OK**.  
      *The Export dialog box closes, and the table is exported.* | Click ![OK button](image) |
| 12.  | Select **Close**.  
      *The Export Access Database dialog box closes.* | Click ![Close button](image) |

Open the **Employee** database from the student data folder. Notice that the **Names** table appears in the **Tables** object list. 
Close **EMPLOYEE.ACCDB**.
CONVERTING FILES

Discussion


Whenever you open a database created in an earlier version of Access, you are given an opportunity to convert the database.

You should always make a copy of your Microsoft Access database before you convert it. This step will ensure that your original file is still intact, should you encounter a problem during the conversion process.

When you convert a previous-version Microsoft Access database that contains linked tables, make sure that the external tables have not been moved; if Microsoft Access cannot find the linked tables, you will not be able to use the converted database.

Procedures

1. Click the Office button .
2. Select Convert .
3. Select the drive where the file you want to save the converted file.
4. Open the folder in which the file you want to save the converted file.
5. Type the desired file name in the File name box.
6. Select Save .
7. Select OK .
Step-by-Step

From the Student Data directory, open ADVDAT2.MDB. Convert an Access 2003 database.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Office button. &lt;br&gt; <em>The Office menu opens.</em></td>
<td>Click</td>
</tr>
<tr>
<td>2. Select the Convert option. &lt;br&gt; <em>The Save As dialog box opens.</em></td>
<td>Click</td>
</tr>
<tr>
<td>3. Select the drive where you want to save the converted file. &lt;br&gt; <em>A list of available folders appears.</em></td>
<td>Click the student data drive</td>
</tr>
<tr>
<td>4. Open the folder in which you want to save the converted file. &lt;br&gt; <em>A list of available folders and files appears.</em></td>
<td>Double-click the student data folder</td>
</tr>
<tr>
<td>5. Type the desired file name in the File name box. &lt;br&gt; <em>The text appears in the File name box.</em></td>
<td>Type AdvDat2</td>
</tr>
<tr>
<td>6. Select Save. &lt;br&gt; <em>Access converts the database, and a Microsoft Office Access warning box opens.</em></td>
<td>Click</td>
</tr>
<tr>
<td>7. Select OK. &lt;br&gt; <em>The Microsoft Office Access warning box closes.</em></td>
<td>Click</td>
</tr>
</tbody>
</table>

PRINTING A RELATIONSHIP DOCUMENT

Discussion

It is a good idea to document your database structure and relationships. The Documenter feature in Access allows you to view, print, and save the design characteristics of database objects. You can view and print such information as the properties associated with tables, queries, forms, and reports. This type of information is very useful for deciding what changes you want to make or when you have to maintain a database that was developed by someone else.
Although the Relationship window is a good way to view table relationships, as well as join lines and types, you cannot print from it. The Documenter feature allows you to print the relationships between tables in your database. The relationship report that the Documenter feature produces provides information on related tables, their attributes, and the type of relationship, which in turn, provides you with all the information you need to analyze your database table relationships.

 Procedures

1. Select the Database Tools tab on the Ribbon.
2. Select the Database Documenter button in the Analyze group.
3. Select the Current Database tab.
4. Select the Relationships option.
5. Select OK.
6. Select the Office button.
7. Select Print.
8. Select OK.

 Step-by-Step

Print a relationship document.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Database Tools tab on the Ribbon. The Database Tools tab is displayed.</td>
<td>Click Database Tools</td>
</tr>
<tr>
<td>2. Select the Database Documenter button in the Analyze group. The Documenter dialog box opens.</td>
<td>Click ![Database Documenter]</td>
</tr>
<tr>
<td>4. Select the Current Database tab. The Current Database page appears.</td>
<td>Click the Current Database tab</td>
</tr>
<tr>
<td>5. Select the Relationships option. The Relationships option is selected.</td>
<td>Click ![Relationships]</td>
</tr>
<tr>
<td>Steps</td>
<td>Practice Data</td>
</tr>
<tr>
<td>-------</td>
<td>---------------</td>
</tr>
</tbody>
</table>
| 6. Select **OK**.  
*The Documenter dialog box closes, and the relationship report appears in print preview.* | Click [OK] |
| 7. Select the **Office** button.  
*The Office menu is displayed.* | ![Office button] |
| 8. Select **Print**.  
*The print dialog box opens.* | ![Print button] |
| 9. Select **OK**.  
*Access prints the desired document.* | Click [OK] |

Close print preview.

## COMPACTING A DATABASE

### Discussion

When you delete tables and other objects in a database, the database size on the disk does not necessarily decrease. Access provides a utility that compacts (defragments) the database, thereby releasing storage space.

You can create a copy of the original database by saving the compacted database with a different name or to a different location. Although you can compact the current database while it is open, the database must be closed in order to make a copy.

### Procedures

1. Open the database you want to compact.

2. Select the **Office** button.

3. Select **Manage**.

4. Select the **Compact and Repair Database** button.
**Step-by-Step**

Compact a database.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the **Office** button.  
*The Office menu opens.* | Click |
| 2. Select **Manage**.  
*The Manage options are displayed.* | Click |
| 3. Select the **Compact and Repair Database** button.  
*Access compacts and repairs the database.* | Click |

**USING NAME AUTOCORRECT**

**Discussion**

The **Name AutoCorrect** feature automatically fixes inconsistencies that can occur when you rename tables, forms, reports, queries, fields, or other controls in an Access database.

The **Name AutoCorrect** options must be enabled, however. The **Track name AutoCorrect info** option saves information about changes, but does not automatically repair the inconsistencies. When the **Perform name AutoCorrect** option is enabled, Access automatically corrects any differences between related objects. Furthermore, if you enable both options, you can also enable the **Log name AutoCorrect changes** option, which creates a table named **Name AutoCorrect Log** that documents changes.

Name AutoCorrect is enabled by default for new Access 2007 databases. However, if you are working in a converted database, you must manually enable it.
Selecting Name AutoCorrect options

Changes made to forms, reports, or other objects must be saved before Name AutoCorrect can fix related objects.

You must have permission to modify the design of an object in order to save changes.

Procedures

1. Select the **Office** button.
2. Select **Access Options**.
3. Select the **Current Database** option.
4. Select the **Track name AutoCorrect info** option.
5. Select **OK**.
6. Select additional options under **Name AutoCorrect** as desired.
7. Select **OK**.
Step-by-Step

Use Name AutoCorrect.

Open the Customers table in Design view and change the Store Name field to Store. Close the Customers table, saving the changes. Then, open the Customers form in Form view; notice that Access is unable to find values for the Store Name field. Close the Customers form.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Office button. <em>The Office menu opens.</em></td>
<td>Click</td>
</tr>
<tr>
<td>2. Select the Access Options button. <em>The Access Options dialog box opens.</em></td>
<td>Click Access Options</td>
</tr>
<tr>
<td>3. Select the Current Database option. <em>The Current Database page is displayed.</em></td>
<td>Click Current Database</td>
</tr>
<tr>
<td>4. Scroll as necessary and select the Track name AutoCorrect info option. <em>The Track name AutoCorrect info option is selected and a Microsoft Office Access warning box opens, telling you that it may take several minutes to generate the name maps.</em></td>
<td>Click Track name AutoCorrect info</td>
</tr>
<tr>
<td>5. Select OK. <em>The Microsoft Office Access warning box closes.</em></td>
<td>Click OK</td>
</tr>
<tr>
<td>6. Select additional options under Name AutoCorrect as desired. <em>The options are selected.</em></td>
<td>Click Perform name AutoCorrect</td>
</tr>
<tr>
<td>7. Select OK. <em>The Access Options dialog box closes.</em></td>
<td>Click OK</td>
</tr>
</tbody>
</table>

View the Reps form in Form view; then, close the Reps form. Open the Reps table in Design view and change the FIRST_NAME field to FirstN. Close the table and save the changes. Open the Reps form again in Design view. Notice that Access automatically corrected the name of the source data for the FIRST_NAME field. Switch to Form view; notice that there are no error messages. Access has corrected the field name discrepancy.

Close the Reps form.
Discussion

It is important to backup your database on a regular basis. Most companies have a backup process to ensure that all data is saved at least once a day; consequently, all databases shared on a company network server are backed up daily as well.

Your database may be saved to the hard drive of a personal computer, another available drive, or removable media (a CD or USB flash drive for example). Backing up your hard drive ensures that all data, queries, forms and reports in your database are saved. As a result, you can recover your database if something were to happen to it.

Procedures

1. Select the Office button.

2. Select Manage.

3. Select Back Up Database.

4. Select the desired drive/folder where you want to back up your data.

5. Rename your backup database, if desired, and click Save.

Step-by-Step

Backup a database

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Office button.</td>
<td>Click</td>
</tr>
<tr>
<td><em>The Office menu opens.</em></td>
<td></td>
</tr>
<tr>
<td>2. Select the Manage option.</td>
<td>Click</td>
</tr>
<tr>
<td><em>The Manage options are displayed.</em></td>
<td></td>
</tr>
<tr>
<td>3. Select Back Up Database.</td>
<td>Click Back Up Database</td>
</tr>
<tr>
<td><em>The Save As dialog box opens.</em></td>
<td></td>
</tr>
</tbody>
</table>
### Steps

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>4. Select the desired drive/folder where you want to back up your data. The desired location is selected.</td>
<td>Select the <strong>Student Drive</strong></td>
</tr>
<tr>
<td>5. Rename your backup database, if desired, and click <strong>Save</strong>. The backup database is saved in the desired location.</td>
<td>Click <img src="image" alt="Save" /></td>
</tr>
</tbody>
</table>

Close **ADVDAT2.ACCDB**.
EXERCISE

USING ADVANCED DATABASE FEATURES

Task

Use advanced database features.

1. Open ADVDATX.ACCDB.

2. Print a relationship document. Then, close the print preview, Report, and the Relationships windows, as needed; do not save the changes.

3. Import the Sales by Rep 2 query from QWIZARD1X.ACCDB.

4. Add a link to the Sales table in QWIZARD1X.ACCDB.

5. Open the Linked Table Manager and update the link to the Types table. Correct its path to QWIZARD1X.ACCDB in the student data folder. Then, select OK as necessary and close the Linked Table Manager.

6. Make sure that the Name AutoCorrect option is enabled. Then, change the name of the LAST_NAME field in the Reps table to LastN and close the Reps table, saving the changes.

7. Open the Reps form in Design view. Notice that, although the label in the Form Header area has not changed, the control source in the Detail area has been corrected to LastN. Close the Reps form.

8. Compact ADVDATX.ACCDB. Then, close ADVDATX.ACCDB.


10. Export the Customer Addresses query to ADVDATX.ACCDB; accept the default name.

LESSON 8 -
USING CONTROLS AND LAYOUTS

In this lesson, you will learn how to:

- Switch views
- Use controls
- Use control layouts
- Use a stacked layout
- Use a tabular layout
- Remove a control from a layout
- Move controls
- View the properties of an object
- Change a control property
SWITCHING VIEWS

Discussion

After you create a form or report, you can view it in a selection of different views: **Report View**, **Print Preview**, **Layout View**, or **Design View**. When a form or report is open, you can switch between these views by clicking the **View** button in the **Views** group on the **Home** tab on the **Ribbon**. The following table explains the different views:

<table>
<thead>
<tr>
<th>View</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report View</td>
<td>This view displays the report as you (or the Report Wizard) designed it.</td>
</tr>
<tr>
<td>Print Preview</td>
<td>This view allows you to view the print layout of your report.</td>
</tr>
<tr>
<td>Layout View</td>
<td>This view looks like <strong>Print Preview</strong>, but allows you to make changes to your report.</td>
</tr>
<tr>
<td>Design View</td>
<td>Displays the report in the <strong>Design View</strong> window, where you can change form elements, move them around and add or delete them, if necessary.</td>
</tr>
</tbody>
</table>

A report in Design view
Procedures

1. Open the desired form or report.

2. Select the View button on the Home tab.

3. Select the desired view.

Step-by-Step

From the Student Data directory, open LAYOUT1.ACCDB. Switch the view.

Open the Line Items report, if necessary.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the View button on the Home tab.  

   *The View drop-down menu is displayed.* | Click |
| 2. Select Design view.  

   *The view changes to layout view.* | Click |

Practice the concept: Follow the above steps and select Layout view.

Close the report.

Using Controls

Discussion

When you create forms or reports in Design view, you work with controls. Controls are objects in a form or report that contain information. Forms and reports usually include bound text box controls and unbound label controls.

Text box controls display data from fields in a table or query on which a form or report is based. Text boxes are also used as entry fields for data in a form. Text boxes are known as bound controls because the source of the data is stored in a specific field in a table.
When you add a control to a form, you decide where the control gets the information it displays. For example, a bound text box control can be added that displays a name from the Name field in an address table. The bound text box control gets the values from the Name field because you have connected or bound it to that field.

Label controls are unbound controls. They display information that is not stored in a table. Unbound controls can be text, images, lines, or rectangles drawn on the design. Unbound controls are often paired with bound controls as labels. Unbound controls are also used to enhance a form or report, or to provide more information, such as instructions for entering data.

Text box and label controls are automatically added to a form created using the Form Wizard. However, you can use the toolbox in Design view to add other controls to a form or report. These controls include list boxes, combo boxes, drop-down list boxes, command buttons, check boxes, option buttons, option groups, toggle buttons, and tabs.

Calculated controls derive their information using an expression to manipulate the table data on which a form is based. For example, you can display an order total on a form that is calculated by multiplying the Unit Price and the Quantity fields in an Orders table. Calculated controls are unbound since the result of the calculation is not stored in a table.

**USING CONTROL LAYOUTS**

**Discussion**

When editing forms or reports in Access 2007, you can now group your form controls into one layout, and manipulate them as a unit. Control layouts align your controls and their respective labels vertically and horizontally, to give your form a uniform appearance.

There are two types of control layout: stacked and tabular.

You can use multiple layouts on a form or report.
**USING A STACKED LAYOUT**

**Discussion**

In stacked layouts, controls are arranged vertically, with the label to the left of each control.

Access automatically creates stacked layouts when you create a new form by using the **Form** button, the **Blank form** button, or the **Form Wizard** button in the **Forms** group on the **Create** tab.

![A stacked layout](image)

**Procedures**

1. Open the desired form or report in design view.
2. Click on the desired control.
3. Hold down the **[Shift]** key and select the other controls you want to add to the layout.

Stacked layouts are always contained within a single form section.
4. Select the Stacked button in the Control Layout group on the Arrange tab.

**Step-by-Step**

Create a stacked layout.

Open the Customer Data Entry form in Design view, if necessary.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Click on the desired control.</td>
<td>Click Customer Number</td>
</tr>
<tr>
<td><em>The control is highlighted.</em></td>
<td></td>
</tr>
<tr>
<td>2. Hold down the [Shift] key and select the other controls you want to</td>
<td>Hold down [Shift] and select Store Name and Contact Name</td>
</tr>
<tr>
<td>add to the layout</td>
<td></td>
</tr>
<tr>
<td><em>Access highlights all the controls within the layout.</em></td>
<td></td>
</tr>
<tr>
<td>3. Select the desired layout in the Control Layout group on the</td>
<td>Click Stacked</td>
</tr>
<tr>
<td>Arrange tab.</td>
<td></td>
</tr>
<tr>
<td><em>The selected controls are added to a stacked control layout.</em></td>
<td></td>
</tr>
</tbody>
</table>

Notice you can now move the controls in the layout as one unit. Drag the layout up approximately one inch to just below the form header.

Close the form without saving.

**USING A TABULAR LAYOUT**

**Discussion**

In tabular layouts, controls are arranged like a spreadsheet in columns and rows, with labels at the top. Access automatically creates a tabbed layout when you create a new report by using the Report button or the Blank Report button in the Reports group on the Create tab.
Procedures

1. Open the desired form or report in **Design** view.

2. Click on the desired control.

3. Hold down the [Shift] key and select the other controls you want to add to the layout.

4. Select the **Tabular** button in the **Control Layout** group on the **Arrange** tab.

---

Step-by-Step

Create a tabular layout.

Open the **Line Items** report in **Design** view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Click on the desired control.  
*The control is highlighted.* | Click **Order Number** |
| 2. Hold down the [Shift] key and select the other controls you want to add to the layout.  
*Access highlights all the controls within the layout.* | Hold down [Shift] and select **Product ID** and **Quantity** |
| 3. Select the **Tabular** button in the **Control Layout** group on the **Arrange** tab.  
*The selected controls are added to a tabular control layout.* | Click **Tabular** |

Notice, you may need to reduce the size of your control fields in order to fit the page.
Removing a Control from a Layout

Discussion

You can remove one or more controls from a layout and place them anywhere on the form without affecting the position of the other controls.

Procedures

1. Open the desired form.
2. Select the desired control.
3. Select the Arrange tab, if necessary.
4. Select the Remove button in the Control Layout group on the Arrange tab.

Step-by-Step

Remove a control from a layout

Open the Items form in Design view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the desired control.  
*The control options menu is displayed.* | Click **Product ID** |
| 2. Select the desired layout.  
*The desired layout is selected.* | Click **+** |
| 3. Select the Arrange tab, if necessary.  
*The Arrange tab is displayed.* | Click **Arrange** |
| 4. Select the Remove button in the Control Layout group.  
*The control is removed from the layout.* | Click **Remove** |

Notice that you can now move the controls individually.
**MOVING CONTROLS**

**Discussion**

You can move a paired bound and unbound control (i.e., a field text box and its label) as a single unit to any location in a form or report in **Design** view. When you move one control in a pair, its corresponding control automatically moves along with it. Moving controls can improve the appearance and efficiency of forms and reports. The controls must be selected before you can move them.

If you want to move both the bound and unbound controls as a single unit, be careful that you do not drag a control by either of the large move handles in the upper left corner of the selected controls. If you do, the mouse pointer changes into a pointing hand instead of an open hand and the paired bound and unbound controls are moved individually, rather than as a single unit.

You can move selected controls with the keyboard by pressing the **[Up]**, **[Down]**, **[Left]**, or **[Right]** arrow keys. The selected objects move to the next grid point. Holding the **[Ctrl]** key while dragging temporarily suspends the **Snap to Grid** feature and allows you to freely position a control.

To move a control while keeping it in the same horizontal or vertical position, hold the **[Shift]** key and click the control, and then drag the control by its move handle either horizontally or vertically. The first direction you drag determines which position will be maintained.

**Procedures**

1. Open the desired form or report in **Design** view.
2. Point to a blank area just above and to the left of the first control you want to select and drag down and to the right to create a box around the desired control(s).
3. Point to the edge of one of the selected controls.
4. Drag the controls to the desired location.
Step-by-Step

Move selected controls.

If you have not been using the Customer Sales form, open the Customer Sales 3 form in Design view.

If necessary, resize the window to view all the fields. Resize the design grid by dragging the right edge of the grid to 12cms on the horizontal ruler.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Point to a blank area just above and to the left of the first control you want to select and drag down and to the right to create a box around the desired control(s). An image of a box appears as you drag and then sizing handles appear around the selected control(s).</td>
<td>Drag to select the Sales to Date and Sales Rep labels and text boxes</td>
</tr>
<tr>
<td>2. Point to the edge of one of the selected controls. The mouse pointer changes into a black, open hand.</td>
<td>Point to the edge of the Sales to Date text box or label</td>
</tr>
<tr>
<td>3. Drag the controls to the desired location. An image of the control(s) appears as you drag and then the control(s) appear in the new location.</td>
<td>Drag the Sales to Date and Sales Rep controls up and to the right, aligning the top edge of the Sales to Date control with the top edge of the Customer Number control</td>
</tr>
</tbody>
</table>

With the controls still selected, use the arrow keys on the keyboard to position the controls as necessary.

Click in a blank area of the form to deselect the controls. Switch to Form view to see the results. Then, switch back to Design view.

**VIEWING THE PROPERTIES OF AN OBJECT**

Discussion

Every object in Access has properties that define its characteristics. Database objects, such as tables, queries, and forms, have very general properties, such as their name and description. Other objects, such as fields in a table or controls on a form, have
many properties that control their appearance, such as font size and color, the number of decimal places, and the control source. You can change the properties of the objects on a form or report in Design view using the Property Sheet. The properties displayed on the Property Sheet depend on what type of object is selected. For example, the properties for a label box differ from the properties for the Detail section of a form. You can also change the properties for page and form headers and footers.

The properties of objects are grouped into five categories:

<table>
<thead>
<tr>
<th>Category</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Format</td>
<td>Specifies the appearance of objects, such as the font characteristics, position and size of a text box, or whether or not scroll bars appear on a form.</td>
</tr>
<tr>
<td>Data</td>
<td>Determines the characteristics of the data displayed, such as the data’s control source, default value, or whether or not it can be edited. You can change the data source for an individual control or for the entire form.</td>
</tr>
<tr>
<td>Event</td>
<td>Specifies a procedure that Access executes when an event occurs. Some examples of events include clicking a control (OnClick), deleting data (OnDelete), and opening the form (OnOpen). The procedure can be an expression, a macro, or a Visual Basic for Access routine.</td>
</tr>
<tr>
<td>Other</td>
<td>Shows additional features of the control, such as the name of the control or whether or not a control is in the tab order.</td>
</tr>
<tr>
<td>All</td>
<td>Displays all the properties of the object in one list.</td>
</tr>
</tbody>
</table>

You can open the Property Sheet by pressing [F4] on the keyboard.

Procedures

1. Open the desired form or report in Design view.
2. Select the desired object.
4. Select the desired tab on the Property Sheet.
Step-by-Step

View the properties of an object.

If you have not been using the Customer Sales form, open the Customer Sales 5 form in Design view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the desired object.</td>
<td>Click the Sales to Date text box</td>
</tr>
<tr>
<td><em>Sizing handles appear around the object.</em></td>
<td></td>
</tr>
<tr>
<td><em>The Property Sheet opens with the properties of the selected object displayed.</em></td>
<td></td>
</tr>
<tr>
<td>3. Select the desired tab on the property sheet.</td>
<td>Click the All tab, if necessary</td>
</tr>
<tr>
<td><em>The appropriate tab is displayed.</em></td>
<td></td>
</tr>
</tbody>
</table>

Scroll down the All page to view the properties of the control. Then, scroll back to the top of the All page.

CHANGING A CONTROL PROPERTY

Discussion

The properties of a control define many of its aspects, including the source of the information displayed in the control, its name, if it is displayed or hidden, and its appearance (font size, color, size, position, etc.). Properties of controls and other objects can be easily changed to suit your needs. For example, you may have a form with records you want to keep constant. You can select No in the form’s Allow Edits property box to prevent any editing of the records. The property sheet also allows you to precisely position and size a control.
You can change the properties of several controls at once. For example, you can select several text boxes and change the font type and size for all of them at the same time, rather than individually.

You can also open the property sheet by double-clicking a label or text box on the form.

**Procedures**

1. Open the desired form or report in **Design** view.
2. Select the desired control.
3. Press **[F4]** to view the **Property Sheet**.
4. Select the desired tab on the property sheet.
5. Select the desired property you want to set.
6. Select the list for the property, if appropriate.
7. Type the desired property setting or choose a property setting from the list.
8. To modify another control, click the desired control on the form.
9. Change the control properties as desired.

Step-by-Step

Change a control property.

If you have not been using the Customer Sales form, open the Customer Sales 5 form in Design view.

If necessary, display the property sheet for the Sales to Date text box.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the desired tab on the property sheet. The appropriate page is displayed.</td>
<td>Click the Format tab</td>
</tr>
<tr>
<td>2. Select the desired property you want to set. The insertion point appears in the property and an arrow appears to the right of the property, if appropriate.</td>
<td>Click in the Format property, if necessary</td>
</tr>
<tr>
<td>3. Select the list for the property, if appropriate. A list of available property settings is displayed.</td>
<td>Click Format</td>
</tr>
<tr>
<td>4. Type the desired property setting or choose a property setting from the list. The property setting appears in the appropriate property.</td>
<td>Click Currency</td>
</tr>
<tr>
<td>5. To modify another control, click the desired control on the form. The property settings appear for the selected control.</td>
<td>Click the Sales to Date label</td>
</tr>
<tr>
<td>6. Change the control properties as desired. The properties are changed.</td>
<td>Follow the instructions shown below the table before continuing on to the next step</td>
</tr>
</tbody>
</table>

Press [F4]

On the Format property sheet, change the Width property to 2cm and press [Enter]. Click the Sales Rep label on the form and change the Width property to 2cm. Notice that the size and position of the controls on the form have changed.

Return to the table and continue on to the next step (step 7).

Switch to Form view. Notice that the number in the Sales to Date field appears in the currency format. Close the form without saving it.

Close LAYOUT1.ACCDB.
EXERCISE

MANIPULATING CONTROLS

Task

Use controls and layouts

1. Open LAYOUT1X.ACCDB.
2. Open the Project Form 1 form in Form view.
3. Switch the view to Layout view.
4. Switch the view to Design view.
5. Drag to select all the controls on the form.
6. Add the selected controls to a stacked layout.
7. Remove the Total Sale control from the layout, and move it to the bottom of the form.
8. Use the property sheet to change the Total Sale control to display a currency format. (Hint: Select the Total Sale text box and use the Format property.) Then, close the property sheet.
9. Switch to Form view to view the changes.
10. Close the form, saving the changes.
LESSON 9 - MANIPULATING FORM CONTROLS IN DESIGN VIEW

In this lesson, you will learn how to:

- Select non-adjacent controls
- Select adjacent controls
- Delete controls
- Size a control by dragging
- Size controls automatically
- Set control margins
- Set control padding
- Hide the ruler
- Disable the Snap to Grid feature
- Display the field list
- Add a field
- Add a field from another table
- Move part of a paired control
- Align controls
- Space controls
SELECTING NON-ADJACENT CONTROLS

Discussion

Controls are the building blocks of a form or report. In order to make any changes to an element of a form or report, you must select the control that defines the element. When a control is selected in Design view, sizing handles appear. Sizing handles are boxes on the corners and sides of the control. The large box that appears in the upper left corner of a control is a move handle. Move handles are used to move an individual control without moving any other controls, even if they are selected.

When you select controls, you should be aware that bound controls are often paired with unbound controls. For example, a bound control (i.e., a text box) in a table often has an unbound control (i.e., a label) next to it containing the field name. When you select the bound control, the unbound control is also selected and is affected by the next operation. However, when you select the unbound control, the bound control is not selected and is unaffected by the next operation.

Selecting non-adjacent controls

Procedures

1. Open the desired form or report in Design view.
2. Click the first control you want to select.
3. Hold [Shift] and click any additional controls.
Step-by-Step

From the Student Data directory, open CONTROL1.ACCDB. Select non-adjacent controls.

Open the **Customer Sales** form in **Design** view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Click the first control you want to select.  
  *Sizing handles appear around the control.* | Click the **Contract Date** text box (bound control) |
| 2. Hold [Shift] and click any additional controls.  
  *Sizing handles appear around the selected controls.* | Hold [Shift] and click the **Customer Type** text box |

Notice the sizing handles that appear around the bound controls (text boxes). Notice that a moving handle also appears in the upper left corner of both the bound (text box) and unbound (label) controls.

**Practice the Concept:** If necessary, hold the [Shift] key and click the **Store Name** unbound control. Then, click in a blank area of the form to deselect the controls.

**SELECTING ADJACENT CONTROLS**

Discussion

By selecting controls in **Design** view, you are telling Access what elements should be affected by the next command or operation you perform. You can select multiple controls to be affected by the next command or operation, rather than selecting each control individually. If the controls are adjacent to one another, you can select the controls by dragging a rectangle around them.

When multiple controls are selected, sizing and move handles appear around each control.
If the ruler is displayed, you can drag in it to select multiple adjacent controls.

You can select all controls by pressing [Ctrl] + A.

Make sure that the mouse pointer does not change into a black hand when you begin to drag a selection box. If it does, you will end up moving the control instead of selecting multiple controls. If you move a control by mistake, use the Undo feature to reverse the action.

Procedures

1. Open the desired form or report in Design view.

2. Point to a blank area just above and to the left of the first control you want to select and drag down and to the right to create a box around the desired controls.

Step-by-Step

Select adjacent controls.
If necessary, open the Customer Sales form in Design view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Point to a blank area just above and to the left of the first</td>
<td>Point just above and to the left of the Customer Number label and drag down</td>
</tr>
<tr>
<td>control you want to select and drag down and to the right to</td>
<td>and to the right to create a box around the Customer Number and Store Name</td>
</tr>
<tr>
<td>create a box around the desired controls.</td>
<td>bound and unbound controls</td>
</tr>
<tr>
<td>An image of a box appears as you drag and then sizing handles</td>
<td></td>
</tr>
<tr>
<td>appear around the controls.</td>
<td></td>
</tr>
</tbody>
</table>

Click in a blank area of the form to deselect the controls.

**DELETING CONTROLS**

**Discussion**

You can delete controls from Design view. When you delete a bound control, you do not delete the field in the table or the data it contains; rather, you keep the data from being displayed in the form or report.

You can click the Undo button on the Quick Access Toolbar to restore a control you have just deleted. However, you cannot restore a deleted control after you have saved the form or report design.

**Procedures**

1. Open the desired form or report in Design view.
2. Select the control(s) you want to delete.
3. Press [Delete].

**Step-by-Step**

Delete controls.
If necessary, open the Customer Sales form in Design view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the control(s) you want to delete.  
  *Sizing handles appear around the control(s).* | Click the Customer Type text box |
| 2. Press [Delete].  
  *The control(s) are deleted.* | Press [Delete] |

Practice the Concept: Delete the Contract Date text box.

**SIZING A CONTROL BY DRAGGING**

**Discussion**

You can change the size of any control in Design view. Controls that display text generally display a single line of text horizontally and are long enough to show the entire data entry. If a control is not large enough to display the entire data entry to which it is bound, you have to scroll the corresponding field in form view to see the entire entry. If a field contains a large amount of text, such as a memo field, you can display several lines of text in the field by vertically increasing the size of the bound control. Changing the size of the control does not change the size of the text it contains.

You can size selected controls with the keyboard by holding the [Shift] key while pressing the [Up], [Down], [Left], or [Right] arrow keys. The selected controls are sized one pixel at a time.

**Procedures**

1. Open the desired form or report in Design view.
2. Select the control(s) you want to size.
3. Point to the desired sizing handle.
4. Drag the sizing handle in the desired direction to expand or contract the control.
**Step-by-Step**

Size a control by dragging a sizing handle.

If you have not been using the Customer Sales form, open the Customer Sales 2 form in Design view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the control(s) you want to size. Sizing handles appear around the control(s).</td>
<td>Click the Sales to Date text box</td>
</tr>
<tr>
<td>2. Point to the desired sizing handle. The mouse pointer changes into a black, double-headed arrow.</td>
<td>Point to the sizing handle in the middle of the right edge of the Sales to Date text box</td>
</tr>
<tr>
<td>3. Drag the sizing handle in the desired direction to expand or contract the control. An image of the control appears as you drag and then the control(s) are sized.</td>
<td>Drag the sizing handle to the left until it is slightly longer than the text it contains</td>
</tr>
</tbody>
</table>

**Practice the Concept:** Reduce the size of the Store Name and Credit Limit bound controls so that they are slightly longer than the text they contain.

---

**SIZING CONTROLS AUTOMATICALLY**

**Discussion**

The Arrange tab on the Ribbon has formatting buttons that you can select to size controls automatically. You can use these buttons to improve the appearance of a form or report by giving the display a consistent and orderly look.

The available sizing options are listed in the following table:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>To Fit</td>
<td>Sizes the controls to fit the contents.</td>
</tr>
<tr>
<td>To Grid</td>
<td>Sizes the controls to the grid.</td>
</tr>
<tr>
<td>To Tallest</td>
<td>All selected controls become as tall as the tallest control in the selection.</td>
</tr>
<tr>
<td>To Shortest</td>
<td>All selected controls become as short as the shortest control in the selection.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>To Widest</td>
<td>All selected controls become as wide as the widest control in the selection.</td>
</tr>
<tr>
<td>To Narrowest</td>
<td>All selected controls become as narrow as the narrowest control in the selection.</td>
</tr>
</tbody>
</table>

![Multiple controls resized to the same width](image)

**Procedures**

1. Open the desired form or report in **Design** view.
2. Select the control(s) you want to size.
3. Select the **Arrange** tab.
4. Select the desired size button in the **Size** group on the **Arrange** tab.

**Step-by-Step**

Size controls automatically.

If you have not been using the **Customer Sales** form, open the **Customer Sales 3** form in **Design** view.
### Steps | Practice Data
--- | ---
1. Select the control(s) you want to size.  
   *An image of a box appears as you drag and then sizing handles appear around the control(s).* | Drag to select all the controls
2. Select the **Arrange** tab.  
   *The Arrange tab is displayed.* | Click **Arrange**
3. Select the desired format button in the **Size** group.  
   *The control(s) are sized automatically.* | Click

Click in a blank area of the form to deselect the controls. Switch to Form view to see the results. Then, switch back to Design view.

## Setting Control Margins

### Discussion

You can use the **Control Margins** button in the **Control Layout** group on the **Arrange** tab to specify the location of information displayed within a control. There are four options to choose from: None, Narrow, Medium, and Wide.

### Procedures

1. Open the desired form or report in Design view.
2. Select the desired control(s).
3. Select the **Arrange** tab.
4. Select the **Control Margins** button in the **Control Layout** group on the **Arrange** tab.
5. Select the desired margin option.
Step-by-Step

Set control margins.

Open the **Customer Data Entry 2** form in **Design** view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the control(s) you want to size. <em>An image of a box appears as you drag and then sizing handles appear around the control(s).</em></td>
<td>Drag to select all the controls</td>
</tr>
<tr>
<td>2. Select the <strong>Arrange</strong> tab. <em>The Arrange tab is displayed.</em></td>
<td>Click <strong>Arrange</strong></td>
</tr>
<tr>
<td>3. Select the <strong>Control Margins</strong> button in the <strong>Control Layout</strong> group. <em>A list of control margin options is displayed.</em></td>
<td>Click <strong>Control Margins</strong></td>
</tr>
<tr>
<td>4. Select the desired control margin option. <em>The control margins are adjusted accordingly.</em></td>
<td>Click <strong>Medium</strong></td>
</tr>
</tbody>
</table>

**SETTING CONTROL PADDING**

Discussion

You can use the **Control Padding** button in the **Control Layout** group on the **Arrange** tab to set the amount of spacing between controls and the gridlines of a layout. There are four options to choose from: **None**, **Narrow**, **Medium**, and **Wide**.

Procedures

1. Open the desired form or report in **Design** view.
2. Select the desired control(s).
3. Select the **Arrange** tab.
4. Select the **Control Padding** button in the **Control Layout** group on the **Arrange** tab.

5. Select the desired padding option.

### Step-by-Step

Set control padding.

Open the **Customer Data Entry 2** form in **Design** view, if necessary.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the control(s) you want to size.  
*An image of a box appears as you drag and then sizing handles appear around the control(s).* | Drag to select all the controls |
| 2. Select the **Arrange** tab.  
*The Arrange tab is displayed.* | Click **Arrange** |
| 3. Select the **Control Padding** button in the **Control Layout** group.  
*A list of control padding options is displayed.* | Click **Control Padding** |
| 4. Select the desired control margin option.  
*The control padding is adjusted accordingly.* | Click **Wide** |

Close **CONTROL1.ACCDB**.

## Hiding the Ruler

### Discussion

You can hide or display the ruler in **Design** view. The ruler provides two scales in the Design window, one across the top and one down the left side. These scales are useful when you want to create controls that are a specific size or place controls in a specific location.
When you move objects, the appropriate area on the ruler is highlighted. This highlighted area indicates the size and position of the control.

The Ruler button on the Arrange tab acts as a toggle. If it is highlighted orange, then the ruler is displayed.

Procedures

1. Open the desired form or report in Design view.
2. Select the Arrange tab.
3. Select the Ruler button in the Show/Hide group.

Step-by-Step

From the Student Data directory, open CONTROL2.ACCDB. Hide the ruler.

If necessary, open the Customer form in Design view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the Arrange tab.  
_The Arrange tab is displayed._ | Click Arrange |
| 2. Select the Ruler button in the Show/Hide group.  
_The ruler is hidden._ | Click |
points. Both the **Grid** and **Snap to Grid** features are enabled by default and can be disabled as desired.

Both the **Grid** and the **Snap to Grid** commands are toggles. If they are highlighted orange, then they are activated.

### Procedures

1. Open the desired form or report in **Design** view.
2. Select the **Arrange** tab.
3. Select the **Snap to Grid** button in the **Control Layout** group.

### Step-by-Step

Disable the **Snap to Grid** feature.

If necessary, open the **Customer** form in **Design** view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the **Arrange** tab.  
*The Arrange menu is displayed.* | Click **Arrange** |
| 2. Select the **Snap to Grid** button in the **Control Layout** group.  
*The Snap to Grid feature is disabled.* | Click **Snap to Grid** |

**Practice the Concept:** Enable the **Snap to Grid** feature.

---

### DISPLAYING THE FIELD LIST

### Discussion

If a form or report is based on a table or query, you can display its field list. This option allows you to easily add fields to the view.
The field list appears as a box that “floats” above Design view. “Floating” means that you can drag the field list by its title bar to reposition it anywhere on the screen. This option allows you to move the field list to a more convenient location while you work.

The Add Existing Fields button acts as a toggle. You click it to display the field list and click it again to close the field list. You can also close the field list by clicking the Close button on the title bar.

Procedures

1. Open the desired form or report in Design view.

2. Click the Add Existing Fields button in the Tools group on the Design tab.

Step-by-Step

Display the field list.

If necessary, open the Customer form in Design view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Click the Add Existing Fields button in the Tools group on the Design tab. The field list is displayed.</td>
<td>Click</td>
</tr>
</tbody>
</table>

Drag the field list to the bottom right corner of the form.
Adding a Field

Discussion

When you add a field to a form or report, you add both a bound and an unbound control. The bound control is a text box that displays the data from the table. The unbound control is a label that contains the field name.

When you add a field, the mouse pointer changes into a small box. This box indicates where the top left corner of the bound control will appear on the form. The unbound control, by default, will be located to the left of the bound control.

If you move the bound control too close to the left margin, the unbound control may not be totally visible.

Procedures

1. Open the desired form or report in Design view.

2. Select the Add Existing Fields button in the Tools group on the Design tab.
3. In the field list, select the name of the field you want to add to the form or report.

4. Drag the field name to the desired location on the form or report.

**Step-by-Step**

Add a field to a form.

If necessary, open the Customer form in Design view and display the ruler.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the <strong>Add Existing Fields</strong> button in the Tools group of the Design tab. <em>The Field List task pane is displayed.</em></td>
<td></td>
</tr>
<tr>
<td><a href="image">Add Existing Fields</a> Click, if necessary</td>
<td></td>
</tr>
<tr>
<td>2. In the field list, select the name of the field you want to add to the form or report. <em>The field name is selected.</em></td>
<td></td>
</tr>
<tr>
<td>Scroll as necessary and click the <strong>Note</strong> field in the field list</td>
<td></td>
</tr>
<tr>
<td>3. Drag the field name to the desired location on the form or report. <em>A small box appears as you drag and then the controls for the field appear on the form.</em></td>
<td></td>
</tr>
<tr>
<td>Drag the <strong>Note</strong> field to the form beneath the <strong>Sales Rep</strong> text box</td>
<td></td>
</tr>
</tbody>
</table>

Close the field list. Notice that the bound and unbound controls are added to the form. Click in a blank area of the form to deselect the controls.

**ADDITION A FIELD FROM ANOTHER TABLE**

**Discussion**

The field list task pane includes fields from other tables in your database. It enables you to drag and drop fields into your form from any table in your database. If the table you select is unrelated to the table in your record source, a relationship is automatically created, or Access prompts you to do so.
Procedures

1. Open the desired form in Design view, if necessary.
2. Select the Design tab on the Ribbon, if necessary.
3. Select the Add Existing Fields button in the Tools group.
4. Select the desired table.
5. Select the desired field from the list.
6. Drag the selected field onto the desired position on the form.
7. Release the mouse button.

Step-by-Step

Add a field from another table.

Open Customer Data Entry form in Design view, if necessary.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the Design tab on the Ribbon, if necessary.  
*The Design tab is displayed.* | Click Design |
| 2. Select the Add Existing Fields button in the Tools group of the Design tab.  
*The Field List task pane is displayed.* | Click Add Existing Fields |
| 3. Select the desired table.  
*The table fields are displayed.* | Click Orders |
| 4. Select the desired field.  
*The desired field is selected.* | Click Customer ID |
| 5. Drag the selected field onto the desired position on the form.  
*The selected field is dragged onto the form, and the Specify Relationship dialog box appears, if necessary.* | Drag Customer ID onto the form, to just above the Store Name control |
Steps | Practice Data
---|---
6. Release the mouse button. *The selected field appears on the form.*

When you have added the desired fields to your form, close the Field List task pane and save.

**MOVING PART OF A PAIRED CONTROL**

**Discussion**

A bound and an unbound control can be paired. When you select a bound control, the unbound control is selected. An example is a field text box (the bound control) and its label (the unbound control). You can reposition these controls as a single unit, or you can reposition them individually.

When you select paired controls, a larger move handle appears in the upper left corner of both the bound and unbound controls. You use these handles to move the controls individually.

**Procedures**

1. Open the desired form or report in **Design** view.
2. Select the control you want to move.
3. Point to the large move handle in the upper left corner of the control you want to move.

4. Drag the selected control to the new location.

\[image\]

**Step-by-Step**

Move part of a paired control.

If you have not been using the Customer form, open the Customer 2 form in Design view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the control you want to move. <em>A move handle appears in the upper left corner of the selected controls.</em></td>
<td>Click the Note label</td>
</tr>
<tr>
<td>2. Point to the large move handle in the upper left corner of the control you want to move. <em>The mouse pointer changes into a black hand with a pointing finger.</em></td>
<td>Point to the large sizing handle in the upper left corner of the Note label</td>
</tr>
<tr>
<td>3. Drag the selected control to the new location. <em>An image of the controls appears as you drag and then the controls appear in the new location.</em></td>
<td>Drag the Note label and center it under the Credit Limit label</td>
</tr>
</tbody>
</table>

**Practice the Concept:** Move the Note text box beneath the Credit Limit text box. Click in a blank area of the form to deselect the control.

**ALIGNING CONTROLS**

**Discussion**

You can automatically align controls with one another. This option allows you to line up the edges of controls quicker and more accurately than lining them up individually.

The available alignment options are listed in the following table:
### Option Description

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left</td>
<td>The left edges of the controls are aligned with the left edge of the leftmost control in the selection.</td>
</tr>
<tr>
<td>Right</td>
<td>The right edges of the controls are aligned with the right edge of the rightmost control in the selection.</td>
</tr>
<tr>
<td>Top</td>
<td>The top edges of the controls are aligned with the top edge of the top control in the selection.</td>
</tr>
<tr>
<td>Bottom</td>
<td>The bottom edges of the controls are aligned with the bottom edge of the bottom control in the selection.</td>
</tr>
<tr>
<td>To Grid</td>
<td>The controls are aligned with the grid.</td>
</tr>
</tbody>
</table>

The **Align** buttons on the **Arrange** tab do not overlap controls. Instead of overlapping controls, Access positions them with the edges together.

### Procedures

1. Open the desired form or report in **Design** view.
2. Select the controls you want to align.
3. Select the **Arrange** tab.
4. Select the desired alignment button.

### Step-by-Step

Align controls in **Design** view.

If you have not been using the **Customer** form, open the **Customer 3** form in **Design** view.

<table>
<thead>
<tr>
<th><strong>Steps</strong></th>
<th><strong>Practice Data</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the controls you want to align. <em>Sizing handles appear around the selected controls.</em></td>
<td>Hold [Shift] and click the <strong>Customer Number</strong>, <strong>Store Name</strong>, <strong>Region</strong>, <strong>Credit Limit</strong>, and <strong>Note</strong> text boxes</td>
</tr>
</tbody>
</table>
**Steps**

2. Select the **Arrange** tab.  
   *The Arrange tab is displayed.*

3. Select the desired alignment button in the **Control Alignment** group.  
   *The controls are aligned accordingly.*

**Practice Data**

- Click **Arrange**
- Click **Right**

Click in a blank area of the form to deselect the controls.

**Practice the Concept:** Select the unbound controls for the same fields and align them to the left. Click in a blank area of the form to deselect the controls.

---

**Spacing Controls**

**Discussion**

You can increase or decrease the spacing between selected controls, or space them evenly between the top and bottom controls. You can also implement spacing changes horizontally or vertically.

**Procedures**

1. Open the desired form or report in **Design** view.
2. Select the controls you want to space.
3. Select the **Arrange** tab on the **Ribbon**.
4. Select the desired spacing command.

**Step-by-Step**

Space controls in **Design** view.

If you have not been using the **Customer** form, open the **Customer 4** form in **Design** view.
**Steps** | **Practice Data**
---|---
1. Select the controls you want to space.  
*Sizing handles appear around the selected controls.* | Drag to select the  
**Customer Number**,  
**Store Name**, **Region**,  
**Credit Limit**, and **Note** bound and unbound controls

2. Select the **Arrange** tab.  
*The **Arrange** tab is displayed.* | Click **Arrange**

3. Select the desired spacing command in the **Position** group.  
*The controls are spaced accordingly.* | Click ![Arrange](image)

Click in a blank area of the form to deselect the controls.

**Practice the Concept:** Drag to select the **Customer Number**, **Store Name**, **Region**,  
**Credit Limit**, and **Note** bound and unbound controls and decrease the space between the controls. Then, click in a blank area of the form to deselect the controls.  
Close **CONTROL2.ACCDB**.
EXERCISE

MANIPULATING FORM CONTROLS IN DESIGN VIEW

Task

Manipulate form controls in design view.

1. Open CONTROLX.ACCDB.
2. Open the Project Form 1 form in Design view.
3. Select the Course Name and Trainer Initials controls.
4. Delete the selected controls.
5. Reduce the size of the Project ID text box so that it is slightly longer than the text it contains.
6. Select all the controls on the form.
7. Size all the selected controls to the widest control on the form.
8. Select the Start Date and End Date controls.
9. Move the selected controls up until they are directly below the Client ID controls.
10. Move the Total Sale controls directly under the End Date controls.
11. Open the Field List, and add the Trainer Initials field to the form, below the Total Sale control.
12. Add all the controls to a stacked layout, set the control padding to Medium.
13. Switch to Form view to view the changes.
14. Close the form, saving the changes.
15. Close the database file.
LESSON 10 - USING DESIGN VIEW

In this lesson, you will learn how to:

- Add a label
- Add an image
- Add a rectangle
- Add a line
- Edit an unbound control
- Use multiple Undo/Redo in Design view


**ADDITION A LABEL**

**Discussion**

You can add text to a form or report. Text usually takes the form of a label and is not bound to a field. Labels can be used for data entry instructions on a form or for identifying groups of controls on a report.

When you use the Label button, the mouse pointer changes into the letter A with a plus sign (+) above and to the left of it. The center of the plus sign (+) indicates the position of the top left corner of the label control.

Access automatically wraps the text in a label box as more text is entered. If you drag to create a label box, the width of the box remains fixed, while the height expands to accommodate additional text. If you click to create a label box, the width of the box expands automatically as you enter text.

**Procedures**

1. Open the desired form or report in Design view.
2. Select the Design tab on the Ribbon.
3. Select the Label button in the Controls group.
4. Click in the form or report where you want the top left corner of the label to appear.
5. Type the text for the label.
6. Press [Enter].

**Step-by-Step**

From the Student Data directory, open DESIGN1.ACCDB. Add a label in Design view.

Open the Customer form in Design view.

If necessary, display the ruler.
Steps | Practice Data
--- | ---
1. Select the **Design** tab on the **Ribbon**. The **Design** tab is displayed. | Click **Design**
2. Select the **Label** button in the **Controls** group. The mouse pointer changes into the letter A with a plus sign (+) when positioned over the form or report. | Click **Label**
3. Click in the form or report where you want the top left corner of the label to appear. The insertion point appears surrounded by a label box. | Click at 3” on the horizontal ruler and 1” on the vertical ruler
4. Type the text for the label. The label box expands and the text appears. | Type **Worldwide Sporting Goods**
5. Press [Enter]. The label box is entered onto the form or report as an unbound control. | Press [Enter]

Click in a blank area of the form to deselect the label.

**ADDING AN IMAGE**

**Discussion**

You can add a control to a form or report that contains an image. The image is unbound and usually added only for aesthetics. Images can be any type of graphic file. If a graphic file is too large to fit in the frame of the control, the entire graphic will not appear. However, you can resize the frame to display more of the image.

When you activate the **Image** tool in the toolbox, the mouse pointer changes into a copy of the tool with a plus sign (+) above and to the left of it. As you drag to draw the frame of the control, the center of the plus sign (+) indicates the position of the top left corner of the frame.

**Procedures**

1. Open the desired form or report in **Design** view.
2. Select the **Design** tab.
3. Click the **Image** button in the **Controls** group.
4. Drag to draw a frame for the control in the form or report.
5. Select the drive where the image is stored.
6. Select the folder where the image is stored.
7. Select the desired image.
8. Select **OK**.

### Step-by-Step

Add an image in **Design** view.

If you have not been using the **Customer** form, open the **Customer 6** form in **Design** view.

If necessary, display the ruler.

<table>
<thead>
<tr>
<th><strong>Steps</strong></th>
<th><strong>Practice Data</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the <strong>Design</strong> tab on the <strong>Ribbon</strong>. The <strong>Design</strong> tab is displayed.</td>
<td>Click <strong>Design</strong></td>
</tr>
<tr>
<td>2. Click the <strong>Image</strong> tool in the <strong>Controls</strong> group. The mouse pointer changes into a copy of the tool with a plus sign (+) when positioned over the form or report.</td>
<td>Click <strong>Image</strong></td>
</tr>
<tr>
<td>3. Drag to draw a frame for the control in the form or report. An image of a box appears as you drag and then the Insert Picture dialog box opens.</td>
<td>Drag from 3” to 4 3/4” on the horizontal ruler and 1 1/4” to 2” on the vertical ruler</td>
</tr>
<tr>
<td>4. Select the drive where the image is stored. A list of available folders is displayed.</td>
<td>Click the student data drive</td>
</tr>
<tr>
<td>5. Open the folder where the image is stored. The contents of the folder is displayed.</td>
<td>Double-click to open the student data folder</td>
</tr>
<tr>
<td>6. Select the desired image. The image is selected.</td>
<td>Click <strong>Tennis</strong>, if necessary</td>
</tr>
</tbody>
</table>
Steps | Practice Data
--- | ---
7. Select **OK**. *The Insert Picture dialog box closes and the image appears in a frame on the form or report.* | Click [OK]

Click in a blank area of the form to deselect the image.

### ADDING A RECTANGLE

#### Discussion

You can draw a rectangle on a form or report. Rectangles can enhance areas of a form or enclose controls.

When you use the **Rectangle** tool in the toolbox, the mouse pointer changes into a rectangle with a plus sign (+) above and to the left of it. As you drag to draw the rectangle, the center of the plus sign (+) indicates the position of the top left corner of the rectangle.

![Adding a rectangle in Design view](image)

#### Procedures

1. Open the desired form or report in **Design** view.
2. Select the **Design** tab.
3. Click the **Rectangle** button in the **Controls** group.
4. Drag to draw a rectangle in the form or report.

**Step-by-Step**

Add a rectangle in **Design** view.

If you have not been using the **Customer** form, open the **Customer 7** form in **Design** view.

If necessary, display the ruler.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the <strong>Design</strong> tab on the <strong>Ribbon</strong>. <strong>The Design</strong> tab is displayed.</td>
<td>Click <strong>Design</strong></td>
</tr>
<tr>
<td>2. Click the <strong>Rectangle</strong> tool in the <strong>Controls</strong> group. <strong>The mouse pointer changes into a rectangle with a plus sign (+) when positioned over the form or report</strong>.</td>
<td>Click</td>
</tr>
<tr>
<td>3. Drag to draw a rectangle in the form or report. <strong>An image of a rectangle appears as you drag and then the rectangle appears on the form or report</strong>.</td>
<td>Drag a rectangle around the <strong>Worldwide Sporting Goods</strong> label and the tennis image</td>
</tr>
</tbody>
</table>

Click in a blank area of the form to deselect the rectangle. Switch to **Form** view.
Notice that the **Worldwide Sporting Goods** label and the tennis image are enclosed in the rectangle. Switch back to **Design** view.

**ADDING A LINE**

**Discussion**

You can draw a line on a form or report. Lines can enhance forms and reports by separating particular areas. For example, you can add a line to a report that separates groups of information.

When you use the **Line** button, the mouse pointer changes into a slanted line with a plus sign (+) above and to the left of it. As you drag to draw the line, a line extends from the center of the plus sign (+).
Procedures

1. Open the desired form or report in Design view.
2. Display the Design tab on the Ribbon.
3. Click the Line button in the toolbox.
4. Drag to draw a line in the form or report.

Step-by-Step

Add a line in Design view.

If you have not been using the Customer form, open the Customer 8 form in Design view. If necessary, display the ruler.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Design tab on the Ribbon. The Design tab is displayed.</td>
<td>Click Design</td>
</tr>
</tbody>
</table>
Steps | Practice Data
--- | ---
2. Select the **Line** button in the **Controls** group. 
*The mouse pointer changes into a line with a plus sign (+) when positioned over the form or report.* | Click

3. Drag to draw a line in the form or report.  
*The line appears on the form or report when you release the mouse button.* | Hold the **[Shift]** key and drag to draw a horizontal line at 5.5cm on the vertical ruler and 1cm to 10cm on the horizontal ruler

Click in a blank area of the form to deselect the line. Draw another horizontal line under the **Worldwide Sporting Goods** label from the left side of the rectangle to the right side.

Switch to **Form** view. Notice the horizontal line at the bottom of the form and between the **Worldwide Sporting Goods** label and the tennis image. Switch back to **Design** view.

**EDITING AN UNBOUND CONTROL**

**Discussion**

You can edit text in an unbound control (i.e., a label). However, you must be in edit mode. In edit mode, the insertion point and a solid background appear in the unbound control. You cannot edit text while the sizing handles are displayed. Also, deleting all the label text does not delete the control.

**Procedures**

1. Open the desired form or report in **Design** view.
2. Select the unbound control you want to edit.
3. Click to position the insertion point in the text.
4. Type the desired changes.
5. Press **[Enter]**.
Step-by-Step

Edit an unbound control.

If you have not been using the Customer form, open the Customer 9 form in Design view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the unbound control you want to edit. <em>Sizing handles appear around the control.</em></td>
<td>Click the Worldwide Sporting Goods label</td>
</tr>
<tr>
<td>2. Click to position the insertion point in the text. <em>The insertion point and a solid background appear in the unbound control.</em></td>
<td>Click after the s in Goods</td>
</tr>
<tr>
<td>3. Type the desired changes. <em>The text in the unbound control is edited.</em></td>
<td>Type , Inc.</td>
</tr>
<tr>
<td>4. Press [Enter]. <em>The edited text is entered into the unbound control on the form or report.</em></td>
<td>Press [Enter]</td>
</tr>
</tbody>
</table>

Move the Worldwide Sporting Goods, Inc. label box so that it is centered within the rectangle. Click in a blank area of the form to deselect the control. Switch to Form view to view the changes. Switch back to Design view.

**Using Multiple Undo/Redo in Design View**

Discussion

The Undo feature allows you to reverse the results of the previous command or action.

Once you have used the Undo feature, the Redo feature becomes available. The Redo feature allows you to restore the results of the command or action you reversed with the Undo feature. Both features can be accessed on the Quick Access Toolbar above the Ribbon.

When you work with Access object types, such as tables, queries, forms, or reports, in Design view, you can also use the list arrow on the Undo or Redo button to undo or redo multiple actions. This feature is useful if you want to reverse a previous action,
but have performed a number of actions subsequent to it. When you select an action to undo or redo, however, all the items performed after the selected action in the list are also reversed or redone.

However, when you open a table or query in **Datasheet** view, you are limited to undoing one action at a time. Each time you choose the **Undo** button in **Datasheet** view, the last action performed is reversed. When all actions have been undone, the **Undo** button becomes grayed out. The redo feature is not available in **Datasheet** view.

The task to be undone or redone appears as part of the **Undo** and **Redo** commands. For example, if you have just deleted text, the **Undo Delete** command would appear on the **Undo** menu.

Multiple undo and redo is also available when working with macros and modules.

### Procedures

1. To undo the previous command or action, click the **Undo** button on the **Quick Access Toolbar**.
2. To redo the undone command or action, click the **Redo** button on the **Quick Access Toolbar**.
3. To undo or redo multiple consecutive actions, click the **Undo** or **Redo** button arrow, as applicable.
4. Select the action you want to undo or redo.

### Step-by-Step

Use the **Undo** and **Redo** features to undo and redo a command.

If you have not been using the **Customer** form, open the **Customer 10** form in **Design** view.

Delete the line below the tennis graphic, the tennis graphic, and the rectangle.
### Steps

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. To undo the previous command or action, click the **Undo** button on the **Quick Access Toolbar**.  
*The previous command or action is reversed.* | Click ![Undo Icon](image) |
| 2. To redo the undone command or action, click the **Redo** button on the **Quick Access Toolbar**.  
*The command or action is redone.* | Click ![Redo Icon](image) |
| 3. To undo or redo multiple consecutive actions, click the **Undo** or **Redo** button arrow, as applicable.  
*A list of previous actions appears, with the most recent action at the top of the list.* | Click the ![Undo Arrow](image) arrow |
| 4. Select the action you want to undo or redo.  
*The actions are undone or redone accordingly.* | Click the last **Delete** command in the list |

Notice that Access returns the line, tennis graphic, and rectangle.

Close the form without saving it.  
Close **DESIGN1.ACCDB**.
EXERCISE

USING DESIGN VIEW

Task

Use Design view.

1. Open DESIGNX.ACCDB.
2. Open the Project Form 2 form in Design view.
3. Add a label at the top right side of the form. Enter the text Worldwide Training Corp.
4. Add an image under the Worldwide Training Corp. label. Add the WWTLOGO.BMP image from the Student Data directory. Center the image under the label.
5. Add a rectangle around the Worldwide Training Corp. label and the world image.
6. Draw a horizontal line across the bottom of the form. (*Hint: Hold the [Shift] key to draw a straight line.)
7. Use the Undo feature to reverse the previous action.
8. Use the Redo feature to redo the reversed action.
9. Switch to Form view to view the completed form.
10. Close the form, saving the changes.
LESSON 11 - USING ADVANCED FORM DESIGN

In this lesson, you will learn how to:

- Use forms in Design view
- Create a combo box
- Editing List Items
- Create a list box
- Create an option group
- Add a logic control
- Set the tab order automatically
- Set the tab order manually
- Add a form header and footer
- Create a blank form
Discussion

You can create or customize a form in Design view. A form has three basic sections: **Detail**, **Form Header/Footer**, and **Page Header/Footer**.

The **Detail** section contains the information from the table or query. You create controls in the **Detail** section that allow you to display or enter information. Access provides a variety of control types you can add to the form to simplify the data entry process. For example, you can replace a text box with a list box or an option group so that you can select a value rather than type it during data entry. In many cases, it is quicker and easier to select a value from a list rather than to remember the value you want to use and then type it. Having a list of choices also helps to ensure the consistency of the data being entered.

The **Form Header** and **Form Footer** sections display at the top and bottom of a form in **Form view**. They are stationary when you scroll the **Detail** section, making them useful for displaying titles or instructions you want visible on the form at all times. If you print the form, these sections appear at the top of the first page and at the bottom of the last page. You can also place controls, including images, labels, and fields in the form header or footer.

The **Page Header** and **Page Footer** sections display at the top and bottom of the form in **Design view**. They do not appear in **Form view**. Rather, they display at the top and bottom of every page when the form is printed. Page headers and footers can contain images, lines, and text, or any other controls you want printed on every page.

When you enable the display of either the page or form header/footer section, both the header and the footer appear. You can drag the header and footer sections to resize them.
Creating a Combo Box

Discussion

You can create a combo box on a form. A combo box provides you with a list of values from which you can choose. Choosing from a list is much faster and more accurate than remembering a value to be typed. However, you can also type a value directly into a combo box if the appropriate value is not available from the list.

A combo box can be bound to a field, meaning that when you select or enter a value, that value is entered into that field in the corresponding table. A combo box can also be unbound, meaning that when you select or enter a value, it is held in memory to be used in another control or calculation.

Access provides a Combo Box Wizard that guides you through the process of creating a combo box. You can select the list of values from an existing table or query, or you can create the values for the list yourself. If you choose to select the list from an existing table or query, the wizard prompts you to enter the table or query and the field name. If you choose to create the list of values yourself, the wizard displays a column for the entries. Either way, once the values are entered into the wizard, you then specify whether the values should be entered into a field in the table or held in memory for later use. You complete the combo box by entering a label.

When you use the Combo Box tool, the mouse pointer changes into a copy of the tool with a plus sign (+) above and to the left of it.
The Combo Box wizard

Procedures

1. Open the desired form in **Design** view.
2. Select the **Design** tab.
3. Click the **Combo Box** button in the **Controls** group.
4. Click in the form in the location where you want the combo box to appear.
5. Select the desired option for the source of the combo box values.
6. Select **Next >**.
7. Select the desired view option.
8. Select the table or query containing the values for the combo box in the **Which table or query should provide the values for your combo box?** list box.
9. Select **Next >**.
10. Select the field containing the values from the **Available Fields** list box.
11. Select **Next >**.
12. Select **Next >**.
13. Select **Next >**.
14. Select the desired storage option for the field.
15. Select the **Store that value in this field** list, if applicable.

16. Select the desired field name, if applicable.

17. Select **Next >**

18. Type a label for the combo box.

19. Select **Finish**

---

**Step-by-Step**

From the Student Data directory, open **ADVFORM.ACCDB**.

Create a combo box on a form.

Open the **Order Entry** form in **Design** view. If necessary, display the ruler.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the <strong>Design</strong> tab on the <strong>Ribbon</strong>.  &lt;br&gt; <em>The Design tab is displayed.</em></td>
<td>Click <strong>Design</strong></td>
</tr>
<tr>
<td>2. Select the <strong>Combo Box</strong> button in the <strong>Controls</strong> group.  &lt;br&gt; <em>The mouse pointer changes into a copy of the tool with a plus sign (+) when positioned over the form.</em></td>
<td>Click ****</td>
</tr>
<tr>
<td>3. Click in the form in the location where you want the combo box to appear.  &lt;br&gt; <em>An outline of the combo box appears on the form and the Combo Box Wizard opens.</em></td>
<td>Click just under the <strong>Customer ID</strong> text box</td>
</tr>
<tr>
<td>4. Select the desired option for the source of the combo box values.  &lt;br&gt; <em>The desired source option is selected.</em></td>
<td>Click <strong>I want the combo box to look up the values in a table or query., if necessary</strong></td>
</tr>
<tr>
<td>5. Select <strong>Next</strong>.  &lt;br&gt; <em>The next page of the Combo Box Wizard is displayed.</em></td>
<td>Click <strong>Next &gt;</strong></td>
</tr>
<tr>
<td>6. Select the desired view option.  &lt;br&gt; <em>The desired view option is selected.</em></td>
<td>Click <strong>Tables, if necessary</strong></td>
</tr>
<tr>
<td>Steps</td>
<td>Practice Data</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>7. Select the table or query containing the values for the combo box</td>
<td>Click Table: Reps</td>
</tr>
<tr>
<td>Which table or query should provide the values for your combo</td>
<td></td>
</tr>
<tr>
<td>box? list box.</td>
<td></td>
</tr>
<tr>
<td>The table or query name is selected.</td>
<td></td>
</tr>
<tr>
<td>8. Select <strong>Next</strong>.</td>
<td>Click Next &gt;</td>
</tr>
<tr>
<td>The next page of the Combo Box Wizard is displayed.</td>
<td></td>
</tr>
<tr>
<td>9. Select the field containing the values from the <strong>Available Fields</strong></td>
<td>Double-click INITIALS</td>
</tr>
<tr>
<td>list box.</td>
<td></td>
</tr>
<tr>
<td>The field name appears in the <strong>Selected Fields</strong> list box.</td>
<td></td>
</tr>
<tr>
<td>10. Select <strong>Next</strong>.</td>
<td>Click Next &gt;</td>
</tr>
<tr>
<td>The next page of the Combo Box Wizard is displayed.</td>
<td></td>
</tr>
<tr>
<td>11. Select <strong>Next</strong>.</td>
<td>Click Next &gt;</td>
</tr>
<tr>
<td>The next page of the Combo Box Wizard is displayed.</td>
<td></td>
</tr>
<tr>
<td>12. Select <strong>Next</strong>.</td>
<td>Click Next &gt;</td>
</tr>
<tr>
<td>The next page of the Combo Box Wizard is displayed.</td>
<td></td>
</tr>
<tr>
<td>13. Select the desired storage option for the field.</td>
<td>Click Store that value in this field</td>
</tr>
<tr>
<td>The desired storage option is selected.</td>
<td></td>
</tr>
<tr>
<td>14. Select the <strong>Store that value in this field</strong> list, if applicable.</td>
<td>Click Store that value in this field</td>
</tr>
<tr>
<td>A list of fields is displayed.</td>
<td></td>
</tr>
<tr>
<td>15. Select the desired field name, if applicable.</td>
<td>Click Sales Rep</td>
</tr>
<tr>
<td>The field name appears in the <strong>Store that value in this field</strong> box</td>
<td></td>
</tr>
<tr>
<td>16. Select <strong>Next</strong>.</td>
<td>Click Next &gt;</td>
</tr>
<tr>
<td>The next page of the Combo Box Wizard appears with the insertion</td>
<td></td>
</tr>
<tr>
<td>point in the <strong>What label would you like for your combo box?</strong></td>
<td></td>
</tr>
<tr>
<td>box.</td>
<td></td>
</tr>
<tr>
<td>17. Type a label for the combo box.</td>
<td>Type Sales Rep</td>
</tr>
<tr>
<td>The text appears in the <strong>What label would you like for your combo box?</strong> box.</td>
<td></td>
</tr>
</tbody>
</table>
Steps | Practice Data
--- | ---
18. Select **Finish**. The Combo Box Wizard closes and the combo box appears on the form. | Click Finish

Move the **Sales Rep** label so that it is lined up with the **Customer ID** label above it. Move the **Sales Rep** combo box so that it is lined up with the **Customer ID** text box above it. Click in a blank area of the form to deselect the combo box.

Switch to **Form** view to test the combo box. Click the **Sales Rep** list to display the list of sales representatives. Switch back to **Design** view.

**EDITING LIST ITEMS**

**Discussion**

When you create a Lookup List in a form, you can now allow users to edit the list items using the Edit List Items dialog box. If you do not want users to be able to edit the list, you can also disable this property.

![Edit List Items dialog box](image)

The **Edit List Items** dialog box

**Procedures**

1. Open the desired form in **Form** View.
2. Select the arrow in the desired field.
3. Select the **Edit List** button below the lookup list.

4. Edit the list, if necessary.

5. Select **OK**.

---

### Step-by-Step

**Edit List Items.**

Open the **Items 2** form in **Form** view.

<table>
<thead>
<tr>
<th><strong>Steps</strong></th>
<th><strong>Practice Data</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the arrow in the desired field. <em>The lookup list is displayed.</em></td>
<td>Click in the <strong>Color</strong> field</td>
</tr>
<tr>
<td>2. Select the <strong>Edit List</strong> button below the lookup list. <em>The Edit List Items dialog box opens.</em></td>
<td>Click</td>
</tr>
<tr>
<td>3. Edit the list, if necessary. <em>The text appears in the list.</em></td>
<td>Type <strong>Red</strong></td>
</tr>
<tr>
<td>4. Select <strong>OK</strong>. <em>The Edit List Items dialog box closes.</em></td>
<td>Click <strong>OK</strong></td>
</tr>
</tbody>
</table>

Notice that when you click on the arrow in the **Color** field, the new option has been added to the list.

---

### CREATING A LIST BOX

### Discussion

You can create a list box on a form. A list box provides you with a list of values from which you can choose. Choosing from a list is much faster and more accurate than remembering a value to be typed. However, unlike a combo box, you can only choose an item from the list; values not present on the list cannot be entered into the table.

A list box can be bound to a field, meaning that when you select or enter a value, the value is entered into a field in the corresponding table. A list box can also be unbound, meaning that when you select or enter a value, it is held in memory to be used in another control or calculation.
The List Box Wizard guides you through the process of creating a list box. You can select the list of values from an existing table or query, or you can create the values for the list yourself. If you choose to select the list from an existing table or query, the wizard prompts you to enter the table or query and the field name. If you choose to create the list of values yourself, the wizard displays a column for the entries. Either way, once the values are entered into the wizard, you then specify whether the values should be entered into a field in the table or held in memory for later use.

When you use the List Box button, the mouse pointer changes into a copy of the tool with a plus sign (+) above and to the left of it. The center of the plus sign (+) indicates the position of the top left corner of the list box.

You can set the default value for a list box by opening the property sheet and typing the desired value in quotation marks in the Default Value property box on the Data page.

Procedures

1. Open the desired form in Design view.
2. Select the Design tab.
3. Click the List Box button in the Controls group.
4. Click in the form in the location where you want the combo box to appear.
5. Select the desired option for the source of the list box values.
6. Select.
7. Type the number of columns for the list box.
8. Press [Tab].
9. Type the first value for the list box.
10. Press [Tab].
11. Continue to type values as desired.
12. Select.
13. Select the desired storage option for the field.
14. Select the Store that value in this field list, if applicable.
15. Select the desired field name, if applicable.
16. Select "Next >".

17. Type a label for the list box.

18. Select "Finish".

**Step-by-Step**

Create a list box on a form.

If you have not been using the Order Entry form, open the Order Entry 2 form in Design view.

If necessary, display the ruler.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the <strong>Design</strong> tab on the <strong>Ribbon</strong>. <em>The Design tab is displayed.</em></td>
<td>Click <strong>Design</strong></td>
</tr>
<tr>
<td>2. Click the <strong>List Box</strong> button in the <strong>Controls</strong> group. <em>The mouse pointer changes into a copy of the tool with a plus sign (+) when positioned over the form.</em></td>
<td>Click</td>
</tr>
<tr>
<td>3. Click in the form in the location where you want the combo box to appear. <em>An outline of the list box appears on the form and the List Box Wizard opens.</em></td>
<td>Click just under the <strong>Shipping Cost</strong> text box</td>
</tr>
<tr>
<td>4. Select the desired option for the source of the list box values. <em>The desired source option is selected.</em></td>
<td>Click ○ <strong>I will type in the values that I want.</strong></td>
</tr>
<tr>
<td>5. Select <strong>Next</strong>. <em>The next page of the List Box Wizard appears with the insertion point in the Number of columns box.</em></td>
<td>Click &quot;Next &gt;&quot;</td>
</tr>
<tr>
<td>6. Type the number of columns for the list box. <em>The number appears in the Number of columns box.</em></td>
<td>Type 1, if necessary</td>
</tr>
</tbody>
</table>
### Steps

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>7. Press [Tab].&lt;br&gt; <em>The insertion point appears in the row under Col1.</em></td>
<td>Press [Tab]</td>
</tr>
<tr>
<td>8. Type the first value for the list box.&lt;br&gt; <em>The text appears in the row.</em></td>
<td>Type US Mail</td>
</tr>
<tr>
<td>9. Press [Tab].&lt;br&gt; <em>The value is entered into the row and the insertion point moves to the next row in the column.</em></td>
<td>Press [Tab]</td>
</tr>
<tr>
<td>10. Continue to type values as desired.&lt;br&gt; <em>The values appear in the rows.</em></td>
<td>Follow the instructions shown below the table before continuing on to the next step</td>
</tr>
<tr>
<td>11. Select Next.&lt;br&gt; <em>The next page of the List Box Wizard is displayed.</em></td>
<td>Click <img src="next.png" alt="Next &gt;" /></td>
</tr>
<tr>
<td>12. Select the desired storage option for the field.&lt;br&gt; <em>The desired storage option is selected.</em></td>
<td>Click <img src="store.png" alt="Store that value in this field" /></td>
</tr>
<tr>
<td>13. Select the <strong>Store that value in this field</strong> list, if applicable.&lt;br&gt; <em>A list of fields is displayed.</em></td>
<td>Click <img src="store.png" alt="Store that value in this field" /></td>
</tr>
<tr>
<td>14. Select the desired field name, if applicable.&lt;br&gt; <em>The field name appears in the Store that value in this field box.</em></td>
<td>Click Shipping Method</td>
</tr>
<tr>
<td>15. Select Next.&lt;br&gt; <em>The next page of the List Box Wizard appears with the insertion point in the What label would you like for your list box? box.</em></td>
<td>Click <img src="next.png" alt="Next &gt;" /></td>
</tr>
<tr>
<td>16. Type a label for the list box.&lt;br&gt; <em>The text appears in the What label would you like for your list box? box.</em></td>
<td>Type Shipping Method</td>
</tr>
<tr>
<td>17. Select Finish.&lt;br&gt; <em>The List Box Wizard closes and the list box appears on the form.</em></td>
<td>Click <img src="finish.png" alt="Finish" /></td>
</tr>
</tbody>
</table>

Enter the following values under **Col1** in the wizard, pressing [Tab] after you type each value: **UPS, DHL, Emery, FedEx.**
Return to the table and continue on to the next step (step 11).

Reduce the height of the Shipping Method list box by dragging the bottom border up to the 5cm mark on the vertical ruler. Line up the Shipping Method label with the Shipping Cost label above it. If necessary, move the Shipping Method list box to left align with the Shipping Cost text box above it. Click in a blank area of the form to deselect the list box.

Switch to Form view to test the list box. Click the various shipping methods. Switch back to Design view.

**CREATING AN OPTION GROUP**

**Discussion**

You can create an option group on a form. An option group provides you with a limited set of values from which you can choose. Choosing from a set of values is often much faster and more accurate than remembering a value to be typed. With an option group, you can only select one option from the set of alternatives. Therefore, option groups are best utilized when there are five or less values from which to choose. Adding more than five values to an option group can crowd a form and is less effective for quick data entry.

An option group has a frame that encloses the set of values. These values appear beside option buttons or check boxes, or on top of toggle buttons.

The Option Group Wizard guides you through the process of creating an option group. An option group can be bound to a field in a table or query. However, only the frame is bound to the field. Within the frame, Access assigns each option a numeric value, starting with the number 1. When the option is selected, this numeric value is entered into the corresponding field. Access assigns a number because the value of an option group cannot be text. For example, if a product comes in three colors (white, black, and green), you can use an option group in an order entry form to select the color being ordered. By default, Access assigns the number 1 to the White option, the number 2 to the Black option, and the number 3 to the Green option. You only see the White, Black, and Green options on the form, but Access actually stores the assigned numbers in the corresponding field in the table.

When you use the Option Group button, the mouse pointer changes into a copy of the tool with a plus sign (+) above and to the left of it. The center of the plus sign (+) indicates the position of the top left corner of the option group.
An option group added to a form

Procedures

1. Open the desired form in Design view.
2. Select the Design tab.
3. Select the Option Group button in the Controls group.
4. Click in the location on the form where you want the option group to begin.
5. Type the desired label for the first option.
6. Press [Tab].
7. Type other labels as desired.
8. Select.
9. Select the desired option for the default.
10. Select.
11. Type new values for the labels, if desired.
12. Select.
13. Select the desired storage option for the field.
14. Select the Store the value in this field list, if applicable.
15. Select the desired field name, if applicable.
16. Select Next >.
17. Select the desired option for the control type.
18. Select the desired style option.
19. Select Next >.
20. Type the caption for the option group.

Step-by-Step

Create an option group on a form.

If you have not been using the Order Entry form, open the Order Entry 3 form in Design view.

If necessary, display the ruler.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Design tab on the Ribbon. <em>The Design tab is displayed.</em></td>
<td>Click Design</td>
</tr>
<tr>
<td>2. Select the Option Group button in the Controls group. <em>The mouse pointer changes into a copy of the tool with a plus sign (+) when positioned over the form.</em></td>
<td>Click [ ]</td>
</tr>
<tr>
<td>3. Click in the location on the form where you want the option group to begin. <em>An outline of a box appears on the form and then the Option Group Wizard opens.</em></td>
<td>Click below the Sales Rep label</td>
</tr>
<tr>
<td>4. Type the desired label for the first option. <em>The label appears in the first row under Label Names.</em></td>
<td>Type Smaller markets</td>
</tr>
<tr>
<td>5. Press [Tab]. <em>The label is entered into the row and the insertion point moves to the next row in the column.</em></td>
<td>Press [Tab]</td>
</tr>
<tr>
<td>Steps</td>
<td>Practice Data</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>---------------------------------------------------</td>
</tr>
<tr>
<td>6. Type other labels as desired.</td>
<td>Follow the instructions shown below the table</td>
</tr>
<tr>
<td>The labels appear in the rows.</td>
<td>before continuing on to the next step</td>
</tr>
<tr>
<td>7. Select Next.</td>
<td>Click Next &gt;</td>
</tr>
<tr>
<td>The next page of the Option Group Wizard is displayed.</td>
<td></td>
</tr>
<tr>
<td>8. Select the desired option for the default.</td>
<td>Click No, I don’t want a default.</td>
</tr>
<tr>
<td>The default option is selected.</td>
<td></td>
</tr>
<tr>
<td>9. Select Next.</td>
<td>Click Next &gt;</td>
</tr>
<tr>
<td>The next page of the Option Group Wizard appears with the insertion</td>
<td></td>
</tr>
<tr>
<td>point in the first row under Values.</td>
<td></td>
</tr>
<tr>
<td>10. Type new values for the labels, if desired, and select Next.</td>
<td>Click Next &gt;</td>
</tr>
<tr>
<td>The next page of the Option Group Wizard is displayed.</td>
<td></td>
</tr>
<tr>
<td>11. Select the desired storage option for the field.</td>
<td>Click Store the value in this field</td>
</tr>
<tr>
<td>The desired storage option is selected.</td>
<td></td>
</tr>
<tr>
<td>12. Select the Store the value in this field list, if applicable.</td>
<td>Click Store the value in this field</td>
</tr>
<tr>
<td>A list of fields is displayed.</td>
<td></td>
</tr>
<tr>
<td>13. Select the desired field name, if applicable.</td>
<td>Scroll as necessary and click Customer Type</td>
</tr>
<tr>
<td>The desired field name appears in the Store the value in this field</td>
<td></td>
</tr>
<tr>
<td>box.</td>
<td></td>
</tr>
<tr>
<td>14. Select Next.</td>
<td>Click Next &gt;</td>
</tr>
<tr>
<td>The next page of the Option Group Wizard is displayed.</td>
<td></td>
</tr>
<tr>
<td>15. Select the desired option for the control type.</td>
<td>Click Check boxes</td>
</tr>
<tr>
<td>The desired control type option is selected and a preview appears in</td>
<td></td>
</tr>
<tr>
<td>the Sample box.</td>
<td></td>
</tr>
<tr>
<td>16. Select the desired style option.</td>
<td>Click Raised</td>
</tr>
<tr>
<td>The desired style option is selected and a preview appears in the</td>
<td></td>
</tr>
<tr>
<td>Sample box.</td>
<td></td>
</tr>
</tbody>
</table>
Steps | Practice Data
--- | ---
17. Select Next. The next page of the Option Group Wizard appears with the insertion point in the What caption do you want for the option group? box. | Click Next >
18. Type the caption for the option group. The text appears in the What caption do you want for the option group? box. | Type Customer Type
19. Select Finish. The Option Group Wizard closes and the option group is displayed on the form. | Click Finish

Type Medium markets on the second row, press [Tab] and type Large metro markets on the third row.

Return to the table and continue on to the next step (step 7).

Click the Note text box and use the [Down] arrow to move the Note field down to remove the overlap with the option group. Click in a blank area of the form to deselect the option group.

Switch to Form view to test the option group. Scroll to record 3 and select the Large metro markets option. Switch back to Design view.

### ADDING A LOGIC CONTROL

**Discussion**

Some tables contain fields that have a Yes/No field type. These fields can contain a Yes (True) value, a No (False) value, or no value at all.

When working with a form that contains a Yes/No field, you can create a logic control that is bound to the Yes/No field. Logic controls give a visual display of the value in a Yes/No field, such as a check box where a check mark appears when the field value is Yes and does not appear when the value is No. Another type of logic control is the toggle button, which appears “sunken” for a value of Yes and “raised” for a value of No. The logic control for a field with a null value (neither Yes nor No is chosen) appears the same as the field with a No value.

Logic controls improve the visual effectiveness of a form and facilitate data entry. With a logic control, the value of a Yes/No field is selected with a single click of the mouse button rather than multiple keystrokes.
The way in which the different controls indicate a Yes or No value are described in the following table:

<table>
<thead>
<tr>
<th>Control</th>
<th>Appearance</th>
</tr>
</thead>
<tbody>
<tr>
<td>Toggle button</td>
<td>Appears “sunken” with a Yes value and “raised” with a No value.</td>
</tr>
<tr>
<td>Option button</td>
<td>Contains a dot with a Yes value and appears empty with a No value.</td>
</tr>
<tr>
<td>Check box</td>
<td>Appears checked with a Yes value and unchecked with a No value.</td>
</tr>
</tbody>
</table>

Procedures

1. Open the desired form in Design view.
2. Select the Design tab on the Ribbon.
3. Select the desired logic control button.
4. Click in the form where you want the logic control to appear.
6. Select the Data tab.
7. Select the Control Source list.
8. Select the Yes/No field you want bound to the logic control.
9. Close the property sheet.
10. Select the label box of the logic control.
11. Select the default text.
12. Type the desired logic control name.
13. Press [Enter].

Step-by-Step

Add a logic control to a form.

If you have not been using the Order Entry form, open the Order Entry 4 form in Design view.
If necessary, display the ruler.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Click the desired logic control tool in the <strong>Controls</strong> group on the <strong>Design</strong> tab. The mouse pointer changes into a copy of the tool with a plus sign (+) when positioned over the form.</td>
<td>Click ☑</td>
</tr>
<tr>
<td>2. Click in the form where you want the logic control to appear. The logic control appears on the form.</td>
<td>Click in the form just below the <strong>Shipping Method</strong> text box</td>
</tr>
<tr>
<td>3. Press [F4] to display the <strong>Property Sheet</strong>. The <strong>Property Sheet</strong> for the selected logic control opens.</td>
<td>Press [F4], if necessary</td>
</tr>
<tr>
<td>4. Select the <strong>Data</strong> tab. The <strong>Data</strong> page appears with the insertion point in the <strong>Control Source</strong> property and an arrow to the right of the property.</td>
<td>Click the <strong>Data</strong> tab</td>
</tr>
<tr>
<td>5. Select the <strong>Control Source</strong> list. A list of field names appears.</td>
<td>Click <strong>Control Source</strong> ☑</td>
</tr>
<tr>
<td>6. Select the <strong>Yes/No</strong> field you want bound to the logic control. The desired <strong>Yes/No</strong> field is selected.</td>
<td>Scroll as necessary and click <strong>Catalog</strong></td>
</tr>
<tr>
<td>7. Press [F4] to close the <strong>Property Sheet</strong>. The <strong>Property Sheet</strong> closes.</td>
<td>Press [F4]</td>
</tr>
<tr>
<td>8. Select the label box of the logic control. Sizing handles appear around the label box.</td>
<td>Click the <strong>Check</strong> label box</td>
</tr>
<tr>
<td>9. Double-click to select the default text. The text is selected.</td>
<td>Double-click <strong>Check</strong> (xx is a number)</td>
</tr>
<tr>
<td>10. Type the desired logic control name. The name appears in the label box.</td>
<td>Type <strong>Send a Catalog?</strong></td>
</tr>
<tr>
<td>11. Press [Enter]. The text in the label box is entered onto the form.</td>
<td>Press [Enter]</td>
</tr>
</tbody>
</table>

Click in a blank area of the form to deselect the logic control.
Switch to **Form** view and scroll through the records. Since the logic control (the check box) is now bound to the **Catalog** field, it reflects the value of the **Catalog** field for each record by appearing checked or unchecked.

## Setting the Tab Order Automatically

### Discussion

The tab order determines the order in which form fields and controls are selected when you press the [Tab] key during data entry. The default tab order is the order in which the fields or controls were added to the form. If you have added, rearranged, or deleted fields or controls, the tab order may not be suitable for data entry. You can choose to have Access automatically rearrange the tab order to reflect the order of the fields on the form. The fields are then accessed from left to right across each row.

### Procedures

1. Open the desired form in **Design** view.
2. Select the **Arrange** tab on the **Ribbon**.
3. Select the **Tab Order** button in the **Control Layout** group.
4. Select the **Auto Order** button.
5. Select **OK**.

### Step-by-Step

Set the tab order automatically.

If you have not been using the **Order Entry** form, open the **Order Entry 5** form in **Form** view.

Press [Tab] to navigate through the controls on the form. Notice the order in which each control is selected. Switch to **Design** view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the <strong>Arrange</strong> tab on the <strong>Ribbon</strong>. Click <strong>Arrange</strong>.</td>
<td><strong>The Arrange tab is displayed.</strong></td>
</tr>
</tbody>
</table>
**Setting the Tab Order Manually**

### Discussion

The tab order determines the order in which form fields and controls are selected when you press the [Tab] key during data entry. The default tab order is the order in which the fields or controls were added to the form. If you have added, rearranged, or deleted fields or controls, the tab order may not be suitable for data entry. You can adjust the tab order manually to reflect whatever order is best for your data entry needs.

### Procedures

1. Open the desired form in **Design** view.
2. Select the **Arrange** tab on the **Ribbon**.
3. Select the **Tab Order** button in the **Control Layout** group.
4. Select the record selector to the left of the field you want to move.
5. Drag the field to the new position.
6. Select **OK**.
**Step-by-Step**

Set the tab order manually.

If you have not been using the **Order Entry** form, open the **Order Entry 6** form in **Design** view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the <strong>Arrange</strong> tab on the <strong>Ribbon</strong>. <em>The Arrange tab is displayed.</em></td>
<td>Click <strong>Arrange</strong></td>
</tr>
<tr>
<td>2. Select the <strong>Tab Order</strong> button in the <strong>Control Layout</strong> group. <em>The Tab Order dialog box opens.</em></td>
<td>Click <strong>Tab Order</strong></td>
</tr>
<tr>
<td>3. Select the record selector to the left of the field you want to move. <em>The field name is selected.</em></td>
<td>Click the record selector next to <strong>Order Date</strong></td>
</tr>
<tr>
<td>4. Drag the field to the new position. <em>A dark line appears as you drag to indicate the new position in the tab order and then the field name appears in the new position.</em></td>
<td>Drag the field between <strong>Frame</strong> (xx is a number) and <strong>Shipping Date</strong></td>
</tr>
<tr>
<td>5. Select <strong>OK</strong>. <em>The Tab Order dialog box closes and the new tab order is set.</em></td>
<td>Click <strong>OK</strong></td>
</tr>
</tbody>
</table>

**Practice the Concept:** Open the Tab Order dialog box. Select the **Note** field and drag it to the end of the list. Close the Tab Order dialog box.

Switch to **Form** view. Press [Tab] and notice the new tab order. Switch back to **Design** view.

---

**ADDING A FORM HEADER AND FOOTER**

**Discussion**

The **Form Header** and **Form Footer** sections display at the top and bottom of the form in **Form** view. They are stationary when you scroll the **Detail** section, making them useful for displaying titles or instructions you want visible on the form at all times. If you print the form, these sections appear at the top of the first page and the bottom of the last page.

You can place controls, including images, labels, and fields, in the form header or footer.
A label added to the Form Header section

You can change the height of a section by dragging the bottom border of the section up or down.

Procedures

1. Open the desired form in **Design** view.
2. Right-click in a blank area of the form.
3. Select **Form Header/Footer**.

Step-by-Step

Add a header and footer to a form.

If you have not been using the **Order Entry** form, open the **Order Entry 7** form in **Design** view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Right-click in a blank area of the form.</td>
<td>Right-click in a blank area of the form</td>
</tr>
</tbody>
</table>

*The form submenu is displayed.*
Steps | Practice Data
--- | ---
2. Select **Form Header/Footer**. The Form Header and Form Footer sections are displayed. | Click Form Header/Footer

Using the **Design** tab add a label to the left side of the form header. Enter the text **Order Entry Form**. Resize the text to **14 pt**. You will probably need to reposition the details section selector so that you can resize the label box for the text to fit. Click in a blank area of the form to deselect the label. Switch to **Form** view. Notice the form header at the top of the page. Switch to **Design** view.

**Practice the Concept:** Add a page header and footer to the form. Add a label to the **Page Header** section. Enter the text **Worldwide Sporting Goods** and then center the label in the section. Click in a blank area of the form to deselect the label.

Switch to **Form** view and print preview the form. Magnify the form to view the form and page headers. Switch back to **Design** view. If necessary, resize header labels as needed.

Close the form without saving it.

**CREATING A BLANK FORM**

**Discussion**

You can create a form from scratch in **Design** view. For example, if a form does not currently exist for a particular table or query, you can create one using the fields in the selected table or query. You can then determine the design of the form by adding fields, control, and options.

**Procedures**

1. Display All Access Objects in the Navigation Pane.
2. Select the **Create** tab on the **Ribbon**.
3. Select the **Blank Form** button in the **Forms** group.
4. Select **Design View**.
5. Select the table or query on which you want to base the form from the Field List.
6. Drag items onto the form as desired.
Step-by-Step

Create a blank form without using a wizard.

If necessary, display All Access Objects in the Navigation Pane.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the <strong>Create</strong> tab on the <strong>Ribbon</strong>. <em>The Create tab is displayed.</em></td>
<td>Click <strong>Create</strong></td>
</tr>
<tr>
<td>2. Select the <strong>Blank Form</strong> button in the <strong>Forms</strong> group. <em>Access creates a blank form in the database window and the Field List Task Pane opens.</em></td>
<td>Click <strong>Blank Form</strong></td>
</tr>
<tr>
<td>3. Select <strong>Design View</strong>. <em>The blank form is displayed in Design View.</em></td>
<td>Click <strong>Design View</strong></td>
</tr>
<tr>
<td>4. Select the table or query on which you want to base the report. <em>The table or query name appears in the Choose the table or query where the object’s data comes from box.</em></td>
<td>Double-click <strong>Line Items</strong> in the Field List</td>
</tr>
<tr>
<td>5. Drag items onto the form as desired. <em>The items appear on the form as appropriate.</em></td>
<td>Follow the instructions shown below the table to complete this step</td>
</tr>
</tbody>
</table>

Drag the **Order Number**, **Product ID**, and **Quantity** fields to the 2” mark on the horizontal ruler. Click in a blank area of the form to deselect the controls. Space the controls vertically on the form and size them to fit.

Close the form and save it as **Customer Orders**. Close **ADVFORM.ACCDB**.
EXERCISE

USING ADVANCED FORM DESIGN

Task

Use advanced form design.

1. Open ADVFORMX.ACCDB.

2. Open the New Payment Form form in Design view. Display the ruler, if necessary.

3. Create a combo box for the trainers’ initials just below the Payment Date text box.

4. Indicate that the combo box should look up values in a table as the source for the values in the list. Select Table: Trainer as the table and include the Initials field in the combo box. Accept the default sort order and column width. Store the values entered in the combo box in the Trainer Initials field and label the combo box Trainer Initials.

5. Create a list box for the credit rating just below the Trainer Initials combo box.

6. Indicate that you want to type in the values for the list box. Use one column and type the values A, B, and C as separate entries. Store the values entered in the list box in the Credit Rating field and label the list box Credit Rating.

7. Reduce the height of the list box so that it displays only one line of text. Move the controls under, and left-aligned with the Trainer Initials controls.

8. Select the Project ID, Payment Date, Trainer Initials, and Credit Rating bound controls (text boxes) and size them to the narrowest size. Then, vertically space them equally.

9. Create an option group just below the Total Sale text box.

10. Type Yes and No as the label names and select Yes as the default choice. Change the default value of the Yes label to -1 and the No label to 0. Store the value entered in the option group in the Recorded field. Use Option buttons as controls and select the Raised style. Enter Recorded? as the label.

11. Open the Tab Order dialog box and set the tab order automatically.
12. Switch to **Form** view and press [Tab] as necessary to view the tab order. Return to **Design** view.

13. Create a custom tab order. Move the **Payment Date** field above the **Amount Paid** field and close the Tab Order dialog box.

14. Display the form header in **Design** view and create a label with the text **Payment Form** in the left side of the form header.

15. Switch to **Form** view and create the following new record.

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project ID:</td>
<td>23</td>
</tr>
<tr>
<td>Payment Date:</td>
<td>10/3/03</td>
</tr>
<tr>
<td>Amount Paid:</td>
<td>600</td>
</tr>
<tr>
<td>Trainer Initials:</td>
<td>EK</td>
</tr>
<tr>
<td>Credit Rating:</td>
<td>B</td>
</tr>
<tr>
<td>Recorded:</td>
<td>No</td>
</tr>
</tbody>
</table>

16. Close the form and save it.

17. Close the database file.
LESSON 12 - USING EDITING TOOLS

In this lesson, you will learn how to:

- Change the font
- Change the font size
- Change the character format
- Change the font color
- Change fill and background colors
- Format lines and borders
- Apply special effects
- Use conditional formatting
- Use the Format Painter
- Use AutoFormat
- Use error checking
- Run the spelling checker
- Set AutoCorrect options
- Add AutoCorrect entries
CHANGING THE FONT

Discussion

You can change the font for any object (i.e., a control or label) to improve the overall appearance of a form or report. Different fonts can also help emphasize desired parts of a form or report.

Access includes many font typefaces from which you can choose. They range from heavy bold typefaces to thin light ones. A list of available font typefaces and a sample of their appearance can be viewed in the Font list in the Fonts group on the Home tab.

You can mix fonts within a single form or report. If you have a form or report with headings and text beneath each heading, you can select one font for the headings and another for the text. Varying the font within a form or report improves the readability of the text and emphasizes key points. However, mixing too many fonts can be distracting.

You can quickly select a font by selecting the text in the Font box in the Fonts group on the Home tab, typing the name of the desired font, and pressing the [Enter] key. The most recently used fonts appear in a list at the top of the Font list.

You can also change a font using the Font Name property on the Format page in the property sheet.
You can use the **Align Left**, **Center**, and **Align Right** buttons on the **Home** tab to align the text in a control.

**Procedures**

1. Open the desired form or report in **Design** view.
2. Select the object for which you want to change the font name.
3. Select the **Home** tab.
4. Click the **Font** list in the **Font** group.
5. Select the desired font name.

**Step-by-Step**

From the Student Data directory, open **EDIT1.ACCDB**. Change the font.

If necessary, right click on the **Items per Order** report and select **Design** view to view the report in **Design** view.

<table>
<thead>
<tr>
<th><strong>Steps</strong></th>
<th><strong>Practice Data</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the object for which you want to change the font name. <em>Sizing handles appear around the object.</em></td>
<td>Click the <strong>Items per Order</strong> label at the top of the report</td>
</tr>
<tr>
<td>2. Select the <strong>Home</strong> tab on the <strong>Ribbon</strong>. <em>The <strong>Home</strong> tab is displayed.</em></td>
<td>Click <strong>Home</strong></td>
</tr>
<tr>
<td>3. Click the <strong>Font</strong> list in the <strong>Font</strong> group. <em>A list of fonts is displayed.</em></td>
<td>Click <strong>Font</strong></td>
</tr>
<tr>
<td>4. Select the desired font name. <em>The font is applied to the object.</em></td>
<td>Scroll as necessary and click <strong>Arial</strong></td>
</tr>
</tbody>
</table>
CHANGING THE FONT SIZE

Discussion

You can select different font sizes for any text displayed. Generally speaking, larger font sizes are used for labels or text of great importance, and smaller font sizes are used for less important objects, such as page numbers.

Font size is measured in points. One point is approximately 1/72 of an inch. Therefore, a word with a 36 point font size is approximately one-half inch in height. The larger the font size, the larger the type.

You can select a font size prior to typing text. As you type, you can mix font sizes. For example, if you are creating a report, you can use a 22 point font for the headings and a 12 point font for the controls. Varying the font within a form or report improves the readability of the text and emphasizes key objects.

You can also change a font size using the Font Size property on the Format page in the property sheet.

Procedures

1. Open the desired form or report in Design view.
2. Select the object for which you want to change the font size.
3. Select the Home tab on the Ribbon.
4. Click the Font Size list in the Font group.
5. Select the desired font size.

Step-by-Step

Change the font size.

If you have not been using the Items per Order report, open the Items per Order 2 report in Design view.
**Steps** | **Practice Data**  
--- | ---  
1. Select the object for which you want to change the font size.  
   *Sizing handles appear around the object.*  
   Scroll as necessary and click the \(\text{= Date()}\) text box in the Report Header section  
2. Select the **Home** tab on the **Ribbon**.  
   *The Home tab is displayed.*  
   Click **Home**  
3. Select the **Font Size** list in the **Font** group.  
   *A list of font sizes is displayed.*  
   Click **Font Size**  
4. Select the desired font size.  
   *The font size is applied to the object.*  
   Click **11**

Adjust the date field so that it is horizontally aligned with the **Current as of** label by holding the [Ctrl] key and pressing the [Up] arrow key on the keyboard twice to align the controls. Preview the report to verify the proper alignment. Switch back to Design view.

### Changing the Character Format

**Discussion**

You can change the character formats of an object, either to add emphasis or to enhance the appearance of the text. The most commonly used character formats are bold, italic, and underline.

Bold formatting is used to call attention to text within a form or report, especially in headings. You might use this format, for example, in a report title.

Italic formatting also calls attention to text, but not as much as bold formatting. Italicized text slants to the right and is often used to emphasize a word within normal text.

Underlining is also used to call attention to text. It is also commonly placed under a total field. The default underline style is a solid, single line.

You can tell which character formats have been applied to specific text by positioning the insertion point in the object. For example, if bold formatting has been applied to the current object, the **Bold** button is highlighted when you position the insertion point in the text.

You can apply character formats to existing text or change character formats as you type text. If you no longer want a character format applied to text, you can remove the formatting.
These font formats apply to the entire contents of the control; you cannot change individual characters within a control.

The **Bold**, **Italic**, and **Underline** buttons are toggles. If you select an object that contains one of these formats and click the **Bold**, **Italic**, and **Underline** button, the format is removed.

You can also use the **Format** page in the property sheet to add font formats to text. You can use the **Font Underline** and **Font Italic** properties to add underlining and italics. The **Font Weight** property provides multiple bolding options, including **Thin**, **Semi-bold**, **Extra Bold**, and **Heavy**.

### Procedures

1. Open the desired form or report in **Design** view.
2. Select the object for which you want to change the character formatting.
3. Click the desired format button on the **Home** tab.

### Step-by-Step

Change the character formatting.

If you have not been using the **Items per Order** report, open the **Items per Order 3** report in **Design** view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the object for which you want to change the character formatting. <strong>Sizing handles appear around the object.</strong></td>
<td>Scroll as necessary and click the <strong>Order Number</strong> label in the <strong>Page Header</strong> section</td>
</tr>
<tr>
<td>2. Click the desired format button on the <strong>Home</strong> tab on the <strong>Ribbon</strong>. <strong>The format is applied to the object.</strong></td>
<td>Click</td>
</tr>
</tbody>
</table>
**Practice the Concept:** Apply the italic format to the remaining page headings. Select the *Total for Order* calculated control in the *Order Number Footer* section and apply the bold and underline formats.

Preview the report and notice the changes. Switch back to *Design* view.

---

**CHANGING THE FONT COLOR**

**Discussion**

You can change the color of the font in any object that contains text. You can change the color of all the text in the object, or you can change only the font color of selected characters. Changing font color draws attention to text.

When selecting a font color for text, you should be aware of the background color of the object. For example, red text will stand out on a white background, whereas yellow text will not.

The *Font/Fore Color* button has two components. The button face displays the currently selected color. To apply the currently selected color to another object, you only have to select the object and click the button. In addition, you can use the *Font/Fore Color* list to select a different color from the color palette.

---

You can also change the font color using the *Fore Color* property on the *Format* page in the property sheet. The *Color* palette allows you to create custom colors.

---

**Procedures**

1. Open the desired form or report in *Design* view.
2. Select the object for which you want to change the font color.
3. Click the arrow on the *Font/Fore Color* button on the *Home* tab.
4. Select the desired font color.

---

**Step-by-Step**

Change the font color of text in an object.
If you have not been using the **Items per Order** report, open the **Items per Order 4** report in **Design** view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the object for which you want to change the font color. <em>Sizing handles appear around the object.</em> Click the <strong>Items per Order</strong> label at the top of the report.</td>
<td></td>
</tr>
<tr>
<td>2. Click the arrow on the <strong>Font/Fore Color</strong> button on the <strong>Home</strong> tab. <em>A color palette is displayed.</em> Click the <strong>arrow</strong>.</td>
<td></td>
</tr>
<tr>
<td>3. Select the desired font color. <em>The font color of the text within the object changes accordingly.</em> Click <strong>Red</strong></td>
<td></td>
</tr>
</tbody>
</table>

**CHANGING FILL AND BACKGROUND COLORS**

**Discussion**

You can change the fill color of a control or drawn object at any time. Adding color to a form may make it easier to enter data when the form is viewed on a monitor. For example, you can differentiate controls by applying the same background color to related controls. Furthermore, if you have a color printer, you may want to use color to create more attractive reports. For example, you can change the background color of a label containing the report name to blue.

In addition to changing the fill color of objects, you can change the background color of the design grid. Each section, **Detail**, **Page Header**, **Report Header** or **Form Header**, can display a different background color.

If the fill color of a drawn object hides text in a form or report, you can remove the fill by selecting the **Transparent** option for that object. Then, only the border of the object appears around the text. You can also layer objects by moving one object behind another. That way you can create a filled color rectangle behind related controls.

The **Fill/Back Color** button consists of two components. The button face displays the currently selected color. To apply the currently selected color to another object, you only have to select the object and click the button. You can also use the **Fill/Back Color** list to select the desired color from the color palette.
The default background color of a report is white, not transparent.

You can change the layer of an overlapping object by selecting the **Arrange** tab and the **Bring to Front** or **Send to Back** buttons.

You can also change the background of an object using the **Format** page in the property sheet. Use the **Back Style** property to specify if the object is filled (**Normal**) or **Transparent** and the **Back Color** property to change background colors. The **Color** palette allows you to create custom colors.

### Procedures

1. Open the desired form or report in **Design** view.
2. Select the object for which you want to change the fill color.
3. Click the arrow on the **Fill/Back Color** button on the **Home** tab.
4. Select the desired fill color.
Step-by-Step

Change the fill and background colors of objects.

If you have not been using the Items per Order report, open the Items per Order 5 report in Design view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the object for which you want to change the fill color. Sizing handles appear around the object.</td>
<td>Click the Items per Order label at the top of the report, if necessary</td>
</tr>
<tr>
<td>2. Click the arrow on the Fill/Back Color button on the Home tab. A color palette is displayed.</td>
<td>Click the arrow</td>
</tr>
<tr>
<td>3. Select the desired fill color. The fill color of the object changes accordingly.</td>
<td>Click Light Blue 1 (Standard Colors)</td>
</tr>
</tbody>
</table>

Practice the Concept: Select the Worldwide Sporting Goods label and click the Fill/Back Color button face to apply the current color. Then, remove the fill color by selecting Transparent from the Fill/Back Color palette.

Click in a blank area in the Order Number Footer section. Use the Fill/Back Color palette to change the background of the section to a light gray. Then, preview the first and second pages of the report. Switch back to Design view.

Format Line and Borders

Discussion

You can format lines and borders by changing the line color, width, and style. In an enclosed object, such as a control, the line is the border around an object. In an open object, such as a drawn line, the line is the object itself.

You can change the width of a line or border using the Line/Border Width button. The default line width is Hairline, but the width of a line can be increased from 1 to 6 points.

The Line/Border Width button has two components. The button face displays the currently selected width. To apply the currently selected width to another object, you only have to select the object and click the button. In addition, you can use the Line/Border Width list to select a different color from the width palette.
You can also change the line/border color of an object using the Line/Border Color button. Changing the border color can enhance the appearance of the object. For example, if you are creating a logo, changing the line color can help distinguish the border of the logo. You can either apply the current color by clicking the button face or select a different color from the Line/Border Color list.

In addition to changing the line width and color, you can also change the line style. The default line style is a solid line, but other choices include dashes, dots, and combinations of dashes and dots. The line style can be changed using the Border Style property on the Format page in the property sheet.

**Procedures**

1. Open the desired form or report in Design view.
2. Select the object for which you want to change the line format.
3. To change the line width, click the arrow on the Line Thickness button ➞ in the Controls group on the Design tab.
4. Select the desired line width.
5. To change the line color, click the arrow on the LineColor button ➞ in the Controls group on the Design tab.
6. Select the desired line color.
7. To change the line type, select the Line Type button ➞ in the Controls group on the Design tab.
8. Select the desired style.

**Step-by-Step**

Format the lines and borders of objects.

If you have not been using the Items per Order report, open the Items per Order 6 report in Design view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the object for which you want to change the line format. <em>Sizing handles appear around the object.</em></td>
<td>Click the line under the labels in the Page Header section</td>
</tr>
</tbody>
</table>
### Steps

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>2. To change the line width, click the arrow on the <strong>Line Thickness</strong> button in the <strong>Controls</strong> group on the <strong>Design</strong> tab. <em>A palette of line widths is displayed.</em></td>
<td>Click 🏛️</td>
</tr>
<tr>
<td>3. Select the desired line width. <em>The line width is applied to the line.</em></td>
<td>Click the 3rd line from the top</td>
</tr>
<tr>
<td>4. To change the line color, click the arrow on the <strong>Line Color</strong> button in the <strong>Controls</strong> group on the <strong>Design</strong> tab. <em>A color palette is displayed.</em></td>
<td>Click 🏛️</td>
</tr>
<tr>
<td>5. Select the desired line color. <em>The line color changes accordingly.</em></td>
<td>Click Blue</td>
</tr>
<tr>
<td>6. To change the line type, click the <strong>Line Type</strong> button in the <strong>Controls</strong> group on the <strong>Design</strong> tab. <em>The property sheet for the selected text box opens.</em></td>
<td>Click 🏛️</td>
</tr>
<tr>
<td>7. Select the desired style. <em>The line type is selected.</em></td>
<td>Click the 6th line from the top</td>
</tr>
</tbody>
</table>

#### Practice the Concept:

Select the **Items per Order** label in the **Report Header** section. Click the **Line Color** button to apply the blue line color to the border of the label. Click the **Line Thickness** button to apply the 3 point line width to the label. Preview the first two pages of the report, and then, switch back to **Design** view.

### Applying Special Effects

#### Discussion

Special three dimensional effects can be applied to objects to create interest or a feeling of depth. There are five special effects you can apply: **Raised**, **Sunken**, **Etched**, **Shadowed**, and **Chiseled**. You can remove a special effect by applying the **Flat** effect.

The **Special Effect** button has two components. The button face displays the currently selected effect. You can either apply the current special effect by clicking the button face or select a different special effect from the **Special Effect** list.
Procedures

1. Open the desired form or report in Design view.
2. Select the object for which you want to apply a special effect.
3. Click the Special Effect button in the Controls group on the Design tab.
4. Select the desired effect.

Step-by-Step

Apply a special effect to an object.

If you have not been using the Items per Order report, open the Items per Order 7 report in Design view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the object for which you want to apply a special effect. &lt;br&gt;&lt;i&gt;Sizing handles appear around the object.&lt;/i&gt;</td>
<td>Click the Items per Order label at the top of the report, if necessary</td>
</tr>
</tbody>
</table>
## Steps | Practice Data
--- | ---
2. Click the **Special Effect** button in the **Controls** group on the **Design** tab.  
* A palette of special effects is displayed. | Click ![Special Effect](image)
3. Select the desired effect.  
* The special effect is applied to the object. | Click ![Special Effect](image): Shadowed

**Practice the Concept:** Select the **Total for Order** calculated control in the **Order Number Footer** section. Apply a black border to the control and the **Sunken** special effect.

Preview the first and second pages of the report. Magnify the preview, if necessary, to see the special effects. Then switch back to **Design view**.

### Using Conditional Formatting

#### Discussion

You can use conditional formatting in forms and reports to change the appearance of controls or to change the appearance of the text within a control, depending on one or more conditions. For example, you may want to format negative numbers in a different color font, so as to draw attention to records that may need further action.

![Conditional Formatting dialog box](image)

*The Conditional Formatting dialog box*

#### Procedures

1. Open the desired form or report in **Design** view.
2. Select the control for which you want to apply conditional formatting.
3. Select the **Design** tab on the **Ribbon**.

4. Click the **Conditional** button in the **Font** group.

5. Specify the desired conditions.

6. Select **OK**.

---

**Step-by-Step**

Apply conditional formatting to a control.

If you have not been using the **Items per Order** report, open the **Items per Order 7** report in **Design** view.

<table>
<thead>
<tr>
<th><strong>Steps</strong></th>
<th><strong>Practice Data</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the control for which you want conditional formatting. <em>Sizing handles appear around the object.</em></td>
<td>Click the <strong>Unit Price</strong> text box in the <strong>Detail</strong> section on the report</td>
</tr>
<tr>
<td>2. Select the <strong>Design</strong> tab on the <strong>Ribbon</strong>. <em>The Design tab is displayed.</em></td>
<td>Click <strong>Design</strong></td>
</tr>
<tr>
<td>3. Click the <strong>Conditional</strong> button in the <strong>Font</strong> group. <em>The Conditional Formatting dialog box opens.</em></td>
<td>Click <strong>Conditional</strong></td>
</tr>
<tr>
<td>4. Specify the desired conditions and select <strong>OK</strong>. <em>The conditional formatting is set.</em></td>
<td>Follow the steps beneath the table</td>
</tr>
</tbody>
</table>

In the **Condition 1** section, make sure the first box is set to **Field Value Is**. The second box should be set to **between**. In the third box type **0**, and in the fourth box, type **50**.

Then, select the **Font Color** button, and select **Yellow**. Click **OK**, then save the report.

Preview the report. Notice that when a unit price is between the values of 0 and 50, the amount is displayed in a yellow font.
Using the Format Painter

Discussion

You can use the **Format Painter** button in the **Font** group on the **Design** tab to copy the style of a specific object and apply it to other objects. This feature saves time when multiple formats have been applied to the object and you want to format other objects with the same formats.

When the Format Painter is active, a paintbrush appears at the bottom right corner of the mouse pointer.

To copy the selected formatting to multiple locations, double-click the **Format Painter** button to enable it. Then, click it again when you have finished formatting text to disable it.

Procedures

1. Open the desired form or report in **Design** view.
2. Select the object containing the style you want to copy.
3. Select the **Format Painter** button in the **Font** group on the **Design** tab.
4. Click the object.

Step-by-Step

Use the Format Painter to copy styles to existing objects.

If you have not been using the **Items per Order** report, open the **Items per Order** report in **Design** view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the object containing the style you want to copy.  
* Sizing handles appear around the object. | Click the **Items per Order** label in the **Report Header** section |
<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>2. Click the <strong>Format Painter</strong> button in the <strong>Font</strong> group on the <strong>Design</strong> tab. <strong>The Format Painter is enabled.</strong></td>
<td><strong>Click</strong> <img src="image" alt="Format Painter" /></td>
</tr>
<tr>
<td>3. Click the object. <strong>The formatting is applied to the object.</strong></td>
<td><strong>Click the <strong>Worldwide Sporting Goods</strong> label</strong></td>
</tr>
</tbody>
</table>

Click in the **Worldwide Sporting Goods** label to display the sizing handles. Double-click the right, middle sizing handle to autofit the label box to the text size.

Preview the report. Then, switch back to **Design** view.

## USING AUTOFORMAT

### Discussion

Access provides you with a variety of predefined formats you can apply to objects in a form or report. The formats control such aspects as font, color, and border style. Access also allows you to customize the predefined formats or create your own. You can use the **AutoFormat** feature to apply a format to an entire form or report or to selected sections and controls.

### Procedures

1. Open the desired form or report in **Design** view.
2. Select the **Arrange** tab on the **Ribbon**.

![AutoFormat](image)

3. Select the **AutoFormat** button in the **Autoformat** group.
4. Select the desired format.

### Step-by-Step

Use the **AutoFormat** feature.

If you have not been using the **Items per Order** report, open the **Items per Order 9** report in **Design** view.
Steps | Practice Data
---|---
1. Select the **Arrange** tab on the **Ribbon**. *The Arrange tab is displayed.* | Click **Arrange**
2. Select the **AutoFormat** button in the **Autoformat** group. *The AutoFormat gallery opens.* | Click **AutoFormat**
3. Select the desired format. *The AutoFormat gallery closes and the format is applied to the selected object(s).* | Click **Office (First Column, 4th Row)**

Preview the report and then close the report without saving the changes.

**USING ERROR CHECKING**

**Discussion**

When you are working with forms and reports in Access 2007, you can correct errors automatically using automatic error checking. When an error is detected in a form or report, a green indicator appears in the upper-left corner of the control. When the indicator is selected, a Trace Error options button containing an exclamation point appears, from which you can select several correction options. For example, if error checking detects a problem with a shortcut key, the error checking menu will allow you to change the shortcut key, edit the property, get help on the error, ignore the error, or open the Options dialog box so that the error checking options can be altered.

Error checking automatically checks for the following types of errors:

<table>
<thead>
<tr>
<th>Error</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Keyboard shortcut errors</strong></td>
<td>The control contains an inappropriate shortcut key, such as one used by another label or button, or a control that uses a space character as its shortcut key.</td>
</tr>
<tr>
<td><strong>Unassociated label and control</strong></td>
<td>A selected label and control are not associated with one another.</td>
</tr>
<tr>
<td><strong>New associated labels</strong></td>
<td>A label, which is added to a form or report, is not associated with any other control.</td>
</tr>
<tr>
<td><strong>Invalid control properties</strong></td>
<td>A control has one or more properties set to invalid values, such as an invalid expression or field name.</td>
</tr>
<tr>
<td>Error</td>
<td>Description</td>
</tr>
<tr>
<td>------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Common report errors</td>
<td>The report is wider than the designated paper size or the defined sorting and grouping option is invalid.</td>
</tr>
</tbody>
</table>

**Error checking options**

- The default color for error checking is green, but you can change the color indicator using the **Error indicator color** button on the **Object Designers** page of **Access Options**.

- If you do not want certain errors to be detected, you can disable the desired options on the **Object Designers** page of **Access Options**.

- When you select an unassociated label and control in order to move or format them, the **Trace Error** options button will appear, but the error checking indicator will not appear.

**Procedures**

1. Open the desired form or report in **Design** view.
2. Click the green error indicator in the upper-left corner of the control you want to correct.
3. Click the **Trace Error** button next to the control.
4. Select the desired error correction option.
Step-by-Step

Use error checking to correct a control.

Open the Orders form in Design view. Notice the error checking indicators in the upper-left corners of the Order Date and Shipping Date controls and notice that each control contains a shortcut key associated with the letter “a”, indicated by the underlined character in the control label.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Click the green error indicator in the upper-left corner of the control you want to correct.  
A Trace Error button appears to the right of the control. | Click the green error indicator in the upper-left corner of the Shipping Date control |
| 2. Click the Trace Error button next to the control.  
A list of error checking options is displayed. | Click 🚭 |
| 3. Select the desired error correction option.  
The error is corrected and the green error indicator is no longer displayed. | Follow the instructions shown below the table |

Point to Change Caption, then select the Shipping Date option. Notice that the green error checking indicators are no longer displayed.

RUNNING THE SPELLING CHECKER

Discussion

You can invoke the spelling checker to spell check text in tables and controls in forms or reports. When checking tables, you can check the entire table or selected columns.

When the spelling checker finds the first word that is not in a dictionary, it pauses and the Spelling dialog box opens. The Spelling dialog box does not open if there are no errors found.

A word identified as misspelled appears in the Spelling dialog box, with possible corrections listed in the Suggestions list box. There are several alternatives when a word is identified as incorrect. You can select the correct spelling of the word in the
Suggestions list box and use the Change button to change just the current occurrence or the Change All button to change all occurrences of the misspelled word. However, if the list of possible alternative spellings in the Suggestions list box does not contain the correct spelling, you can type the correct spelling directly into the Spelling dialog box. If the word is correct, you can use the Ignore Once button to disregard just the current occurrence or the Ignore All button to disregard all occurrences of the error. Another alternative for a correctly spelled word (such as a company name, acronym or abbreviation) is to use the Add button to add the word to the custom dictionary.

If you make a mistake during a spell check, you can use the Undo Last button in the Spelling dialog box to reverse any changes you make. The Undo Last button can reverse multiple spelling actions one at a time, working backward from the previous action.

- When using the spelling checker in a table, you have the option of ignoring certain fields. This option is useful for fields containing names of people or obscure text.
- Using the Proofing page in Access Options, you can run the spell checker in a different language, and choose to ignore words in uppercase, words with numbers, and Internet and file addresses during the spell check.
- You can also reverse the changes you make during a spell check by clicking in the table and using the Undo button on the Quick Access Toolbar.

Procedures

1. Open the object you want to spell check.

2. If checking a table, select the heading of the column(s) you want to spell check.

3. Click the Spelling button in the Records group on the Home tab.

4. To change the spelling of an identified word, select the desired spelling for the identified word from the Suggestions list box.

5. Select Change or Change All, as desired.

6. To ignore an identified word, select Ignore or Ignore All, as desired.
7. To add an identified word to the custom dictionary, select **Add**.

8. To edit an identified word, type the correct spelling of the identified word in the **Not In Dictionary** box.

9. Select **Change** or **Change All**, as desired.

10. To reverse an action, select **Undo Last**.

11. To end a spell check before it is completed, select **Close**.

12. If prompted, select **OK** to end a spell check when it is complete.

### Step-by-Step

Run the spelling checker to check a table for errors.

Open the **Packing Slip** table in **Datasheet** view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. If checking a table, select the heading of the column(s) you want to spell check.  
*The column is selected.* | Click the **Product Description** column heading |
| 2. Click the **Spelling** button in the **Records** group on the **Home** tab.  
*The Spelling dialog box opens and the first identified word is highlighted.* | Click [Spelling](#) |
| 3. To change the spelling of an identified word, select the desired spelling for the identified work from the **Suggestions** list box.  
*The suggested word is selected.* | Click **badminton**, if necessary |
| 4. Select **Change** or **Change All**, as desired.  
*The identified word(s) in the object are replaced with the word selected from the **Suggestions** list box.* | Click [Change](#) |
**Steps** | **Practice Data**
---|---
5. To ignore an identified word, select **Ignore** or **Ignore All**, as desired.  
*This occurrence of the identified word is ignored or all occurrences are ignored and the next identified word is highlighted.* | Click **Ignore All** to ignore all occurrences of TreadMaster
6. To edit an identified word, type the correct spelling of the identified word in the **Not In Dictionary** box.  
*The text appears in the Not In Dictionary box.* | Type **biking** to replace **bkg**
7. Select **Change** or **Change All** as desired.  
*The identified word(s) in the object are changed.* | Click **Change All**
8. Continue the spell check as desired.  
*The spell check proceeds and a Microsoft Office Access message box opens when the spell check is complete.* | Follow the instructions shown below the table before continuing on to the next step
9. If prompted, select **OK** to end a spell check when it is complete.  
*The Microsoft Office Access message box closes and the spell check is complete.* | Click **OK**

Ignore all occurrences of the words **womens** and **mens**.

*Return to the table and continue on to the next step (step 9).*

Close the table.

---

**SETTING AUTO CORRECT OPTIONS**

**Discussion**

AutoCorrect automatically corrects misspelled or mistyped words as you type. For example, if you inadvertently type **teh** instead of **the**, Access will automatically make the correction. Access uses a predefined list of commonly misspelled or mistyped words.

Access provides several AutoCorrect options that can be enabled or disabled as desired. For instance, you can enable or disable the automatic correction of two
consecutive capital letters (such as **GReat** to **Great**) or the accidental use of the [Caps Lock] key, as well as the automatic capitalization of the first letter in a sentence and the days of the week.

AutoCorrect cannot make the corrections immediately, because it needs to sense what you are typing before it can make a change. As soon as you press the [Spacebar] key or type punctuation, AutoCorrect attempts to make the correction.

You may have situations in which you do not want AutoCorrect to correct text. In these cases, you can disable the applicable option, or you can use the **AutoCorrect Options** list to reverse the AutoCorrect correction or to automatically stop correcting the entry.

### Procedures

1. Select the **Office** button.
2. Select the **Access Options** button.
3. Select **Proofing**.
4. Select the **AutoCorrect Options** button.
5. Select or deselect the desired options.
6. Select **OK**.

### Step-by-Step

Set AutoCorrect options.

Open the **Reps** table in **Datasheet** view.

Select the **REGION** field in the new record row. Type **SAmerica** and press [Tab]. Notice that Access corrects the data to **Samerica**. Delete the **Region** entry.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the <strong>Office</strong> button. <strong>The Office menu is displayed.</strong></td>
<td>Click</td>
</tr>
<tr>
<td>2. Select <strong>Access Options</strong>. <strong>The Access Options window opens.</strong></td>
<td>Click</td>
</tr>
</tbody>
</table>
### Steps

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 3. Select **Proofing**.  
*The Proofing page is displayed.* | Click **Proofing** |
| 4. Select the **AutoCorrect Options** button.  
*The AutoCorrect dialog box opens.* | Click  
[AutoCorrect Options...](#) |
| 3. Select or deselect the desired options.  
*The options are enabled or disabled as appropriate.* | Click **Correct Two Initial Capitals**  
to deselect it |
| 4. Select **OK**.  
*The AutoCorrect dialog box closes and the AutoCorrect options are set.* | Click **OK** |

Select the **REGION** field, if necessary. Type **SAmerica** again and press **[Tab]**. Notice that Access does not correct the two initial caps. Delete the entry in the **Region** field.

**Practice the Concept:** Open the AutoCorrect dialog box, select the **Correct Two Initial Capitols** option and close the dialog box.

---

### ADDING AUTOCORRECT ENTRIES

#### Discussion

To use AutoCorrect to its full potential, it is a good idea to add the typing mistakes you make most often and the correct replacements to the AutoCorrect dictionary. You can also add abbreviations for commonly typed text. For example, you can add initials and the corresponding full name to the dictionary so that when you type **JAD**, AutoCorrect replaces it with **John Alan Doe**.
Adding an AutoCorrect entry

You can delete an AutoCorrect entry you no longer use by opening the AutoCorrect dialog box, selecting the entry from the AutoCorrect list and selecting Delete.

To quickly find an entry in the AutoCorrect dictionary, you can type the first few letters of the entry in the Replace box. The list box scrolls automatically to the entry.

Procedures

1. Select the **Office** button.
2. Select the **Access Options** button.
3. Select **Proofing**.
4. Select the **AutoCorrect Options** button.
5. Type the text you want to replace in the Replace box.
6. Press [Tab].
7. Type the replacement text in the With box.
8. Select **Add**.
9. Select **OK**.

![Step-by-Step](image)

**Step-by-Step**

Add AutoCorrect entries.

If necessary, open the **Reps** table in **Datasheet** view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the <strong>Office</strong> button.</td>
<td>Click</td>
</tr>
<tr>
<td><em>The Office menu is displayed.</em></td>
<td></td>
</tr>
<tr>
<td>2. Select <strong>Access Options</strong>.</td>
<td>Click Access Options</td>
</tr>
<tr>
<td><em>The Access Options window opens.</em></td>
<td></td>
</tr>
<tr>
<td>3. Select <strong>Proofing</strong>.</td>
<td>Click Proofing</td>
</tr>
<tr>
<td><em>The Proofing page is displayed.</em></td>
<td></td>
</tr>
<tr>
<td>4. Select the <strong>AutoCorrect Options</strong> button.</td>
<td>Click AutoCorrect Options...</td>
</tr>
<tr>
<td><em>The AutoCorrect dialog box opens with the insertion point in the <strong>Replace</strong> box.</em></td>
<td></td>
</tr>
<tr>
<td>5. Type the text you want to replace in the <strong>Replace</strong> box.</td>
<td>Type <strong>NE</strong></td>
</tr>
<tr>
<td><em>The text appears in the <strong>Replace</strong> box.</em></td>
<td></td>
</tr>
<tr>
<td>6. Press [Tab].</td>
<td>Press [Tab]</td>
</tr>
<tr>
<td><em>The insertion point appears in the <strong>With</strong> box.</em></td>
<td></td>
</tr>
<tr>
<td>7. Type the replacement text in the <strong>With</strong> box.</td>
<td>Type <strong>Northeast</strong></td>
</tr>
<tr>
<td><em>The text appears in the <strong>With</strong> box.</em></td>
<td></td>
</tr>
<tr>
<td>8. Select <strong>Add</strong>.</td>
<td>Click Add</td>
</tr>
<tr>
<td><em>The entry is added to the AutoCorrect dictionary in alphabetical order.</em></td>
<td></td>
</tr>
<tr>
<td>9. Select <strong>OK</strong>.</td>
<td>Click OK</td>
</tr>
<tr>
<td><em>The AutoCorrect dialog box closes and the AutoCorrect entry is now available.</em></td>
<td></td>
</tr>
</tbody>
</table>

In the **Reps** table, select the **REGION** field in the new record row, if necessary. For the region, type **NE** and press [Tab]. Notice that **NE** is replaced with **Northeast**.
**Practice the Concept:** Open the AutoCorrect dialog box and type **NE** in the **Replace** box to select the entry. Select **Delete** to delete the entry from the **Replace** list and then Select **OK**.

Close the **Reps** table.
Close **EDIT1.ACCDB**.
EXERCISE

USING EDITING TOOLS

Task

Use editing tools.

1. Open EDIT1X.ACCDB.
2. Open the Client Information Report report in Design view.
3. Use AutoFormat to apply the Apex style.
4. Change the font size of the controls to 12. Preview the report.
5. Set the Client ID bound control (text box) to appear in bold and italic style.
6. Using the Format Painter, apply the style of the Client ID bound control to all of the other bound controls. Adjust the size of the controls to fit the entire text as necessary.
7. Preview the report and then close it without saving the changes.
9. Change the background color of the Page Header and Page Footer sections to light gray.
10. Make the background of the Project Information Report label transparent and the font color white.
11. Use conditional formatting to change the font color of all Total Sale values under $10,000 to green.
12. Add a raised special effect to the Trainer Initials text box and a shadow special effect to Project Information Report label.
13. Preview the report.
14. Close the report, saving the changes.
15. Open the Invoice table in Datasheet view.
16. Spell check the City column making the necessary changes as desired.
17. Close the Invoice table and open the Client table in Datasheet view.
18. Add the letters ch to represent Chicago in the AutoCorrect dialog box.
19. Add a new record with the **Client ID ABC**. Press [Tab] to the **City** field, type the AutoCorrect entry, and press [Tab].

20. Delete the **ch** entry for **Chicago** in the AutoCorrect dialog box.

21. Close the table, and then close the database file.
LESSON 13 - USING ADVANCED REPORT DESIGN

In this lesson, you will learn how to:

- Add report sections in Design view
- Create a calculated control
- Create a running summary
- Insert a date/time control
- Insert a page break
- Change the report margins
- Use the Label Wizard
- Create a report without using a wizard
Adding Report Sections in Design View

Discussion

You can create or customize a report in Design view. A report has three basic sections: Detail, Report Header/Footer, and Page Header/Footer.

The Detail section contains the information from the table or query. You create controls in the Detail section that display information. You can display either one record per page or multiple records per page.

The Report Header and Report Footer sections display at the top and bottom of the report in Design view. When you print the report, these sections appear at the beginning and the end of the report only. The header can be used for report titles, while the footer can be used for report totals or other summaries.

The Page Header and Page Footer sections display at the top and bottom of the report in Design view. When the report is printed, these sections appear at the top and bottom of every page. Page headers and footers can contain images, lines, text, or any other controls you want printed on every page.

When you enable the display of either header and footer section, both the header and the footer appear. You can drag the header and footer sections to size them.
Procedures

1. Open the desired report in Design view.
2. Select the Arrange tab on the Ribbon.
3. Select the Page Header/Footer button or Report Header/Footer button.

Step-by-Step

From the Student Data directory, open ADVREP.ACCDB.
Add report sections in Design view.

Open the Items report in Design view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Arrange tab on the Ribbon. <em>The Arrange tab is displayed.</em> Click Arrange.</td>
<td></td>
</tr>
<tr>
<td>2. Select the Page Header/Footer or Report Header/Footer button in the Show/Hide group. <em>The Page Header and Page Footer or the Report Header and Report Footer sections appear.</em> Click ▽</td>
<td></td>
</tr>
</tbody>
</table>

If necessary, select the Design tab and add a label to the left side of the report header. Enter the text Order Entry Report. Preview the report. Notice the report header at the top of the page. Switch back to Design view.

**Practice the Concept:** Use the Arrange tab to add a page header and footer to the report. Add a label to the center of the page header. Enter the text Worldwide Sporting Goods.

Preview the report and change to a 2-page view. Notice that the report header only appears on the first page, but the page header appears at the top of each page. Switch to Design view.

Close the report without saving the changes.
CREATING A CALCULATED CONTROL

Discussion

You can add a calculated control to a form or report. A calculated control is not bound to a field. It contains an expression that uses information from fields to calculate a result. The result is not stored in a table. It is calculated when the report or form is run.

You can type the expression that calculates the result directly into the control or open the property sheet and type the expression into the Control Source property box on the Data page.

Procedures

1. Open the desired report in Design view.
2. Select the Design tab on the Ribbon.
3. Click the Text Box tool in the Controls group.
4. Click in the desired location for the control.
5. Type the desired calculated control expression.
6. Press [Enter].
7. Select the label box paired with the control.
8. Press [Delete].

Step-by-Step

Create a calculated control in a report.

Open the Items by Order report in Design view and display the ruler.

Scroll, if necessary, to display the Item Total column in the Page Header section.
**Steps** | **Practice Data**
---|---
1. Click the **Design** tab on the **Ribbon**. *The Design tab is displayed.* | Click **Design**
2. Click the **Text Box** tool in the **Controls** group. *The mouse pointer changes into a text box with a plus sign (+) when positioned over the report.* | Click **Text Box**
3. Click in the desired location for the control. *An unbound text box and a label appear.* | Click in the **Detail** section at 15" on the horizontal ruler
4. Type the desired calculated control expression. *The calculated expression appears in the text box.* | Type \( \text{Type } \) \( \text{=unit price}*\text{[quantity]} \)
5. Press **[Enter]**. *The calculated control expression is entered into the control.* | Press **[Enter]**
6. Select the label box paired with the control. *Sizing handles appear around the label.* | Click the **Text**: (xx is a **number**) label to the left of the calculated control
7. Press **[Delete]**. *The label box is deleted.* | Press **[Delete]**

Select the calculated control, open the **Property Sheet**, and use the **Format** property on the **Format** page to change the properties of the control so that it displays in currency format. Close the **Property Sheet**.

Select the **Quantity** text box control and the new calculated control in the **Detail** section and use the **Align** submenu to align the tops of both controls.

Preview the report. Scroll as necessary and view the **Item Total** column. Notice that the product of the unit price and the quantity is producing the **Item Total** column. Also, notice that the **Item Total** column appears in currency format. Switch back to **Design** view.
CREATING A RUNNING SUMMARY

Discussion

In a grouped report, you can create a running summary of the items in the group. A running summary provides a cumulative total for all the groups above.

Often, the running summary is positioned in the group footer, which appears at the bottom of every group. For example, in a sales report grouped by region, you can create a calculated field that displays information in a running summary. After each group, a cumulative total for all the groups above appears.

![Using an expression to create a running summary](image)

Procedures

1. Open the desired report in Design view.
2. Create the group summary calculated control expression.
3. Select the calculated control.
5. Select the Data tab.
6. Select the Running Sum property.
7. Select the Running Sum list.
8. Select the desired option.
Step-by-Step

Create a running summary in a report.

If necessary, display the ruler.

If you have not been using the Items by Order report, open the Items by Order 4 report in Design view and maximize the window.

Scroll as necessary to display the Order Number Footer section and select the calculated control to the right of the Total for Order label.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>2. Select the Data tab. The Data page appears with the insertion point in the Control Source property box.</td>
<td>Click the Data tab</td>
</tr>
<tr>
<td>3. Select the Running Sum property. The insertion point appears in the Running Sum property and an arrow appears to the right of the property.</td>
<td>Click the Running Sum property</td>
</tr>
<tr>
<td>4. Select the Running Sum list. A list of options appears.</td>
<td>Click Running Sum ▼</td>
</tr>
<tr>
<td>5. Select the desired option. The desired option appears in the Running Sum property.</td>
<td>Click Over Group</td>
</tr>
</tbody>
</table>

Preview the report. Scroll as necessary and notice the cumulative subtotals calculated for each order number. Switch back to Design view.

Inserting a Date/Time Control

Discussion

You can insert controls that display the current date and/or time in a report. Each control updates automatically every time the report is previewed or printed. By
default, a date/time control is inserted into the Report Header section. However, you can easily move it to another section. For example, you could place the date in the Report Footer section so that it would be readily visible on the last page of the report.

The Date and Time dialog box inserts a control that uses the =Date() function to display the current date.

If you create a report with the Report Wizard, Access automatically inserts a date/time control in the Page Footer section with the =Now() function, formatted to show the date only in Long Date format.

Procedures

1. Open the desired report in Design view.
2. Select the Design tab on the Ribbon.
3. Select the Date and Time button in the Controls group.
4. Select or deselect options as desired.
5. Select OK.
6. Drag the date control to the desired position in the report.

Step-by-Step

Insert a date/time control in a report.

If you have not been using the Items by Order report, open the Items by Order 5 report in Design view and maximize the window. Scroll as necessary to view the Report Header section.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Design tab on the Ribbon. &lt;br&gt;The Design tab is displayed.</td>
<td>Click Design</td>
</tr>
<tr>
<td>2. Select the Date and Time button in the Controls group. &lt;br&gt;The Date and Time dialog box opens.</td>
<td>Click</td>
</tr>
</tbody>
</table>
### Steps | Practice Data
---|---
3. Select or deselect options as desired. *A sample of the selected options appears in the Sample box.* | Click [Include Time] to deselect it
4. Select OK. *The Date and Time dialog box closes and the date control appears in the Report Header section.* | Click [OK]
5. Drag the date control to the desired position in the report. *An image of the control appears as you drag and then the selected control appears in the new location in the report.* | Drag the date control to the right of the Current as of label in the Report Header section

Preview the report. Scroll as necessary to view the date in the report header. Switch back to Design view.

## INSERTING A PAGE BREAK

### Discussion

When you print a report, Access automatically starts a new page when necessary. You can control the pagination by inserting a page break. You can insert a page break in the Group Footer section to place each group on its own page, or you can insert a page break in the Report Header section to create a separate title page for a report.

### Procedures

1. Open the desired report in Design view.
2. Select the Design tab on the Ribbon.
3. Click the Page Break button in the Controls group.
4. Click in the location for the page break.

### Step-by-Step

Insert a page break in a report.
If you have not been using the **Items by Order** report, open the **Items by Order 6** report in **Design** view.

<table>
<thead>
<tr>
<th><strong>Steps</strong></th>
<th><strong>Practice Data</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the <strong>Design</strong> tab on the <strong>Ribbon</strong>. The <strong>Design</strong> tab is displayed.</td>
<td>Click <strong>Design</strong></td>
</tr>
<tr>
<td>2. Click the <strong>Page Break</strong> button in the <strong>Controls</strong> group. <strong>The mouse pointer changes into a page with a plus sign (+) when positioned over the report</strong></td>
<td>Click <strong>Page Break</strong></td>
</tr>
<tr>
<td>3. Click in the location for the page break. <strong>A row of six small, black dots appears, indicating the page break location.</strong></td>
<td>Click near the bottom of the <strong>Report Header</strong> section</td>
</tr>
</tbody>
</table>

Click in a blank area of the form to deselect the dots indicating the page break. Preview the report in a two-page view. Notice that the report header appears by itself on the first page. Switch back to **Design** view.

**CHANGING THE REPORT MARGINS**

**Discussion**

By default, the margins for a report are one inch on all sides. You can control the margin settings to fit more or less data on a page as necessary. The margins you set for a report are saved and applied each time you print the report.

**Procedures**

1. Open the desired report in **Print Preview**.

2. Select the **Page Setup** button in the **Page Layout** group on the **Print Preview** tab.

3. Select the text in the **Top** box.

4. Type the new measurement for the top margin.
5. Select the text in the **Bottom** box.
6. Type the new measurement for the bottom margin.
7. Select the text in the **Left** box.
8. Type the new measurement for the left margin.
9. Select the text in the **Right** box.
10. Type the new measurement for the right margin.
11. Select **OK**.

### Step-by-Step

Change the report margins.

If you have not been using the **Items by Order** report, open the **Items by Order 7** report in **Print Preview**.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the **Page Setup** button in the **Page Layout** group on the **Print Preview** tab.  
  *The Page Setup dialog box opens with the **Margins** page displayed.* | Click **Page Setup**             |
| 2. Select the text in the **Top** box.  
  *The text in the **Top** box is selected.* | Double-click in the **Top** box  |
| 3. Type the new measurement for the top margin.  
  *The new measurement replaces the existing measurement in the **Top** box.* | Type **.75**                    |
| 4. Select the text in the **Bottom** box.  
  *The text in the **Bottom** box is selected.* | Press **[Tab]**                 |
| 5. Type the new measurement for the bottom margin.  
  *The new measurement replaces the existing measurement in the **Bottom** box.* | Type **.75**                    |
| 6. Select the text in the **Left** box.  
  *The text in the **Left** box is selected.* | Press **[Tab]**                 |
### Steps

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 7. Type the new measurement for the left margin.  
_The new measurement replaces the existing measurement in the Left box._ | Type .75 |
| 8. Select the text in the **Right** box.  
_The text in the Right box is selected._ | Press [Tab] |
| 9. Type the new measurement for the right margin.  
_The new measurement replaces the existing measurement in the Right box._ | Type .75 |
| 10. Select **OK**.  
_The Page Setup dialog box closes and the margins for the report are set._ | Click **OK** |

Preview the report to view the completed report with the new margins.

Close print preview and the report without saving the changes.

## Using the Label Wizard

### Discussion

Access has a Label Wizard that guides you through the process of creating a report that prints labels. You can choose from many standard types of labels, or you can create your own custom label definition.

The Label Wizard provides a sample label into which you insert the fields you want to print in their desired order. You can also type additional text that you want to appear on each label. For example, if you are creating an address label, you may want to include the text **Attn:** before the name of the addressee.
Procedures

1. Select the table which contains the label information in the Navigation Pane.
2. Select the Create tab on the Ribbon.
3. Select the Labels button in the Reports group.
4. Select the Filter by manufacturer list.
5. Select the desired label manufacturer.
6. Select the desired label type under Product number in the What label size would you like? list box.
7. Select Next >
8. Select the desired font and color options.
9. Continue selecting the desired font and color options.
10. Select the desired table or query.
11. Select Next >
12. Select the field for the first row from the Available fields list box.
13. Press [Enter].
14. Continue adding fields from the Available fields list box, as appropriate.
15. Select Next >
16. Add the field by which you want to sort from the **Available fields** list box.

17. Select `Next >`.

18. Type a name for the report.


---

**Step-by-Step**

Use the Label Wizard to create file folder labels.

If necessary, display **All Access Objects** in the Navigation Pane.

---

<table>
<thead>
<tr>
<th><strong>Steps</strong></th>
<th><strong>Practice Data</strong></th>
</tr>
</thead>
</table>
| 1. Select the table which contains the label information in the Navigation Pane.  
*A desired table is highlighted in the Navigation Pane.* | Click **Customers** |
| 2. Select the **Create** tab on the **Ribbon**.  
*The Create tab is displayed.* | Click **Create** |
| 3. Select the **Labels** button in the **Reports** group.  
*The Label Wizard opens.* | Click **Labels** |
| 4. Select the **Filter by manufacturer** list.  
*A list of manufacturers is displayed.* | Click **Filter by manufacturer** |
| 5. Select the desired label manufacturer.  
*The desired manufacturer is selected and the corresponding label types appear in the What label size would you like? list box.* | Click **Avery** |
| 6. Select the desired label type under **Product number** in the What label size would you like? list box.  
*The desired label type, dimensions, and number of labels printed across a page is selected.* | Scroll as necessary and click **J8361** |
<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>7. Select Next.</td>
<td>Click <img src="#" alt="Next &gt;" /></td>
</tr>
<tr>
<td>The next page of the Label Wizard is displayed.</td>
<td></td>
</tr>
<tr>
<td>8. Select the desired font and color options.</td>
<td>Click <img src="#" alt="Font name" /></td>
</tr>
<tr>
<td>The desired font and color options are selected.</td>
<td></td>
</tr>
<tr>
<td>9. Continue selecting the desired font and color options.</td>
<td>Scroll as necessary and click <strong>Times New Roman</strong></td>
</tr>
<tr>
<td>The desired font and color options are selected.</td>
<td></td>
</tr>
<tr>
<td>10. Select Next.</td>
<td>Click <img src="#" alt="Next &gt;" /></td>
</tr>
<tr>
<td>The next page of the Label Wizard is displayed.</td>
<td></td>
</tr>
<tr>
<td>11. Select the desired table or query.</td>
<td>Click <strong>Customers</strong></td>
</tr>
<tr>
<td>The desired table or query name is selected.</td>
<td></td>
</tr>
<tr>
<td>12. Select the field for the first row from the Available fields list box.</td>
<td>Double-click <strong>Store Name</strong></td>
</tr>
<tr>
<td>The field name, enclosed in brackets, appears in the <strong>Prototype label</strong> box.</td>
<td></td>
</tr>
<tr>
<td>13. Press [Enter].</td>
<td>Press [Enter]</td>
</tr>
<tr>
<td>The highlight bar and the insertion point move down to the next row in the <strong>Prototype label</strong> box.</td>
<td></td>
</tr>
<tr>
<td>14. Continue adding fields from the Available fields list box, as appropriate.</td>
<td>Follow the instructions shown below the table before continuing on to the next step</td>
</tr>
<tr>
<td>The field names, enclosed in brackets, appear in the <strong>Prototype label</strong> box.</td>
<td></td>
</tr>
<tr>
<td>15. Select Next.</td>
<td>Click <img src="#" alt="Next &gt;" /></td>
</tr>
<tr>
<td>The next page of the Label Wizard is displayed.</td>
<td></td>
</tr>
<tr>
<td>16. Add the field by which you want to sort from the Available fields list box.</td>
<td>Double-click <strong>Store Name</strong></td>
</tr>
<tr>
<td>The field name appears in the <strong>Sort by</strong> list box.</td>
<td></td>
</tr>
</tbody>
</table>
Steps | Practice Data
--- | ---
17. Select Next. The next page of the Label Wizard is displayed with the insertion point in the What name would you like for your report? box. | Click Next >
18. Type a name for the report. The text appears in the What name would you like for your report? box. | Type Customer Labels
19. Select Finish. The Label Wizard closes and the labels appear in the print preview window. | Click Finish

Create the following label. Insert the correct punctuation by typing a comma and space after the City field, and a space between the State/Province and Postal Code fields. Two lines under the Country field, add the text Attn: and insert the Contact Name field.

{Store Name}
{Address}
{City}, {State/Province} {Postal Code}
{Country}

Attn: {Contact Name}

*Return to the table and continue on to the next step (step 15).*

Notice that the labels appear in three columns. The address labels are printed in alphabetical order by store name and the text Attn: appears on every label before the contact name. Close the print preview window and the label report.

---

**CREATING A REPORT WITHOUT USING A WIZARD**

**Discussion**

You can create a report from scratch in Design view. For example, if a report does not currently exist for a particular table or query, you can create one using the fields in the selected table or query. You can then determine the design of the report by adding fields, controls, and options.
Procedures

1. Display All Access Objects in the Navigation Pane.
2. Select the Create tab on the Ribbon.
3. Select the Blank Report button in the Reports group.
4. Select Design View.
5. Select the table or query on which you want to base the report from the Field List.
6. Drag items onto the report as desired.

Step-by-Step

Create a report without using a wizard.

If necessary, display All Access Objects in the Navigation Pane.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Create tab on the Ribbon.</td>
<td>Click Create</td>
</tr>
<tr>
<td>The Create.tab is displayed</td>
<td></td>
</tr>
<tr>
<td>2. Select the Blank Report button in the Reports group.</td>
<td>Click Blank Report</td>
</tr>
<tr>
<td>Access creates a blank report in the database window and the Field List Task Pane opens.</td>
<td>Follow the instructions shown below the table to complete this step</td>
</tr>
<tr>
<td>3. Select Design View.</td>
<td>Click</td>
</tr>
<tr>
<td>The blank report is displayed in Design View.</td>
<td></td>
</tr>
<tr>
<td>4. Select the table or query on which you want to base the report.</td>
<td>Double-click Customers in the Field List</td>
</tr>
<tr>
<td>The table or query name appears in the Choose the table or query where the object’s data comes from box.</td>
<td>Follow the instructions shown below the table to complete this step</td>
</tr>
<tr>
<td>5. Drag items onto the report as desired.</td>
<td>Follow the instructions shown below the table to complete this step</td>
</tr>
<tr>
<td>The items appear on the report as appropriate.</td>
<td></td>
</tr>
</tbody>
</table>
Drag the **Customer Number**, **Store Name**, **Contact Name**, and **Sales Rep** fields to the 3” mark on the horizontal ruler in the **Detail** section. Click in a blank area of the report to deselect the controls and equally space the controls vertically on the report.

Enlarge the report grid to the 6” mark on the horizontal ruler. Then, move the **Customer Number** controls to the left margin. Decrease the size of the **Detail** section by dragging the bottom border up, just under the last field.

Display the report header and footer sections and add a left-aligned label to the **Report Header** section with the text, **Customer Contact Information**.

**Print preview** the report and then return to **Design** view.

Close the report and save it as **Customer Contact**.
Close ADVREP.ACCDB.
EXERCISE

USING ADVANCED REPORT DESIGN

Task

Use advanced report design.

1. Open ADVREPX.ACCDB.

2. Create a new report in Design view based on the Project table.

3. Add the Client ID field to the 1” mark on the horizontal ruler in the Detail section. Below the Client ID field, add the Course Name, Trainer Initials, and Students fields to the report at the 3” mark on the horizontal ruler in the Detail section.

4. Display the report header and footer. Using the toolbox, add a label to the left side of the report header. Enter the text Client Information.

5. Preview the report. Then, close the report and save it as Client Info.


7. Add a calculated control below the Trainer Initials text box to calculate the profit margin of each project. The calculation should use the following formula: = [Total Sale] * .08. Format the calculation as currency. Position the calculated control under the Trainer Initials text box. Change the text in the label to Profit Margin. If necessary, resize the label to view all the text, and then, position it under the Trainer Initials label.

8. Preview the report. Notice the profit margin calculation. Then, switch back to Design view.


10. Insert the date only using the default date format. Move the date control to the Page Footer section.

11. Adjust the top and bottom page margins to 40mm.

12. Preview the report to see the new margins. Notice that the date appears on each page of the report. Close the report, saving the changes.
13. Use the Label Wizard to create labels based on the Trainer table. Use the Avery L7161 labels and the default font and color settings. Include the First Name and Last Name fields, separated by a space on the same line. Sort the labels by the Last Name and First Name fields. Use Labels Trainer as the name of the report.

14. Close the labels report after viewing it.

15. Close the database file.
INDEX

Actions
   redoing, 181, 182
   reversing, 181, 182
   undoing, 181, 182
Append queries
   creating, 91, 92
AutoCorrect
   adding entries, 235, 236, 237
   setting options, 234, 235
AutoFormat
   using, 227, 228
Automatic error checking, 228, 230
Background color
   changing, 218, 219, 220
Borders
   formatting, 220, 221
Bound controls
   text box, 135
Calculated controls
   creating, 244
Calculated fields
   creating, 68, 69
   formatting, 70
Columns
   changing the name, 3, 4
   deleting, 5
   hyperlink, 10
   inserting in a table, 2
   lookup, 6, 7, 8
Combo boxes
   creating, 187, 188, 189
Comparison operators
   using, 51
Concatenation
   using in a query, 78, 79
Conditions
   And, 52, 53
   Or, 54, 55, 56
Control layouts, 136
   removing a control, 140
   stacked, 136, 137, 138
   tabular, 136, 138, 139
Control margins
   setting, 157, 158
Control padding
   setting, 158, 159
Controls
  adding logic, 200, 201
  aligning, 167, 168
  alignment options, 167
  bound, 135
  changing a property, 144, 145, 146
  conditional formatting, 224, 225
  creating calculated, 244
  deleting, 153
  labels, 136
  moving, 141, 142
  moving paired bound and unbound, 141, 142
  moving part of a paired, 166, 167
  paired bound and unbound, 141
  selecting adjacent, 151, 152
  selecting non-adjacent, 150, 151
  sizing, 154, 155
  sizing automatically, 155, 156
  sizing by dragging, 154, 155
  spacing, 169
  text box, 135
  unbound, 136
  using, 135
  using the Combo Box tool, 187, 188, 189
  using the Image button, 175, 176
  using the Label button, 174
  using the Line button, 178, 179
  using the List Box button, 193, 194
  using the Option Group button, 196, 197, 198
  using the Rectangle button, 177, 178
Converting
  database files, 123, 124
Criteria
  creating expressions, 58, 59, 60
Crosstab queries
  creating, 100, 101
Crosstab Query Wizard
  using, 100, 101
Data
  exporting, 120, 121
  importing, 112, 113
  linking to a table, 115, 116
Data formats, 120
Database objects
  exporting, 120, 121
  importing, 112, 113
Databases
  backing up, 130
  compacting, 126, 127
  converting, 123, 124
Date control
inserting, 247, 248

Date/Time formats
setting, 24, 25

Default values
setting, 28, 29

Delete queries
creating, 94, 95

Design view
adding a field, 163, 164
adding a line, 178, 179
adding a rectangle, 177, 178
adding an image, 175, 176
adding labels, 174
aligning controls, 167, 168
disabling the Snap to Grid feature, 160, 161
displaying the field list, 161, 162
editing an unbound control, 180, 181
hiding the ruler, 159, 160
moving part of a paired control, 166, 167
spacing controls, 169

Documenter
using, 124, 125

Editing tools
adding AutoCorrect entries, 235, 236, 237
automatic error checking, 228, 230
change the font, 212
changing the font, 213
changing the font size, 214
formatting characters, 215, 216
running the spelling checker, 231, 232
setting AutoCorrect options, 234, 235
using AutoFormat, 227, 228
using the Format Painter, 226

Exporting
data, 120, 121

Expression box, 58
Expression Builder
using, 58, 59, 60

Field list
displaying, 162

Field properties
creating an input mask, 32, 33, 35, 36
limiting the field size, 19, 20
lookup list, 44
property types, 18
setting date/time formats, 24, 25
setting default values, 28, 29
setting number formats, 23
setting validation rules/text, 30, 31
setting yes/no formats, 26, 27
using, 18
Field size
  limiting, 20
Fields
  adding, 163, 164
  adding fields from another table, 164, 165
  Yes/No, 200, 201
Fill color
  changing, 218, 219, 220
Find Duplicates Query Wizard
  using, 103, 104
Find Unmatched Query Wizard
  using, 105, 106
Font color
  changing, 217
Fonts
  changing, 212, 213
  changing the size, 214
  formatting characters, 215, 216
Footer
  adding to a form, 205, 206
  adding to a report, 242, 243
Form Footer, 186
Form Header, 186
Format Painter
  using, 226
Forms
  adding a form header and footer, 205, 206
  adding logic controls, 200, 201
  creating a combo box, 187, 188, 189
  creating a list box, 192, 193, 194
  creating an option group, 196, 197, 198
  creating blank, 207, 208
  creating without a wizard, 207, 208
  sections, 186
  setting the tab order automatically, 203
  setting the tab order manually, 204, 205
  using in Design view, 186
Header
  adding to a form, 205, 206
  adding to a report, 242, 243
Hyperlink columns
  inserting, 10, 11
Images
  adding, 175, 176
Input mask
  creating, 32, 33
  creating custom, 37, 38
Input Mask Wizard, 32, 37, 38
Label Wizard
  using, 252, 253, 254
Labels
adding, 174
editing text, 180, 181

Lines
adding, 178, 179
formatting, 220, 221

Linked Table Manager, 117, 118, 119

List boxes
creating, 192, 193, 194

Lookup columns
inserting, 6, 7, 8

Lookup field
creating, 40, 41, 42
properties, 44

Lookup list
creating, 40, 41, 42

Lookup List
editing list items, 191, 192

Lookup properties
modifying, 44

Lookup Wizard, 6
creating a list, 40, 41, 42

Make-table queries
creating, 86, 87

Margins
changing, 250, 251

Name AutoCorrect
options, 127, 128, 129
using, 127, 128, 129

Number formats
setting, 21, 23

Objects
applying special effects, 222, 223
changing the fill and background color, 220
changing the fill or background color, 218, 219
changing the font color, 217
formatting lines, 221
formatting lines and borders, 220, 221
removing the fill color, 218, 219
viewing properties, 142, 143, 144

Operators
And, 52, 53
Between And, 57
Or, 54, 55, 56

Option groups
creating, 196, 197, 198

Options
sizing, 155, 156

Page breaks
inserting, 249

Page Footer, 186, 242
Page Header, 186, 242
Parameter queries
  creating, 75, 76
Properties
  changing, 144, 145, 146
  objects, 142, 143, 144
  viewing, 142, 143, 144
Queries
  append, 91, 92
  applying a filter, 80, 81
  creating a calculated field, 68, 69
  creating with functions, 73, 74
  delete, 94, 95
  filtering, 80, 81
  formatting calculated fields, 70
  grouping records, 73, 74
  make-table, 86, 87
  parameter, 75, 76
  setting top values, 66, 67
  totals row, 71, 72
  update, 89, 90
  using a concatenation in, 78, 79
  using an And condition, 52, 53
  using an Or condition, 54, 55, 56
  using comparison operators, 50, 51
  using multivalued fields, 76, 77
  using the Between And operator, 57
  using the Expression builder, 59, 60
  using wildcard characters, 61, 62
Rectangles
  adding, 177, 178
Redo
  using, 181, 182
Relationship documents
  printing, 124, 125
Relationships
  creating many-to-many, 11, 12, 13
Reports
  adding headers and footers, 242, 243
  changing the margins, 250, 251
  creating a calculated control, 244
  creating a running summary, 246, 247
  creating blank, 256, 257
  creating without a wizard, 256, 257
  inserting a date control, 247, 248
  inserting a page break, 249
  inserting a time control, 248
  sections, 242
  using in Design view, 242
  using the Label Wizard, 252, 253, 254
Ruler
  displaying, 159, 160
hiding, 159, 160
Running summary
creating, 246, 247
Snap to Grid
disabling, 160, 161
Special effects
applying, 222, 223
removing, 222, 223
Spelling checker
correcting words, 231, 232
ignoring words, 231
running, 231, 232
Tab order
setting automatically, 203
setting manually, 204, 205
Tables
changing a column name, 3, 4
deleting a column, 5
inserting a column, 2
inserting a hyperlink column, 10, 11
inserting a lookup column, 7, 8
linking, 115
linking data, 115, 116
Time control
inserting, 247, 248
Trace Error
using, 228, 230
Unbound controls
editing, 180, 181
labels, 135
Undo
using, 181, 182
Update queries
creating, 89, 90
Validation rules/text
setting, 30, 31
Views
switching views, 134, 135
Wildcard characters
using, 61, 62
Wizards
Crosstab Query, 101
Find Duplicates Query, 103, 104
Find Unmatched Query, 105, 106
Input Mask, 37, 38
Yes/No formats
setting, 26, 27