Microsoft Office 2007

Microsoft Office Access 2007 - New Features

Exploring Access
Creating and Working with Tables
Finding and Filtering Data
Working with Queries and Recordsets
  Working with Forms
  Working with Reports
  Working with Macros
Using Data Collection By E-mail
Customizing the Navigation Pane
ABOUT ONDEMAND SOFTWARE

The OnDemand Software Division of Global Knowledge is the worldwide leader of software solutions that enable rapid adoption, broad acceptance and increased accuracy in the use of enterprise applications related to enterprise resource planning, supply chain management, procurement, e-commerce and customer relationship management.

The flagship product, OnDemand Personal Navigator™, provides one synchronized documentation, training and performance support platform. Founded in 1986, the OnDemand Software Division has over 850 Global 2000 customers in 12 countries. The OnDemand Software Division of Global Knowledge, a Welsh, Carson, Anderson and Stowe portfolio company, is headquartered in King of Prussia, Pennsylvania, with offices located worldwide. Additional information can be found at http://www.ondemandgk.com.

COPYRIGHT

Copyright © Global Knowledge Software LLC. 2008. All rights reserved. Information in this document is subject to change without notice and does not represent a commitment on the part of Global Knowledge.

No part of this publication, including interior design, cover design, icons or content may be reproduced by any means, be it transmitted, transcribed, photocopied, stored in a retrieval system, or translated into any language in any form, without the prior written permission of Global Knowledge Network, Inc.

Products mentioned herein, including SAP R/3, PeopleSoft, Siebel Systems, Microsoft Windows, Microsoft Office, Microsoft FrontPage, Microsoft Outlook, Macromedia Flash, Adobe Acrobat, and JavaScript are trademarks or registered trademarks of their respective owners.

OnDemand Personal Navigator and Courseware Express are trademarks of Global Knowledge Software LLC. CustomDOC and Knowledge Pathways are registered trademark of Global Knowledge Software LLC. Global Knowledge and the Global Knowledge logo are trademarks of Global Knowledge, Inc.

DISCLAIMER

Global Knowledge has taken every effort to ensure the accuracy of this manual. If you should discover any discrepancies, please notify us immediately.

Global Knowledge Software LLC.
OnDemand Software Division
475 Allendale Road
King of Prussia, PA 19406
(610) 337-8878
www.ondemandgk.com
MICROSOFT OFFICE ACCESS 2007 - NEW FEATURES

ABOUT ONSERMAND SOFTWARE ................................................................. I
COPYRIGHT .............................................................................................. I
DISCLAIMER ............................................................................................ I

LESSON 1 - EXPLORING ACCESS ......................................................... 1
  Opening an Existing Database ............................................................ 2
  Using Database Objects ..................................................................... 4
  Using the Navigation Pane .............................................................. 5
  Opening Database Objects ............................................................... 7
  Using Tabbed Documents .................................................................. 8
  Closing a Tabbed Document ............................................................ 10
  Closing all Tabbed Documents ....................................................... 11
  Using the Status Bar ....................................................................... 11
  Using the Options Dialog Box ......................................................... 12
  Closing a Database .......................................................................... 14
  Exercise ............................................................................................. 16
  Exploring Access .............................................................................. 16

LESSON 2 - CREATING AND WORKING WITH TABLES ......................... 19
  Using a Database Template ............................................................... 20
  Using a Table Template ................................................................... 22
  Creating a Table in Datasheet View ................................................ 24
  Using Field Templates ..................................................................... 25
  Using Multi-Valued Fields in Tables ............................................... 27
  Using Rich Text in a Memo Field .................................................... 30
  Using the Attachment Data Type .................................................... 31
  Displaying a Totals Row in a table ................................................. 33
  Using Alternate Background Colors .............................................. 35
  Displaying Truncated Numbers ..................................................... 36
  Exercise ............................................................................................. 39
  Creating and Working with Tables ............................................... 39

LESSON 3 - FINDING AND FILTERING DATA ....................................... 41
LESSON 4 - WORKING WITH QUERIES AND RECORDSETS ............49
Using Multi-Valued Fields in a Query ..................................50
Displaying a Totals Row in a Query .....................................52
Exercise ........................................................................55
Working with Queries and Recordsets ..................................55

LESSON 5 - WORKING WITH FORMS .................................57
Creating a Form with the Create Tab ..................................58
Using Form/Layout/Design Views ........................................60
Moving Fields in a Form ......................................................62
Using the Field List Task Pane ..........................................63
Adding a Field from Another Table .....................................65
Creating a Split Form .........................................................67
Converting an Existing Form to a Split form .......................68
Editing a Split Form ..........................................................69
Using Control Layouts in Forms .........................................71
Using a Stacked Layout in a Form .......................................72
Using a Tabular Layout in a Form .......................................73
Removing a Control from a Layout in a Form ......................75
Using the Calendar for Date Picking ...................................76
Editing List Items .............................................................78
Exercise ........................................................................80
Working with Forms ..........................................................80

LESSON 6 - WORKING WITH REPORTS ..............................81
Creating a Report Using the Create Tab ..............................82
Using Layout and Design Views in a Report .........................84
Using a Stacked Layout in a Report .....................................86
Using a Tabular Layout in a Report .....................................87
Removing a Control from a Layout .....................................88
Moving Fields in a Report ....................................................89
LESSON 1 - EXPLORING ACCESS

In this lesson, you will learn how to:

- Open an existing database
- Use database objects
- Use the Navigation Pane
- Open database objects
- Use tabbed documents
- Close a tabbed document
- Close all tabbed documents
- Use the status bar
- Use the Options dialog box
- Close a database
OPENING AN EXISTING DATABASE

Discussion

An Access database is a collection of information organized into a number of objects including tables, queries, forms, reports, pages, macros, and modules.

When you want to work with an Access database, you must first load the database file into memory. This process enables you to open all the tables or other objects within that database.

You can view or edit an existing database by opening it from disk. You do not need to remember the file name because the Open dialog box displays a list of folders and files in the current drive and folder. You can select the desired database file from the list, or you can type the name of the database you want to open.

If the database resides in a different drive or folder, you can use the Folders or Favorite Links list to select the correct location. The folders and files residing in the selected location appear in the box to the right of the Folders list. If necessary, you can resize the Open dialog box.

While the Open button opens the selected database, the Open list provides additional options. For instance, if you want to protect the original version of a database from modifications, you can open a copy of a database or open the database as read-only.

The Files of type list in the Open dialog box enables you to open files created in other programs. For instance, you can open a file created in Excel in Access.

The Views button at the top of the Open dialog box allows you to change views. You can choose to have files displayed as icons or a list.

You can also open the Open dialog box by selecting the More link in the Getting Started task pane or by selecting the Office button and then the Open command.
Procedures

1. Click the Office button.

2. Select Open.

3. Select the Folders arrow.

4. Select the drive where the database you want to open is located.

5. Open the folder where the database you want to open is located.

6. Select the name of the database you want to open.

7. "Select.

8. Select Options..., if necessary.

9. Select the desired security options.

10. Select OK.

---

Step-by-Step

From the Student Data directory, open WSGOODS1.ACCDB.
Open an existing database from a specific drive and folder location.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Click the Office button. &lt;br&gt; <em>The Office Menu opens.</em></td>
<td>Click</td>
</tr>
<tr>
<td>2. Select Open. &lt;br&gt; <em>The open dialog box opens.</em></td>
<td>Click Open</td>
</tr>
<tr>
<td>3. Select the Folders list arrow. &lt;br&gt; <em>A list of available drives appears.</em></td>
<td>Click Folders</td>
</tr>
<tr>
<td>4. Select the drive where the database you want to open is located. &lt;br&gt; <em>A list of available folders appears.</em></td>
<td>Click the student data drive</td>
</tr>
</tbody>
</table>
Lesson 1 - Exploring Access

Steps | Practice Data
--- | ---
5. Open the folder where the database you want to open is located. *The contents of the folder appear.* | Double-click to open the student data folder
6. Select the name of the database you want to open. *The file name is selected.* | Scroll as necessary and Click Wgoods1
7. Select **Open.** *The Open dialog box and Getting Started task pane close, and the Security Warning message box appears below the Ribbon, if necessary.* | Click **Open**
8. Select **Options,** if necessary. *The Security Options dialog box opens asking if you want to open the file since it may contain unsafe code.* | Click **Options...**, if necessary
9. Select the desired security options. *The database content is enabled or remains disabled.* | Click **Enable this content,** if necessary
10. Select **OK,** if necessary. *The Security Options dialog box closes and the database opens in the application window.* | Click **OK**

Close **WSGOODS1.ACCDB.**

**Using Database Objects**

**Discussion**

An Access database file can contain objects such as tables, queries, forms, reports, macros, and modules. Database objects are created to input, edit, retrieve, display, and print data. You can include up to six different object types in an Access database. A description of each of these object types is listed in the following table:

<table>
<thead>
<tr>
<th>Object Type</th>
<th>Object Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Table</strong></td>
<td>This object type defines the structure of an Access database. Tables display multiple records in rows and columns. Information in these records can be entered, edited, stored, and retrieved.</td>
</tr>
</tbody>
</table>
### Object Type | Object Purpose
--- | ---
**Query** | A way of requesting selected information from a table. When you run a query, a selected set of records, called the recordset, appears. You can then edit or print the recordset.

**Form** | A screen display you can create to show selected fields in a record. Forms allow you to enter, view, and edit data. You can use a form as an alternative to displaying data in rows and columns.

**Report** | A design for printed data. Reports can include lists and mailing labels, as well as database reports. Reports can also perform mathematical operations and calculate summaries.

**Macro** | A stored set of Access commands that can be repeated as a unit to automate database functions.

**Module** | This object type stores Visual Basic for Applications Edition programming code that can be used to further customize and enhance database functions.

When you open a database, all objects in the database are grouped under one of the object types listed in the preceding table. The object types Table, Query, Form and Report, along with their corresponding objects, appear in the Navigation Pane.

### Using the Navigation Pane

#### Discussion

When you open a database or create a new one, the names of your objects appear in the Navigation Pane on the left side of the application window. It replaces the database window from earlier versions of Access and can also be used instead of switchboards, the screens previously used to navigate around a database.

The Navigation Pane displays tables, queries, forms and reports in filtered lists. You can change the objects included in the list by clicking the list header and selecting the category or group of objects you want to display. A number of predefined categories are available, and it is possible to filter the groups within categories in various ways. Selecting the **Queries** object type displays all query objects in the database and selecting the **Forms** object type displays all the form objects.
The Navigation pane

- You can hide the Navigation Pane by clicking the **Shutter Bar Open/Close** button on the title bar, or by pressing **[F11]**.
- You can resize the Navigation Pane by dragging the right hand side to the required size.

Procedures

1. Open the desired database.
2. Select the arrow in the Navigation Pane header.
3. Select the desired object type.

Step-by-Step

From the Student Data directory, open **WSGOODS1.ACCDB**.
Use the Navigation Pane to select an object type.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the arrow in the Navigation Pane header.</td>
<td>Click</td>
</tr>
</tbody>
</table>

*The Navigation Pane menu appears.*
Discussion

You can open a database object to view the data stored in it. The view in which the data appears depends on the type of object you open. Tables and queries appear in **Datasheet** view. Forms appear in **Form** view. Reports display the data in **Print preview**. Macros and modules run programs attached to the object.

- You can open an object by double-clicking its name in the Navigation Pane.
- You can use the **Close** button on the applicable window title bar to close a database object (such as a table or form), a database, or Access itself.

Procedures

1. Open the desired database.
2. Display the desired object list.
3. Double click the name of the object you want to open.

Step-by-Step

Open a database object.

If necessary, display the **Tables** object list in the Navigation Pane.
Steps | Practice Data
--- | ---
1. Select the name of the object you want to open. *The object appears in the corresponding view, or the corresponding program runs* | Double click Customers, if necessary

Click the Close button on the Customers Table window title bar to close the Customers table.

**Practice the Concept:** Display the Forms object list. Select the Orders Entry Form object, if necessary, and then double-click it to display the form in Form view. Close the Orders Entry Form window.

Display the Reports object list to display the Orders Report object in Print preview. Close the Orders Report window.

**USING TABBED DOCUMENTS**

**Discussion**

In Access 2007 you can display database objects in tabbed documents instead of overlapping windows. Using tabbed documents helps to keep open objects visible and accessible. New databases in Access 2007 display tabbed documents by default; databases created in earlier versions use overlapping windows by default. You can enable or disable tabbed documents using Access Options.

When you open an object, it appears in a single pane as a tabbed document. Opening further objects will create additional tabbed documents in the application window. To move among the objects you simply click the tabs at the top of the documents.
Tabbed documents

If you use Access Options to change the tabbed document settings, you must close and re-open the database for the new settings to take effect.

Procedures

1. Open the desired database.
2. Select the arrow in the title bar of the Navigation Pane.
3. Select All Access Objects.
4. Open the desired objects.

Step-by-Step

View tabbed documents.

If necessary, select All Access Objects in the Navigation Pane.

Steps

1. Select the first desired table. The desired table opens.

Practice Data

Double-click Customers
<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>2. Select the second desired table.</td>
<td>Double-click <strong>Items</strong></td>
</tr>
<tr>
<td>3. Select the desired form.</td>
<td>Double-click <strong>Data Entry Form</strong></td>
</tr>
<tr>
<td>4. Select the desired report.</td>
<td>Double-click <strong>Orders Report</strong></td>
</tr>
</tbody>
</table>

Notice that the active object tab is orange in color and the tab title is displayed in bold type.

**CLOSING A TABBED DOCUMENT**

**Discussion**

When using tabbed documents in Access 2007, you may have a number of forms, tables, queries or reports open at any given time. Multiple objects use more system resources, so in order to be efficient, you should close any objects you are not using. When you have finished working on a particular object you can close it independently, without closing any other open objects.

**Procedures**

1. Select the desired object tab.
2. Select **Close**

**Step-by-Step**

Close a tabbed document.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the desired object tab.</td>
<td>Click the <strong>Customers</strong> tab</td>
</tr>
<tr>
<td><em>The desired object tab becomes active.</em></td>
<td></td>
</tr>
<tr>
<td>2. Select the <strong>Close</strong> button on the active object tab.</td>
<td>Click ✗</td>
</tr>
<tr>
<td><em>The object tab closes.</em></td>
<td></td>
</tr>
</tbody>
</table>
CLOSING ALL TABBED DOCUMENTS

Discussion

When you have finished working with a number of tabbed documents, you can close them all at once, instead of closing each object individually.

Procedures

1. Right-click any open object tab.
2. Select Close All.

Step-by-Step

Close all tabbed documents.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Right-click the desired object tab.</td>
<td>Right-click the Items tab</td>
</tr>
<tr>
<td>A drop-down menu appears.</td>
<td></td>
</tr>
<tr>
<td>2. Select Close All.</td>
<td>Click Close All</td>
</tr>
<tr>
<td>All open tabbed documents close.</td>
<td></td>
</tr>
</tbody>
</table>

Notice you can right-click on any open tab to close all tabbed documents.

USING THE STATUS BAR

Discussion

As with previous versions of Access, you can display a status bar at the bottom of the application window which displays status messages and progress indicators.

In Access 2007, the status bar has two other standard functions: you can change the view of the active window using the controls on the right of the status bar, and if you
are viewing an object that supports variable zoom, a report for instance, you can zoom in and out using the slider on the right of the status bar.

You can disable the status bar using Access Options.

Procedures

1. Open the desired table.
2. Select the desired button on the status bar.

Step-by-Step

Use the status bar.

If necessary, open the Customers table

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the desired button on the status bar.  
*The view changes.* | Click                              |
| 2. Select the desired button on the status bar.  
*The view changes back.* | Click                              |

Practice the concept: You can use the buttons on the status bar to view the Pivot Table View and Pivot Chart View.

Using the Options Dialog Box

Discussion

There may be times when you want to make changes to the way items appear in the application window or Datasheet. For example, you may want to change the display of recently-used documents on the Getting Started task pane from four documents to more or less than that.
The Access Options dialog box allows you to make interface changes as well as many other types of changes in the way Access works. You can alter the way error and spelling checks are performed, how tables and queries appear, and how the keyboard performs to name a few. The Access Options dialog box plays an integral part in allowing you to customize Access based on your personal needs.

![The Access Options dialog box]

**Procedures**

1. Select the **Office** button.
2. Select the **Access Options** button.
3. Select the option corresponding to the features you want to change.
4. Select or deselect options as desired.
5. Select **OK**.

**Step-by-Step**

Use the Access Options dialog box.
Steps | Practice Data
--- | ---
1. Select the **Office** button. 
*The Office menu appears.* | Click ![Office](image)
2. Select the **Access Options** button. 
*The Access Options dialog box opens.* | Click ![Access Options](image)
3. Select the option corresponding to the features you want to change. 
*The appropriate page appears.* | Click the **Current Database** option, if necessary
4. Select or deselect options as desired. 
*The options are selected or deselected accordingly.* | Click ![Display Status bar](image) to deselect it
5. Continue selecting or deselecting options as desired. 
*The options are selected or deselected accordingly.* | Follow the instructions shown below the table before continuing on to the next step
6. Select **OK**. 
*The Options dialog box closes, and the options are enabled or disabled accordingly.* | Click ![OK](image)

Select the **Datasheet** option, select the **Font Color** list under **Default colors** and select a dark blue color from the palette. Then, select the **Background** list and select a light blue color from the palette. You may be prompted to close and re-open the database in order for the changes to take effect.

*Return to the table and continue on to the next step (step 6).*

Notice that the status bar no longer appears. Open the **Customers** table and notice the changes to the display. Close the **Customers** table.

**Practice the Concept:** Open the Access Options dialog box and select the **Status bar** option on the **Current Database** page. Then, display the **Datasheet** page and change the default font color in the **Font Color** option to **Black** and the background color in the **Background** list to **White**. Select **OK** to close the Options dialog box.

**CLOSING A DATABASE**

**Discussion**

It is important to remember that you cannot have more than one database open at a time. When you have finished working on a database, you can close it using the **Office** button.
If a database object has been modified but not saved, an Access dialog box will prompt you to save the changes before closing.

✅ Procedures

1. Select the Office button.

2. Select Close Database.

⚠️ Step-by-Step

Close a database.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Office button. <em>The Office menu appears.</em></td>
<td>Click</td>
</tr>
<tr>
<td>2. Select Close Database. <em>The database closes and the Getting Started task pane appears.</em></td>
<td>Click</td>
</tr>
</tbody>
</table>
EXERCISE

EXPLORING ACCESS

Task

Explore Access.

1. Start Access, if necessary.
2. Open Train50x.
3. Open the Navigation Pane, if necessary.
4. Select the Queries, Forms, and Reports object types to view the objects in each; then, select Access All Objects.
5. Open all the tables.
6. Use Access Options to change the background color.
7. Resize the Navigation Pane so that it is half its original width.
8. Hide the Navigation Pane.
9. Open the Trainer report.
10. Use the slider on the Status Bar to zoom in.
11. Close the Trainer report.
12. Use Close All to close the remaining open objects.
13. Reset your usage data and return the background color to white.
LESSON 2 -
CREATING AND WORKING WITH TABLES

In this lesson, you will learn how to:

- Use a database template
- Use a table template
- Create a table in datasheet view
- Use field templates
- Use multi-valued fields in tables
- Use rich text in a memo field
- Use the Attachment data type
- Display a Totals row in a table
- Use alternate background colors
- Display truncated numbers
**Using a Database Template**

**Discussion**

When you create a database in Access, you are creating a container for related tables, forms, queries, reports, and other database objects. You can create a new database manually or with the help of a Database Template. If you create a new database manually, you must then create your own tables, queries, and other objects. To save time, you can use a Local or Online Template.

Access 2007 offers several database templates you can use to quickly create a database. The templates include pre-formatted database objects, such as tables, forms, and reports. A variety of business and personal database templates are available on the Template Categories section on the Getting Started task pane. If you use any template, Access creates not only the database, but also the tables, queries, and other objects in it.

After you have used a database template, a link to it appears under the Open Recent Database section in the Getting Started task pane.

![Local templates](image)

To find out more about a specific template, hover the mouse pointer over its icon and a pop up window appears with further information about the database template and its common uses.

If you are connected to the Internet, you can also access Online Templates.
Procedures

1. Select **Local Templates** in the Getting Started task pane.
2. Select the desired database template.
3. Type the desired file name.
4. Select the **Save in** folder icon.
5. Select where you want to store the file.
6. Select **OK**.
7. Select **Create**.
8. Open the Navigation Pane

Step-by-Step

Use a template to create a new database.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the **Local Templates** option in the Getting Started task Pane.  
   *The Local Templates task pane appears.* | Click **Local Templates** |
| 2. Select the desired database template.  
   *The database template is selected the template appears in the right-hand pane.* | Click **Contacts** |
| 3. Type the desired file name.  
   *The text appears in the File name box.* | Type **Contacts_NF**, if necessary |
| 4. Select the **Save in** folder icon.  
   *A list of available drives appears.* | Click **** |
| 5. Select the drive where you want to store the file.  
   *A list of available folders appears.* | Click the student data drive, if necessary |
Steps | Practice Data
---|---
6. Open the folder where you want to store the file.  
* A list of available folders and files appears. | Double-click to open the student data folder, if necessary
7. Select **OK**.  
* The folder list closes. | Click **OK**
8. Select **Create**.  
* The Local Templates task pane closes, and the database opens. | Click **Create**
* The Navigation Pane opens. | Open the Navigation Pane, if necessary

When you open the Navigation Pane, it is a good idea to select All Access Objects, in order to display all the objects in the database. You can double-click any object in the Navigation Pane to open it. You can now enter data directly into the new database, or modify it to meet your needs.

### USING A TABLE TEMPLATE

#### Discussion

A table is the basic building block of a database. All queries, reports, and forms use the fields and records in the database tables as the basis for their output. You must create at least one table in the database before you can create any other object.

In Access 2007, you can create a table using one of five available templates: **Contacts**, **Tasks**, **Issues**, **Events** and **Assets**.
The Tasks Table template

Procedures

1. Open the desired database.
2. Select the Create tab on the Ribbon.
3. Select the Table Templates button.
4. Select the desired template.

Step-by-Step

Create a table using a table template

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Create tab on the Ribbon. The Create tab appears.</td>
<td>Click the Create tab</td>
</tr>
</tbody>
</table>
Steps | Practice Data
--- | ---
2. Select the **Table Templates** button. *The table template list appears.*

Notice that the **Datasheet** tab automatically appears on the **Ribbon** when a datasheet is displayed.

The new table appears in the **Table** object list in the Navigation Pane with the default name **Table1**.

Close the database.

**CREATING A TABLE IN DATASHEET VIEW**

**Discussion**

When you create a new table, you can use either **Datasheet** or **Design** view, use table templates, import data from another data source, or link to data in another data source. **Datasheet** view displays a grid of rows and columns. Field names are entered as column headings.

![A table in datasheet view](image)
Procedures

1. Display the Tables object list in the Navigation Pane, if necessary.
2. Select the Create tab on the Ribbon.
3. Select the Table button.

Step-by-Step

Create a table in Datasheet view.

If necessary, display the Tables object list in the Navigation Pane.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Create tab on the Ribbon.</td>
<td>Click the Create tab</td>
</tr>
<tr>
<td><em>The Create tab appears.</em></td>
<td></td>
</tr>
<tr>
<td>2. Select the Table button.</td>
<td>Click</td>
</tr>
<tr>
<td><em>A new table in appears in Datasheet view.</em></td>
<td></td>
</tr>
</tbody>
</table>

Notice that the Datasheet Tab automatically appears on the ribbon when a datasheet is displayed.

The new table appears in the Table object list in the Navigation Pane with the default name Table1.
Close CONTACTS_NF.ACCDB.

USING FIELD TEMPLATES

Discussion

Access 2007 has a number of predefined fields that can be used when creating a table. The Field Templates task pane displays fields listed in categories, which you can drag and drop onto a table opened in Datasheet view. The field template defines the field name, data type, format and a number of field properties.
**Procedures**

1. Open the desired table in **Datasheet** view.
2. Select the **Datasheet** tab on the **Ribbon**.

![New Field](image)

3. Select the **New Field** button in the **Fields & Columns** group.
4. Select the desired field from the field list.
5. Drag the field into the desired position on the datasheet.
6. Release the mouse button.

**Step-by-Step**

From the Student Data directory, open **WSGOODS2.ACCDB**.
Use the Field Template task pane.

Open the **Customers** table in **Datasheet** view.

<table>
<thead>
<tr>
<th><strong>Steps</strong></th>
<th><strong>Practice Data</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the <strong>Datasheet</strong> tab on the <strong>Ribbon</strong>. &lt;br&gt; <em>The Datasheet tab appears.</em></td>
<td>Click <strong>Datasheet</strong></td>
</tr>
<tr>
<td>2. Select the <strong>New Field</strong> button in the <strong>Fields &amp; Columns</strong> group. &lt;br&gt; <em>The Field Templates task pane appears.</em></td>
<td>Click <strong>New Field</strong></td>
</tr>
<tr>
<td>3. Select the desired field from the Contacts field list. &lt;br&gt; <em>The desired field is selected.</em></td>
<td>Click <strong>E-mail Address</strong></td>
</tr>
<tr>
<td>4. Drag the desired field into the desired position on the <strong>Datasheet</strong>. &lt;br&gt; <em>The desired field is dragged onto the Datasheet.</em></td>
<td>Drag <strong>E-mail Address</strong> onto the <strong>Datasheet</strong> between the <strong>Fax Number</strong> and <strong>Address</strong> fields</td>
</tr>
<tr>
<td>5. Release the mouse button. &lt;br&gt; <em>The desired field appears in the Datasheet.</em></td>
<td>Release the mouse button</td>
</tr>
</tbody>
</table>
USING MULTI-VALUED FIELDS IN TABLES

Discussion

In Access 2007 it is possible to create a field that holds multiple values. This can be used to store a multiple valued selection from a list of choices, but only when the list of choices is relatively small. For example, if you are tracking issues, and the same issue is reported by multiple clients, you can create a lookup list to enter that data.

When the combo box is selected, you can select or deselect check boxes to indicate your choices. The selections are then stored in the multi-valued field, and are separated by commas when displayed.

In Access 2007, you can use the Lookup Wizard to create a multi-valued field. The Lookup Wizard takes you through the steps needed to create a lookup list. It automatically sets the appropriate field properties and creates relationships where necessary.

![The Lookup List]

Procedures

1. Open the desired table in Design View, if necessary.
2. Type the desired field name in the next available row in the Field Name column.
3. Click in the data type column next to the new field name.
4. Click the arrow and select **Lookup Wizard**.

5. Select the desired lookup source.

6. Enter the desired data into the column.

7. Enter the desired number of columns.

8. Select the box below the **Col1** heading.

9. Enter the first desired lookup value.

10. Enter additional lookup values as desired.

11. Select **Next >**.

12. Type the desired label for the lookup column.

13. Select **Allow Multiple Values**.

14. Select **Finish**.

15. Select **Save** on the **Quick Access Toolbar**.

16. Select **Datasheet View** on the Status bar.

17. Use the lookup list to enter the desired values.

---

**Step-by-Step**

Create a multi-valued field.

Open the **Items** table in **Design view**, if necessary.

<table>
<thead>
<tr>
<th><strong>Steps</strong></th>
<th><strong>Practice Data</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Type the desired field name in the next available row in the Field Name column. The new field name appears in the Field Name column.</td>
<td>Type <strong>Color</strong> in the Field name column</td>
</tr>
<tr>
<td>2. Click in the data type column next to the new field name. The data-type menu arrow appears.</td>
<td>Click the mouse pointer in the data type column</td>
</tr>
<tr>
<td>3. Click the arrow and select <strong>Lookup Wizard</strong>. The Lookup wizard appears.</td>
<td>Click <strong>Lookup Wizard</strong></td>
</tr>
</tbody>
</table>
### Steps

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 4. Select the desired lookup source.  
*The desired option is selected.* | Click I will type in the values I want |
| 5. Enter the desired data into the column.  
*The next page of the Lookup wizard appears with the Number of columns box selected.* | Click Next > |
| 6. Enter the desired number of columns.  
*The desired options are selected.* | Type 1, if necessary |
| 7. Select the box below the Col1 heading.  
*The insertion point appears in the first column, and the specified number of columns appears.* | Press [Tab] |
| 8. Enter the first desired lookup value.  
*The text appears in the first Col1 box.* | Type Green |
| 9. Enter additional lookup values as desired.  
*The text appears in the columns.* | Follow the instructions shown below the table before continuing on to the next step |
| 10. Select Next.  
*The next page of the Lookup wizard appears.* | Click Next > |
| 11. Type the desired label for the lookup column.  
*The new label name appears in the text field.* | Type Color, if necessary |
| 12. Select Allow Multiple Values.  
*The Allow Multiple Values check box is selected.* | Click Allow Multiple Values |
*The Lookup Wizard disappears.* | Click Finish |
| 14. Select Save.  
*The table is saved.* | Click |
| 15. Select Datasheet view.  
*The table opens in Datasheet view and the new column can be seen.* | Click on the Status bar |

Type the following values in the lookup list, pressing the [Tab] key to move to the next row as needed:
Return to the table and continue on to the next step (step 10).

Notice that when you click in a record in the Color Column, an arrow appears. When you select the arrow, a lookup list appears. When you select the check boxes next to the required values, and click OK, the desired values appear in the field, separated by commas.

**USING RICH TEXT IN A MEMO FIELD**

**Discussion**

Access 2007 supports rich text. This enables you to store text that has been formatted with common formatting options such as bold, italics, numbering and so on. Access 2007 stores rich text using the Memo data type.

In order to create a field that can support rich text, you must first create a Memo field, then set the text format property of that field to rich text.

**Procedures**

1. Open the desired table in Design view.
2. In the table design grid, select the desired Memo field.
3. Select the General tab in the Field Properties section, if necessary.
4. Select the Text Format box.
5. Click on the arrow and select Rich Text.
6. Select Yes.

**Step-by-Step**

Using Rich Text.

If necessary, open the Customers table in Design view.
### Steps

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. In the table design grid, select the desired Memo field.  
The desired Memo field is selected. | Click Note |
| 2. Select the General tab in the Field Properties section, if necessary.  
The General tab appears. | Click General, if necessary |
| 3. Select the Text Format box.  
The insertion point appears in the Text Format box and the arrow appears. | Click in the Text Format box |
| 4. Click on the arrow and select Rich Text.  
A warning appears explaining that the Field will be converted to Rich Text, and all the data it contains will be HTML coded. | Click and select Rich Text |
| 5. Select Yes.  
The field is converted to Rich Text. | Click Yes |

Once you have converted the field to Rich Text, save the table, and return to Datasheet View. If you highlight any text in the Note field, you will notice that the Mini Toolbar appears, giving you the option to change the format of the text. Close WSGOODS2.ACCDB.

### Using the Attachment Data Type

#### Discussion

To use attachments in Access 2007, you must first add an attachment field to at least one of the tables in your database. The attachment data type allows you to store all types of documents, including graphics, presentations and binary files, in a database without dramatically increasing its file size. Attachments are automatically compressed to maximize space usage.
Once a field has been set to the attachment data type it cannot be changed, but it can be deleted.

Procedures

1. Open the desired table in **Datasheet** view, if necessary.
2. Select the first available blank column.
3. Select the **Datasheet** tab on the **Ribbon**, if necessary.
4. Select the **Data Type** arrow in the **Data Type & Formatting** group.
5. Select the **Attachment** data type.

Step-by-Step

From the Student Data directory, open **WORLD61a.ACCDB**. Create an attachment data type field.

Open the **Customers** table in **Datasheet** view, if necessary.
Steps | Practice Data
--- | ---
1. Select the first available blank column. The column is selected. | Click the blank column
2. Select the **Datasheet** tab on the **Ribbon**, if necessary. The Datasheet tab appears. | Click **Datasheet**
3. Select the **Data Type** arrow in the **Data Type & Formatting** group. The data type menu appears. | Click **down arrow**
4. Select the **Attachment** data type. Access sets the field data type. | Click **Attachment**

To add an attachment to a record, you simply double-click in the attachment field and select **Add** to browse through your folders and select the desired file.

**DISPLAYING A TOTALS ROW IN A TABLE**

**Discussion**

Access 2007 has a new feature that allows you to add a totals row to a **Datasheet**. This can be used to count the number of items in a column, calculate a sum, average, or find the maximum or minimum value. (These are all examples of aggregate functions).

![A Totals row in a table](image-url)
Procedures

1. Open the desired table in Datasheet view, if necessary.
2. Select the Home tab on the Ribbon, if necessary.
3. Select the Totals button on the Records section of the Home tab.
4. In the totals row, select the desired field.
5. Select the arrow.
6. Select the desired aggregate function.

Step-by-Step

Create a Totals row in a table.

Open the Line Items table in datasheet view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Home tab on the Ribbon, if</td>
<td>Click Home</td>
</tr>
<tr>
<td>necessary.</td>
<td></td>
</tr>
<tr>
<td>The Home tab appears.</td>
<td></td>
</tr>
<tr>
<td>2. Select the Totals button in the Records</td>
<td>Click ∑Totals</td>
</tr>
<tr>
<td>section of the Home tab.</td>
<td></td>
</tr>
<tr>
<td>The totals row appears in the datasheet.</td>
<td></td>
</tr>
<tr>
<td>3. In the totals row, select the field you</td>
<td>Click in the Quantity field</td>
</tr>
<tr>
<td>want to total.</td>
<td></td>
</tr>
<tr>
<td>The arrow appears.</td>
<td></td>
</tr>
<tr>
<td>4. Select the arrow.</td>
<td>Click ▼</td>
</tr>
<tr>
<td>The aggregate function list appears.</td>
<td></td>
</tr>
<tr>
<td>5. Select the desired function.</td>
<td>Click Sum</td>
</tr>
<tr>
<td>Access displays the total sum.</td>
<td></td>
</tr>
</tbody>
</table>

Notice that you can clear the totals row by clicking the Totals button in the Records section of the Home tab again.
USING ALTERNATE BACKGROUND COLORS

Discussion

You can use the Datasheet Formatting dialog box to set or change an alternate background color. This option shades every other row in a datasheet, report or form, with a color of your choice, which can make viewing easier.

You can also use Access Options to set or change the alternate background color.

You can use a different alternate background color for each object.

Procedures

1. Open the desired table.
2. Select the Home tab, if necessary
3. Select the launcher button in the bottom right corner of the Font group.
4. Select the Alternate Background Color arrow.
5. Select the desired color.

6. Select OK.

Step-by-Step

Change the alternate background color.

Open the Line Items table in Datasheet view, if necessary.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Home tab, if necessary.</td>
<td>Click Home</td>
</tr>
<tr>
<td>The Home tab appears.</td>
<td></td>
</tr>
<tr>
<td>2. Select the launcher arrow in the</td>
<td>Click</td>
</tr>
<tr>
<td>bottom right corner of the Font group.</td>
<td></td>
</tr>
<tr>
<td>The datasheet formatting dialog box</td>
<td></td>
</tr>
<tr>
<td>appears.</td>
<td></td>
</tr>
<tr>
<td>3. Select the Alternate Background Color</td>
<td>Click</td>
</tr>
<tr>
<td>arrow.</td>
<td></td>
</tr>
<tr>
<td>The Color Palette appears.</td>
<td></td>
</tr>
<tr>
<td>4. Select the desired color.</td>
<td>Click Red</td>
</tr>
<tr>
<td>The selection is shown in the sample</td>
<td></td>
</tr>
<tr>
<td>section.</td>
<td></td>
</tr>
<tr>
<td>5. Select OK.</td>
<td>Click</td>
</tr>
<tr>
<td>The Datasheet Formatting dialog box</td>
<td></td>
</tr>
<tr>
<td>disappears, and the alternate background</td>
<td></td>
</tr>
<tr>
<td>color on the Datasheet changes.</td>
<td></td>
</tr>
</tbody>
</table>

Follow the above process to change the background color back to the original color.

DISPLAYING TRUNCATED NUMBERS

Discussion

You now have the option to check for truncated number fields. When this option is enabled, numbers in a field are displayed as ###### when a column is too narrow to display the entire value. When this option is disabled, you only see part of the values in a column.
Procedures

1. Open the desired database.

2. Select the **Office** button.

3. Select the **Access Options** button.

4. Select the **Current Database** option.

5. Select the **Check for Truncated number fields** check box.

6. Select **OK**.

Step-by-Step

Check for truncated number fields.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the **Office** button.  
  *The Office menu appears.*           | Click                  |
### Steps

| 2. Select the **Access Options** button.  
The Access Options window opens. | **Practice Data** |
|---|---|
| 3. Select the **Current Database** option.  
The Current Database options window opens. | Click **Current Database** |
| 4. Select the **Check for Truncated number fields** check box.  
The option is selected. | Click **Check for Truncated number fields** |
| 5. Select **OK**.  
The Access Options window closes. | Click **OK** |

Notice, if you open the **Customers** table and reduce the width of the **Credit Limit** column, the numbers in the field will be displayed as #### if the column width is too narrow to display the entire number.

Close **WORLD61a.ACCDB**.
**EXERCISE**

**CREATING AND WORKING WITH TABLES**

**Task**

Create and work with tables.

1. Use the **Students** Local Template to create a database. Name the database **Student1** and save it to the student data folder.

2. Use the Navigation Pane to display objects by type, then select **All Access Objects**.

3. Open the **Students** table.

4. After you have viewed the table, close it. Then, close the **Student** database as well.

5. Open the **Train51x** database.

6. Open the **Trainer** table in **Design** view. Convert the **Memo** field to a rich text field.

7. Open the **Project** table and add a totals row to calculate the **Average** cost.

8. Change the alternate background color to green.
LESSON 3 -
FINDING AND FILTERING DATA

In this lesson, you will learn how to:

- Use the Search box
- Use AutoFilter
- Use Quick Filters
**USING THE SEARCH BOX**

**Discussion**

The Search box feature allows you to find specific records in a **Datasheet** quickly. The Search box is located at the bottom of the **Datasheet**, above the status bar and to the right of the record navigation VCR buttons.

**Procedures**

1. Open the desired table in **Datasheet** view, if necessary.
2. Click in the search box.
3. Type the text you want to find in the Search box.
4. Press [Enter], if necessary.

**Step-by-Step**

From the Student Data directory, open **WORLD62.ACCDB**. Use the Search box to search for a specific record.
Open the **Customers** table, if necessary.

<table>
<thead>
<tr>
<th><strong>Steps</strong></th>
<th><strong>Practice Data</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Click in the search box. <em>The insertion point appears in the search box.</em></td>
<td>Click in the Search box</td>
</tr>
<tr>
<td>2. Type the text you want to find in the Search Box. *The text appears in the Search box and Access highlights the first instance of the text in the <em>Datasheet</em>.</td>
<td>Type <em>athlete</em></td>
</tr>
<tr>
<td>3. Press [Enter]. *Access highlights the second instance of the text in the <em>Datasheet</em>.</td>
<td>Press [Enter]</td>
</tr>
</tbody>
</table>

Notice if you continue to hit the enter key, Access continues to highlight further instances of the specified text in the **Datasheet**.

**USING AUTOFILTER**

**Discussion**

You can filter data in Access. Filtering data allows you to view specific records only, hiding all records that do not meet the filter criteria. For example, you can filter data in a customers table so that only the records of those customers located in a specific region appear.

A quick and easy way to filter data in Access is to use the new AutoFilter feature. AutoFilter allows you to select among the unique values in a column, or sort values by using language context menu options such as *Sort Smallest to Largest*. 
When a filter is in effect, the (Filtered) indicator appears at the bottom of the datasheet to the left of the Search Box.

A filter remains in effect until you remove it.

**Procedures**

1. Open the desired table in **Datasheet** view.
2. Select the desired column.
3. Select the **Home** tab, if necessary.
4. Select the **Filter** button in the **Sort & Filter** group.
5. Select (Select All) to clear the filter option check boxes.
6. Select the desired filter options.
7. Select **OK**.
8. Select the **Toggle Filter** button to remove the filter.
Step-by-Step

Use AutoFilter.

Open the Customers table, if necessary.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the desired column.</td>
<td>Click Sales Rep</td>
</tr>
<tr>
<td><em>The desired column is selected.</em></td>
<td></td>
</tr>
<tr>
<td>2. Select the Home tab, if necessary.</td>
<td>Click Home</td>
</tr>
<tr>
<td><em>The Home tab is selected.</em></td>
<td></td>
</tr>
<tr>
<td>3. Select the Filter button in the Sort &amp; Filter group.</td>
<td>Click Filter</td>
</tr>
<tr>
<td><em>The Filter menu appears.</em></td>
<td></td>
</tr>
<tr>
<td>4. Clear the filter option check boxes.</td>
<td>Click ☑ (Select All) to clear all check boxes</td>
</tr>
<tr>
<td><em>The filter option check boxes are cleared.</em></td>
<td></td>
</tr>
<tr>
<td>5. Select the desired filter options.</td>
<td>Click ☐ FLW</td>
</tr>
<tr>
<td><em>The desired options are selected.</em></td>
<td></td>
</tr>
<tr>
<td>6. Select OK.</td>
<td>Click OK</td>
</tr>
<tr>
<td><em>The desired filter is applied to the table.</em></td>
<td></td>
</tr>
<tr>
<td>7. Select the Toggle Filter button to remove the filter.</td>
<td>Click ☑ Toggle Filter</td>
</tr>
<tr>
<td><em>The filter is removed.</em></td>
<td></td>
</tr>
</tbody>
</table>

Using Quick Filters

Discussion

Another quick and easy way to filter data in Access is to use Quick Filters. These are menu commands that limit information based on the data that you select. Quick filter options change automatically, based on the data type selected.
Quick Filter options

Procedures

1. Open the desired table in **Datasheet** view.
2. Select the desired column.
3. Select the arrow on the right of the desired field header.
4. Select the desired filter options.
5. Select the desired Quick Filter.
6. Specify the desired filter options.
7. Select **OK**.
8. Select the **Toggle Filter** button to remove the filter.

Step-by-Step

Use Quick Filters.

Open the **Line Items** table.
### Steps

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the desired column.</td>
<td>Click <strong>Quantity</strong></td>
</tr>
<tr>
<td><em>The desired column is selected.</em></td>
<td></td>
</tr>
<tr>
<td>2. Select the arrow on the right of the desired field header.</td>
<td>Click ▼ in the x field header</td>
</tr>
<tr>
<td><em>The Filter menu appears.</em></td>
<td></td>
</tr>
<tr>
<td>3. Select the desired filter options.</td>
<td>Select <strong>Number Filters</strong></td>
</tr>
<tr>
<td><em>The desired option is selected and further filter options appear based on the data type selected.</em></td>
<td></td>
</tr>
<tr>
<td>4. Select the desired Quick Filter.</td>
<td>Select <strong>Less Than</strong></td>
</tr>
<tr>
<td><em>The Custom Filter dialog box appears.</em></td>
<td></td>
</tr>
<tr>
<td>5. Specify the desired filter options.</td>
<td>Type <strong>5</strong></td>
</tr>
<tr>
<td><em>The text appears in the text field.</em></td>
<td></td>
</tr>
<tr>
<td>6. Select <strong>OK</strong>.</td>
<td>Click <img src="image" alt="OK" /></td>
</tr>
<tr>
<td><em>The filter is applied to the table.</em></td>
<td></td>
</tr>
<tr>
<td>7. Select the <strong>Toggle Filter</strong> button to remove the filter.</td>
<td>Click <img src="image" alt="Toggle Filter" /></td>
</tr>
<tr>
<td><em>The filter is removed.</em></td>
<td></td>
</tr>
</tbody>
</table>

Close **WORLD62.ACCDB**.
EXERCISE

FINDING AND FILTERING DATA

Task

Find and filter data.

1. Start Access, if necessary.
2. Open the Train52x database.
3. Open the Payment table.
4. Use the Search Box to find the courses paid for by Check.
5. Use the AutoFilter to filter the table to show only the projects run by the trainer with the initials RW.
6. Remove the filter using the Toggle Filter button.
7. Use the Quick Filter number filter to find all Amounts Paid between £50 and £125.
8. Remove the filter.
9. Close the table without saving.
10. Close the database.
In this lesson, you will learn how to:

- Use multi-valued fields in a query
- Display a Totals row in a query
USING MULTI-VALUED FIELDS IN A QUERY

Discussion

When using a multi-valued field in a query, you have two options. You can choose whether to retrieve the entire multi-valued field containing all the values separated by commas, or a separate row for each value.

A multi-valued field in a query

Procedures

1. Open the desired table.
2. Select the Create tab on the Ribbon, if necessary.
3. Select the Query Design button in the Other group.
4. Select the table that contains the multi-valued field.
5. Select
6. Select
7. Drag the multi-valued field into the query grid.
8. Release the mouse button.
9. Drag any other desired fields into the query grid.
10. Release the mouse button.
11. Select the Design tab on the Ribbon.
12. Select the Run button in the Results group.

Step-by-Step

From the Student Data directory, open WSGOODS3.ACCDB. Create a multi-valued field in a query.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Create tab on the Ribbon, if necessary. <em>The Datasheet tab appears.</em></td>
<td>Click Create</td>
</tr>
<tr>
<td>2. Select the Query Design button in the Other group. <em>The Show Table dialog box appears.</em></td>
<td>Click Query Design</td>
</tr>
<tr>
<td>3. Select the table that contains the multi-valued field. <em>The desired table is selected.</em></td>
<td>Click Items</td>
</tr>
<tr>
<td>4. Select Add. <em>The desired table is added to the query.</em></td>
<td>Click Add</td>
</tr>
<tr>
<td>5. Select Close. <em>The Show Table dialog box disappears.</em></td>
<td>Click Close</td>
</tr>
<tr>
<td>6. Drag the multi-valued field into the query grid. <em>The multi-valued field is selected.</em></td>
<td>Drag the Color field into the query grid</td>
</tr>
<tr>
<td>7. Release the mouse button. <em>The multi-valued field is added to the query grid.</em></td>
<td>Release the mouse button.</td>
</tr>
</tbody>
</table>
### Displaying a Totals Row in a Query

#### Discussion

You can now perform calculations in a query using aggregate functions, such as displaying a totals row. Access queries support the aggregate functions shown in the following table:

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sum</td>
<td>Calculates the total of the values in a field.</td>
</tr>
<tr>
<td>Avg</td>
<td>Calculates the average of the values in a field.</td>
</tr>
<tr>
<td>Count</td>
<td>Calculates the number of values in a field, not counting Null (blank) values.</td>
</tr>
<tr>
<td>Min</td>
<td>Calculates the lowest value in a field.</td>
</tr>
<tr>
<td>Max</td>
<td>Calculates the highest value in a field.</td>
</tr>
<tr>
<td>StDev</td>
<td>Calculates the standard deviation of the values in a field.</td>
</tr>
<tr>
<td>Var</td>
<td>Calculates the variance of the values in a field.</td>
</tr>
</tbody>
</table>
A Totals row in a query

Procedures

1. Open the desired query in **Datasheet** view.
2. Select the **Home** tab on the **Ribbon**, if necessary.
3. Select the **Totals** button in the **Records** group.
4. In the totals row, select the field you want to total.
5. Select the arrow.
6. Select the desired function.

Step-by-Step

Display a totals row in a query.

Open the **Customers** query in datasheet view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the <strong>Home</strong> tab on the <strong>Ribbon</strong>, if necessary. <strong>The Home</strong> tab appears.</td>
<td>Click <strong>Home</strong></td>
</tr>
</tbody>
</table>
### Steps

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 2. Select the **Totals** button in the **Records** group.  
*The Show Tables dialog box appears.* | Click $\sum$ **Totals** |
| 3. In the totals row, select the field you want to total.  
*The arrow appears.* | Click in the **Fax number** field |
| 4. Select the arrow.  
*The aggregate function list appears.* | Click $\downarrow$ |
| 5. Select the desired function.  
*Access displays the desired aggregate function result.* | Click **Count** |

Notice if you click the Totals button again, the Totals Row is removed from the query. Close **WSGOODS3.ACCDB**.
EXERCISE

WORKING WITH QUERIES AND RECORDSETS

Task

Work with queries and recordsets.

1. Start Access, if necessary.
2. Open the Train53x database.
3. Use the Query Design button to create a simple query.
4. Select the Issues table and add the Client ID, Project ID, and Assigned to fields.
5. Run the query to view results, then close and save as Outstanding Issues.
6. Open the Client/Project query.
7. Add a totals row to Count the number of Project IDs.
8. Close the query without saving.
9. Close the database.
LESSON 5 - WORKING WITH FORMS

In this lesson, you will learn how to:

- Create a form with the Create tab
- Use Form/Layout/Design views
- Move fields in a form
- Use the Field List task pane
- Add a field from another table
- Create a split form
- Convert an existing form to a split form
- Edit a split form
- Use Control layouts in forms
- Use a Stacked layout in a form
- Use a Tabular layout in a form
- Remove a Control from a layout in a form
- Use the Calendar for date picking
- Edit list items
Creating a Form with the Create Tab

Discussion

You can create a form quickly and easily in Access 2007 by using the Forms section of the Create tab on the Ribbon. First, you must choose the table or query on which you want to base your form. You can then choose from a number of different methods of form creation, using the various buttons in the Forms section on the Create tab.

If you base a form on multiple tables, the tables must all be related. If you are using the Form Wizard, it will prompt you to select how you want to group the fields on the form.

Procedures

1. Select the Create tab.
2. Select the More Forms button in the Forms group.
3. Select Form Wizard.
4. Select the Tables/Queries list.
5. Select the table or query on which you want to base the form.
6. Add the desired fields to the Selected Fields list box, or add all the fields.
7. Select Next >.
8. Select the desired form layout.
9. Select Next >.
10. Select the desired form style.
11. Select Next >.
12. Type the desired form name.
Step-by-Step

From the Student Data directory, open **WORLD63.ACCDB**.
Create a Form with the Create Tab.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Create tab.</td>
<td>Click Create</td>
</tr>
<tr>
<td>The Create tab appears.</td>
<td></td>
</tr>
<tr>
<td>2. Select the More Forms button in the</td>
<td>Click More Forms</td>
</tr>
<tr>
<td>Forms group.</td>
<td></td>
</tr>
<tr>
<td>The More Forms list appears.</td>
<td></td>
</tr>
<tr>
<td>3. Select Form Wizard.</td>
<td>Click Form Wizard</td>
</tr>
<tr>
<td>The Form Wizard opens.</td>
<td></td>
</tr>
<tr>
<td>4. Select the Tables/Queries list.</td>
<td>Click Tables/Queries</td>
</tr>
<tr>
<td>A list of tables and queries appears.</td>
<td></td>
</tr>
<tr>
<td>5. Select the table or query on which you</td>
<td>Click Table: Customers, if necessary</td>
</tr>
<tr>
<td>want to base the form.</td>
<td></td>
</tr>
<tr>
<td>The table or query is selected, and the</td>
<td></td>
</tr>
<tr>
<td>fields in the selected table or query</td>
<td></td>
</tr>
<tr>
<td>appear in the Available Fields list box.</td>
<td></td>
</tr>
<tr>
<td>6. Add the desired fields to the Selected</td>
<td>Click Customer Number, then click &gt;</td>
</tr>
<tr>
<td>Fields list box, or add all the fields.</td>
<td></td>
</tr>
<tr>
<td>The fields appear in the Selected Fields</td>
<td></td>
</tr>
<tr>
<td>list box.</td>
<td></td>
</tr>
<tr>
<td>7. Enter additional fields as desired.</td>
<td>Follow the instructions shown below the table before continuing on to the next step</td>
</tr>
<tr>
<td>The text appears in the columns.</td>
<td></td>
</tr>
<tr>
<td>8. Select Next &gt;.</td>
<td>Click Next &gt;</td>
</tr>
<tr>
<td>The next page of the Form Wizard opens.</td>
<td></td>
</tr>
<tr>
<td>9. Select the desired form layout.</td>
<td>Click Columnar, if necessary</td>
</tr>
<tr>
<td>A preview of the layout appears in the</td>
<td></td>
</tr>
<tr>
<td>Form Wizard.</td>
<td></td>
</tr>
<tr>
<td>10. Select Next &gt;.</td>
<td>Click Next &gt;</td>
</tr>
<tr>
<td>The next page of the Form Wizard opens.</td>
<td></td>
</tr>
<tr>
<td>11. Select the desired form style.</td>
<td>Click Median</td>
</tr>
<tr>
<td>A preview of the style appears in the</td>
<td></td>
</tr>
<tr>
<td>Form Wizard.</td>
<td></td>
</tr>
</tbody>
</table>
**Steps** | **Practice Data**
---|---
12. Select Next >.
   *The next page of the Form Wizard opens, and the text in the What title do you want for your form? box is selected.* | Click Next >
13. Type the desired form name.
   *The name appears in the What title do you want for your form? box.* | Type Customer Data Entry
   *The Form Wizard closes, and the new form opens.* | Click Finish

Select the following fields in the Available Fields list: **Store Name, Contact Name, Phone Number, Fax Number** and **Address**.

*Return to the table and continue on to the next step (step 8).*

Notice the new form is now listed under the **Forms** section on the Navigation Pane.

**USING FORM/LAYOUT/DESIGN VIEWS**

**Discussion**

After you create a form, you can initially view it in three different views: **Form View**, **Layout View**, or **Design View**. When a form is open, you can switch between these views by clicking the View button in the Views section of the Home tab on the Ribbon. The following table explains the three views:

<table>
<thead>
<tr>
<th>View</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Form View</strong></td>
<td>This view displays the form as you (or the Form Wizard) designed it.</td>
</tr>
<tr>
<td><strong>Layout View</strong></td>
<td>This view looks like Print Preview, but allows you to make changes to your form.</td>
</tr>
<tr>
<td><strong>Design View</strong></td>
<td>Displays the form in the Design View window, where you can change form elements, move them around and add or delete them as necessary.</td>
</tr>
</tbody>
</table>
Procedures

1. Open the desired form.

2. Select the View Button on the Home tab.

3. Select the desired view.

Step-by-Step

Change the form view.

Open the Customer Data Entry form, if necessary.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the View button on the Home tab.  
*The View drop-down menu appears.* | Click View  
**View** |
| 2. Select the desired view.  
*The form changes to the desired view.* | Click Layout view |

Practice the concept: Follow the above steps and select Design view.
MOVING FIELDS IN A FORM

Discussion

Once you have created your basic form, you can then edit the design to suit your own needs. In Access 2007, you can move fields in your form with ease using Design View or Layout view.

When you create a form, the controls are automatically created in a stacked layout. If you want to move individual controls, you must first remove them from the default layout.

Procedures

1. Open the desired form in design view.
2. Select the desired control.
3. Select the desired control layout.
4. Drag the control layout to the desired position.
5. Release the mouse button.
6. Select Save

Step-by-Step

Move fields in a form.

Open the Customer Data Entry form in design view, if necessary.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the desired control. <em>The desired control is selected.</em></td>
<td>Click the <strong>Customer Number</strong> control</td>
</tr>
<tr>
<td>2. Select the desired control layout. <em>The control layout is selected.</em></td>
<td>Click <strong>+</strong></td>
</tr>
</tbody>
</table>
### Steps

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>3. Drag the control layout to the desired position. <em>The control layout is moved to a new position on the form.</em></td>
<td>Drag the layout down by approx. 1 inch</td>
</tr>
<tr>
<td>4. Release the mouse button.</td>
<td>Release the mouse button</td>
</tr>
</tbody>
</table>

When you are satisfied with your form layout, save and close the form. If you forget to save your form, Access will prompt you to do so.

### Using the Field List Task Pane

#### Discussion

It is easy to add fields to a form using the Field List task pane, which lists all the tables in your database in various categories including fields available in related tables and fields available in other tables.
Procedures

1. Open the desired form in **Design** view, if necessary.
2. Select the **Design** tab on the **Ribbon**, if necessary.
3. Select the **Add Existing Fields** button in the **Tools** group.
4. Select the desired field from the list.
5. Drag the selected field onto the desired position on the form.

*The Field List task pane*
6. Release the mouse button.

## Step-by-Step

Use the Field List task pane.

Open **Customer Data Entry** form in **Design** view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| **1.** Select the **Design** tab on the **Ribbon**, if necessary.  
  *The Design tab appears.* | Click **Design** |
| **2.** Select the **Add Existing Fields** button in the **Tools** group.  
  *The Field List task pane appears.* | Click **Add Existing Fields** |
| **3.** Select the desired field from the list.  
  *The selected field is highlighted.* | Click **City** |
| **4.** Drag the selected field onto the desired position on the form.  
  *The selected field is dragged onto the form.* | Drag **City** onto the form below the **Address** field |
| **5.** Release the mouse button.  
  *The selected field appears on the form.* | Release the mouse button |

When you have added the desired fields to your form, close the Field List task pane and save.

## ADDING A FIELD FROM ANOTHER TABLE

### Discussion

The field list task pane includes fields from other tables in your database. It enables you to drag and drop fields into your form from any table in your database. If the table you select is unrelated to the table in your record source, a relationship is automatically created, or Access prompts you to do so.
Procedures

1. Open the desired form in Design View, if necessary.
2. Select the Design tab on the Ribbon, if necessary.

3. Select the Add Existing Fields button in the Tools group.
4. Select the desired table.
5. Select the desired field from the list.
6. Drag the selected field onto the desired position on the form.
7. Release the mouse button.

Step-by-Step

Add a field from another table.

Open Customer Data Entry form in Design view, if necessary.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Design tab on the Ribbon, if necessary. The Design tab appears.</td>
<td>Click Design</td>
</tr>
<tr>
<td>2. Select the Add Existing Fields button in the Tools group of the Design tab. The Field List task pane appears.</td>
<td>Click Add Existing Fields</td>
</tr>
<tr>
<td>3. Select the desired table. The table fields appear.</td>
<td>Click Orders</td>
</tr>
<tr>
<td>4. Select the desired field. The desired field is selected.</td>
<td>Click Sales Rep</td>
</tr>
<tr>
<td>5. Drag the selected field onto the desired position on the form. The selected field is dragged onto the form, and the Specify Relationship dialog box appear if necessary.</td>
<td>Drag Sales Rep onto the form above Customer Number</td>
</tr>
</tbody>
</table>
Steps | Practice Data
--- | ---
6. Release the mouse button. *The selected field appears on the form.* | Release the mouse button.

When you have added the desired fields to your form, close the Field List task pane and save.

**CREATING A SPLIT FORM**

**Discussion**

A Split Form is a new feature that allows you to create a form that combines the **Datasheet** view and the **Form** view, providing you with two different views of your data simultaneously. You can use the **Datasheet** section to quickly locate records, and the **Form** section to view and edit them as required. Selecting a field in one part of the form selects the same field in the other part. You can add, delete and edit the data in either part of the form.

**Procedures**

1. Open the desired table in datasheet view.
2. Select the **Create** tab, if necessary.
3. Select the **Split Form** button in the **Forms** group.

---

**Step-by-Step**

Create a Split Form

Open the **Items** table in datasheet view, if necessary.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the <strong>Create</strong> tab, if necessary.</td>
<td><strong>Click Create</strong></td>
</tr>
<tr>
<td><em>The cursor appears in the search box.</em></td>
<td></td>
</tr>
<tr>
<td>2. Select the Split Form button in the <strong>Forms</strong> group.</td>
<td><strong>Click</strong></td>
</tr>
<tr>
<td><em>The new split form appears in the application window.</em></td>
<td></td>
</tr>
</tbody>
</table>

Save the form with the default form name **Items**, and close it.

---

**CONVERTING AN EXISTING FORM TO A SPLIT FORM**

**Discussion**

You can convert an existing form into a split form by changing your form properties. This will enable you to view your form in two different views simultaneously.

**Procedures**

1. Open the desired form in design view.
3. Select **Form** from the dropdown list at the top of the property sheet.
4. Select the **Format** tab on the property sheet, if necessary.
5. Select **Split form** from the drop-down list next to **Default** view.
6. Select **Form** view on the Views group of the **Home** tab.
Step-by-Step

Convert an existing form into a split form.

Open the Customer Data Entry form in **Design** view, if necessary.

<table>
<thead>
<tr>
<th><strong>Steps</strong></th>
<th><strong>Practice Data</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><em>The property sheet appears.</em></td>
<td></td>
</tr>
<tr>
<td>2. Select <strong>Form</strong> from the selection type dropdown list at the top of the property sheet, if necessary.</td>
<td>Select <strong>Form</strong></td>
</tr>
<tr>
<td><em>The form option is selected.</em></td>
<td></td>
</tr>
<tr>
<td>3. Select the <strong>Format</strong> tab on the property sheet, if necessary.</td>
<td>Click <strong>Format</strong> tab</td>
</tr>
<tr>
<td><em>The format tab appears.</em></td>
<td></td>
</tr>
<tr>
<td>4. Select <strong>Split Form</strong> from the drop-down list next to Default view.</td>
<td>Select <strong>Split Form</strong></td>
</tr>
<tr>
<td><em>Access converts the form to a split form.</em></td>
<td></td>
</tr>
<tr>
<td>5. Select <strong>Form</strong> view on the <strong>Views</strong> section of the <strong>Home</strong> tab.</td>
<td>Select [image]</td>
</tr>
<tr>
<td><em>The view changes to form view.</em></td>
<td></td>
</tr>
</tbody>
</table>

**Practice the concept:** To convert the form back to its original state, follow the above steps and at step 4 select **Single Form**.

**EDITING A SPLIT FORM**

Discussion

After you have created a split form, you can edit it using the property sheet. To improve the appearance of your form, you can change the control properties, such as font color and size, alignment, fill color and border.
Procedures

1. Open the desired form.
3. Select the desired control from the dropdown list at the top of the property sheet.
4. Select the desired tab on the property sheet, if necessary.
5. Amend the desired field.
6. Press [Enter].
Step-by-Step

Edit a split form.

Open the Customer Data Entry form in Design view, if necessary.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>2. Select the desired control from the dropdown list at the top of the property sheet. <em>The desired control is selected.</em></td>
<td>Click Form Header</td>
</tr>
<tr>
<td>3. Select the desired tab on the property sheet, if necessary. <em>The desired tab appears.</em></td>
<td>Click Format</td>
</tr>
<tr>
<td>4. Change the desired control format. <em>The desired control format is changed.</em></td>
<td>In header height field type 3cm and press Enter</td>
</tr>
</tbody>
</table>

When you have finished editing your form, close the Property Sheet and save.

**Using Control Layouts in Forms**

Discussion

When editing forms in Access 2007, you can now group your form controls into one layout, and manipulate them as a unit. Control layouts align your controls and their respective labels vertically and horizontally, to give your form a uniform appearance.

There are two types of control layout: stacked and tabular.

You can use multiple layouts on a form.
**USING A STACKED LAYOUT IN A FORM**

**Discussion**

In stacked layouts, controls are arranged vertically, with the label to the left of each control. Access automatically creates stacked layouts when you create a new form by using the **Form** button, the **Blank form** button or the **Form Wizard** button in the **Forms** group on the Create tab.

![A Stacked layout in a form](image)

Stacked layouts are always contained within a single form section.

**Procedures**

1. Open the desired form in design view.
2. Click on the desired control.
3. Hold down the [Shift] key and select the other controls you want to add to the layout.
4. Select the Stacked Layout button in the Control Layout section of the Arrange tab.

**Step-by-Step**

Create a stacked layout.

Open the Customer Data Entry form in Design view, if necessary.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Click on the desired control. <em>The control is highlighted.</em></td>
<td>Click Customer Number</td>
</tr>
<tr>
<td>2. Hold down the [Shift] key and select the other controls you want to add to the layout. <em>Access highlights all the controls within the layout.</em></td>
<td>Hold down [Shift] and select Store Name and Contact Name</td>
</tr>
<tr>
<td>3. Select the desired layout in the Control Layout group on the Arrange tab. <em>The selected controls are added to a stacked control layout.</em></td>
<td>Click Stacked</td>
</tr>
</tbody>
</table>

Notice you can now manipulate the new group as one unit. Move the new stacked layout to a different location on the form. Close WORLD63.ACCDB.

**USING A TABULAR LAYOUT IN A FORM**

**Discussion**

In tabular layouts, controls are arranged like a spreadsheet in columns and rows, with labels at the top. Data fields appear below the appropriate label.
Procedures

1. Open the desired form in design view.
2. Click on the desired control.
3. Hold down the [Shift] key and select the other controls you want to add to the layout.
4. Select the Tabular layout button in the Control Layout group on the Arrange tab.

Step-by-Step

From the Student Data directory, open WORLD64.ACCDB. Create a tabular layout.

Open the Items form in Design view, if necessary.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Click on the desired control.</td>
<td>Click ProductID</td>
</tr>
<tr>
<td>The control is highlighted.</td>
<td></td>
</tr>
</tbody>
</table>
Steps | Practice Data
--- | ---
2. Hold down the [Shift] key and select the other controls you want to add to the layout. *Access highlights all the controls within the layout.* | Hold down [Shift] and select **Product Description** and **Unit price**

3. Select the **Tabular layout** button in the **Control Layout** group on the **Arrange** tab. *The selected controls are added to a stacked control layout.* | Click **Tabular**

Notice, you may need to reduce the size of your control fields in order to fit the page.

**REMOVING A CONTROL FROM A LAYOUT IN A FORM**

**Discussion**

You can remove one or more controls from a layout and place them anywhere on the form without affecting the position of the other controls. This enables you to move the desired controls independently.

**Procedures**

1. Open the desired form.
2. Select the desired control.
3. Select the **Arrange** tab, if necessary.
4. Select the **Remove** button on the **Control Layout** group on the **Arrange** tab.

**Step-by-Step**

Remove a control from a layout in a form.

Open the **Items** form in **Design** view, if necessary.
**Steps**

1. Select the desired control.
   *The control options menu appears.*

2. Select the desired layout.
   *The desired layout is selected.*

3. Select the **Arrange** tab, if necessary.
   *The layout options appear.*

4. Select the **Remove** button on the **Control Layout** group.
   *The control is removed from the layout.*

---

**Practice Data**

- Click **Product ID**
- Click **Arrange**
- Click **Remove**

Notice that you can now move the controls individually.

Close **WORLD64.ACCDB**.

---

### USING THE CALENDAR FOR DATE PICKING

#### Discussion

In Access 2007, fields and controls that employ the Date/Time data type have new support - a built-in interactive calendar for choosing dates. This new function simplifies the date-picking process.

![The Calendar for date picking](image-url)
Procedures

1. Open the desired form.
2. Press [F4] to open the property sheet, if necessary.
3. Select the desired control from the dropdown list at the top of the property sheet.
4. Select the Format tab on the property sheet, if necessary.
5. In the Show Date Picker field, select For Dates, if necessary.

Step-by-Step

From the Student Data directory, open WORLD65.ACCDB. Use the calendar for date picking in a form.

Open the Orders form in Design view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>2. Select the desired date field from the Selection Type dropdown list at the top of the property sheet. The date field is selected.</td>
<td>Click ▼ and select Order Date</td>
</tr>
<tr>
<td>3. Select the Format tab on the property sheet, if necessary. The format tab appears.</td>
<td>Click Format</td>
</tr>
<tr>
<td>4. In the Show Date Picker field, select For Dates, if necessary. The For Dates option is selected.</td>
<td>Click For Dates, if necessary</td>
</tr>
<tr>
<td>5. Select Save. The form is saved.</td>
<td>Click ▼</td>
</tr>
</tbody>
</table>

Notice when you edit data in the Order Date field in Form view, the calendar will appear to the right of the field. You can then click on the calendar and select the desired date.
EDITING LIST ITEMS

Discussion

When you create a Lookup List in a form, you can now allow users to edit the list items using the Edit List Items dialog box. If you do not want users to be able to edit the list, you can also disable this property.

The Edit List Items dialog box

Procedures

1. Open the desired form in Form view.
2. Select the arrow in the desired field.
3. Select the **Edit List** button below the lookup list.
4. Edit the list, if necessary.
5. Select **OK**.

Step-by-Step

Edit List Items.
Open the **Items2** Form in **Form** view.

<table>
<thead>
<tr>
<th><strong>Steps</strong></th>
<th><strong>Practice Data</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the arrow in the desired field. <em>The lookup list appears.</em></td>
<td>Click ↓ in the <strong>Color</strong> field</td>
</tr>
<tr>
<td>2. Select the <strong>Edit List</strong> button below the lookup list. <em>The Edit List Items dialog box appears.</em></td>
<td>Click</td>
</tr>
<tr>
<td>3. Edit the list, if necessary. <em>The text appears in the list.</em></td>
<td>Type <strong>Red</strong></td>
</tr>
<tr>
<td>4. Select <strong>OK</strong>. <em>The Edit List Items dialog box closes.</em></td>
<td>Click <strong>OK</strong></td>
</tr>
</tbody>
</table>

Notice that when you click on the arrow in the **Color** field, the new option has been added to the list.

Close **WORLD65.ACCDB**.
**EXERCISE**

**WORKING WITH FORMS**

**Task**

Work with forms.

1. Start Access, if necessary.
2. Open the Train54x database.
3. Using the **Form Wizard**, create a form using the **Trainer** table. Add all the available fields from the **Trainer** table, in a **Columnar** layout, using the **Urban** style. Name the form **Trainer Info**.
4. Select **Design** view and open the **Field List** task pane, if necessary.
5. Use the **Field List** task pane to add the **Project ID** field and the **Start Date** field from the **Project** table to the form. Adjust the height of the form, if necessary.
6. Convert the form to a split form.
7. Remove the **Initials** field and its corresponding control from the layout, and move it up to a different location on the form.
8. Close the database without saving.
LESSON 6 -
WORKING WITH REPORTS

In this lesson, you will learn how to:

- Create a report using the Create tab
- Use Layout and Design views in a report
- Use a Stacked layout in a report
- Use a Tabular layout in a report
- Remove a Control from a layout
- Move fields in a report
- Group and sort in reports
- Display report totals
Creating a Report Using the Create Tab

Discussion

You can create a report quickly and easily in Access 2007 by using the Reports section of the Create Tab on the Ribbon. First, you must choose the table or query on which you want to base your report. You can then choose from a number of different methods of report creation, using the various buttons in the Reports section on the Create tab.

If you include fields from unrelated tables in the report, Access closes the Report Wizard and opens the Relationships window so that you can create the necessary relationship.

Procedures

1. Select the Create tab.
2. Select the Report Wizard button.
3. Select the Tables/Queries list.
4. Select the table or query on which you want to base the report.
5. Add the desired fields to the Selected Fields list box, or add all the fields.
6. Select Next >
7. Select the desired grouping options.
8. Select Next >
9. Select the desired sorting options.
10. Select Next >
11. Select the desired report layout.
12. Select Next >
13. Select the desired report style.
14. Select [Next >]
15. Type the desired report name.
16. Select [Finish]

**Step-by-Step**

From the Student Data directory, open WORLD66.ACCDB. Create a report with the **Create** Tab.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the **Create** tab.  
*The Create tab appears.* | Click **Create** |
| 2. Select the **Report Wizard** button.  
*The Form Wizard dialog box opens.* | Click ![Report Wizard] |
| 3. Select the **Tables/Queries** arrow.  
*A list of tables and queries appears.* | Click ![Tables/Queries] |
| 4. Select the table or query on which you want to base the report.  
*The table or query is selected, and the fields in the selected table or query appear in the **Available Fields** list box.* | Click **Table: Orders**, if necessary |
| 5. Add the desired fields to the **Selected Fields** list box, or add all the fields.  
*The fields appear in the **Selected Fields** list box.* | Click ![Add Fields] to add all fields |
| 6. Select **Next**.  
*The next page of the Report Wizard appears.* | Click ![Next >] |
| 7. Select the desired grouping options.  
*A preview of the layout appears in the Report Wizard.* | Select **Order Number** and click ![Group Options] |
| 8. Select **Next**.  
*The next page of the Report Wizard appears.* | Click ![Next >] |
| 9. Select the desired sorting options.  
*The next page of the Report Wizard appears.* | Click ![Sort Options] and select **Customer ID** |
Lesson 6 - Working with Reports

Steps | Practice Data
--- | ---
10. Select **Next**. The next page of the Report Wizard appears. | Click **Next >**
11. Select the desired report layout. A preview of the layout appears in the Report Wizard. | Click **Landscape**, if necessary
12. Select **Next**. The next page of the Report Wizard appears. | Click **Next >**
13. Select the desired form style. A preview of the style appears in the Report Wizard. | Click **Median**
14. Select **Next**. The next page of the Report Wizard appears, and the text in the **What title do you want for your report?** box is selected. | Click **Next >**
15. Type the desired form name. The name appears in the **What title do you want for your report?** box. | Type **Orders**, if necessary
16. Select **Finish**. The Report Wizard closes, and the new form open in **Print Preview**. | Click **Finish**

Notice the new Report is now listed under the Reports section on the Navigation Pane. Close **Print Preview**.

**USING LAYOUT AND DESIGN VIEWS IN A REPORT**

**Discussion**

After you create a report, you can view it in a selection of different views: **Report View**, **Print Preview**, **Layout** view, or **Design** view. When a report is open, you can switch between these views by clicking the **View** button in the Views section of the **Home** tab on the Ribbon. The following table explains the different views:
### View Description

<table>
<thead>
<tr>
<th>View</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report View</td>
<td>This view displays the report as you (or the Report Wizard) designed it.</td>
</tr>
<tr>
<td>Print Preview</td>
<td>This view allows you to view the print layout of your report.</td>
</tr>
<tr>
<td>Layout View</td>
<td>This view looks like Print Preview, but allows you to make changes to your report.</td>
</tr>
<tr>
<td>Design View</td>
<td>Displays the report in the Design View window, where you can change form elements, move them around and add or delete them, if necessary.</td>
</tr>
</tbody>
</table>

A report in Design view

### Procedures

1. Open the desired report.
2. Select the **View** button on the **Home** tab.
3. Select the desired view.

### Step-by-Step

Change the report view.
Open the Orders report, if necessary.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the View Button on the Home tab.</td>
<td><img src="View.png" alt="View" /> View drop-down menu appears.</td>
</tr>
<tr>
<td>2. Select Design view.</td>
<td><img src="Design.png" alt="Design" /> Design view. The form changes to layout view.</td>
</tr>
</tbody>
</table>

Practice the concept: Follow the above steps and select Print Preview. Close WORLD66.ACCDB.

**USING A STACKED LAYOUT IN A REPORT**

**Discussion**

In stacked layouts, controls are arranged vertically, like you might see on a paper form, with the label to the left of each control. Stacked layouts are always contained within a single report section.

**Procedures**

1. Open the desired report in design view.
2. Click on the desired control.
3. Hold down the [Shift] key and select the other controls you want to add to the layout.
4. Select the Stacked Layout button in the Control Layout group of the Arrange tab.

**Step-by-Step**

From the Student Data directory, open WORLD67.ACCDB. Create a stacked layout.
Open the Customers report in Design view, if necessary.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Click on the desired control.</td>
<td>Click Customer Number</td>
</tr>
<tr>
<td>The control is highlighted.</td>
<td></td>
</tr>
<tr>
<td>2. Hold down the [Shift] key and select the other controls you want</td>
<td>Hold down [Shift] and</td>
</tr>
<tr>
<td>to add to the layout.</td>
<td>click Store Name and</td>
</tr>
<tr>
<td>Access highlights all the controls within the layout.</td>
<td>Contact Name</td>
</tr>
<tr>
<td>3. Select the desired layout in the Control Layout group on the</td>
<td>Click Stacked</td>
</tr>
<tr>
<td>Arrange tab.</td>
<td></td>
</tr>
<tr>
<td>The selected controls are added to a stacked control layout.</td>
<td></td>
</tr>
</tbody>
</table>

**USING A TABLE LAYOUT IN A REPORT**

**Discussion**

In tabular layouts, controls are arranged like a spreadsheet in columns and rows, with labels at the top. Access automatically creates a tabbed layout when you create a new report by using the Report button or the Blank Report button in the Reports section of the Create tab.

**Procedures**

1. Open the desired report in Design view.
2. Click on the desired control.
3. Hold down the [Shift] key and select the other controls you want to add to the layout.
4. Select the Tabular layout button in the Control Layout group of the Arrange tab.
Step-by-Step

Create a Tabular layout in a report.

Open the Line Items report in Design view, if necessary.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Click on the desired control. <em>The control is highlighted.</em></td>
<td>Click Order Number</td>
</tr>
<tr>
<td>2. Hold down the [Shift] key and select the other controls you want to add to the layout. <em>Access highlights all the controls within the layout.</em></td>
<td>Hold down [Shift] and click <strong>Product ID</strong>, <strong>Quantity</strong> and <strong>Unique ID</strong></td>
</tr>
<tr>
<td>3. Select the Tabular layout button in the Control Layout group on the Arrange tab. <em>The selected controls are added to a stacked control layout.</em></td>
<td>Click <img src="image" alt="Tabular" /></td>
</tr>
</tbody>
</table>

REMOVING A CONTROL FROM A LAYOUT

Discussion

You can remove one or more controls from a layout and place them anywhere on the report without affecting the position of the other controls. To make this possible, you must first remove the desired controls from the default layout.

Procedures

1. Open the desired report.
2. Select the desired control.
3. Select the Arrange tab, if necessary.
4. Select the Remove button on the Control Layout group on the Arrange tab.
Step-by-Step

Remove a control from a layout in a report

Open the Line Items report in Design layout, if necessary.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the desired control. The control options menu appears.</td>
<td>Click Unique ID</td>
</tr>
<tr>
<td>2. Select the Arrange tab, if necessary. The layout options menu appears.</td>
<td>Click Arrange</td>
</tr>
<tr>
<td>3. Select the Remove button on the Control Layout group on the Arrange tab. The control is removed from the layout.</td>
<td>Click Remove</td>
</tr>
</tbody>
</table>

Notice that you can now move the Unique ID control without affecting any of the other controls in the report.

MOVING FIELDS IN A REPORT

Discussion

Once you have created your basic report, you can then edit the design to suit your own needs. In Access 2007, you can move fields in your report with ease using Design view or Layout view.

When you create a report, the controls are automatically created in a tabular layout. If you want to move individual controls, you must first remove them from the default layout.

Procedures

1. Open the desired report in design view.
2. Select the desired control.
3. Select the desired control layout.
4. Drag the control layout to the desired position.
5. Release the mouse button.

**Step-by-Step**

Move fields in a report.

Open the **Line Items** report in **Design** view, if necessary.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the desired control.  
*The View drop-down menu appears.* | Click **Order Number** |
| 2. Select the desired control layout.  
*The control layout is selected.* | Click [ ] |
| 3. Drag the control layout to the desired position.  
*The control layout is dragged to a new position on the report.* | Drag the layout to the right |
| 4. Release the mouse button.  
*The control layout is moved.* | Release the mouse button |

When you are satisfied with your report layout, save and close the report.

**GROUPING AND SORTING IN REPORTS**

**Discussion**

You can perform simple grouping, sorting and totaling operations when working with reports by using the Group, Sort & Total task pane, which can make your report easier to read. In addition to grouping and sorting options, you can also add counts, totals or other arithmetic operations to each group as required.
Procedures

1. Open the desired report in **Design** view.

2. Select the **Group & Sort** button in the **Grouping & Totals** group on the **Design** tab.

3. Select the desired grouping or sorting options.

4. Select the desired option.

5. Select the **Close** button on the Group, Sort & Total task pane.

Step-by-Step

Use the Group, Sort & Total task pane.

Open the **Line Items** report in **Design** view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the **Group & Sort** button in the **Grouping & Totals** section of the **Ribbon**.  
*The Group, Sort and Total task Pane appears.* | Click **Group & Sort** |
Steps | Practice Data
---|---
2. Select the desired grouping or sorting options. 
* A drop-down list of options appears. | Click Add a Sort

3. Select the desired option. 
* The desired option is selected. | Click Order Number

4. Select the Close button on the Group, Sort & Total task pane. 
* The task pane closes. | Click 

If you view your report in **Print Preview**, you will see that the desired Grouping, Sorting or Totaling options have been amended.

## Displaying Report Totals

### Discussion

If your report contains numbers, you may choose to make the data more understandable by using aggregate functions to create totals, averages, percentages or running sums.

You can create report totals using **Design** view or **Layout** view. In **Design** view, you have more control over the placement and appearance of your totals.
Procedures

1. Open the desired report in Layout view.
2. Select the Design tab on the Ribbon.
3. Select the desired field.
4. Select the Totals button $\Sigma$ Totals in the Grouping & Totals group on the Format tab.
5. Select the desired aggregate function from the totals drop down menu.
6. Select Save.

Step-by-Step

Create report totals.

Open the Items report in Design view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Design tab on the Ribbon.</td>
<td>Click Design</td>
</tr>
<tr>
<td>The Design tab opens.</td>
<td></td>
</tr>
<tr>
<td>2. Select the desired field.</td>
<td>Click on the Unit Price field</td>
</tr>
<tr>
<td>The desired field is selected.</td>
<td></td>
</tr>
<tr>
<td>3. Select the Totals button in the</td>
<td>Click $\Sigma$ Totals</td>
</tr>
<tr>
<td>Grouping &amp; Totals Group on the Format tab.</td>
<td></td>
</tr>
<tr>
<td>The Totals drop-down menu appears.</td>
<td></td>
</tr>
<tr>
<td>4. Select the desired aggregate function</td>
<td>Select Sum</td>
</tr>
<tr>
<td>from the totals drop down menu.</td>
<td></td>
</tr>
<tr>
<td>The desired calculation appears at the</td>
<td></td>
</tr>
<tr>
<td>bottom of the report.</td>
<td></td>
</tr>
</tbody>
</table>

Practice the concept: Follow the above steps and try out other aggregate functions. Close WORLD67.ACCDB.
EXERCISE

WORKING WITH REPORTS

Task

Work with reports.

1. Start Access, if necessary.
2. Open the Train55x database.
3. Open the Project table.
4. Use the Report button on the Create tab to create a report.
5. Select Design view.
6. Remove the layout from all controls.
7. Select Layout view.
8. Using the Group, Sort & Totals pane, sort the report by Course Name.
9. Close Group, Sort & Totals pane.
10. Save and close the report.
LESSON 7 - WORKING WITH MACROS

In this lesson, you will learn how to:

- Display macro design arguments
- Use embedded macros
- Explore increased security
- Work with error handling and debugging
- Use temporary variables
**DISPLAYING MACRO DESIGN ARGUMENTS**

**Discussion**

A macro performs a set of commands in sequence. While macros in word processors and spreadsheets are used mainly to duplicate keystrokes or mouse movements, macros in Access often automate an action or a series of actions. Such actions include opening tables, printing forms, finding records, or applying filters. Macros can even be used to add command buttons, create menus and toolbars, and build complete applications.

Macro commands in Access consist of an action and its arguments. The action is the task to be performed, such as opening a form. The arguments determine the specifics for the action, such as which form to open.

The Macro Builder in Access 2007 has a new Arguments column, which allows you to view an argument assigned to an action on the same line as the action.

![The Macro Design Builder](image)

You can display the Arguments column in the Macro Builder by using the Show/Hide options section on the **Design** tab.
USING EMBEDDED MACROS

Discussion

In Access 2007, you can create embedded macros. When you embed a macro in an event provided by a form, report or control, it is stored in the properties of that event. Therefore, if you export your form or report to another Access database, the embedded macro is included.

- Embedded macros are trusted because they are automatically prevented from performing certain potentially unsafe operations.
- An embedded macro is not visible in the Macros list in the Navigation Pane.

Procedures

1. Open the desired form or report.
3. Select the desired control that contains the event property in which you want to embed the macro.
4. Select the Event tab in the property sheet.
5. Select the event property in which you want to embed the macro, and click
6. Select Macro Builder.
7. Select [OK].
8. Select the desired action from the Action drop down list.
9. Add the required arguments in the Action Arguments pane, if necessary.
10. Select Save.
Step-by-Step

From the Student Data directory, open WORLD68.ACCDB. Create an embedded macro.

Open the Orders report in Design view.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>2. Select the control that contains the event property in which you want to embed the macro from the Selection Type drop-down list in the Property Sheet. <em>The desired control is selected.</em></td>
<td>Click ‾ and select Report</td>
</tr>
<tr>
<td>3. Select the Event tab in the Property Sheet. <em>The Event tab appears.</em></td>
<td>Click Event</td>
</tr>
<tr>
<td>4. Select the event property in which you want to embed the macro. <em>The Choose Builder dialog box appears.</em></td>
<td>Click On No Data and click ‾</td>
</tr>
<tr>
<td>5. Select Macro Builder. <em>The Macro Builder is selected.</em></td>
<td>Click Macro Builder</td>
</tr>
<tr>
<td>6. Select OK. <em>The Macro Builder appears.</em></td>
<td>Click OK</td>
</tr>
<tr>
<td>7. Select the desired action from the Action drop down list. <em>The desired action is selected.</em></td>
<td>Click ‾ and select MsgBox</td>
</tr>
<tr>
<td>8. Add the required arguments in the Action Arguments pane, if necessary. <em>The desired argument is added to the Action Arguments Pane.</em></td>
<td>Type <em>There is no data available to create this report</em> in the Message field in the Action Arguments pane</td>
</tr>
<tr>
<td>9. Select Save. <em>The embedded macro is saved.</em></td>
<td>Click Save</td>
</tr>
</tbody>
</table>

When you close the Macro Builder, notice that the On No Data event in the Property Sheet now has an embedded macro listed.
The macro will run every time the event is triggered. If a user tries to run the Orders report, but there is no data available to do so, Access will display the message box. Close WORLD68.ACCDB.

EXPLORING INCREASED SECURITY

Discussion

In Access 2007, if you open a database that contains macro actions that are not on the Trusted Publishers list, a security dialog box will appear in the message bar below the ribbon. If you want to enable the content, you have to explicitly grant the publisher trusted status. By selecting the Options button in the message bar, you can view further information about the content, and choose whether to grant the publisher trusted status, or not.

You can use Access Options to amend your security settings. If you are connected to the Internet, you can also follow the links in this section to Microsoft Windows Online Security Center for further tips on protecting your privacy and updating your security.

Do not enable content unless you are sure that the document and macro come from a trustworthy source.
WORKING WITH ERROR HANDLING AND DEBUGGING

Discussion

Access 2007 has two new macro actions which enable you to perform specific actions if errors occur when your macro is running: **OnError**, and **ClearMacroError**.

If you anticipate that certain errors may occur, you can use the above macro actions to trap them and inform you of their occurrence without stopping the execution of the macro, or displaying an error message to the user.

Another new error-handling and debugging feature is the new **SingleStep** macro action, which enables you to enter single-step mode at any point in your macro. This slows down the execution of the macro, and enables you to step through the code line by line, amending any errors as you go.

USING TEMPORARY VARIABLES

Discussion

Temporary variables can be used in conditional expressions for any purpose that requires a temporary storage place for a value. In Access 2007, there are three new macro actions which allow you to create and use temporary variables: **SetTempVar**, **RemoveTempVar** and **RemoveAllTempVars**.

The following table explains the functions of these temporary variables:

<table>
<thead>
<tr>
<th>Variable</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>SetTempVar</td>
<td>Use this action to create a temporary variable and set it to a specific value.</td>
</tr>
<tr>
<td>RemoveTempVar</td>
<td>Use this action to remove a single temporary variable that you created using the <strong>SetTempVar</strong> action.</td>
</tr>
<tr>
<td>RemoveAllTempVars</td>
<td>Use this action to remove all temporary variables that you created using the <strong>SetTempVar</strong> action.</td>
</tr>
</tbody>
</table>
You can have up to 255 temporary variables defined at one time. If you do not remove a temporary variable, it will remain in memory until you close the database.
LESSON 8 -
USING DATA COLLECTION BY E-MAIL

In this lesson, you will learn how to:

- Use data collection
- Use the Collect Data by E-mail Messages wizard
- Set Data Collection by E-mail options
- Manually process replies
USING DATA COLLECTION

Discussion

Access 2007 allows you to collect data through e-mail. You can send a form using Outlook, then process the responses as you add the data collected to your database.

The following table provides examples of when to use Data Collection via e-mail:

<table>
<thead>
<tr>
<th>Surveys</th>
<th>When you want to perform a survey and compile the results in Access.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Status Reports</td>
<td>Team members around the world can send e-mail messages with updated status reports at regular intervals.</td>
</tr>
<tr>
<td>Event Management</td>
<td>When organizing an event, such as a conference, you can send a number of forms as e-mails for gathering delegate contact information.</td>
</tr>
</tbody>
</table>

In order to collect data through e-mail, you must have Access 2007 and Outlook 2007 installed on your computer.

USING THE COLLECT DATA BY E-MAIL MESSAGES WIZARD

Discussion

The Collect Data Through E-mail Messages Wizard guides you through the process of creating e-mail messages that include a data entry form.

Before you start the Collect Data Through E-mail Messages Wizard, you must first identify or create a table containing the fields that you want to include in your e-mail.
Before you use the Collect Data Through Email Messages Wizard, you must ensure that your recipients use an email client that supports HTML format.

Your table must contain fields that support data collection in order for the Collect Data Through Email Messages Wizard to start.

Procedures

1. Open the desired table.
2. Click in the first empty record on your table.
3. Select the **External Data** tab on the ribbon.
4. Select the **Create Email** button in the **Collect Data** group on the **External Data** tab.
5. Read the instructions, then select Next >
6. Select the desired type of data-entry form.

7. Select the desired collection options.

8. Select the desired reply processing option.

9. Select the desired type of data-entry form.

10. Select the fields you want to include in your form.

11. Select the desired reply processing option.

12. Select how to specify your e-mail recipients.

13. Select the desired type of data-entry form.

14. Review the subject and introduction of the e-mail message making changes, if necessary, and select the desired reply processing option.

15. Select the desired type of data-entry form.

16. Select your e-mail recipients by typing their e-mail addresses, or selecting them from your Outlook Address Book.

17. Send the e-mail.

Step-by-Step

From the Student Data directory, open WSGOODS4.ACCDB. Use the Collect Data Through E-mail Messages Wizard.

Open the Customers table.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Click in the first empty record on your table. The insertion point appears in the first empty record.</td>
<td>Click in the first empty record</td>
</tr>
</tbody>
</table>
### Steps

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
</table>
| 2. | Select the **External Data** tab on the Ribbon.  
*The External Data tab appears.* |
|   | Click **External data** |
| 3. | Select the **Create Email** button in the **Collect Data** group on the **External Data** tab.  
*The Collect Data Through E-mail Messages Wizard appears.* |
|   | Click **Create E-mail** |
| 4. | Read the instructions, then select **Next**.  
*The next page in the Wizard appears.* |
|   | Click **Next >** |
| 5. | Select the desired type of data-entry form.  
*The HTML form option is selected.* |
|   | Click **HTML form** |
| 6. | Select **Next**, then read the note after the step by step before continuing to step 5.  
*The next page in the Wizard appears.* |
|   | Click **Next >** |
| 7. | Select the desired collection options, if necessary.  
*The Collect New Information option is selected.* |
|   | Click **Collect New Information Only**, if necessary |
| 8. | Select **Next**.  
*The next page in the Wizard appears.* |
|   | Click **Next >** |
| 9. | Select the fields you want to include in your form.  
*The desired fields are selected.* |
|   | Select **Store Name** and **Contact Name** and **Phone Number**  
*Repeat for Contact Name and Phone Number* |
| 10. | Select **Next**.  
*The next page in the Wizard appears.* |
|   | Click **Next >** |
| 11. | Select the desired reply processing option.  
*The Automatically Process Replies Option is selected.* |
|   | Click **Automatically process replies and add data to Customers** |
| 12. | Select **Next**.  
*The next page in the Wizard appears.* |
|   | Click **Next >** |
| 13. | Select how to specify your e-mail recipients  
*The Enter the E-mail addresses in Office Outlook option is selected.* |
|   | Click **Enter the e-mail addresses in Office Outlook** |
14. Select Next.  
   *The next page in the Wizard appears.*

15. Review the subject and introduction of the e-mail message making changes, if necessary, and click Next.  
   *The Wizard displays a page informing you that you can now create your e-mail messages.*

16. Select Create.  
   *An Outlook message containing a data entry form is displayed.*

17. Select your e-mail recipients by typing their e-mail addresses, or selecting them from your Outlook Address Book.  
   *The e-mail recipients are selected.*

18. Select Send.  
   *The e-mails are sent to the specified recipients.*

The Wizard page that is displayed after Step 4 depends on whether the destination object supports the updating of data. If your table does not have a Primary Key field or does not contain any records, the Wizard assumes that you want to add new records, and prompts you to select the form fields. In all other cases, the Wizard prompts you to select whether you want to add or update your data before asking you to select your form fields. Continue to Step 5.

**SETTING DATA COLLECTION BY E-MAIL OPTIONS**

**Discussion**

When using the Collect Data Through E-mail Messages Wizard, you may want to change some collection options. Using the Collecting Data via E-mail Options dialog box you can adjust the import and automatic processing settings.
You can only access the Collecting Data via E-mail Options dialog box from the **Specify How you want to process the replies** page of the Collect Data Through E-mail Messages Wizard.

**Procedures**

1. Select the **Select properties to control the automatic processing of replies** link.
2. Select desired settings and click **OK**.

**Step-by-Step**

Set the Collecting Data via e-mail options.

Start the Collecting Data via E-mail Wizard, and follow the steps through to the **Specify how you want to process the replies** page.
Lesson 8 - Using Data Collection By E-mail  
Moving Up to Office 2007 - Access

### Steps

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the Select properties to control the automatic processing of replies link. The Collecting Data Using E-mail Options dialog box appears.</td>
<td>Click Select properties to control the automatic processing of replies</td>
</tr>
<tr>
<td>2. Select desired settings and click OK. The settings are updated and the Collecting Data Using E-mail dialog box closes.</td>
<td>Click OK</td>
</tr>
</tbody>
</table>

When the dialog box closes, Access returns to the Specify how you want to process the replies page, and you can continue using the Collecting Data Through E-mail Messages wizard.

---

**MANUALLY PROCESSING REPLIES**

#### Discussion

When using Data Collection by e-mail, if you want to choose when and which replies are processed, you can choose to process your replies manually. In order to manually process a reply, you have to export the data from Outlook 2007.

![Outlook dialog box](image)

In order to process replies manually, when prompted to specify how you want to process your replies by the Data Collection Through E-mail Messages wizard, make sure you clear the Automatically process replies and add data to check box.
You can only export one reply at a time from Outlook 2007.

If you chose to have the replies processed automatically, and the process failed, you must troubleshoot the error that caused the failure before processing the replies manually.

Procedures

1. Open Office Outlook 2007, if necessary.
2. Right-click the reply you want to process manually.
4. Select OK.

Step-by-Step

Manually process data collection replies.

Open Office Outlook 2007, if necessary.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Right-click the reply you want to process manually. The options drop down menu appears.</td>
<td>Right-click the reply</td>
</tr>
<tr>
<td>2. Select Export Data to Microsoft Access. The Export Data to Microsoft Access dialog box appears.</td>
<td>Click Export data to Microsoft Access</td>
</tr>
<tr>
<td>3. Select OK. Access displays message to confirm if the export operation was successful, or if it failed.</td>
<td>Click OK</td>
</tr>
</tbody>
</table>

Close WSGOODS4.ACCDB.
**Exercise**

**Collecting Data by E-mail**

**Task**

Collect data by email.

1. Start Access, if necessary.

2. Open the **Train56x** database.

3. Use the Data Collection Through E-mail Wizard to create an e-mail message that includes a form for collecting the following Client information: **Name**, **Address**, **City**, **State**, **Zip** and **Phone No.**

4. Choose to manually process the replies.

5. Send to the e-mail address of two of your fellow students.

6. When your recipients respond, open **Outlook 2007** and manually process the replies.
LESSON 9 -
CUSTOMIZING THE NAVIGATION PANE

In this lesson, you will learn how to:

- Create custom categories
- Create custom groups
- Add database objects to a group
- Show/Hide the unassigned objects group
- Delete objects from a group
CREATING CUSTOM CATEGORIES

Discussion

Although you can use a switchboard to provide users with easy access to selected objects in your database, in Access 2007, it is easier to do so by creating a custom category using the Navigation Pane.

You can create up to a maximum of ten custom categories, each of which can contain multiple custom groups.

Procedures

1. Open the desired database, if necessary.
2. Show the Navigation Pane, if necessary.
3. Select the arrow in the Navigation Pane header.
4. Select All Access Objects.
5. Right-click the All Access Objects category.
7. Select Add Item under the Categories List.
8. Type a name for the new category, then press [Enter].
9. Select , if necessary.

Step-by-Step

From the Student Data directory, open PRODUCT2.ACCDB.
Create a Custom Category

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Show the Navigation Pane, if necessary.</td>
<td>Press [F11] to open the Navigation Pane, if necessary</td>
</tr>
</tbody>
</table>

The Navigation Pane menu appears.
### Steps

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>2. Select the arrow in the Navigation Pane Header.</td>
<td>Click <a href="#">▼</a></td>
</tr>
<tr>
<td><em>The Navigation Pane menu appears.</em></td>
<td></td>
</tr>
<tr>
<td>3. Select All Access Objects.</td>
<td>Click All Access Objects</td>
</tr>
<tr>
<td><em>The object type is selected, and the objects stored in it appear in the object list.</em></td>
<td></td>
</tr>
<tr>
<td>4. Right-click the All Access Objects header.</td>
<td>Right-click the All Access Objects header</td>
</tr>
<tr>
<td><em>The options menu appears.</em></td>
<td></td>
</tr>
<tr>
<td>5. Select <strong>Navigation Options</strong>.</td>
<td>Click Navigation Options</td>
</tr>
<tr>
<td><em>The Navigation Options dialog box opens.</em></td>
<td></td>
</tr>
<tr>
<td>6. Select <strong>Add Item</strong> under the Categories List.</td>
<td>Click <img src="#" alt="Add Item" /></td>
</tr>
<tr>
<td><em>A new category appears in the category list.</em></td>
<td></td>
</tr>
<tr>
<td>7. Type a name for the new category, then press <code>[Enter]</code>.</td>
<td>Type <em>Product Info</em>, then press <code>[Enter]</code></td>
</tr>
<tr>
<td><em>The new category is renamed.</em></td>
<td></td>
</tr>
<tr>
<td>8. Select <strong>OK</strong>, if necessary.</td>
<td>Click <img src="#" alt="OK" />, if necessary</td>
</tr>
<tr>
<td><em>The Navigation Options dialog box closes.</em></td>
<td></td>
</tr>
</tbody>
</table>

Notice when you click on the header of the Navigation Pane, your new custom category now appears in the drop-down list.

---

### Creating Custom Groups

#### Discussion

After you have created your custom category, you can then create one or more custom groups for that category. There is no limit to the number of custom groups you can create.

#### Procedures

1. Show the Navigation Pane, if necessary.
2. Right-click the Navigation Pane header.
5. Select the desired category in the Categories list.
6. Select the **Add Group** button under the Groups list for the desired category.
7. Type a name for the new group, then press [Enter].
8. Select **OK**, if necessary.

### Step-by-Step

Create a custom group.

<table>
<thead>
<tr>
<th><strong>Steps</strong></th>
<th><strong>Practice Data</strong></th>
</tr>
</thead>
</table>
| 1. Show the Navigation Pane, if necessary.  
*The Navigation Pane appears.* | Press [F11], if necessary |
| 2. Right-click the Navigation Pane header.  
*The Navigation Pane menu appears.* | Right-click the Navigation Pane header |
*The Navigation Options dialog box opens.* | Click **Navigation Options** |
| 5. Select the desired category in the Categories list.  
*The desired category is selected.* | Click **Product Info** |
| 6. Select the **Add Group** button under the Groups list for the desired category.  
*A new group appears in the group list.* | Click **Add Group** |
| 7. Type a name for the new group, then press [Enter].  
*The Navigation Options dialog box disappears.* | Type **Product Group 1**, then press [Enter] |
| 8. Select **OK**, if necessary.  
*The Navigation Options dialog box closes.* | Click **OK**, if necessary |
Notice when you click on the header of the Navigation Pane and select the **Product Info** category, your new custom group now appears in the drop-down list. You can repeat the above process to add as many custom groups that you need.

## ADDING DATABASE OBJECTS TO A GROUP

### Discussion

Once you have created your custom group, you can now select which objects you want to assign to it. You can select objects individually, or select multiple objects by holding down \[Ctrl\] as you select.

### Procedures

1. Select the arrow \( \downarrow \) on the Navigation Pane header.
2. Select your new category.
3. Select the object you want to assign from the Unassigned Objects Group.
4. Drag your item to your group.

### Step-by-Step

Add database objects to a group.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select the arrow on the Navigation Pane header. ( \downarrow )</td>
<td>Click ( \downarrow )</td>
</tr>
<tr>
<td><em>The Navigation Pane menu appears.</em></td>
<td></td>
</tr>
<tr>
<td>2. Select your new category. ( \downarrow )</td>
<td>Click <strong>Product Info</strong></td>
</tr>
<tr>
<td><em>The group(s) that you created for your category appear in the lower section of the Navigation Pane menu, together with the Unassigned Objects group.</em></td>
<td></td>
</tr>
<tr>
<td>3. Select the object you want to assign from the Unassigned Objects Group. ( \downarrow )</td>
<td>Click the <strong>Items</strong> table</td>
</tr>
<tr>
<td><em>A drop-down menu appears.</em></td>
<td></td>
</tr>
</tbody>
</table>
Steps | Practice Data
---|---
4. Drag your item to your group. The Navigation Options dialog box opens. | Drag item to group Product Group 1

Practice the concept: Add the Line Items table to Product Group 1.

Notice your actions create shortcuts to the chosen objects. You can rename the shortcuts by right-clicking them and selecting Rename Shortcut.

**SHOWING/HIDING THE UNASSIGNED OBJECTS GROUP**

**Discussion**

The Unassigned Objects group displays all objects that have not been assigned to a custom group. When you have finished creating your custom groups and have assigned your chosen objects, you can leave the Unassigned Objects group visible in the Navigation Pane, or you can choose to hide it.

**Procedures**

1. Show the Navigation Pane, if necessary.
2. Right-click the Navigation Pane header.
4. Clear the Unassigned Objects check box in the Groups for list.
5. Click .

**Step-by-Step**

Hide the Unassigned Objects group.
### Steps

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Show the Navigation Pane, if necessary. <em>The Navigation Pane menu appears.</em></td>
<td>Press [F11], if necessary</td>
</tr>
<tr>
<td>2. Right-click the Navigation Pane header. <em>A drop-down menu appears.</em></td>
<td>Right-click the Navigation Pane header</td>
</tr>
<tr>
<td>4. Select the desired category in the Categories list. <em>The desired category is selected.</em></td>
<td>Click <a href="#">Product Info</a></td>
</tr>
<tr>
<td>4. Clear the Unassigned Objects check box in the Groups for list. <em>The check box is cleared.</em></td>
<td>Click <a href="#">Unassigned Objects</a> to clear the check box</td>
</tr>
<tr>
<td>5. Click <strong>OK.</strong> <em>The Navigation Options dialog box disappear, and the Unassigned Objects group is hidden.</em></td>
<td>Click <strong>OK</strong></td>
</tr>
</tbody>
</table>

### Deleting Objects from a Group

#### Discussion

You may need to change your custom groups, due to user or business demands. You can easily add or remove any objects within a group at any time.

#### Procedures

1. Select the desired category in the Navigation Pane.
2. Select the desired object in the desired Group.
3. Press [Delete].
Step-by-Step

Delete objects from a group.

<table>
<thead>
<tr>
<th>Steps</th>
<th>Practice Data</th>
</tr>
</thead>
</table>
| 1. Select the desired category in the Navigation Pane.  
*The category appears in the Navigation Pane.* | Select Product Info |
| 2. Select the object you want to remove in the desired group.  
*The desired object is highlighted.* | Select the Line Items table in Product Group 1 |
| 3. Press [Delete].  
*The objects options menu disappears and the selected object is removed from the group.* | Press [Delete] |

Close PRODUCT2.ACCDB.
EXERCISE

CUSTOMIZING THE NAVIGATION PANES

Task

Customize the Navigation Pane.

1. Start Access, if necessary.
2. Open the Train57x database.
3. Use the Navigation Options dialog box to create a custom category.
4. Rename the custom category Client Data.
5. Within the Client Data category, create a custom group called Payment Data.
6. Close the Navigation Options dialog box.
7. Select the Client Data category in the Navigation Pane.
8. Add the following objects to the Payment Data group: the Payment table and the Client/Payment query.
9. Hide the Unassigned Objects group.
10. Close the database.
INDEX

Access Options
using, 12, 13
Calendar for date picking, 76, 77
Control layouts, 71
  removing controls from a layout, 88, 89
  stacked, 72, 73
  tabular, 73, 74, 87, 88
Control Layouts
  removing controls from a layout, 75
  stacked, 86
Custom categories
  creating, 114
Custom Groups
  adding database objects, 117
  creating, 115, 116
  deleting objects from a group, 119
  Showing/hiding the Unassigned Objects group, 118, 119, 120
Data collection
  Collect Data Through E-mail Messages Wizard, 104, 105, 106
  manually processing replies, 110, 111
  setting options, 108, 109
  via e-mail, 104
Data type
  attachment, 31, 32
Database
  closing, 14, 15
  opening existing, 2, 3
Database objects
  object type, 4
  opening, 7
Database template, 20, 21
Field List task pane, 63, 64, 65
Field templates, 25, 26
Fields
  adding, 65, 66
  multi-valued, 27, 28
Filtering
  AutoFilter, 43, 44, 45
  quick filters, 45, 46
Forms
  converting to split form, 68, 69
  creating, 58, 59
  editing list items, 78
  editing split forms, 69, 70, 71
  moving fields, 62
  split form, 67, 68
views, 60, 61
Macros
  embedded, 97, 98
  error handling and debugging, 100
  working with, 96
Navigation Pane, 5, 6
Queries
  multi-valued fields, 50, 51
  totals row, 52, 53
Reports
  changing views, 84, 85
  creating, 82, 83
  Group, Sort & Total task pane, 90, 91
  moving fields, 89, 90
  totals row, 92, 93
Rich Text
  using, 30
Search box
  using, 42
Security
  Trusted Publisher list, 99
Status bar, 11, 12
Tabbed documents
  closing, 10
  closing all, 11
  using, 8, 9
Tables
  alternate background color, 35, 36
  datasheet view, 24, 25
  templates, 22, 23
  totals row, 33, 34
  truncated numbers, 36, 37
Variables
  temporary, 100