
Work with Tables

Sort Records in a Table According to One Field
In the table, select the field by which you need to sort the table. 
On the Home tab, in the Sort & Filter group, click the Ascending/
Descending button to sort the table in ascending or  
descending order.

Find and Replace Data in a Record
Press Ctrl+H to display the Replace tab in the Find And Replace 
dialog box. 
In the Find What text box, type the text you want to find. 
Set the search options.

Note: To only find text, press Ctrl+F, and instead of Steps 4 and 5, 
click Find Next. 
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In the Replace With text box, type the text that you want to 
replace the existing text with. 
Click Replace to replace the selected instance of the search 
criteria. Click Replace All to replace every instance.
Click the Close button.

Add the Total Row to a Table
On the Home tab, in the Records group, click Totals to add a 
Total row at the end of the table. 
In the Total row, click the field under the column on which you 
need to perform a mathematical function, and select the  
desired function.

Save a Table as an XPS File
In the Navigation Pane, select the desired table. 
Click the Microsoft Office button and choose Save As > PDF  
Or XPS. 
From the Save As Type drop-down list, select XPS Document. 
Click Publish.

Filter Records in a Table
Select the column that the data is to be filtered by. 
On the Home tab, in the Sort & Filter group, click Filter. 
On the context menu that is displayed, uncheck the options that 
are not required and click OK.

Modify Subdatasheets
Click the plus sign (+) to the left of the record you need to 
modify to expand the subdatasheet and view the related data. 
Double-click the field to select it and type the desired value. 
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Create a Table Using a Template
On the Create tab, in the Tables group, 
click Table Templates and select the 
desired template to open a new table 
based on the selected template.
Save the table.

Click the Microsoft Office button 
and choose Save.
In the Table Name text box, double-
click, type the desired name, and 
click OK.
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In the Data Type column, click the box corresponding to the field 
you have chosen, and from the drop-down list, select  
Lookup Wizard. 
In the Lookup Wizard, choose to base the values of the list from a 
table or query and click Next. 
Choose the desired table or query and click Next. 
Select the fields to appear in the lookup list and click Next. 
Choose any desired sort criteria for the columns displayed in the 
lookup column and click Next. 
Type a label for the lookup list field and click Finish.

Create an Input Mask

In the database, open a table in Design view. 
In the Field Name column, click the field for which you want to 
add an input mask. 
In the Field Properties pane, click in the Input Mask property  
text box. 
To the right of the text box, click the Build button to start the 
Input Mask Wizard. 
Click the Edit List button to display the Customize Input Mask 
Wizard dialog box. 
On the Record Navigation bar, click the New (Blank)  
Record button. 
Enter the description, input mask, placeholder, and sample data of 
the new input mask you want to create. 
Select a mask type and click Close. 
Select the new input mask that you have created and click Next. 
From the Placeholder Character drop-down list, select the desired 
placeholder and click Next. 
Select an option to specify whether the symbols should be 
displayed to the user or not, and click Next.
Click Finish to build the input mask. Switch to Datasheet view and 
test the new input mask. 

Work with Queries
Save a Filter as a Query

Open the desired table.
Filter the records in the table.
Click the Microsoft Office button and choose Save As.
Type the desired name for the query.
From the As drop-down list, select Query.
Click OK.
In the Microsoft Office Access dialog box, click Yes.
Observe that the query is displayed in the Navigation Pane.
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Create and Print a Table Relationship

On the Database Tools tab, in the Show/Hide group, click 
Relationships to display the Relationships window. 
Create a table relationship.

On the Design tab, in the Relationships group, click  
Show Table.
In the Show Table dialog box, on the Tables tab, select the 
desired tables and click Add. 
Click Close. 
In the Relationships window, in the desired table, click the 
desired field and drag it to the matching field in the  
other table. 
In the Edit Relationships dialog box, check the Enforce 
Referential Integrity check box to enforce referential integrity 
in the relationship. 
Click Create to establish a relationship between the  
two tables. 

Print a table relationship. 
On the Design tab, in the Tools group, click Relationship 
Report to display the table relationship in the form of  
a report. 
Save the table relationship report. 
On the Print Preview tab, click Print. 
In the Print dialog box, click OK. 

Work with Fields
Create a Multivalued Field

Display the desired table in Design view. 
Click in the Data Type column next to the desired field, and from 
the Data Type drop-down list, select Lookup Wizard. 
Select the I Will Type In The Values That I Want option to specify 
the desired values, and click Next. 
In the list box, specify the necessary values and click Next. 
Check the Allow Multiple Values check box to display multiple 
values, and click Finish. 

Create a Lookup Column Based on a Table or a Query
Open a table in Design view. 
In the Field Name column, click the field for which you want to 
add a lookup column.
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Filter data in a query.
Open the query in Datasheet view.
Select the field to which you want to apply the filter.
In the Sort & Filter group, click Filter and apply the desired 
filter option.

Find and Replace Data Using Wildcards
On the Home tab, in the Find group, click the Replace button. 
In the Find What text box, enter a value along with a wildcard. 
In the Replace With text box, enter the value. 
From the Look In, Match, and Search drop-down lists, select the 
desired options and click Next. 
Click Replace to replace the data.

Show Specific Records
To show the top or bottom values:

Open a query in Design view. 
On the Design contextual tab, in the Query Setup group, 
provide a value for the Top Values property box. 
In the Sort cell of the query design grid, set the value as 
descending for the desired field to show bottom values, and 
run the query. 

To show records that contain unique values in selected fields:
Open a query in Design view.
On the Design contextual tab, display the Property  
Sheet pane. 
Set the Unique Values property to Yes and run the query. 

To suppress records that contain duplicate information:
Open a query in Design view.
On the Property Sheet pane, set the Unique Records property 
to Yes. 
Run the query to observe the results.

 
Create a Join Line Between Tables

In the Navigation Pane, click the drop-down arrow and  
select Queries. 
Display the desired query in Design view. 
Drag a field from one field list to the matching field in the other 
field list to create a join line. 

 
Create a Self Join

In the Navigation Pane, click the drop-down arrow and  
select Queries. 
Display the desired query in Design view. 
On the Design contextual tab, in the Query Setup group, click 
Show Table. 
In the Show Table dialog box, on the Tables tab, select the table 
and click Add so that it appears twice in your query. 
After adding the table, click Close. 
Join the related fields. 
Add the fields that you want to display to the grid and run  
the query.

  
Change the Join Type

In the Navigation Pane, click the drop-down arrow and  
select Queries. 
Display the desired query in Design view and double-click the  
join line. 
In the Join Properties dialog box, select an option to create an 
inner join or an outer join and click OK.
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Create a Select Query Using the Query  
Design Feature

On the Create tab, in the Other group, click Query. 
In the Show Table dialog box, select the tables or queries to be 
used for the query. For each desired table or query, click Add to 
add the database element to Design view and click Close.
On the Design contextual tab, click Select to run a Select query. 
In the query window, in the list box, double-click the required 
fields to add them to the query design grid. 
Save the query. 
On the Design contextual tab, in the Results group, click Run to 
run the query.

Create and Run a Parameter Query
Open a query in Design view. 
Click in the Criteria cell for the appropriate field(s) and type the 
desired expression within square brackets ([ ]). If necessary, enter 
the desired wildcards within the criteria and run the query. 
When you are prompted to enter a parameter value, enter the 
value of the data you want to view and click OK.

Create an Action Query to Update Records
Run a Select query to determine the records that will be affected. 
In Design view, in the Query Type group, select the Update option 
to create an Update query. 
In the design grid, in the Update To cell, modify the query so that 
the proper fields will be updated with the new data, and run  
the query. 
When a message box is displayed indicating the number of 
records that will be affected, click Yes.

Create an Action Query to Append Records

Run a Select query to determine the records that will  
be appended. 
In Design view, in the Query Type group, select the Append 
option to change the query type to append. 
In the Append dialog box, select or enter the table you are 
appending records to and click OK. 
Click Run to run the query, and when a message box is displayed 
indicating the number of records that will be appended, click Yes.

Create a Make Table Query
Run a Select query to determine the records that will be inserted 
into the new table. 
In Design view, in the Query Type group, select the Make Table 
option to change the query type to Make Table. 
In the Make Table dialog box, select or enter the table name to 
which the records will be output, and click OK. 
Click Run to run the query, and when a message box is displayed 
indicating the number of records that will be inserted into the new 
table, click Yes.

Sort and Filter Data in a Query
To sort data in a query:

Open a query in Design view. 
For the desired field in the Design grid, in the Sort cell, select 
the Ascending/Descending option.
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Design a Form
Switch to Layout view and select the desired fields on the form.
Design a form.

Design a form using the Format contextual tab. 
On the Format contextual tab, in the Views group, click View 
and select a view.
Choose an appropriate command from the Font, Formatting, 
Gridlines or Controls groups.

Design a form using the Arrange contextual tab. 
On the Arrange tab, in the Control Layout group, choose a 
command to control the layout of the elements on  
the form.
In the Control Alignment group, choose a command to 
align the elements on the form.
In the Position group, choose a command to position the 
elements on the form.
In the Tools group, select Property Sheet to view and edit 
the properties of the form.

Group and Anchor Form Controls
Open the form in Design view. 
To anchor a group of controls, on the Arrange contextual tab, in 
the Size group, click Anchoring and select the Anchor position.
To group form controls, select the desired controls and then on 
the Arrange contextual tab, in the Control Layout group, click  
the Group. 
To ungroup form controls, select the desired grouped controls 
and then on the Arrange contextual tab, in the Control Layout 
group, click the Ungroup button.

Add an Image to a Form
On the Design contextual tab, in the Controls group, select the 
Image tool. 
Click in the form where you want the image displayed. 
In the Insert Picture dialog box, browse to the desired file’s 
location, select it, and then click OK. 

Create Command Buttons Using the Wizard
In Design view, open the form you want to add command  
buttons to. 
In the Controls group, select the Button tool. 
In the Design View window, click where you want the command 
button to be created. 
In the Command Button Wizard, in the Categories list box, select 
a category. 
Select an action and click Next.
The remaining steps of the wizard depend on the type of action 
you chose. Select the text or image to be displayed on the button.
On the What Do You Want To Name The Button page of the 
wizard, type a name for the command button and click Finish.  

Create a Subform Using the Wizard
Open the form in Design view. 
On the Design contextual tab, in the Controls group, select the 
Subform/Subreport tool. 
Click in the location of the form in which you’d like to place  
the subform. 
In the Subform Wizard, select the data source for the subform.
Select the table/query/form that will create the subform and  
click Next.
Select one of the links that Access suggests, or create one of your 
own, and click Next. 
Name the form and click Finish.
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Join Unrelated Tables
In the Navigation Pane, click the drop-down arrow and  
select Queries. 
Display the query in Design view. 
On the Design contextual tab, in the Query Setup group, click 
Show Table. 
In the Show Table dialog box, on the Tables tab, select the desired 
table and click Add. 
Click Close. 
Join the tables and add the fields that you want to display to the 
design grid, and complete your query design. 

Work with Forms
Create Forms Using Various Form Creation Tools

Select a table for which a form needs to be created. 
Generate a form using the options in the Forms group on the 
Create tab.

Click Form to generate a simple form.
Click Split Form to generate a form that displays the datasheet 
and the form.
Click Multiple Items to generate a form that displays all the 
records in the table.
Click Blank Form to generate a blank form that can  
be customized.
Click More Forms and select Datasheet to display the forms in 
Datasheet view.

On the Quick Access toolbar, click the Save button. 
In the Save As dialog box, in the Form Name text box, specify a 
name and then click OK. 

Create and Modify a Form with the Form Wizard
On the Create tab, in the Forms group, choose More Forms > 
Forms Wizard.
From the Tables/Queries drop-down list, select the first data 
source for the form.
Add the fields you want in the form to the Selected Fields list box.
Choose the form layout and click Next.
Choose the form style and click Next.
Click Finish.
To modify the form, open it in Design view and select the controls 
you need to work with.

To move the control, click and drag the control to the  
desired location.
To increase or decrease the size of the controls, drag a  
sizing handle.
To set the appropriate position, right-click the selected 
controls and choose Align.
If necessary, adjust the tab order of the form fields.

On the Arrange tab, in the Control Layout group, click  
Tab Order.
Click Auto Order and then click OK.

To add a title or other descriptive text, on the Design 
contextual tab, in the Controls group, click the Title button.
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On the Design tab, in the Controls group, click the Text  
Box button. 
In the report document window, click in the section where you 
want to add the calculated control. 
On the Ribbon, on the Design tab, in the Tools group, click 
Property Sheet.
In the Property Sheet pane, on the Data tab or the All tab, click 
the Control Source property. 
Click the Build button, and in the Expression Builder dialog box, 
build the desired expression by adding the desired operators and 
field names. Click OK.
In the report document window, remove the default label control 
or type the desired name for the calculated field.

Define a Summary Field
Open the report in Design view. 
Expand the width or height of a section to make room in the 
report for the new control. 
On the Design contextual tab, in the Controls group, select the 
Text Box tool. 
On the report, click where you want to create the Text  
Box control. 
In Design view, on the Design contextual tab, in the Tools group, 
select the Property Sheet option. 
In the Property Sheet pane, change the properties of the selected 
controls as desired. 
In the Control Source property, enter an expression for the 
summary operation to be performed. 
To preview the report, click the Microsoft Office button and 
choose Print > Print Preview.

Control Report Pagination Using Design View
Select a section and then change the Height property in the 
Property Sheet pane to adjust line spacing. 
On the Design contextual tab, in the Grouping & Totals group, 
click Group & Sort to open the Group, Sort, And Total pane. 
In the Group, Sort, And Total pane, click More, click the Do Not 
Keep Group Together On One Page drop-down arrow, and choose 
the desired Keep Together property. 
In the Property Sheet pane, set the Force New Page property for 
the group.

Create a Subreport
Open the main report in Design view. 
If necessary, create space for the subreport. 
On the Design contextual tab, in the Controls group, select the 
Subform/Subreport tool. 
In the report, click where you want to place the subreport. 
In the Subreport Wizard dialog box, select the record source for 
the subreport, and then click Next. 
Choose which fields will link the main report to the subreport or 
choose None, and then click Next.
Name the control and click Finish.

Create a Mailing Labels Re port
Open the report for which you want to create a mailing label.
On the Create tab, in the Reports group, click Labels to start the 
Label Wizard. 
Choose the type of mailing label and click Next. 
Choose the text style for the label and click Next. 
Arrange fields in the Prototype Label box to create a label layout 
and click Next. 
Select a field to sort the labels by and click Next. 
Name the mailing label report and click Finish. 
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Work with Reports
Create a Report Using the Report Wizard

On the Create tab, in the Reports group, click Report Wizard. 
In the Report Wizard dialog box, from the Tables/Queries drop-
down list, select the desired table/query. 
Add the desired field(s) to the Selected Fields list box and  
click Next. 
Set the desired view, grouping, sort, and summary options, and 
then click Next. 
Set the layout options and click Next. 
On the What Style Would You Like page, in the list box, select the 
desired style and click Next. 
In the What Title Do You Want For Your Report text box, type the 
desired title. 
Set the preview option and click Finish.

Sort and Group the Records with the Report Wizard
Select a table, and on the Create tab, click Report Wizard to start 
the Report Wizard. 
Select the fields that you want displayed in the report. 
Add the fields that you want to group by and click Next. 
From the first drop-down list, specify a sort field. 
Specify ascending or descending options.
If you want to sort on more than one field, select the fields and 
click Finish. 

Group and Sort the Records in a Report Using the 
Group, Sort, And Total Pane

Switch to Layout view or Design view. 
On the Design contextual tab, in the Grouping And Totals group, 
select Group And Sort.
In the Group, Sort, And Total pane, click Add A Sort. 
From the Sort By Select Field drop-down list, specify a sort field. 

Use the Totals Feature in a Report
Switch to Layout view or Design view. 
In the report window, select a column. 
In the Grouping And Totals group, click Totals and choose an 
aggregate function.

Add a Custom Calculated Field to a Report
Display the desired report in Design view. 
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Link Excel Data with Access
On the External Data tab, in the Import group, click Excel. 
Specify the source and destination of Excel data to be linked. 
Select the Link To The Data Source By Creating A Linked Table 
option, and then click OK.
In the Link Spreadsheet Wizard, select the data to be imported. 
In the list box, select the table to be imported and click Next. 
In the Linked Table Name text box, specify a different name for 
the table and click Finish.

Export Data to a Text File
Open the database window. 
On the External Data tab, in the Export group, click Text File. 
In the Export - Text File dialog box, in the Specify The Destination 
File Name And Format section, click Browse, navigate to the 
desired location, and save the file. 
In the Specify Export Options section, check the Export Data 
With Formatting And Layout check box. 
Check the Open The Destination File After The Export Operation 
Is Complete check box. 
If necessary, check the Export Only The Selected Records  
check box. 
In the Export Text Wizard, choose the format in which you want to 
export the file and click Next. 
Select a delimiter option and click Finish. 
If desired, check the Save Export Steps check box. 
Save the export.

Merge an Access Table or Query with an Existing  
Word Document

In the database window, select the table or query. 
On the External Data tab, in the Export group, click More and 
choose Merge It With Microsoft Office Word. 
Select the Link Your Data To An Existing Microsoft Word 
Document option and click OK. 
In the Select Microsoft Word Document dialog box, navigate to 
and select the Word document you want to open and click Open. 
In the document window, in the Mail Merge task pane, verify the 
Use An Existing List option is selected and click the Next: Write 
Your Letter link. 
Place the mouse pointer in the Word document in the location of 
your choice. 
On the Mailings tab, in the Write & Insert Fields group, click the 
Insert Merge Field button to select the desired fields from only 
the fields in the database or from the address fields. Separate the 
fields by pressing Enter or by using a comma or period. 
In the Mail Merge task pane, click the Next: Preview Your Letters 
link and review the resulting merged letters. 
If necessary, click the Find A Recipient link to display the Find 
Entry dialog box. 
If necessary, type a name and click Find Next to display the name 
of the field in the letter. 
Click the Next: Complete The Merge link. 
In the Merge section, click the Print link to print the document.
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Import and Export Data
Import an Excel Worksheet

On the External Data tab, in the Import group, click Excel. 
In the Import Spreadsheet Wizard, select the data to be imported. 
In the list box, select the table to be imported and click Next. 
Check the First Row Contains Column Headings check box and 
click Next. 
In the Field list box, select a field. 
If necessary, specify the field options and click Next. 
Specify the primary key and click Next. 
In the Import To Table text box, specify a different name for the 
table and click Finish. 
If desired, check the Save Import Steps check box to save the 
import steps.  

Import a Text File
In the database, on the External Data tab, in the Import group, 
click Text File. 
Specify the source and destination of the text data to  
be imported. 
Specify the delimitation option of the data in the source file and 
click Next. 
In the Choose The Delimiter That Separates Your Fields section, 
select the delimiter that separates the fields in the text document.   
Check the First Row Contains Field Names check box. 
From the Text Qualifier drop-down list, select the desired option.
Specify field breaks and click Next. 
If you want to modify the information of a field, select the 
appropriate field. 
Specify the required field options and click Next. 
If necessary, specify the primary key and click Next. 
In the Import To Table text box, specify a different name for the 
table and click Finish. 

Import Data from an Access Database
Specify the source and destination of the Access data to  
be imported. 
In the Import Objects dialog box, select the database object 
that you want to import. You can select Tables, Queries, Forms, 
Reports, Macros, or Modules. 
Click Options and specify additional settings. Click OK.
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